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Welcome! 

Note: Up until now, the manual contains only basic information on how to opera-

te the software using the new ribbon interface. More detailed instructions will be 

added in a later edition.  

Tip: A table showing which ribbon command corresponds to each menu com-

mand can be found here: section “Menu commands and corresponding ribbon 

commands” (page 605). 

Welcome to TextMaker! You have purchased a word processor that combines user-

friendliness with powerful features at an affordable price. With TextMaker, you 

will be able to complete your writing tasks quickly and comfortably.  

Note: In SoftMaker FreeOffice (the free version of SoftMaker Office), some 

features have been disabled. Features that are not available in the free version are 

tagged with a red box like this one. 

Some features of TextMaker 

 Available for Windows, Mac, Linux, and Android 

 Well-designed, ergonomic user interface - either with modern “ribbons” or 

classic menus and toolbars 

 Practical document templates: pre-designed letterheads, fax forms, etc. for 

creating new documents in no time 

 Extensive paragraph formatting capabilities, including automatic num-

bering, bullets, borders, shadows, fill patterns 

 Paragraph and character styles that allow you to apply frequently needed 

formats to text with the press of a button 

 Desktop publishing (DTP) features like “master pages”, drop caps, small 

caps, automatic paragraph control, adjustable character spacing and pitch 

 Graphics support in numerous file formats, extensive drawing functions, 

TextArt module for fancy text effects 

 Powerful table functions, including arithmetic functions 
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 File and document manager with search capabilities (not included in Soft-

Maker FreeOffice) 

 Table of contents and indexes, footnotes, outline view (outline view not in-

cluded in SoftMaker FreeOffice) 

 Reliable spell checking, hyphenation, and synonym dictionaries (not in-

cluded in SoftMaker FreeOffice) 

 Integrated address book (database) 

... and much more 

TextMaker is in continuing development, and we welcome comments and sugges-

tions from our users. If, in the course of your work, you encounter a need for a fea-

ture that isn’t present, or you have other suggestions, write to us – we want Text-

Maker to measure up to the users’ wishes!  

Additional features in SoftMaker Office Professional 

Available only for Windows, Mac and Linux: 

The even more powerful SoftMaker Office Professional includes an extended ver-

sion of TextMaker which offers the following additional features: 

 Integrated Berlitz translation dictionaries – enabling you to translate words 

between five languages (English, French, German, Italian, and Spanish) with 

the push of a button 

Android versions 

FreeOffice: Currently, there is no Android version of SoftMaker FreeOffice 

available. However, we are offering free versions of our Android apps from time 

to time. Visit www.freeoffice.com to find out more.  

TextMaker is also available for Android devices. There are two different versions: 

 TextMaker HD for Android 

 This version contains practically all features of the Windows version. It is de-

signed to be used on tablets.  

http://www.freeoffice.com/
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 TextMaker Mobile for Android 

 This version contains only parts of the features of the Windows version. It is 

designed to be used on smart phones. 

All instructions in this manual refer to the HD version. (The Mobile version comes 

with its own user manual.) 

Technical support 

If you have any questions, our technical support team will be glad to assist you. 

You can reach us as follows: 

Website 

Our website provides program updates, tips and tricks, free downloads, and much 

more.  

Visit us at: www.softmaker.com 

Support forums 

Feel free to communicate with our technical support team, as well as other users, in 

our support forums. 

You find them at: forum.softmaker.com 

Inquiries to our support 

If you have a problem with our software, we will gladly help you. 

You can post your questions here: www.softmaker.com/en/support-assistant 

About this manual 

TextMaker has a wide variety of functions. In the beginning you might find this a 

bit intimidating – but don’t worry: You don’t have to master all the commands! 

http://www.softmaker.com/
http://forum.softmaker.com/
http://www.softmaker.com/en/support-assistant
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While you’re getting started, just use those you need. Later, when you would like 

to make use of TextMaker’s extended functions, you can review the appropriate 

pages in the manual. 

The manual for TextMaker is laid out as follows: 

 The chapter “Installation and program startup” (page 23) covers the installa-

tion of TextMaker. You also learn how to start the program. 

 The chapter “The application screen” (page 29) describes the individual com-

ponents of TextMaker’s main window. Ideal for beginners! 

 The chapter “Basics” (page 37) acquaints you with TextMaker’s most im-

portant commands. Ideal for beginners! 

 The chapter “The TextMaker Tour” (page 45) treats the topic of text editing in 

tutorial form and introduces you to the operation of TextMaker with some prac-

tical examples. 

 The chapters “Working with selections” (page 65) and following are the refe-

rence part of the manual. These chapters are organized by subject, like a refe-

rence book, and describe all the functions of the program in detail. 

System requirements 

In order to run this software, the following hardware and software is required:  

Windows version 

 Windows 10, Windows 8/8.1, or Windows 7 (32 or 64 bit) 

Mac version 

 macOS or OS X version 10.9 (“Mavericks”) or better 

Linux version 

 Any x86 Linux (32 or 64 bit) 
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Android-Version 

 Android 4.0 or better 

 ARM compatible CPU 

 Display size: 7 inch or larger recommended 
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Installation and program startup 
This chapter covers information on installing and starting TextMaker. 

It is divided into the following sections: 

 Installing under Windows 

 Installing under macOS 

 Installing under Linux 

 Installing on an Android device 

Please go directly to the section that covers your operating system. 

Installing under Windows 

Download 

If you obtained the software by download from our website, you will find installa-

tion instructions in the e-mail that you received after purchasing the software. 

CD-ROM 

If you obtained the software on CD-ROM, please launch the installation program 

provided in the root folder of the CD. 

Then, follow the installation program’s instructions to install the software. 

Starting 

To start the installed programs, use the Start menu at the lower left corner of the 

screen. You will find your SoftMaker Office applications in a sub-folder called 

SoftMaker Office.  

Note: When you start TextMaker for the first time, you will be asked to enter your name and address. 

This information is not for the purpose of registering the program. Rather, TextMaker needs it to auto-

matically personalize the document templates for letters, faxes, etc. that come with the program. You 
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can always change this information later (see the section “Preferences, General tab” beginning on page 

539). 

Installing under macOS 

You will find information about installing the software in the e-mail that you recei-

ved after purchasing it. 

Error message appears when launching the installation program? 

Depending on your system settings, you may receive the following error message 

when you try to start the installation program: 

 

This happens when your system's security settings specify that only programs that 

have been downloaded from the App Store should be allowed to run. 

Clicking on the question mark in the lower left corner of the message reveals how 

you can launch the installation program anyway. A help window appears, recom-

mending the following procedure: 

1. Close the error message. 

2. Hold down the ctrl key and click on the installation program. 

3. A context menu appears. Select the Open command. 

4. A message appears asking if you really want to open this application. Confirm 

this by clicking on the Open button. 

The installation program will now start. 
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Starting 

After the installation is complete, icons for each of the installed applications will 

appear in both the Launchpad and the Dock at the bottom of the screen. To start 

one of the apps, click on its icon. 

Installing under Linux 

You will find information about installing the software in the e-mail that you recei-

ved after purchasing it. 

Starting 

In most Linux distributions, the installer automatically creates shortcut icons for all 

SoftMaker Office applications in the menu. To start any of the applications, click 

on the corresponding icon. 

Alternatively, the following shell scripts are available for launching the programs: 

 textmaker18free launches TextMaker 

 planmaker18free launches PlanMaker 

 presentations18free launches Presentations 

You can execute these scripts in a shell, for example. 

Note: When you start TextMaker for the first time, you will be asked to enter your name and address. 

This information is not for the purpose of registering the program. Rather, TextMaker needs it to auto-

matically personalize the document templates for letters, faxes, etc. that come with the program. You 

can always change this information later (see the section “Preferences, General tab” beginning on page 
539). 

Installing on an Android device 

FreeOffice: Currently, there is no Android version of SoftMaker FreeOffice 

available. However, we are offering free versions of our Android apps from time 

to time. Visit www.freeoffice.com to find out more.  

http://www.freeoffice.com/
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The installation procedure on Android devices depends on where you purchased 

the software:  

Purchased in Google Play Store 

When you purchase an app using the Google Play Store on your Android device, 

there is nothing you have to do: The app will be downloaded and installed automa-

tically, right after you bought it.  

Purchased in Amazon App Shop 

The same applies when you purchase an app in the Amazon App Shop on your 

device: The app will be downloaded and installed automatically right afterwards.  

Note: In case the installation aborts with an error message saying that apps from 

“unknown sources” cannot be installed, please read the section “Allowing the 

installation of apps from unknown sources” below. 

Purchased on our website www.softmaker.com 

If you have purchased SoftMaker Office directly on our website www.soft-

maker.com, proceed as follows to install the software: 

1. Immediately after your purchase, you will receive an e-mail containing down-

load links for each of the individual components of SoftMaker Office. Click on 

each of these links to download the respective installation archives (APK files). 

2. If you are downloading these files on your Android device, the installation 

might start automatically as soon as the download is finished – this depends on 

the device. If the installation does not start automatically, you can always start 

it manually: Launch any file manager of your choice and open the Download 

folder on your SD card in it. There, tap once on each of the downloaded files. 

 If, on the other hand, you have performed the download on a different device 

(for example, a PC), first copy the downloaded APK files to your Android de-

vice, and then tap on each of the files in a file manager. 

This will start the installation process of the respective application. 

Note: In case the installation aborts with an error message saying that apps from 

“unknown sources” cannot be installed, please read the section “Allowing the 

installation of apps from unknown sources” below. 
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Allowing the installation of apps from unknown sources 

If you have purchased the apps via the Amazon App Shop or directly from our 

website, you might encounter an error message when trying to install the software: 

Most Android devices are configured to allow the installation of applications only 

from within Google Play Store. When you try to install an installation archive di-

rectly, an error message will appear, saying that apps from “unknown sources” 

cannot be installed. 

In order to be able to install the software, you must first allow the installation of 

software from “unknown sources”. This can be achieved as follows:  

1. Open the Settings of your Android device. 

2. Tap on Security. 

3. Activate the option Unknown Sources. 

After that, you will be able to install SoftMaker Office as described above. 

Hint: When the installation is complete, you should consider turning this option off 

again for security reasons. 
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The application screen 
On the following pages, the individual components of TextMaker’s user interface 

are described in detail. 

 

TextMaker’s application window 

Note: Most of the illustrations in this manual were prepared with the Windows 

version of TextMaker. On other operating systems, some of the controls have a 

slightly different appearance, but their modes of operation are identical. 

Title bar 

At the top of the application window, you will find the title bar. 

 

The title bar indicates the name of the application and the name of the current 

document. 
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If this document contains changes that have not been saved yet, a little asterisk is 

displayed behind its name. 

Menu bar 

The menu bar is found directly under the title bar. 

 

It contains all of TextMaker’s commands in the form of clearly arranged menus. 

Click on a menu item to open a menu and invoke a command. 

Context menu 

In addition, a menu called context menu is also available.  

This menu contains different commands depending on the current situation. For 

example, when you select some text and open the context menu, it will offer com-

mands for cutting, copying, or formatting that text. 

 

To open the context menu, you usually first select something in your document and 

then click on that selection with the right mouse button. 



 

Manual TextMaker The application screen  •  31 

Android: In the Android version, you can also open the context menu with your fin-

ger: Just tap on the screen and hold your finger there for about a second. 

Standard toolbar 

The Standard toolbar is shown below the menu bar. It contains icons for most 

commonly used commands. 

 

Toolbars, such as the Standard toolbar, allow fast access to a program’s functions. 

Each icon represents a specific command. If you click on it, the corresponding 

command is invoked. 

Tip: If you point the mouse cursor at an icon (without clicking) and hold it there, 

a text box called a “tooltip” is shown. The tooltip describes the icon’s function. 

There are additional toolbars in TextMaker that you can turn on and off as you 

choose. To do this, either invoke the menu command View > Toolbars or click 

with the right mouse button on one of the displayed toolbars. A menu appears, 

from which you can select toolbars that you would like displayed. 

Customizing toolbars: You can customize the built-in toolbars to your liking and even 

create your own toolbars. For more information, see the section “Customizing 

toolbars” beginning on page 573. 

Formatting toolbar 

Beneath the Standard toolbar you find the Formatting toolbar. With it, you can 

both examine and modify the most often used formats (font, bold, italic, etc.) for 

the current text. 

 

If you select a section of text beforehand, formatting changes affect only the selec-

ted text. Otherwise, the text that you subsequently type in is affected. 

To choose, for example, a different font, click on the little arrow to the right of the 

font name to open a list, and then select a font. 
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Other icons in the Formatting toolbar are switches that you can turn and off by 

clicking – for example the B for bold. 

Ribbon 

If you have selected in the settings that you would prefer to use a ribbon interface 

instead of classic menus and toolbars, the uppermost area of the program window 

will look like this on your device: 

  

The ribbon and the Quick Access Toolbar (at the bottom) 

Ribbons are a modern type of user interface supposed to replace menus and tool-

bars (by combining them) in order to simplify the handling of the software.  

As you can see, the ribbon has several tabs that are displayed at its top (File, Ho-

me, Insert, etc.). You can switch between them with the click of a mouse. Each tab 

contains icons for a specific topic. 

The Quick Access Toolbar is displayed below the ribbon. It provides a selection of 

the most frequently used commands. 

Note: Up until now, the manual contains only basic information on how to opera-

te the software using the ribbon. More detailed instructions will be added in a 

later edition.  

Tip #1: A table showing which ribbon command corresponds to each menu 

command can be found here: section “Menu commands and corresponding rib-

bon commands” (page 605). 

Tip #2: You can access the classic menu also from the ribbon: Simply click on 

the  icon in the Quick Access Toolbar to open it. 
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Tip #3: You can switch the user interface between ribbon and classic menus and 

toolbars at any time. To do this, invoke the menu command Tools > Option (or, 

in the ribbon, the command File > Options). In the dialog, switch to the 

Appearance tab and click on the User Interface button. A dialog box appears in 

which you can select the type of user interface you prefer. 

Document tabs 

FreeOffice: The functions for working with Document tabs are not included in 

SoftMaker FreeOffice. However, you can open several documents in different 

program windows. 

A bar with document tabs can be found below the toolbars or the ribbon. It displays 

one tab for each open document. 

 

The document tabs bar 

The following actions can be performed here: 

 To make a document become the active document, click on its tab with the left 

mouse button. This allows you to switch between the currently open documents 

quickly. 

 To close a document, click on its tab with the middle mouse button. (Alterna-

tively, left-click on the x icon displayed on the right of the tab). 

Documents can also be opened in a new program window if desired. For details on 

working with multiple documents at the same time, see the chapter “Working with 

multiple documents” beginning on page 531. 

Horizontal ruler 

The horizontal ruler is found at the top of the document. The margins and tab stops 

for the active paragraph (or for all the paragraphs that might be selected at a given 

moment) are shown there. The unit of measure used is inch or centimeter, depen-

ding on your computer’s settings. 
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Indentations and tab stops are not just shown here, they can also be changed using 

the mouse. You will learn how in the sections “Indents” (page 84) and “Tabs” (pa-

ge 90). 

Document 

The document itself takes up the largest area of the program window. 

Information on editing documents can be found in the rest of this manual, starting 

with the chapter “Working with selections” (page 65).  

If you are new to TextMaker, you recommend that you take a look at the chapter 

“Basics” (starting on page 37) first. Tip: Also, don’t miss the chapter “The Text-

Maker Tour” (starting on page 45) which will introduce you to TextMaker’s basic 

features with some practical examples. 

Sidebar 

The pane displayed to the right of the document, called sidebar, is a very useful 

tool: 

It can be used, for example, to display a list of all headings in a document. When 

you double-click on one of its entries, TextMaker immediately jumps to the corres-

ponding heading in your document. 

The icons in the small toolbar displayed on the top of the sidebar let you choose 

what to display in the sidebar (navigator, character styles, or paragraph styles) 

The sidebar can be switched on and off anytime by choosing the View > Sidebar 

menu command. A submenu opens where you can change the position of the side-

bar, or hide the sidebar. 

FreeOffice: In SoftMaker FreeOffice, the sidebar occasionally opens automati-

cally when you launch the software, in order to display some interesting informa-

tion on SoftMaker Office. 
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To learn more about the sidebar and its individual functions, see the following sec-

tions: 

 Navigating documents with the sidebar (page 169) 

 Character styles and the sidebar (page 137) 

 Paragraph styles and the sidebar (page 146) 

Status bar 

The Status bar is found at the bottom of the program window. 

 

When you point to an icon or other control in the user interface with your mouse, a 

short explanation of its function is displayed in the status bar. 

Apart from that, the following information is provided in the status bar (from left 

to right): 

Example Explanation 

L 37 Col 8 The text cursor is positioned at line 37 and column 8 on the current 

page. 

Section 1 The text cursor is positioned in section 1 of the document (see chap-

ter “Multi-column page layouts”, page 153). 

Chapter 1 The text cursor is positioned in chapter 1 of the document (see sec-

tion “Dividing a document into chapters”, page 119). 

Page 1 of 2 The text cursor is positioned on page 1 of a document with a total of 

2 pages. 

English The text at the current position of the text cursor (or the currently 

selected text, respectively) is formatted in English language (see also 

section “Setting the language”, page 330). 

Ins Shows whether Insert Mode (Ins) or Overwrite Mode (Ovr) is active: 

 Ins: Insert mode is active – newly entered text will be inserted into 

existing text. 

 Ovr: Overwrite mode is active – newly entered text will be written 

over existing text. 
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 The standard setting is Ins. You can switch between these two modes 

with the (Ins) key. 

Additionally, a zoom slider can be found in the status bar:  

 

To change the zoom level, either drag the slider with your mouse, or click on the 

minus or plus icon. (See also section “Changing the zoom level”, page 571.) 
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Basics 
This chapter gives you a brief description of TextMaker’s most important basic 

functions.  

After that, you should consider taking the TextMaker Tour in the next chapter, 

which guides you through the program step by step with practical examples. 

Note: Most of the illustrations in this manual were prepared with the Windows 

version of TextMaker. On other operating systems, some of the controls have a 

slightly different appearance, but their modes of operation are identical. 

Entering text 

When you start TextMaker, an empty document is opened automatically. Thus, you 

can begin entering text immediately.  

Note: At the end of lines, do not press the Enter key (¢) in order to begin a new 

line. If a word you type won’t fit on the current line, TextMaker will transfer it to 

the next line automatically.  

You should press the Enter key (¢) only in the following cases: 

 to end a paragraph 

 to enter blank lines 

So, while inside a paragraph, simply let TextMaker take care of making correct line 

breaks. 

Moving the text cursor 

While editing text you always see a blinking line. This is the so-called text cursor. 

When you type something, the letters always appear where this text cursor is posi-

tioned. 

You can move the text cursor anywhere between the beginning and the end of the 

document. The direction keys are provided for this purpose. The arrow keys (æ) 
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and (Æ), for example, move the text cursor one character to the left and right 

respectively. 

Altogether the following direction keys are available for moving the text cursor: 

Key Function 

(æ) One character to the left 

(Æ) One character to the right 

(½) One line up 

(¼) One line down 

(Home) To the beginning of the line 

(End) To the end of the line 

(Ctrl)(½) To the beginning of the current paragraph or, when pressed 

again, the previous paragraph 

(Ctrl)(¼) To the next paragraph 

(Ctrl)(Home) To the beginning of the document 

(Ctrl)(End) To the end of the document 

Apart from that, you also click on the desired place with your mouse to position the 

text cursor there. 

Android: In the Android version, you can alternatively tap on the desired position 

with your finger. 

Deleting text 

Everyone makes typing mistakes now and then and would like to delete them. The-

re are numerous ways to do this in TextMaker. 

Deleting characters: To delete a character, use the Backspace key (æ__) situated 

above the Enter key (¢). This key deletes the character to the left of the text cur-

sor. The following text moves back automatically. 

You can also delete in the opposite direction: The (Del) (“Delete”) key does this. It 

deletes the character not to the left, but to the right of the text cursor.  
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Deleting words: If you place the text cursor before the first letter of a word and then 

press (Ctrl)(Del) the word is deleted. If the text cursor is positioned in the middle 

of the word, this key combination deletes only the letters following the cursor to 

the end of the word. 

Deleting a carriage return: You can remove a carriage return inserted by mistake. Test 

it: Type a multi-line paragraph and then insert a carriage return in the middle of the 

paragraph by pressing the Enter key (¢). The following text leaps to the next line 

and the paragraph is divided. In certain cases, as when a paragraph is too long and 

must be divided into two paragraphs, this can be done intentionally. Here, however, 

it was a “mistake” – so press the Backspace key (æ__) to remove the carriage re-

turn.  

Deleting large sections of text: The above mentioned delete keys are well suited for 

removing short sections of text, but too time-consuming for removing larger parts 

of text. For this reason there is yet another method of deleting that involves first 

selecting text and then e.g. pressing the (Del) key to delete it all at once. There is 

more about this in chapter “Working with selections” beginning on page 65. 

Undoing changes 

TextMaker is very forgiving, as it allows you to reverse the most recently comple-

ted changes with the Edit > Undo menu command. For example, if you delete so-

me text and then realize you want the text back, all you need to do is invoke Edit > 

Undo to reverse the deletion. 

This works not only with text deletions, but also with practically any type of chan-

ge you make in a document. You can, for example, undo an insertion of an object. 

The Undo command can be applied repeatedly. For example, you can invoke it 

five times to reverse the last five changes.  

Redoing undone actions 

There is also an opposite to the Undo command: the menu command Edit > Redo. 

It restores the effect of your most recent undo action. 
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Insert or overwrite? 

Text entry works very simply. You move the text cursor to the desired place and 

begin typing.  

In TextMaker, Insert mode is on by default. If you type a character in this mode, it 

is entered in the existing text and shifts the following text forward. 

Alternatively, you can switch to Overwrite mode. In this mode entered text 

overwrites the following text. 

The status bar always shows which mode is presently active: If INS appears there, 

the insert mode is active. If OVR is shown, you are working in overwrite mode.  

You can switch back and forth between the two modes with the (Ins) key. 

Beginning a new document 

To begin a new document, invoke the menu command File > New. 

 

A dialog window appears, in which you can select the document template for the 

new document. 
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If you simply want to begin a new document and don’t want to concern yourself 

further at the moment with document templates, just choose the standard template 

NORMAL.TMVX. 

As soon as you confirm with OK the new document will be set up. 

Using document templates 

Apart from the standard template NORMAL.TMVX you will also see some folders 

that can be opened with a double click. These folders contain prepared document 

templates for letters, faxes, etc. All you have to do is fill them in.  

Hint: In the right half of the dialog, a preview of the currently selected template 

is presented. The preview can be turned on/off with the >> button and the << 

button anytime you wish. 

For detailed information on working with document templates, see the section 

“Document templates” beginning on page 149. 

“New program window” option 

The New program window checkbox in this dialog has the following meaning: If 

it is switched on, the new document will be opened in a new program window. If 

not, the new document will appear in the existing window. 

(Note: This option is not available in the Android version.) 

Opening documents 

To open an existing document, invoke the menu command File > Open. 

A dialog box appears that can look, for example, as follows:  
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The most recently accessed folder will display with all existing documents listed 

(based on the listed file types). To choose the file to be opened, type its name in 

manually or simply select a file from the list. Then, click the Open button. 

New program window: The New program window checkbox in this dialog has the 

following meaning: If it is switched on, the document will be opened in a new pro-

gram window. If not, the document will appear in the existing window. (Note: This 

option is not available in the Android version.) 

Opening other file formats 

In addition to opening files created in TextMaker’s default file format, you can also 

open files created within other software, such as Microsoft Word. To open a file 

from another application, choose the format of the file you want to open from the 

Files of type list. This will display all matches to that software’s file extensions in 

the dialog. 

You will find more information about this in chapter “Working with other file for-

mats” beginning on page 517. 
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Previewing a document 

When the Preview option is activated, a little box displaying a preview of the cur-

rently selected document is displayed alongside the dialog. 

Using Quick Paths 

With the Quick Path button, you can create quick paths in order to quickly move 

to a specified folder when opening or saving files. This allows you to create a list 

of your most frequently used folders, permitting much faster navigation.  

You will find more information about this in section “Quick paths” beginning on 

page 502. 

Using the File manager 

FreeOffice: The File manager is not included in SoftMaker FreeOffice. 

The File manager button opens the integrated file manager. This shows a list of 

your documents, and allows you to open, print, view, or delete them, as well as 

perform searches.  

You will find more information about this in section “The file manager” beginning 

on page 505. 

Using the list of recently opened files 

Tip: At the bottom of the File menu you will find a list of recently opened files. 

Simply click on one of these files to open it again. 

Printing documents 

To print the active document, choose the File > Print menu command. 

A dialog box appears, in which you can specify the pages and the number of copies 

to be printed. By default, one copy of the entire document is printed. 

For more information on outputting documents (printing, e-mailing, etc.), see the 

chapter “Outputting documents” beginning on page 485. 
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Saving documents 

When you are working on a document, it is good practice to save it frequently.  

You can use the File > Save menu command to save the document in the active 

window under its current filename. If the document does not yet have a name, 

TextMaker automatically asks you to supply a name by opening the Save as dialog 

box. 

Saving under a different name or in a different place 

To save a document under a new name or location on your computer, use the menu 

command File > Save as. This saves your document too, but you can first give it 

another name or select another folder in which to save it. 

Saving in a different file format 

With the File > Save as menu command, you can also save a document in another 

file format. To do so, simply choose the desired format from the Save as type list 

before clicking the Save button. See also chapter “Working with other file formats” 

beginning on page 517. 

Saving all open documents 

If you have multiple documents open at the same time, you can use the menu 

command File > Save all to save all documents open in all the windows. TextMa-

ker checks which of the documents have been altered since the last save and saves 

only those that have been changed.  

Exiting the application 

To exit TextMaker, use the File > Exit menu command. 

If any of the open documents have been altered since they were last saved, Text-

Maker automatically asks whether you would like to save them first. 
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The TextMaker Tour 
Welcome to the TextMaker Tour!  

On the next pages, we will introduce you to some of TextMaker’s basic functions 

using practical examples. 

When working through the exercises, don’t be afraid to experiment with new 

commands as you get acquainted with them! There is no harm done if something 

goes completely amiss. We have provided example documents for every lesson; 

this way, at the beginning of each new lesson, you can open the appropriate examp-

le document and use it to get started. 

Note: Most of the illustrations in this manual were prepared with the Windows 

version of TextMaker. On other operating systems, some of the controls have a 

slightly different appearance, but their modes of operation are identical. 

A practice letter 

Ready for the first exercise? Then start TextMaker now. 

Note: When you start TextMaker for the first time, you will be asked to enter y-

our name and address. TextMaker needs this information to automatically perso-

nalize the document templates for letters, faxes, etc. that come with the program. 

You can always change this information later with the menu command Tools > 

Options (see the section “Preferences, General tab” beginning on page 539). 

After the program starts, it always displays an empty document in which you can 

immediately start typing. The text cursor blinks at the beginning of the document. 

When you type something, it always appears just behind the text cursor, which 

moves forward to accommodate it. 

To start, we would like to begin a simple letter from “Escher & Sons, Architects.” 

Simple, but by no means less than professional quality. At the end of this tour you 

will have composed a full-fledged business letter, complete with all the bells and 

whistles. 

At this point you might say: “This will be a lot easier if I invoke the command File 

> New and select one of the prepared letter templates.” Naturally – but you won’t 

learn anything that way. If you are going to participate in this tour, you have to 
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invest a little time – but afterwards you will be in command of the program’s most 

important functions and can immediately start adapting the templates to your 

needs! 

So let’s get started. First, type something resembling the example text that follows. 

You don’t have to copy it exactly; you can enter whatever text you please – the 

content doesn’t matter. 

Note: Press the Enter key (¢) only at the indicated places. When using a word 

processor, you don’t press this key at the end of every line. Rather, you press it 

only at the end of a paragraph, or to insert blank lines.  

Dear Clients,(¢) 

(¢) 
This year we have been building more than usual, not just 

for you, but also for ourselves. The new Escher Complex, one 

of the most daring building projects in town, will become 

our new home. We cordially invite you to the opening 

ceremony.(¢) 

(¢) 
The celebration will take place next Saturday at 38-42 

Linden Street. We have taken every care for your personal 

comfort, and the program we have organized for this event 

will make for an unforgettable afternoon.(¢) 

(¢) 
Bring your family along for a day of fun and 

entertainment.(¢) 

(¢) 

Typing mistakes: When you make a typing mistake, you can immediately delete it by 

pressing the Backspace key (æ__) (situated above the Enter key (¢) on PC and 

Mac keyboards). 

If you have followed the example, your document should look something like this: 
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The finished text 

Next, we’d like to insert an address above the text of our letter, as follows:  

To get to the beginning of the document, press the key combination (Ctrl)(Home). 

Then, press the Enter key (¢) seven times to insert some blank lines. This makes 

room for our own address, which is to be entered later on. By the way, you can 

remove blank lines you might have inserted inadvertently with the Backspace key 
(æ__). 

Next, press the (½) key once to position the text cursor in the blank line above the 

text of the letter.  

Now type the name and address of the person to whom the letter is to be sent, for 

example: 

Fred Backfish(¢) 

7 Shepard’s Way(¢) 

Salmon River, Oregon 77123(¢) 

When done, insert additional blank lines by pressing the Enter key (¢) eleven 

times to create a space between the address and the text of the letter. 

We have now created the most important elements of a simple letter and at this 

point would like to save them. 
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Saving the practice letter 

Note: You will find detailed information about this topic in the section “Saving 

documents” beginning on page 44. 

To save the current document, use the Save command in the File menu. (From now 

on we will use the notation File > Save to represent this.) Invoke this command as 

follows: 

Mouse: Click on File in the menu bar. The File menu opens, and you can invoke 

the Save command with a mouse click. 

Keyboard: PC users can alternatively use the underlined letters in the menus to 

invoke the corresponding commands. Type them while holding down the Alt key. 

To save the file, press (Alt)(F) for File and then (S) for Save. 

Perhaps, while using the menu, you may have noticed that “Ctrl+S” is displayed to 

the right of the Save command. This is the keyboard shortcut for this command. 

This means you can also press (Ctrl)(S) to invoke this command and save your 

document. 

There is also a shortcut for mouse users: In the Standard toolbar you will find icons 

for the most frequently needed commands. 

 

To save your document, click on the diskette icon in the Standard toolbar (the third 

icon from the left). 

Tip: If you point the mouse cursor at a toolbar icon (without clicking) a text box 

appears, giving the icon’s function. 

If the Standard toolbar is not displayed, it is probably deactivated. To reactivate it, 

invoke the command View > Toolbars and click on the checkbox in front of Stan-

dard. 

The Save dialog box 

If the letter has no name, the program automatically displays a dialog box that asks 

you to specify the filename when you invoke the File > Save command. There, 

type a name for the document in the Filename box or, if you would like to 

overwrite an existing file, choose a name from the list of files. 
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We are going to name the document LETTER. So enter “Letter” in the Filename 

box and click on OK or press the Enter key (¢) to confirm your entry. TextMaker 

saves the file under the specified name and automatically appends the extension 

.TMDX. Thus, the full filename reads LETTER.TMDX. 

The next time you invoke File > Save this dialog box will not appear, since the 

document now has a name. Hereafter, it will be saved immediately under its name. 

By the way, you could have exited the dialog box without executing the Save 

command. You could have done that by clicking Cancel instead of OK on the con-

trol panel, or by pressing (Esc). This “escape route” is available to you in all dialog 

boxes. 

Simple formatting 

Now we come to the more interesting functions – for example, to text formatting, 

and thus to the application of fonts, text emphasis (bold, italic, etc.), indentation, 

etc. 

First, we will insert a line with our return address above the address, as is customa-

ry for letters that are to be sent in windowed envelopes. 

So let’s position the text cursor two lines above the address (line 5) and type the 

address of our firm: 

Escher & Sons, Architects – 78 Baker Street - Atlanta, GA 

30009 

Of course this line is much too wide for a windowed envelope’s view window, and 

so we would like to decrease the font size a bit. In this way, we come to an im-

portant topic: selecting. 

First select, then format 

Note: You will find detailed information about selecting in chapter “Working with 

selections” beginning on page 65. 

To format a section of text after it has been entered, you must first select it, so that 

TextMaker knows what area should be modified. 

To select the lines containing the address, proceed as follows: 
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Mouse: While pressing the mouse button, drag the mouse cursor from the begin-

ning to the end of the text you want to select. By the way, there is an easy way to 

select complete lines: click in the margin to the left of the line. The complete line 

will be immediately selected. 

Keyboard: If you prefer to work with the keyboard, you can make selections by 

moving the text cursor while holding down the Shift key (ª). In this case, select 

the address line by positioning the text cursor in front of the first character with the 
(Home) key and then pressing the key combination (Shiftª)(¼). 

Android: Please note that in the Android version, selecting text is done in a quite 

different way. For details, see the section “Selecting text and objects” (page 65). 

Once you have selected the address line, you can modify the font size. To do this, 

use the Formatting toolbar, which presents all the most frequently needed format-

ting commands. If the Formatting toolbar is not visible, invoke View > Toolbars 

and click on the little box in front of Formatting to activate it. 

The Formatting toolbar 

Note: You will find detailed information about the Formatting toolbar in the chap-

ters “Character formatting” (beginning on page 71) and “Paragraph formatting” 

(beginning on page 83). 

 

The font size of the selected text is displayed to the right of the font type – at 

present, 10 point is set. Click with the mouse on the little arrow to the right of the 

“10” to open a list of the most commonly used font sizes. Choose “8” from the list. 

Now choose also a different font type. To do this, click on the arrow to the right of 

the font and choose the MicroSquare font from the list. If you have not installed 

this font, you can choose any other font you like. 

After these modifications, the Formatting toolbar should display the following set-

tings:  

 

The MicroSquare font in 8 point size was set. 

Accordingly, the sender’s and receiver’s addresses should look something like this: 
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Now it is time once again to save the document with File > Save. 

When something goes wrong ... 

Note: You will find more information about this topic in section “Undoing chan-

ges” beginning on page 39. 

In TextMaker, the most recently completed changes can be reversed with the Edit 

> Undo command. For example, if you format text with a different font – and don’t 

like it, all you need to do is invoke Edit > Undo to make it undone. 

This works not only with formatting, but also with practically all kinds of changes 

– so you can also, for example, undo the entry or deletion of text. 

The command Undo can be applied repeatedly as needed. For example, invoke it 

five times to cancel the last five changes. 

There is also an opposite to the Undo command: the command Edit > Redo. It 

restores the effect of your most recently canceled action. So you can undo the 

cancellation of a change. 

Opening files 

Note: You will find detailed information about this topic in section “Opening 

documents” beginning on page 41. 
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Now we will open the example file TOUR1.TMDX that is provided with the pro-

gram. It contains our practice document as it should look at this stage of our work. 

To open a document, invoke the command File > Open from the menu. 

Then, change to the folder containing SoftMaker’s example documents. To locate 

this folder, proceed as follows: 

 Under Windows, navigate to your DOCUMENTS folder. There, go to the folder 

SOFTMAKER\SAMPLES. 

 Under macOS or Linux, navigate to your home folder. There, go to the folder 

SOFTMAKER/SAMPLES. 

 On an Android device, go to the folder SOFTMAKER/SAMPLES on your SD 

card. 

In this folder, locate the file TOUR1.TMDX, and double click on this file to open it. 

Setting up a letterhead 

Naturally, our letter needs a distinguished-looking letterhead, with the company 

name in a larger font and perhaps a line that explains what our company has to 

offer. 

Let’s get to work! With (Ctrl)(Home) move the text cursor to the beginning of the 

document TOUR1.TMDX you just opened. Now type: 

Escher & Sons, Architects(¢) 

Design and Planning of Construction Projects of all Sizes 

The company name might safely be somewhat larger: Select the first line and, with 

aid of the Formatting toolbar, format it in the MicroSquare font, choose a font size 

of 32 points and turn on bold. 

32 is not present in the list of font sizes? It doesn’t matter – because the list offers 

only the most commonly needed sizes, and you can always enter values manually. 

Simply click on the font size shown in the Formatting toolbar, enter “32” there, and 

confirm with the Enter key (¢). 

By the way, you can even specify non-integer font sizes by using a decimal point 

(e.g. 11.6 points), for example, when the area at your disposal is fixed and you 

want the text to fit precisely. 
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In the end, the Formatting toolbar should look like this: 

 

Font is now set to MicroSquare 32 point bold 

Next we want to format the second line in MicroSquare 12 point italic. To do that, 

we must first select it as before. This time, however, don’t use the Formatting tool-

bar to change the font size. Instead, invoke Format > Character, so that you can 

get acquainted with this frequently needed command as well. 

A dialog box opens, revealing all the possibilities for formatting characters. 

 

Note: You will find detailed information about this dialog box in chapter 

“Character formatting” beginning on page 71. 

The settings in this dialog box are distributed over several “index cards”. You can 

switch between them by clicking on one of the tabs along the top of the dialog. As 

you can see, this dialog has tabs for Font, Spacing, and Hyperlink. Since we only 

want to modify the font, we can stay on the Font tab. 

Open the dropdown list Typeface by clicking on the little arrow to its right, and 

choose the MicroSquare font. Then choose the 12 point font size from the Size list 

to the right of the Typeface list. Turn on italic by opening the dropdown list Style 

and selecting the entry Italic. 
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Confirm the settings by clicking the OK button. Then save your document. 

Paragraph alignment 

The way TextMaker arranges text between the margins is called paragraph align-

ment.  

You change the paragraph alignment with the command Format > Paragraph. 

When you invoke this command, a dialog box appears. Open the dialog’s Align-

ment list on the Paragraph tab. Then, choose the desired paragraph alignment 

from the list. 

By the way, this can be done faster with the Formatting toolbar, which contains 

four icons that you can click on with the mouse to change the alignment:  

   Flush left 

   Centered 

   Flush right 

   Justified 

We’ll now center the company name. To do this, move the text cursor to the front 

of any character within the company name “Escher & Sons, Architects” and click 

on the icon for “Centered” in the Formatting toolbar. 

Note: Paragraph format actions – in other words, all format actions that you can 

carry out with the command Format > Paragraph – always affect complete pa-

ragraphs. So, if you want to modify the paragraph format of a single paragraph, 

you don’t need to select it first. Simply move the text cursor to any position 

within the paragraph. 

On the other hand, if you want to modify the formatting of several successive pa-

ragraphs, you must select them beforehand. The selection can begin at any position 

within the first paragraph and end anywhere in the last paragraph. 

Let’s try this out. Invoke the command Edit > Undo and the company name will 

again be formatted flush left. Starting from any letter in the company name, hold 

the mouse button down and drag the selection into the next line. Then click on the 

icon for “Centered” in the Formatting toolbar. Both paragraphs will now be cen-

tered. 
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After you have done this, your application screen should look something like this: 

 

We could now put our “With best regards” at the bottom of the letter and send it off 

without further ado. But there are no doubt still a few things in this letterhead that 

could be made more attractive. 

So let’s begin with some refinements. 

Tabs 

Before going further, you can open the document TOUR2.TMDX and compare it 

with your results so far. This document contains our example document as it should 

look at this stage of our work. 

Many business letters include a line with information like “Your reference,” “Your 

letter of,” etc. We want to insert such a line now, and, in the course of doing so, get 

acquainted with the application of tabs. 

Note: You insert tabs by pressing the Tab key. Although this key is labeled (_ÿ_) 

on most keyboards, the designator (Tab) is used in this manual to better distin-

guish this key from the arrow keys.  

Now move the text cursor to the beginning of the 17th line and type the following 

line: 



 

56  •  The TextMaker Tour Manual TextMaker 

Your reference:(Tab)Your letter of:(Tab)Our reference:(Tab)Our 

letter of:(Tab)Date: 

Next, format this line in the MicroSquare font, 8 point. 

You have now inserted tabs into the text, but you have not yet determined their 

exact positions. To do this, set the tab stops. By default, TextMaker automatically 

puts a tab stop every 0.5 inch – but in general you should not adopt this conventi-

on, which originated with the typewriter. 

Tab stops can be set with the command Format > Tabs or with the help of the ho-

rizontal ruler, which is displayed at the top of the document. 

 

The horizontal ruler 

If the horizontal ruler is not visible, you must turn it on first with the command 

View > Horizontal ruler. 

Using the ruler, you can set tab stops as follows: 

1. Select the paragraph in which the tab stops are to be set. 

 If you want to adjust the tab stops of several paragraphs, you must first select 

these paragraphs as previously described. 

 Now please select the line you just entered and the line below it, because we 

want the tab stops for the next line, which is to be filled out later, to be set the 

same way. 

2. Choose the desired tab type. 

 To change the tab type, click on the icon to the left of the ruler. Each mouse 

click rotates through the tab types, which are designated by the following icons: 

 Flush left tab 

 Centered tab (the text is centered on the tab position) 

 Flush right tab (the text ends at the tab position) 

 Decimal tab (numbers are aligned on the decimal separator) 

 To continue, click on this control until the icon for flush left tabs appears. 
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3. Click on the desired tab positions in the ruler. 

 With the mouse, click on the (approximate) positions 1 inch, 3 inches, 4 inches 

and 5.5 inches to set tab stops at those positions. Notice how the text is adjusted 

according to your settings. 

By the way, you could have proceeded in the opposite way: You could have defi-

ned the tab stops before you typed the line “Your reference,” etc., and then typed 

the text along with the tabs. 

The ruler and text should now look something like this: 

 

The tab stops are now set and are displayed in the ruler. 

If the position of a tab stop doesn’t suit you, you can shift it right there in the ruler: 

First, select the paragraphs to be modified as necessary; then, with your mouse, 

point at the tab stop and drag it to a new position in the ruler. Note also that when 

you drag a tab stop downward out of the ruler, it is deleted. 

There is yet another way to proceed when setting tab stops. With both paragraphs 

selected, invoke Format > Tabs. A dialog box opens and shows you the exact po-

sitions of the tab stops that are currently set. This dialog works as follows:  

To ... Do this ... 

Set new tab stops Enter the desired position in the Tabs field and click on 

Set. 

Delete tab stops Select one of the existing tab stops in the list and click 

on Clear. To remove all tab stops at once, click on Clear 

all. 

Shift tab stops Delete the tab stop and set a new one. 

Change the alignment Click on one of the tab stops given in the list, choose a 

new alignment with Alignment and click on Set. 

Back to our practice letter: 
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Now that the tab stops for the line “Your reference,” etc., and the line under it have 

been set, we want to put something in the second line. 

Move the text cursor to the beginning of this line (line 18) and type, for example, 

the following: 

MB(Tab)10/29/16(Tab)HG(Tab)10/25/16 

You see, since this line was selected along with the line above it when the tab stops 

were set, those same tab stops are used here too. 

Of course, what is still missing is today’s date. In the next lesson segment, we will 

let TextMaker insert it automatically and in this way we will get acquainted with 

fields. 

Inserting dates and other fields 

Today’s date should be inserted in the area below “Date:” which has remained 

empty up until now. Of course we don’t want to type it manually; rather, we leave 

this task to TextMaker. 

Insert a tab following the text you just entered with the (Tab) key and invoke the 

menu command Insert > Field.  

 



 

Manual TextMaker The TextMaker Tour  •  59 

From the Field type list, select the field “Print date”. On the right, in the Date 

Formats list, you can select the format in which the date is to be inserted. Choose 

the desired format and click on Insert. 

TextMaker now inserts the current date in the text and our letterhead looks some-

thing like this: 

 

Fields are very practical aids. First, you have already been spared the trouble of 

typing the current date manually, and beyond that, the “Print date” field is not 

merely a fixed value, but a symbolic value that stands for the current date. It is au-

tomatically updated when you print the document. So, if you print the practice let-

ter tomorrow, tomorrow’s date will appear in the same place. 

With the help of fields you can not only insert the date, but also output the current 

page number of your text, its filename and many other kinds of information. 

Furthermore, fields can be used to put in database fields from a database, as is re-

quired for form letters. 

Page footers 

Before you continue, you can open the file TOUR3.TMDX. It contains the example 

document as it should look at this stage of the exercise. 
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You can set up page headers and footers for every document – headers will be 

printed at the top, and footers at the bottom, of every page. 

For page footers you invoke the command Insert > Footer. Nothing much really 

happens: the text cursor is just positioned in the bottom margin. This is the area in 

which you can enter footers. 

This time we will select the MicroSquare font in 8 point before typing. So, select 

this font with the aid of the Formatting toolbar. Now, when text is entered it 

appears immediately in the chosen font. 

For the footer, type, for example, the address of our architecture firm and some 

other information like our firm’s bank details. Of course, you don’t have to follow 

the example exactly, if that is too much typing for you: 

Escher & Sons, Architects – 78 Baker Street – Atlanta, GA 

30009(¢) 

Telephone: 555-555-4242 - Fax: 555-555-4243 

Next, center both footer lines (select them first!) with the icon  in the Format-

ting toolbar, so that the footer lines appear on the screen something like this: 

 

To get back to the normal text after setting up the footer lines, simply click on any 

position in the text with the mouse. Later, if you want to edit the footer lines again, 

all you have to do is click again with the mouse on one of the footer lines. 

Give it a try: click on the line under “Bring your family along ...” in the text – and 

you are back in the text. 

This gives us an opportunity to place the complementary close under the last line 

of the text. Enter a blank line there with (¢) and type: 
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With best regards,(¢) 

(¢) 
(¢) 
(¢) 
M.C. Escher(¢) 

Escher & Sons, Architects(¢) 

With this, our letter is essentially finished. In this next and last lesson segment, all 

we want to do is place a line above the footer to emphasize it better. 

Lines and borders 

Note: You will find detailed information about this topic in section “Borders and 

lines” beginning on page 100. 

In a letter, a line is often drawn between the footer and the body text. This is very 

easily accomplished in TextMaker with the command Format > Borders. Its pur-

pose is to put border lines around a paragraph, or to put single lines along the left, 

right, top and/or bottom edges. 

To place a line above the footer, click into the first line of the footer and invoke the 

command Format > Borders.  

A dialog box similar to the following appears: 
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The dialog for border lines (here: for table cells) 

Essentially, you operate this dialog as follows: First, you specify what type of line 

you want. After that, you pick where to apply this line. 

Accordingly, to place a line above the paragraph, proceed as follows: 

1. First, choose what kind of border line you want – by specifying the following 

settings in the dialog:  

 Line style (single, double, or dashed lines) 

 Thickness  

 Color  

 In our example, we would like to have a single line, 1 pt. thick, in black color. 

 However, since these are the default settings of the dialog anyway, there’s actu-

ally nothing you have to do in the first step. 

2. After that, specify where to apply this line (top, bottom, left, right, etc.). For 

this purpose, a preview box surrounded by a set of buttons is available in the 

right half of the dialog.  

 To apply a border line, simply click on the corresponding border – right in the 

preview box. 
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 Alternatively, you can click on the buttons displayed to the left and below the 

preview. Each button represents one border (indicated by the symbol displayed 

on the icon). 

 In our example, add a border line above the paragraph by clicking on the top 

line in the preview (or, on the respective button). 

 We could add additional border lines by clicking on some of the other borders 

in the preview – however, all we currently want is a line at the top. 

3. Confirm with OK. 

The paragraph should now be displayed with a thin black line above it. 

Normal text paragraphs can be furnished with lines using the same method as for 

footers. The same even goes for some types of objects – for example, table cells. 

Printing the practice letter 

If you want, you can now print your first composition for proofing. To do this, in-

voke the command File > Print. 

 

The dialog box for File > Print 
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In the “Print” dialog box you can determine how many copies and which pages are 

to be printed. By default, one copy of all pages is printed. So confirm with OK. 

Hint: Before actually printing a document, you can preview the printout using 

the File > Print preview menu command. 

Finished! 

Our TextMaker Tour ends here. You will find the final example document (for the 

completed TextMaker Tour) in the file TOUR4.TMDX. 

You now know many of the program’s basic functions and you ought to take some 

time at this point to investigate them further. It would be a good exercise, for exa-

mple, to format the letter differently, to give it a more attractive font, etc.  

Next, you can delve into the rest of the manual. It has been intentionally put toge-

ther in such a way that you can read a single chapter at a time as it becomes neces-

sary in the course of your work. So step by step you can familiarize yourself with 

the functions as you want to use them. 

Have fun with TextMaker! 
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Working with selections 
This chapter marks the beginning of the reference section of the manual. This part 

of the manual provides detailed descriptions of all TextMaker’s functions orga-

nized into chapters by subject matter, as is customary in a reference book. 

The first chapter in the reference section is about working with selections. When 

you want to delete, copy, or move a part of a document, you must first select it. 

This is the case for objects (pictures, drawings, etc.) as well as for text. 

In addition, you must select a text segment before you can apply certain commands 

that modify its formatting. For example, if you want to format a single word in a 

specific font, you must select the word before you specify the font. 

The following pages will teach you everything there is to know about working with 

selections. Topics covered: 

 Selecting text and objects 

 Moving, deleting and copying 

 Pasting with special formatting 

 Inserting a document 

Selecting text and objects 

Before you execute a TextMaker command you can, in many cases, select a seg-

ment of text (or an object) to which you want the command to apply. The com-

mand is then performed only on the selected text or object. 

Depending on the operating system in use, the way you proceed when selecting 

something is a bit different. For that reason, this section is split into two parts: 

 Selecting in the Windows, Mac, and Linux version 

 Selecting in the Android version 
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Selecting in the Windows, Mac, and Linux version 

In the Windows, Mac, and Linux version of TextMaker, you can make a selection 

either with the mouse or the keyboard: 

Using the mouse for selection 

You make selections with the mouse as follows: 

 Selecting text 

 To select a text segment of any length, position the mouse cursor at the begin-

ning of the segment, press and hold down the left mouse button, and drag the 

cursor to the end of the segment. 

 To select a word, double click on the word. 

 To select an entire line, click into the left page margin beside the line. You can 

select multiple lines by dragging the mouse pointer up or down beside them in 

the left margin. 

 To select a whole paragraph, double click into the left margin beside the para-

graph. 

 To select the whole document, press and hold the (Ctrl) key and click into the 

left page margin (beside any paragraph of the document). 

 Selecting objects 

 To select an object (e.g. a picture, a drawing, etc.), simply click on it with the 

mouse. A frame appears around the object to indicate that it is selected. 

Using the keyboard for selection 

You make selections with the keyboard as follows: 

 Selecting text 

 Move the text cursor to the beginning of the text segment you want to mark. 

Press the Shift key (ª), hold it down, and move the cursor in any direction with 

the arrow keys. 

 You can select as little as a single character with (Shiftª)(æ) or (Shiftª)(Æ), 

and as much as whole pages with (Shiftª)(PgUp½) or (Shiftª)(PgDn¼). 
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 To select the whole document, you can correspondingly use the key combinati-

on (Ctrl)(Home), followed by the key combination (Ctrl)(Shiftª)(End). Or, al-

ternatively, invoke the menu command Edit > Select all which does the same. 

 Selecting objects 

 Objects can be selected only with the mouse (see above). 

Selecting in the Android version 

In the Android version, the procedure for selecting something is a bit different. You 

can use either your finger or a mouse. Proceed as follows: 

 Selecting text 

 The easiest way to select a segment of text is the following: 

 Select the word that you want to use as the starting point of the selection by 

double-tapping on it. Large “handles” will appear before and after the word to 

indicate that the word is now selected. 

   

 These two handles represent start and end of the selection. They allow you to 

extend the selection easily: Simply drag these handles to the desired positions. 

 Selecting objects 

 To select an object (picture, drawing, etc.), tap on it. A frame appears around 

the object to indicate that it is selected. 

Moving, deleting and copying 

All the operating systems that TextMaker supports have an extremely useful fea-

ture: the clipboard. 

The clipboard works like this: when you select something in the document and 

then cut or copy it, your selection goes into the clipboard. The clipboard holds the 

selection temporarily, so that it is available for reinsertion anywhere in the 
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document. In this way, the clipboard facilitates the deletion, copying and moving 

of text segments (as well as objects). 

All the required commands are found in the Edit menu: 

Command Explanation 

Delete If you select a text segment (or object) and invoke the menu com-

mand Edit > Delete, the segment or object will be deleted – without 

being moved into the clipboard. There is a keyboard shortcut for this 

command to invoke it faster: the (Del) key. 

Cut The Edit > Cut menu command likewise deletes the content of a 

selection – but not permanently. Instead, it places this content in the 

clipboard, so that it remains available for insertion later anywhere in 

the document.  

Copy The Edit > Copy menu command copies the content of the selection 

into the clipboard. 

Paste You use the Edit > Paste menu command to insert the content of the 

clipboard into the text. Move the text cursor to the place in the text 

where you want to make the insertion and then invoke this com-

mand. You can insert the content of the clipboard multiple times in 

this manner. 

Everything works the same way for objects like pictures and drawings, as it does 

for text. 

Moving and copying text with the mouse (“drag and drop”) 

Note: This feature is not available in the Android version. 

You can select a text segment with the mouse, drag it to another position and drop 

it there. With this technique, known as “drag and drop”, you can move or copy 

text very quickly. 

Proceed as follows: 

1. Select the text segment. 

2. Position the mouse cursor on the selection. 

3. Press the left mouse button and hold it down. 

4. With the mouse button held down, drag the selection to the desired position. 
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5. When you release the mouse button, the content of the selection is moved to the 

new position. When you release the mouse button while pressing the (Ctrl) key, 

the selection is instead copied to the new position. 

Pasting with special formatting 

In addition to common clipboard operations like Cut, Copy, and Paste, TextMaker 

offers the Edit > Paste special menu command which gives you more control over 

how the clipboard content is pasted into your document. 

In detail: 

When you place information in the clipboard using the Cut or the Copy command, 

this information is saved there in several formats. For example, if you cut or copy 

text, the text is saved both in formatted form and in unformatted form. 

Normally, you don’t need to be concerned about this, because TextMaker automa-

tically selects the most appropriate format when it inserts the content of the clip-

board into your document in response to a Paste command. However, if you need 

to, you can select the format in which the content is to be inserted yourself. You 

use the Edit > Paste special menu command to do this. 

When you invoke this command, a dialog box appears and presents you with a list 

of all the formats in which the information currently residing in the clipboard is 

saved. When you select a format and then confirm with OK, the content of the 

clipboard is inserted in the selected format.  

Inserting a document 

FreeOffice: The Insert Document menu command is not included in SoftMaker 

FreeOffice. 

With the Insert > Document menu command, you can insert a complete TextMa-

ker document into the current document. 

Note: Objects in frames (e.g. text frames, picture frames, etc.) will not be im-

ported. 

Proceed as follows: 
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1. Move the text cursor to the position in the current document at which the other 

document is to be inserted. 

2. Invoke the menu command Insert > Document. 

3. A dialog box opens and allows you to select the document to be inserted. 

4. After making your selection, confirm with OK. 

The selected document is inserted. 
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Character formatting 

Using the Format > Character menu command, you can change the appearance 

of one or more characters in the text. 

 

The options in the dialog of the Format > Character menu command are distribu-

ted over several “index cards”. You can switch between them by clicking on one of 

the tabs along the top of the dialog: 

 Font tab 

 For selecting the typeface and font size, font styles (like bold, italic, underli-

ned), colors and language 

 Spacing tab 

 For changing properties like super- and subscript, character spacing and pitch, 

and kerning 

 Hyperlink tab 

 For inserting and editing hyperlinks (e.g., to web pages). You will find informa-

tion about this topic in section “Creating hyperlinks” beginning on page 481. 
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Modifying character formatting 

There are two ways to modify character formatting: 

 After text has been entered, you can modify character formatting by selecting 

the desired text, invoking the Format > Character menu command and ma-

king the desired changes. 

 As you type new text, you can modify character formatting by pausing to select 

the format for the text to follow with the Format > Character dialog, and then 

continuing to type. For example, you can select a new font. From that point on, 

all text that you enter will appear in the new font – until you again make a font 

selection. 

Additional information on the topic of character formatting is presented on the 

following pages. 

Typeface and font size 

To change the typeface and/or the font size, do the following: 

1. Select the text to be modified. 

2. Invoke the menu command Format > Character.  

3. In the associated dialog, switch to the Font tab (if necessary). 

Now you can set the desired typeface and font size: 

 To change the typeface, open the Typeface dropdown list box by clicking on 

the small arrow to its right and select the desired typeface.  

 The most useful font sizes are presented in the Size dropdown list box. You can 

select one of these sizes or enter a different size manually. Type sizes can be 

given with a precision of a tenth of a point – thus a size such as 12.7 is allowed. 

Font sizes are usually given in points (abbreviated “pt”). As a rule, you should use 

font sizes between 10 and 12 points for normal text, and a somewhat larger size, 

say 14 to 18 pt, for headings. Major headings may be even larger (24 pt, for exa-

mple). 
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Using the Formatting toolbar 

You can also change the typeface and font size with the Formatting toolbar. 

 

The Formatting toolbar 

This is done by selecting the text you want to format, opening the dropdown list 

box containing typefaces or the one containing type sizes and selecting the desired 

format from the list with a mouse click. 

Text styles 

Text styles are formatting options like bold, italic, underline, etc. that give emphasis 

to text.  

TextMaker supports the following text styles: 

 Italic: A slanted variant of the typeface. 

 Bold: A heavier (“thicker”) variant of the typeface. 

 Underline: The text is underlined (single, double, words only single, words 

only double, etc.).  

 SMALL CAPS: Lowercase letters are replaced with small uppercase letters. 

 ALL CAPS: All letters are rendered in uppercase. 

 Strike out: The text is struck through. 

 Hidden: The text does not appear on the screen, or on the printed page, or both 

(see the section “Hiding text” beginning on page 78). 

 Protected: The text cannot be modified (see the section “Protecting text” be-

ginning on page 79). 

 Superscript (e.g. r2 ) and subscript (e.g. H2O): These text styles are found on 

the next tab (see “Superscripts and subscripts” beginning on page 76). 

 Text color and Background color: see the next section 

 Language: If necessary, you can also specify the language of a section of text 

(only required when you use more than one language in a document – see sec-

tion “Setting the language” beginning on page 330). 
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Applying text styles 

To apply text styles, proceed as follows: 

1. Select the desired text. 

2. Invoke the menu command Format > Character. 

3. In the associated dialog, switch to the Font tab (if necessary). 

To turn on bold or italic, open the Style list (to the right of font size option) and 

select the desired style from the list: Regular, Italic, Bold or Bold-Italic. 

To apply other text styles, turn them on or off by clicking on the corresponding 

checkbox in the Styles section of the dialog. 

You are not limited to just one style; rather, you can apply combinations of the sty-

les to text (although not all combinations are possible). 

Using the Formatting toolbar 

The most commonly used text styles can also be applied using the Formatting tool-

bar. 

 

Click on the icon for the text style you want to apply or remove: The B stands for 

bold, the I for italic, and the U for single underline. 

Keyboard shortcuts 

There are also keyboard shortcuts for the application of text styles:  

Command  Windows/Linux  Mac 

Bold            (Ctrl)(B)            (Cmd)(B) 

Italic  (Ctrl)(I)  (Cmd)(I) 

Underline  (Ctrl)(U)  (Cmd)(U) 
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Text color 

You can specify the color for both the text itself and for its background. 

To do this: 

1. Select the desired text. 

2. Invoke the menu command Format > Character. 

3. In the associated dialog, switch to the Font tab (if necessary). 

You can now select the desired color for the text from the Text color list. 

You can also specify a background color for the text using the Background color 

list. By default, the background color is set to Transparent. If you choose a diffe-

rent color for the background, the text will appear against this color. 

Notes 

 If none of the existing colors offered in the color list suits you, you can always 

compose your own colors. To do this, click on “Define color...”, which is the 

last item in the color list (see also section “Document properties, Colors tab” 

beginning on page 564). 

 The default color named “Auto” has a special feature: Text formatted in this 

color is normally displayed in black. However, when you change the back-

ground color of the text to some very dark color, this color automatically swit-

ches to white (to keep the text readable). 

 The text color can also be changed using the  icon in the Formatting 

toolbar:  

 To do so, select the text of interest and click on the little arrow right of this icon 

(not on the icon itself). Then, choose the desired color from the list that opens. 

 Tip: To apply to same color to another piece of text, select the text and simply 

click on the icon itself. 

 Directly to the right of the font color icon, the Formatting toolbar additionally 

offers an icon for the Highlighter function. This control works exactly the sa-

me way as the text color control, but adds a colored background to the selected 

text – just like a highlighter. 

 Note: This color is not identical to the background color described above. It is 

an additional color (that can be applied only via this icon). That is not necessa-
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rily logical, but Microsoft Word offers this feature exactly this way, so it was 

implemented in TextMaker the same way for compatibility reasons. 

Superscripts and subscripts 

You can position text above or below the baseline and in this way create a super-

script (e.g. r2 ) or subscript (e.g. H2O). 

Simply select the text, invoke the menu command Format > Character, switch to 

the Spacing tab and check the Superscript or Subscript check box. 

If you wish, you can specify the amount of offset above or below the baseline by 

entering a percentage in the Position edit box. In addition, you can specify the size 

reduction to be applied to the superscripted or subscripted text by entering a per-

centage in the Size edit box. For example, if you want a subscript to be the same 

size as adjoining normal text, you can specify 100 percent. 

Letter spacing and character pitch 

TextMaker also allows you to change the spacing and pitch of text. 

Spacing is the horizontal distance between characters. Giving a value smaller than 

100% causes the characters to appear closer together than normal; giving a value 

larger than 100% causes the characters to appear farther apart. 

If you change the character pitch, the width of the characters themselves, rather 

than the spacing between them, is affected. 

To change these settings, invoke the menu command Format > Character, switch 

to the Spacing tab and enter the desired value at Spacing between characters or 

Character pitch. 

Note: For some printers, changing the pitch of characters formatted in one of the 

printer’s internal fonts is ignored in the printout. 
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Kerning 

Certain pairs of letters look better when the spacing between these letters is re-

duced or increased a bit. Such adjustments, called Kerning, can be made automati-

cally by TextMaker. 

A picture illustrates best what kerning is about: 

 

Top: without kerning, bottom: with kerning 

The upper half of the picture (without kerning) shows that the letters “V” and “A” 

are too far apart when no kerning is applied. In the lower half (with kerning), this 

has been corrected. 

To activate kerning, select the text of interest, choose the Format > Character 

menu command, switch to the Spacing tab and activate the option Use kerning. 

TextMaker now automatically adjusts the spacing between all letters where this 

would improve the text appearance. 

Note: Not all typefaces provide kerning information in their font data, which is 

required to determine which letter pairs to adjust and how. Almost all font collec-

tions published by SoftMaker include extensive kerning information. 

Transferring formatting 

With the menu command Format > Transfer formatting you can quickly apply a 

character’s format (typeface, size, styles etc.) to other characters. 

To do so, proceed as follows: 

1. Select the character whose format you want to transfer. You can also select mul-

tiple characters; they should however have the same character format. 

2. Invoke the menu command Format > Transfer formatting. 
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 The mouse pointer now becomes a little brush:  

3. Drag the mouse (with the mouse button held down) over the characters to 

which the format is to be transferred.  

Hint: If you press and hold the (Ctrl) key while you do this, not only the cha-

racter format is transferred but also the paragraph format. 

4. If you want to apply the format to additional characters, repeat step 3 as often 

as required. 

5. When finished, invoke the Transfer formatting command again or simply 

press the (Esc) key. 

Hiding text 

You can hide sections of text. Normally, hidden text is displayed on the screen but 

not printed. 

Hidden text is ideal for comments or notes that you want to incorporate into a 

document so that, for example, they will be viewable on the screen, but not appear 

on the printed page. 

Hiding text 

To hide text, do the following: 

1. Select the text you want to hide. 

2. Invoke the menu command Format > Character. 

3. Switch to the Font tab. 

4. Check the Hidden option.  

The text is now hidden. By default, it will still be displayed on the screen, but will 

not appear on the printed page. 
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Displaying/printing hidden text 

By default, hidden text is visible on the screen but does not appear on the printed 

page. However, you can specify in the document’s properties whether hidden text 

is to be visible on the screen and whether it is to be printed. 

To do this, invoke the menu command File > Properties and switch to the View 

tab. In the Hidden text section, you will find the following options: 

 Show hidden text 

 This option controls the visibility of hidden text on the screen. 

 By default, this option is checked, so that hidden text is visible. Hidden text is 

displayed with a dotted underline to distinguish it from normal text. 

 If you disable this option, hidden text is not visible on the screen. 

 Print hidden text 

 The Print hidden text option controls the printing of hidden text along with the 

document’s normal text. 

 By default, this option is not checked and hidden text is not included on the 

printed page. 

 If you want all hidden text segments to be printed you must enable this option. 

Removing the “Hidden” property 

If you want to remove the Hidden formatting, do the following: 

1. Make sure that the Show hidden text option in the document properties is 

enabled (see above), so that you can see the text.  

2. Select the hidden text, invoke the menu command Format > Character and 

uncheck the Hidden option on the Font tab. 

The text is now without the Hidden property. 

Protecting text 

You can protect a segment of text to prevent it from being changed or deleted. 
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Protecting text 

To protect text, do the following: 

1. Select the text you want to protect. 

2. Invoke the menu command Format > Character.  

3. Switch to the Font tab. 

4. Check the Protected option. 

Text that is protected in this manner cannot be edited. If you position the text cur-

sor in such text and attempt to insert or delete something, your attempts will have 

no effect. 

Important note: If you select a range of text that includes some protected text 

and delete the entire range, the protected text included in the range will be dele-

ted along with the other text! Protection only prevents editing or deleting within 

the protected segment itself. 

Removing the “Protected” property 

To remove the “Protected” property, select the segment of protected text, invoke 

the menu command Format > Character and uncheck the Protected option on the 

Font tab. 

The text segment is no longer protected and can be edited as normal. 

Removing character formatting 

In case you need to remove character formatting, TextMaker lets you do this easily. 

Proceed as follows: 

1. Select the text segment of interest. 

2. Invoke the menu command Format > Standard. 

TextMaker now removes any character formatting that you have applied to the sel-

ected text. 
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Paragraph formatting and character formatting that is part of a paragraph style 

remains in place. 

Note: This process also removes the Hidden and Protected property of charac-

ters. Accordingly, text that was previously hidden becomes visible, and text that 

was previously protected can again be edited. 

Changing the default character format 

You can easily modify the default character format settings anytime. For example, 

if you don’t like the default font face in a document, setting it to a different font is 

just a matter of a few mouse clicks. 

Proceed as follows: 

1. Invoke the menu command Format > Character.  

2. In the dialog, adjust the character format settings to your liking.  

3. Now comes the distinctive step: Instead of clicking on OK, click on the Set as 

default button. 

4. TextMaker asks you if you want to change the default settings only for the cur-

rent document or for all future documents: 

 Change in this document only: If you choose this option, the new default set-

tings will affect only the current document. 

 Change for all new documents: If you choose this option, the new default 

settings will also be stored in the standard document template (Normal.tmvx), 

meaning that all future documents will use these settings. 

5. Make a choice and confirm with OK. 

6. To exit the dialog, click on OK once more. 

TextMaker will now save the formatting options that you have chosen in the dialog 

as the new default character format. 

(For advanced users: Technically speaking, TextMaker simply applies these set-

tings to the default character style “Normal”. See also section “The character style 

Normal”, page 135.) 
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Paragraph formatting 

To specify the formats for paragraphs, use the Format > Paragraph menu com-

mand. 

Some of the most common paragraph formats include: 

 Indents 

 Line spacing 

 Spacing above/below a paragraph 

 Paragraph alignment 

 Character format for entire paragraphs 

 Tabs 

The following additional paragraph formats are available: 

 Bulleted lists (and numbered lists) 

 Drop caps 

 Shading 

 Borders and lines 

 Outline level 

 Hyphenation frequency (see section “Hyphenation”) 

 Forcing breaks before paragraphs (page breaks, column breaks) 

 Paragraph control (keeping certain paragraphs together, etc.) 

 Suppressing line numbers 

See the next pages for details. 

Paragraph formats always apply to complete paragraphs. Changes to paragraph 

formatting affect the entire paragraph in which the text cursor is positioned. If you 

select multiple paragraphs, all the selected paragraphs are affected. 

Changing the paragraph formatting 

You can modify the paragraph formatting in either of the following ways: 

 To change the formatting of paragraphs after they have been typed, select the 

paragraphs of interest, invoke the Format > Paragraph menu command and 

make the desired changes.  

 To change the paragraph formatting while typing new text, set the desired for-

matting with Format > Paragraph without anything selected. The current pa-

ragraph is re-formatted according to your settings. Moreover, from this point 
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on, every new paragraph that you begin by pressing the Enter key (¢) takes on 

the same new format – until you change the paragraph formatting again. 

Paragraph styles (for the advanced user): You will find that paragraph styles can 

relieve you of a considerable amount of the work involved in formatting para-

graphs. With their help you can apply pre-defined formats to paragraphs very 

quickly. You will find information about this topic in the chapter “Styles” begin-

ning on page 129. 

Units of measure: You can enter values in TextMaker’s dialog boxes not only in in-

ches*, but also in other units of measure. To enter a value in specific units, simply 

add one of the following units of measure after the number: 

Unit Explanation 

cm centimeter 

in inch – 1 in equals 2.54 cm. 

pt point – 72 pt equal 1 in. 

pi pica (character) – 1 pi equals 12 pt. 

* The default unit of measure depends on your computer’s region settings. 

For example, if you type 7.62 cm as the position for a tab stop, TextMaker puts it at 

3 in (= 7.62 cm). 

Indents 

With the help of indents, you can change the left and right margins of paragraphs to 

inset or widen text. The indent for the first line of a paragraph can be specified se-

parately. 

Indents are always given relative to the page margins. For example, if the left page 

margin is set at 1 in and you set the Left indent to 1.5 in, the text begins at 2.5 in. 

Note: You set the page margins themselves with the help of the File > Page 

setup menu command, not with indents. 

To use indents, place the text cursor in the desired paragraph or select multiple 

paragraphs to be modified. Then, invoke the Format > Paragraph menu com-

mand and switch to the Paragraph tab. 
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In the Indents group box, you can set the Left indent, the Right indent, and the 

First line indent. Enter the desired values in the respective edit boxes. 

You can also enter negative values when, for example, you want to widen the text. 

Using the Horizontal ruler 

Indents can also be set with the help of the horizontal ruler, which is displayed 

above the document. (If the horizontal ruler is not visible, you must turn it on first 

with the command View > Horizontal ruler.) 

Indents are shown in the ruler as small handles, as follows: 

 

The horizontal ruler (with colorized indent handles) 

To change an indent, first select the paragraph(s) you want to modify; then click 

with the mouse on the corresponding handle (see illustration), hold the mouse but-

ton down and drag the handle to the desired position. 

Note: When changing the Left indent, be careful to catch hold of the correct hand-

le: The lower triangle is the one that will affect this indent. Likewise, the upper 

triangle is only for the First line indent. The rectangular slider under both triangles 

changes both the Left and First indents together.  

Keyboard shortcuts 

Indents can also be changed using the following keyboard shortcuts: 

Command  Windows/Linux  Mac 

Increase left indent            (Ctrl)(M)            (Cmd)(M) 

Decrease left indent  (Ctrl)(Shiftª)(M)  (Cmd)(Shiftª)(M) 

Increase hanging indent*  (Ctrl)(T)  (Cmd)(T) 

Decrease hanging indent*  (Ctrl)(Shiftª)(T)  (Cmd)(Shiftª)(T) 

* Increases the Left indent while at the same times decreasing the First line indent. As a result, the first 

line of the paragraph keeps its position and only the other lines are indented. 
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Line spacing 

Line spacing is the distance between the lines of a paragraph. 

To change the line spacing, do the following: 

1. Place the text cursor in the paragraph of interest (or select multiple paragraphs 

to be modified). 

2. Invoke the Format > Paragraph menu command. 

3. Switch to the Paragraph tab. 

 You will find the options for line spacing in the Line spacing group box: 

4. First, select the method you want to use to specify the line spacing (see below) 

from the dropdown list box. 

5. Then enter the spacing in the edit box to its right. 

When you confirm with OK, the line spacing will be changed according to your 

settings. 

Methods of specifying the line spacing 

You can specify the line spacing in different ways. The Line spacing dropdown list 

allows you to choose from the following methods:  

 Single 

 Automatic single line spacing. 

 Determines the optimum line spacing automatically: 

 If you increase the font size in the paragraph, the line spacing will be increased 

accordingly.  

 If you decrease the font size, the line spacing is reduced accordingly. 

 Multiple 

 Multiple of automatic single line spacing. 

 Just like the Single option, this option determines the optimum line spacing 

automatically. However, whenever required, you can increase or decrease the 

line spacing easily: Simply enter the desired number of lines into the edit box 

right of this option. 
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 Some examples: 

 When you enter “1.5” in the Lines edit box, the automatically determined spa-

cing is multiplied by 1.5 (giving you automatic one and a half line spacing). 

 When you enter “2”, the automatically determined spacing is multiplied by 2 

(giving you automatic double line spacing). 

 Entering “1” corresponds to choosing the option Single (giving you automatic 

single line spacing). 

 Exactly 

 Fixed line spacing. 

 If you choose this option, you can enter the exact line spacing manually in 

points. Here, the line spacing will not be adapted to the font size. 

 Tip: A rule of thumb for correct line spacing is: 

  Line spacing = Font size * 1.2 

 So, for a 10 point font a line spacing of about 12 points is suggested. 

 At least 

 Automatic line spacing with a given minimum. 

 Just like the Single option, this option also provides automatic single line spa-

cing – but prevents any reduction below the specified minimum value.  

 So, if you enter e.g. 12 points as a minimum value, normally automatic single 

line spacing is applied. However, if the automatic line spacing becomes smaller 

than 12 points (for example, because you used a very small font size), a fixed 

line spacing of 12 points is applied instead. 

By default, the line spacing is set to Single. 

Keyboard shortcuts 

Keyboard shortcuts are available for the most common settings, as follows: 

Command  Windows/Linux  Mac 

Automatic single line spacing (1 line)            (Ctrl)(1)            (Cmd)(1) 

Automatic one and a half line spacing (1.5 lines)  (Ctrl)(5)  (Cmd)(5) 
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Command  Windows/Linux  Mac 

Automatic double line spacing (2 lines)  (Ctrl)(2)  (Cmd)(2) 

Spacing above/below a paragraph 

Besides the line spacing, you can specify the amount of empty space to be added 

above the first line and below the last line of a paragraph.  

To change these settings, invoke the Format > Paragraph menu command and 

switch to the Paragraph tab. 

In the Paragraph Spacing group box, the following options are available: 

Before 

Here you can set the amount of spacing to be added between the end of the previ-

ous paragraph and the beginning of the current paragraph. 

After 

Here you can set the amount of spacing that TextMaker should reserve between the 

end of the current paragraph and the beginning of the next paragraph. 

Suppress for paragraphs with the same paragraph style 

This option was introduced mainly for compatibility reason with Microsoft Word. 

Enabling it has the following effects: 

 If the current paragraph and the previous paragraph utilize the same paragraph 

style, the spacing Before will not be applied. 

 If the current paragraph and the next paragraph utilize the same paragraph style, 

the spacing After will not be applied. 

By default, the option is disabled. 
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Paragraph alignment 

The way TextMaker arranges text paragraphs is called paragraph alignment. In 

TextMaker there are four kinds of paragraph alignment, listed as follows: 

 Flush left  

 Centered 

 Flush right 

 Justified (evenly distributed between left and right margin) 

To modify the paragraph alignment, proceed as follows: 

1. Place the text cursor in the paragraph of interest (or select multiple paragraphs 

to be modified). 

2. Invoke the Format > Paragraph menu command. 

3. Switch to the Paragraph tab. 

4. Select the desired paragraph alignment from the Alignment dropdown list. 

The paragraph alignment changes accordingly. 

Using the Formatting toolbar 

You can also use the Formatting toolbar to change the alignment. To do so, click on 

one of the following buttons: 

   Flush left 

   Centered 

   Flush right 

   Justified 

Keyboard shortcuts 

The paragraph alignment can also be changed using the following keyboard short-

cuts: 

Command  Windows/Linux  Mac 

Flush left            (Ctrl)(L)            (Cmd)(L) 
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Command  Windows/Linux  Mac 

Centered  (Ctrl)(E)  (Cmd)(E) 

Flush right  (Ctrl)(R)  (Cmd)(R) 

Justified  (Ctrl)(J)  (Cmd)(J) 

Character format for entire paragraphs 

In the dialog box for the Format > Paragraph menu command, you will also find 

a button called Character on the Paragraph tab. With the help of this button, you 

can modify the character formatting (font, text style, etc,) for entire paragraphs. 

This is especially useful in paragraph styles (see section “Paragraph styles”, begin-

ning on page 138). 

To change the character formatting of complete paragraphs, select the paragraphs 

you want to change, invoke the Format > Paragraph menu command and click 

on this button. A dialog box like the one for the Format > Character menu com-

mand will appear and let you set up the desired character format (see chapter 

“Character formatting”, beginning on page 71). 

Tabs 

A tab stop is a kind of “jump target” that you can use to position the text cursor at a 

specific point within a line by inserting a tab. Tabs help you to compose, for exa-

mple, tabular reports. 

To work with tabs, two steps are required: 

1. Define the tab stops with the Format > Tabs menu command. This command 

is used to specify the positions for which tabs will move the cursor. 

2. Now you can use the (Tab) key to make the text cursor jump from one tab stop 

to the next – this is called inserting tabs. 

For detailed information on using tabs, see the pages that follow. 
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Using tabs 

By default, tab stops are preset at 0.5 inch intervals. However, these preset tab 

stops are merely relics from the era of the typewriter, and you are by no means 

limited to them. 

You can define different tab stops for every paragraph of the document. 

To set tab stops, proceed as follows: 

1. Place the text cursor in the paragraph of interest (or select multiple paragraphs 

to be modified). 

2. Invoke the menu command Format > Tabs. 

  

3. In the Tabs edit box, enter the desired position relative to the left page margin – 

thus, “0” corresponds to the left page margin.  

4. If desired, select another Alignment and another Tab leader for the tab stop 

(see below). 

5. Don’t forget: Click on the Set button.  

6. Set up any additional tab stops you need in the same way before you exit the 

dialog box with OK. 

Once tab stops have been set, you can use the (Tab) key to insert tabs in the text to 

move from one tab stop to the next. 
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Note: You can also use this dialog to enter the Default width for the predefined tab 

stops mentioned earlier (normally 0.5 inch). However, once you have defined your 

own tab stops for a given paragraph, the predefined tab stops are ignored. 

Tab alignment 

Using the Format > Tabs menu command, you can specify not only the position 

for a new tab stop, but also its alignment: 

Alignment Function 

Left A normal “left-aligned” tab stop: The tab stop determines where 

the following text begins. 

Centered The text after the tab is centered on the tab position. Thus, the 

tab stop determines where the middle of the text falls. 

Right Here the text following the tab is aligned flush right. Thus, the 

tab stop determines where the text ends. 

Decimal For formatting columns of numbers. The numbers are positioned 

in such a way that their decimal separators are vertically alig-

ned. 

Hint: To change the alignment of an existing tab stop, invoke the Format > Tabs 

menu command. Select one of the tab stops that have been set, change its align-

ment by selecting a new alignment from the Alignment list and click on Set. 

Tab leader 

The space that a tab skips over can be filled with a leader character, if desired, as 

follows: 

None  A tab without a leader 

Solid _______________  A tab with underscores as leaders 

Dashed -------------------  A tab with dashes as leaders 

Dots ...............................  A tab with dots as leaders (used frequently in tables of 

contents and indices) 

Middle dots ··············  A tab with middle dots as leaders 
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Hint: To provide an existing tab stop with a leader, invoke the Format > Tabs 

menu command. Select one of the tab stops that have been set, choose the desired 

leader from the Tab leader list and click on Set. 

Deleting and moving tab stops 

Tab stops can be modified at any time after they have been defined. For this purpo-

se, select the paragraphs whose tab stops are to be edited, and invoke the Format > 

Tabs menu command. 

To remove one of the tab stops, select it from the Tabs list and click the Clear but-

ton. To remove all tab stops, use the Clear all button. 

Note: It is not possible to move a tab stop to a new position with this command. 

You can only can clear the tab stop and then set a new one at the desired position. 

However, moving tabs is easier with the horizontal ruler, as described in the next 

section. 

Using the horizontal ruler 

All tab stops set for the current paragraph are shown in the horizontal ruler as in 

the following example: 

 

The horizontal ruler (with some flush left tabs set at various positions) 

With this ruler, tab stops can easily be set, moved and deleted. 

To set tab stops, proceed as follows: 

1. Place the text cursor in the paragraph of interest (or select multiple paragraphs 

to be modified). 

2. To choose the desired tab type, click on one of the following icons in the For-

matting toolbar: 

 Flush left tab 

 Centered tab (the text is centered on the tab position) 

 Flush right tab (the text ends at the tab position) 

 Decimal tab (numbers are aligned on the decimal separator) 
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 Alternatively, you can click the icon directly left of the ruler to change the tab 

type. Each mouse click rotates through the available tab types. 

3. When the desired tab type is set, click on the ruler on the desired position to set 

the tab stop. If you want to set additional tab stops, simply repeat the last step.  

If the position of a tab stop does not suit you, you can move it very easily by cli-

cking on it with the mouse and, while holding the mouse button down, dragging it 

to another position. 

To clear a tab stop, drag it downward outside the ruler. 

Bulleted lists 

Lists in which each item is placed in its own paragraph and set off with a marker, 

are much easier to read than comma separated lists. The markers used for such lists 

(typically little boxes, circles, etc.) are called bullets. 

Creating bulleted lists is an easy task for TextMaker users: TextMaker can add 

bullets to paragraphs and automatically inset them with the press of a key. 

Alternatively, you can create lists whose elements are numbered rather than bulle-

ted. In this case, the paragraphs are automatically numbered with 1., 2., 3., etc. You 

will find information about this in chapter “Automatic numbering” beginning on 

page 181. 

Adding bullets 

To begin a bulleted list, do the following: 

1. Invoke the menu command Format > Bullets and numbering. 

2. Switch to the Bullets & Simple numbering tab. 

3. Under Type, select the option Bullet. 
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4. Select the kind of bullet you want by clicking on one of the bullets in the Bullet 

section. 

5. Confirm with OK. 

6. Now type your text. At the end of the paragraph press the Enter key (¢) to 

start a new paragraph. TextMaker automatically indents the paragraph and adds 

a bullet. 

Naturally, you can also add bullets to paragraphs after they have been typed. To do 

this, select the text, invoke the command introduced above, and select a bullet. 

Removing bullets 

To end a list or remove existing bullets, proceed as follows: 

1. At the end of the last bulleted paragraph, press the Enter key (¢) to start a new 

paragraph. 

 Alternatively: Select the bulleted paragraphs where you want the bullets to be 

removed. 
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2. Invoke the menu command Format > Bullets and numbering. 

3. Switch to the Bullets & Simple numbering tab. 

4. Turn bulleting off by selecting the option None in the Type group box. 

5. Confirm with OK. 

Dialog options 

The Bullets & Simple numbering tab in the dialog of the Format > Bullets and 

numbering menu command allows you to make the following settings for bullets: 

 Type 

 Here you can specify either a Bullet or Numbering for the paragraph. So, for 

bullets you select the Bullet option. (For more information about numberings, 

see the section “Simple enumerations” beginning on page 182.) 

 If you set the Type to None, any existing bulleting or numbering is removed. 

 You can transform a bulleted list into a numbered list any time you like by 

changing the Type to Numbering. Naturally, you can also do the opposite. 

 Default and Custom 

 Here you can select the bullet to be used. Predefined bullets are presented in the 

Default row. The bullets presented in the Custom row can be edited to create 

user-defined bullets (see below).  

 Color (default bullets only) 

 You can select a different color for the bullet from the Color dropdown list. 

The default colors presented in this list can always be supplemented with colors 

you compose yourself (see section “Document properties, Colors tab” begin-

ning on page 564). 

Tip: If you set the color to “Auto”, TextMaker will automatically set the color 

of the bullet to the color assigned to the paragraph at its right. 

 Size (default bullets only) 

 Here you can change the size (in points) of the bullet as required. 

Tip: If you select the option “Auto”, TextMaker will automatically set the si-

ze of the bullet to the font size specified for the paragraph at its right. 
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 Character button (custom bullets only) 

 If you have selected a bullet from the Custom row, the two options mentioned 

above are replaced by a Character button. Click on this button if you want to 

change the character formatting (font size, color, emphasis, etc.) of the bullet. 

Tip: If you do not make any changes to the character format, the bullet will 

automatically use the character format of the paragraph at its right (except for 

the font face). 

 Horizontal position 

 Specifies how far the text is to be inset to the right to make room for the bullet. 

 Vertical position 

 Specifies the vertical position of the bullet on the line. A negative value makes 

the bullet lower; a positive value makes it higher. 

 Numbered lists tab 

 This tab gives access to an additional option for creating bulleted or numbered 

paragraphs: numbered lists. Numbered lists can be saved and re-used whenever 

you need them. In addition, numbered lists can have hierarchical numbering (1., 

1.1., 1.1.1. etc.). 

 You will find information about numbered lists in section “Numbered lists” 

beginning on page 186. 

Using user-defined bullets 

If the bullets presented in the dialog described above are not sufficient, you can 

select from many custom symbols to choose a bullet. 

Recall that the dialog box for this command presents two rows of bullet icons: The 

bullets in the Default row cannot be modified. The bullets in the Custom row, on 

the contrary, can be swapped at will. 

Proceed as follows: 

1. In the Custom row, click on the icon that you want to change. 

2. Click on the Change button to the right of the row. 

3. A character table appears. First, set the Font that you want to use.  
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 Tip for Windows users: The Symbol and Wingdings fonts contain numerous characters that are 

suitable for bullets. 

4. Double click on the character you want to select. 

5. The selected character now appears in the row of available Custom bullets. 

Click on OK to apply it.  

Note: Although only six user defined bullets are shown in the dialog box, you are 

not limited to using only six different bullets. The custom bullets can be redefi-

ned as often as you like – even within the same document. 

Drop caps 

A “drop cap” refers to a large ornamental letter at the beginning of a paragraph. 

TextMaker is capable of creating such an ornamental letter automatically from the 

first letter of a paragraph, and of automatically adjusting the following paragraph 

text so that it flows smoothly around this first letter. 

Note: Drop caps can be used only in paragraphs that have been aligned flush left 

or justified. 

To create a drop cap, do the following: 

1. Position the text cursor in the paragraph that is to be ornamented with a drop 

cap.  

2. Invoke the menu command Format > Drop caps. 

3. From the Drop caps options, select the type of drop cap you want. 

4. Select the desired Font size. If you want the drop cap to be rendered in a font 

different from the paragraph font, click on the Character button and set the de-

sired character formatting. 

5. Change the Margins for the drop cap as required. 

As soon as you have confirmed with OK, TextMaker renders the drop cap of the 

paragraph as you have specified. The content of the paragraph can still be edited as 

usual. 



 

Manual TextMaker Paragraph formatting  •  99 

Removing drop caps 

To remove drop caps, again invoke the Format > Drop caps menu command and 

set the Drop caps option to None. 

Shading 

With the Format > Shading menu command you can add a color shade or a pat-

tern to designated paragraphs in the text. 

 

To do this, select the paragraphs of interest, invoke the Format > Shading menu 

command and then continue as follows: 

 Adding a shade 

 You can add a color shade mixed from a specific foreground color and back-

ground color to the selected paragraphs.  

 To add a shade, set the Type to Shading and specify the following settings: 

 First, choose a Foreground and a Background color. (The background color is 

set to white by default.) 
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 In the Shades section, several mixtures of these two colors are now offered. 

Click on one of these suggestions to choose it. Alternatively, you can enter an 

exact percentage for the shade in the edit box below Shading (in the Type sec-

tion). Values between 0 (100% background color) and 100 (100% foreground 

color) are allowed. 

 Adding a pattern 

 To add a pattern, click on one of the patterns in the Pattern section. 

 You can also select a different Foreground and Background color for the pat-

tern. 

 Removing a shade or pattern 

 If you want to remove an existing shade or pattern, select None in the Type list. 

Then confirm with OK. 

Borders and lines 

The menu command Format > Borders allows you to add border lines to para-

graphs and certain objects. You can add lines at their left, right, top and/or bottom. 

When you invoke this command, a dialog like the following is opened: 
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The dialog for border lines (here: for table cells) 

A similar dialog box appears for all types of objects that allow you to add border 

lines (e.g. text frames or table cells). 

Essentially, you operate this dialog as follows: 

1. First you specify what kind of border lines you want (by selecting a line style, 

thickness, and color). 

2. Then you pick where to apply the specified border lines – by clicking on the 

respective lines in the preview box displayed in the right half of the dialog (or 

on the buttons surrounding it). 

Let’s have a look at the entire procedure in detail:  

For example, to add borders to a text paragraph, proceed as follows: 

1. Place the text cursor in the paragraph of interest (or select multiple paragraphs 

to be modified). 

2. Invoke the menu command Format > Borders. 

3. First, choose what kind of border lines who want – by specifying the following 

options:  

 Line style (single, double, or dashed lines) 
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 Thickness of the line 

 Color of the line 

4. Then, specify where to apply this line (top, bottom, left, right, etc.).  

 For this purpose, a preview box surrounded by a set of buttons is available in 

the right half of the dialog. Use it as follows:  

 A) When you click on one of the lines in this preview, the selected type of bor-

der line is applied to the corresponding border. 

 B) Alternatively, you can click on the buttons displayed to the left and below 

the preview. Each button represents one border (indicated by the symbol dis-

played on the icon). 

 C) The buttons shown above the preview provide some shortcuts: 

 The Outline button applies the currently set up border line to all outer borders. 

 The Inside button does the same for all inner lines (e.g. with table cells). 

 The None button removes all lines at once. 

5. Add as many lines as you like – by simply repeating step 4. 

 Of course you can always modify the line settings (step 3) before you apply the 

line (step 4). 

6. When done, confirm with OK. 

For more information on each of the options in this dialog, see below. 

Changing or removing existing border lines 

You can change the style, thickness or color of existing border lines anytime – and 

of course you can also remove border lines. To do so, invoke the Format > Bor-

ders menu command again and proceed as follows:  

 Modifying: To modify the appearance of a line, first choose the desired settings 

(style, thickness, color). Then, click on the line of interest in the preview (or on 

its button) in order to apply the line there. 

 Removing: To remove a border line, click on it in the preview (or on its button) 

twice. Clicking once applies a line to a border, clicking once more removes it 

again. 

 Hint: The None button displayed above the preview removes all lines at once. 
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Dialog options 

In detail, the dialog box for border lines contains the following options: 

 Line style 

 Determines the kind of line to be drawn. You can choose between various varia-

tions of single, double, or dashed lines. 

 Thickness 

 Determines the width of the line.  

 Color 

 Here you can change the colors of the line. 

 You can use the colors presented, or colors that you compose yourself (see sec-

tion “Document properties, Colors tab” beginning on page 564). 

 Preview field 

 A preview box is displayed in the right half of the dialog. It gives an impression 

of how the border lines will look like when the changes currently made in the 

dialog are applied. 

 Apart from that, the preview field also allows you to add and remove lines, as 

follows: 

 When you click on one of the borders displayed in the preview, the correspon-

ding border line is applied (using the currently selected line style, thickness, 

and color). When you click again, the line is removed. 

 Alternatively, buttons are available for the same task, displayed to the left and 

below the preview. Each button represents one border (indicated by the symbol 

displayed on the icon). 

 The buttons shown above the preview are shortcuts: None removes all lines at 

once, Outline adds border lines to all outer borders, Inside does the same for 

all inner lines (e.g. with table cells). 

 Bounds 

 Only with text paragraphs: Determines where the lines should begin and end. 

 Options available: 

 Page margins: Lines extend from the left page margin to the right page mar-

gin. 
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 Paragraph indents: Lines extend from the paragraph’s left indent to its right 

indent. This is the default setting. 

 Text: Lines are the same width as the text they surround. 

 Clearance 

 Only with text paragraphs: Determines the distance from the lines to the text. 

Outline level 

Long documents (manuals, for example) are usually organized and composed on 

the basis of outlines. 

TextMaker provides an Outline view for setting up and editing a document’s out-

line. Here, you can assign normal text to headings and promote or demote existing 

headings to different levels in the outline. 

Note: Normally, you should not change a paragraph’s outline level manually 

with the Format > Paragraph menu command; it is preferable to perform this 

action using the buttons in the Outline view. 

FreeOffice: Outline view is not included in SoftMaker FreeOffice. 

In the rare occasion that you need to change the outline level manually, invoke the 

Format > Paragraph menu command, switch to the Paragraph tab, and specify 

the desired level using the Outline level control. 

You will find detailed information about working with outlines in section 

“Outlines” beginning on page 418. 

Forcing breaks before paragraphs 

You can direct TextMaker to always insert a page or column break before the cur-

rent paragraph. To do this, invoke the menu command Format > Paragraph, 

switch to the Text flow tab, and enable the Page break or Column break option. 

From this point on, TextMaker will always break the page or column before this 

paragraph – even if the paragraph is moved to another position in the text. 
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Paragraph control 

The Text flow tab in the dialog box for the menu command Format > Paragraph 

also provides options for limiting the way that automatic pagination is handled in 

order to ensure that pages have the desired appearance. 

In the Spacing group box, the following options are available for this: 

 Keep with next 

 If this option is enabled, TextMaker is prevented from inserting an automatic 

page break that would separate the current paragraph from the paragraph follo-

wing. Instead, TextMaker inserts the break before the current paragraph. 

 If several paragraphs are selected, these paragraphs and the paragraph that 

follows next after them are kept together. 

 Application example: If you enable Keep with next for a heading, you can 

avoid the situation in which a heading would fall at the end of a page, and the 

text belonging to it would begin on the following page. 

 Keep together 

 Enabling this option prevents TextMaker from inserting a page break in the 

middle of the paragraph. Instead, TextMaker puts the automatic page break be-

fore the paragraph, so that all of it falls on the next page. 

 The same applies to column breaks (with multi-column text). 

 Avoid widows/orphans 

 This option prevents paragraphs from being broken in such a way that so-called 

widows or orphans would result. A widow or orphan is a single line of a para-

graph that has been separated by a page break from all the other lines of the pa-

ragraph. Widows and orphans are not especially pleasant to the eye and interfe-

re with the reading of a longer document. 

 If you enable this option, pagination is performed in such a way that a para-

graph is not broken where the break would leave fewer than two of its lines on 

a given page. If a paragraph cannot be broken in this way – for example becau-

se it has only two lines – the entire paragraph is placed on the next page. 

Non-breaking spaces 

There’s another method to control the text flow: 
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In certain cases, it is necessary to keep two words that are separated by a space 

character on the same line. TextMaker knows nothing about this, and possibly puts 

the words on separate lines when it automatically inserts line breaks. 

An example: You want all the parts of the expression “USD 29.80” to remain toge-

ther and unbroken. You can ensure this by inserting a so-called non-breaking space 

or protected space between “USD” and “29.80”. To insert such a space, press the 

key combination (Ctrl)(Shiftª)(Space) instead of the space bar alone. 

When printed, the non-breaking space looks exactly like a normal space. It differs 

only in directing TextMaker to ensure that the designated words are not separated 

on two lines. 

Suppressing line numbers 

The option Suppress line numbers on the Text flow tab in the dialog box of the 

menu command Format > Paragraph has the following function: 

Using the Format > Section menu command, Line numbers tab, you can instruct 

TextMaker to display line numbers in the left page margin. For paragraphs where 

you don’t want a number to be displayed, simply turn on the Suppress line num-

bers option. 

Detailed information on line numbers can be found in the section “Adding line 

numbers” (page 196). 
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Page formatting 
This chapter covers everything related to the formatting of pages in TextMaker. It 

includes the following sections: 

 Inserting manual page breaks 

 If you want to begin a new page before the text has reached the end of the cur-

rent page, you can always insert a manual page break. Read this section for mo-

re details. 

 Page setup 

 You can specify the page format of a document with the File > Page setup 

menu command. Here you can set such things as paper size, page orientation 

(portrait or landscape), and page margins. 

 Headers and footers 

 Headers and footers are lines of text that are always printed the same way at the 

top and bottom respectively on every page of the document. This section 

describes how to create and edit them. 

 Master pages 

 Headers and footers are parts of the so-called master page. On the master page, 

you can insert all types of object frames – for example an image frame contai-

ning a watermark. Objects added on the master page appear on every page of 

the document. 

 Dividing a document into chapters 

 Changes to any of the above options always affect the entire document – unless 

you divide the document into chapters. Each chapter can have its own page 

formatting. You should divide the document into chapters when, for example, 

you need to change the headers and footers or the paper format in the middle of 

the document. Read this section to learn more about it. 

 Changing the page background 

FreeOffice: The Page background menu command is not included in Soft-

Maker FreeOffice. 

 You can change the page background of your document’s pages, for example, 

to add some color to them. There are two different menu commands available 
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for this: Format > Page background and Format > Chapter. In this section, 

you will learn how to work with these two commands and what differences the-

re are between them. 

Inserting manual page breaks 

Normally, TextMaker fills the pages of a document automatically – from top to 

bottom. When the text reaches the end of a page, an automatic page break is per-

formed, and the text is continued on the following page. If you want to start a new 

page before the text has reached the end of the current page, you can always insert 

a manual page break. 

Whenever you want to do this, position the text cursor at the point in the text where 

the new page is to begin and invoke the menu command Insert > Break > Page 

break. Alternatively, you can use the keyboard shortcut (Ctrl)(¢). 

TextMaker now inserts a forced page break. 

When you need to remove a manual page break that you have forced in this man-

ner you can do so by positioning the text cursor at the beginning of the first line 

following the break and pressing the Backspace key (æ__). 

Specifying a page break at the beginning of a specific paragraph 

You can force an early page break not only with the Insert > Break > Page break 

menu command, but also by giving a paragraph the attribute “always begins on a 

new page here.” 

To do the latter, position the text cursor within the paragraph of interest, invoke the 

menu command Format > Paragraph, switch to the Text flow tab, and check the 

Page break option. TextMaker will then always insert a page break before this 

paragraph – even when you move the paragraph to a different place in the text. 

Page setup 

You can specify the page format of a document with the File > Page setup menu 

command. Here you can set such things as paper size, page orientation (portrait or 

landscape), and page margins. 
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The settings that can be made are as follows: 

 Orientation 

 Here you can specify the Orientation of the document on the printed page: 

Portrait or Landscape. 

 Paper 

 Here you can specify the size of the paper for which the document is to be for-

matted. The Size dropdown list contains all paper sizes that are supported by 

the current printer. If you want to specify a size that is not listed, you can do so 

by manually entering values in the Width and Height fields. 

 Margins 

 Lets you enter values for the page margins. 

 Gutter 

 A gutter can be added in addition to the page margins. To do so, select the posi-

tion of the gutter and enter its size. 
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 Paper bins 

 Available only under Windows: If your printer has multiple paper trays, you 

can select which one(s) the printer should use. If you don’t want TextMaker to 

influence tray selection, you should retain the default setting Use printer set-

ting. On the other hand, if you want the first page of your document to be 

printed on paper from tray 1 and the remaining pages on page from tray 2, for 

example, you should change the settings accordingly. 

 Chapter tab 

 This tab contains settings related to the chapter format, which is discussed in 

section “Dividing a document into chapters” (beginning on page 119). 

Note: Changes of these settings affect the whole document unless you divide the 

document into chapters. Each chapter can have its own page formatting. You 

should divide the document into chapters when, for example, you want to change 

the paper format in the middle of the document (see section “Dividing a 

document into chapters” beginning on page 119). 

Headers and footers 

Headers and footers are lines of text that are always printed the same way at the 

top and bottom respectively on every page of the document. 

TextMaker places headers in the top and footers in the bottom page margins. When 

you change the margins of your document, the positions and sizes of the headers 

and footers are adjusted automatically. 

The following pages present everything you will ever need to know about headers 

and footers. 

Creating and editing headers and footers 

To enter a header invoke the Insert > Header menu command. TextMaker then 

positions the text cursor in the header frame in the top page margin. Here you can 

enter and format text as usual. 

The header frame is initially only one line high; however, it grows automatically as 

you type text that extends beyond this single line, or when you begin a new line 

with the Enter key (¢). 
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To get back to the normal text from the header frame, simply click anywhere in the 

normal text with the mouse. If you should later want to edit the header again, you 

can invoke the menu command Insert > Go to Header or click in the header frame 

with the mouse to return to the header and perform your editing. 

The insertion and editing of footers is accomplished in a similar way. A footer is 

inserted in the bottom page margin with the Insert > Footer menu command and 

edited with the Insert > Go to Footer menu command. 

Note: By default, the header and footer apply to the whole document. If you 

want to use different headers and footers within the same document you must di-

vide the document into chapters. Then headers and footers can be set up for each 

separate chapter (see section “Dividing a document into chapters” beginning on 

page 119). 

Tip: Using the header and footer toolbar 

TextMaker provides a useful aid for editing headers and footers: the Header and 

Footer toolbar. 

 

The Header and Footer toolbar 

This toolbar appears automatically when you position the text cursor in a header or 

footer, unless it has been disabled. If it is not displayed, invoke the View > Tool-

bars menu command and click in the check box for Header and Footer to re-

enable it. 

The icons in this toolbar represent the following functions (from left to right): 

 Change the properties of the current header or footer (see section “Changing 

the properties of headers and footers” beginning on page 114) 

 Change the page format (invokes the File > Page setup menu command) 

 Insert a header (or go to the existing header) 

 Insert a footer (or go to the existing footer) 

 Delete the current header 

 Delete the current footer 

 Insert the page number (as a field) 

 Insert the page count (as a field) 

 Insert the date the document was last printed (as a field) 

 Insert the time the document was last printed (as a field) 

 Insert other fields (invokes the Insert > Field menu command) 
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 Go to the previous header or footer 

 Go to the next header or footer 

 Switch between header and footer 

 Exit header or footer (position the text cursor back in the text) 

Tip: If you point with the mouse to one of the icons (without clicking), a text box 

appears, giving the icon’s function. 

Inserting the page number, date, etc. 

Headers and footers often contain the page number, date, etc. With TextMaker, you 

can insert this sort of information using what are called fields.  

To do this, move the text cursor to the desired position in the header or footer, in-

voke the Insert > Field menu command and select the desired field – for example 

“Page number” or “Print date”. You will find information about the various kinds 

of fields in chapter “Fields” beginning on page 171. 

Tip: There are some buttons in the Header and Footer toolbar for inserting the 

most frequently used fields (page number, date, etc.). See the previous section. 

Example: inserting the page number in a footer 

For example, to insert the page number in a footer, proceed as follows: 

1. Click in the footer to position the text cursor there. 

2. Invoke the Insert > Field menu command. 

3. Select “Page number” from the Field type list. 

4. Optional: In case you want to choose a different number format for the page 

number, choose it from the Format list. 

5. Confirm with OK. 

TextMaker now inserts a page number field in the footer. 

Controlling page numbering 

By default, the first page of every document is assigned the number “1”. However, 

if necessary you can instruct TextMaker to begin with a different number. 
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To do this, invoke the Format > Chapter menu command and click on the Page 

numbers button. In the associated dialog, change the Numbering setting from 

Increment to Value and enter the desired starting number in the edit box. For 

example, type “42” to assign the number 42 to the first page. 

For more information on the settings in this dialog (most of them are related to the 

format of page numbers), see the section “Page number format” (page 124). 

Using alignment tabs 

In addition to normal tabs, a very special type of tabs can be used in headers and 

footers: the so-called “alignment tabs”. 

Alignment tabs have the following special features: 

 They can be inserted only in headers and footers. 

 They ignore all tab settings made in a paragraph (e.g. with the Format > Tabs 

command) – because: 

 They always align the following text relative to the page margins – either left-

justified, centered or right-justified. 

The word “relative” is what makes this type of tabs particularly interesting:  

For example, when you insert a centered alignment tab in the footer and add a “Pa-

ge number” field behind it, the field will be centered in the footer. So far so good. 

However, if you change the page margins now – or even set the page format to 

landscape –, the page number will still be centered. A normal centered tab stop 

would not be able to accomplish this, since normal tabs always have a specific ab-

solute position. 

To insert an alignment tab, proceed as follows: 

1. Click inside the header or footer to place the text cursor there (or insert a new 

header/footer).  

2. Click on the  icon in the Header and Footer toolbar (located at the bottom 

of the program window) to insert an alignment tab. 

3. A dialog box appears, allowing you to select the desired orientation for the tab 

and make some other settings (see below). 

As soon as you confirm, the alignment tab is inserted and the text behind it is alig-

ned accordingly. 



 

114  •  Page formatting Manual TextMaker 

Dialog options 

The options in this dialog box have the following functions: 

 Alignment 

 Determines the alignment of the alignment tab: left-justified, centered or right-

justified (each relative to the page margins). 

 Tab leader 

 Here you can select a fill character, just like with normal tabs, to fill the area to 

the left of the tab. 

 Relative to 

 Determines what the tab is to align itself with: the page margins (without 

considering paragraph indentations) or the indents for the current paragraph. 

Changing the properties of headers and footers 

Like all types of frames, header frames and footer frames (that contain the headers 

and footers) have certain properties that can be modified using the Object > Pro-

perties menu command. For example, you can change their height or modify their 

distance from the text and page edges. 

To do this, proceed as follows: 

1. Click with the mouse in the header or footer frame – depending on whether you 

want to edit the header or the footer. 

 Alternatively, invoke the menu command Insert > Go to Header or Insert > 

Go to Footer, which will accomplish the same thing. 

2. Invoke the Object > Properties menu command to bring up the associated 

dialog. 

 Tip: This dialog can also be invoked by clicking on the  icon in the Header 

and Footer toolbar. 

The following settings can be made in this dialog: 

Properties tab 

The Properties tab allows you to edit the following properties: 
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 Height 

 Here you can change the height of the header or footer frame: 

 At least: This is the default setting. The height of the frame is adjusted automa-

tically. The more text you enter, the larger the frame becomes. The edit box to 

the right allows you to enter a minimum height, if desired. 

 Fixed: If you select this option, you can specify the exact height of the frame 

yourself. Note: With this setting, TextMaker will display a red bar at the bottom 

edge of the frame whenever the header or footer text grows too large to be fit-

ted completely in the frame. If this bar appears, you should enter a greater value 

for the fixed height, select the Growing option, or reduce the amount of text in 

the frame. 

Note: The width of header and footer frames is adjusted by TextMaker au-

tomatically (to match the left and right page margin). However, you can al-

ways add paragraph indents to the text in headers/footers in order to make 

them wider or narrower. 

 Distance to edge 

 Here you can specify the amount of space TextMaker should leave between the 

frame and the (top or bottom) edge of the page. 

 Distance to text 

 Here you can specify the amount of space TextMaker should leave between the 

frame and the normal body text. 

Borders tab 

Here you can specify border lines for the frame. 

The options on this tab correspond to those for the Format > Borders menu com-

mand (see section “Borders and lines” beginning on page 100). 

Shades tab 

Here you can specify a shaded or patterned background for the frame. 

The options on this tab correspond to those for the Format > Shading menu com-

mand (see section “Shading” beginning on page 99). 
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Different headers/footers on the first page 

The header and footer are parts of the so-called master page (see also section 

“Master pages” beginning on page 117). By default, the content of the master page 

is repeated on every page of the document.  

If required, you can specify that a different master page should be used for the first 

page of the document (including a different header and footer). This is useful 

when, for example, you plan to print the first page of a letter to a pre-printed letter-

head and the pages 2 and following to plain white paper. 

To achieve this, invoke the Format > Chapter menu command and activate the 

option Different first page. From now on, headers and footers on the first page 

can be edited independently from the rest of the document.  

Different headers/footers on left and right pages 

In books, different headers and footers are often used on left and right facing pa-

ges. For example, on left pages of manuals, the page number is usually flush left in 

the footer and on right pages it is flush right. 

To enable different headers and footers for left and right facing pages, proceed as 

follows: 

1. Invoke the Format > Chapter menu command. 

2. Check the Different left and right pages option. 

You will now be able to set up different headers and footers for left and right facing 

pages. 

More precisely: When you set up or edit a header on any left page of the document, 

the header for the right pages will remain untouched. Likewise, changes to the 

header on any right page will affect only the right pages. 

The same goes, of course, for footers. 

Deleting headers and footers 

You can remove the text from a header any time you like by clicking in the header 

frame, selecting all the text and then simply deleting it. 
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As required, you can also completely remove the header frame itself from the 

document, even though this is normally not necessary. To do this, proceed as 

follows: 

1. Position the text cursor within the header frame. 

2. Click on the  icon in the Header and Footer toolbar (located at the bottom 

of the program window). 

The header frame, together with all its content, is now removed.  

Alternatively, you delete a header by right-clicking on any empty area in the header 

frame and choosing the Delete Header/Footer command from the context menu. 

The procedure for removing footers is similar. 

Master pages 

This chapter has already introduced you to headers and footers, which have to be 

entered only once and then appear on every page. This is a very useful thing; but 

TextMaker has yet another trick up its sleeve:  

The master page likewise appears on every page of the document. However, as its 

name implies, it is not limited to a few lines at the top and bottom margins, but can 

cover an entire page.  

Please note that only frames are permitted on a master page (thus, for example, text 

frames, picture frames etc.). 

For example, if you wanted to enhance a letter with a “watermark”, you would 

simply insert a picture frame containing an appropriate picture on the master page 

and set the Text wrapping property of the picture to “Behind text”. The watermark 

would then appear on every page of the document, and the text would flow right 

over it. 

Editing the master page 

If you want objects to appear on every page of a document or chapter, simply put 

them on the master page. To do this, switch to the master page view and insert the 

objects there. 
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Note: Only frames (text frames, picture frames, etc.) and drawings can be inser-

ted on master pages. You can find information about working with these objects 

in chapter “Frames and drawings” beginning on page 259.  

You edit the master page as follows: 

1. Switch to the master page view with the menu command View > Master pa-

ges. 

2. Make the desired changes. For example, to insert a picture, invoke the Object > 

New picture frame menu command; to be able to insert text, add a text frame 

using the menu command Object > New text frame, etc. 

3. When you are finished, invoke the View > Standard menu command to exit 

the master page view. 

Any object that you have inserted on the master page will now appear on all pages 

of the document. 

By the way: Both the header and the footer are also parts of the master page. Apart 

from the fact that they are automatically positioned in the top and bottom margins, 

they behave in principle like a text frame inserted on a master page.  

Different master pages in the same document 

By default, the master page applies to the whole document. If you want to use dif-

ferent master pages within a single document, the document must be divided into 

chapters, for each chapter has its own master page. You can read more about this in 

section “Dividing a document into chapters” beginning on page 119. 

There, you will also learn how to set up a master page that applies only to the first 

page of the document, and how to create different master pages for the left and the 

right pages of the document. 

Hint: In master page view, the type of master page is displayed in the top area of 

each master page. For example, if TextMaker displays “Chapter 7, right master 

page” there, the corresponding page is the master page for all right pages in 

chapter 7. 
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Locking master page objects in normal view 

Optionally, objects that have been inserted on a master page can be “locked” to 

prevent them from being moved accidentally with the mouse when the document is 

being edited in normal view. 

To lock such objects, invoke the File > Properties menu command and switch to 

the View tab. Check the Lock objects on master page option in the Locking 

group box. 

Once locked, master page objects can be neither moved nor resized when the 

document is edited in normal view. They can be modified only in Master Page 

view. 

Note: This setting affects only the current document. 

Dividing a document into chapters 

By default, the page formatting options described in this chapter always apply to 

the whole document. Thus, all pages will have the same header and footer, the pa-

per format will remain constant throughout the document, etc. 

Chapters provide a way around this limitation. With the Insert > Break > Chapter 

break menu command, you can divide a document into as many chapters as you 

wish. 

This has the following effects on the page formatting of the document: 

 Paper format, orientation and margins can be set separately for each chapter. 

 Each chapter can have its own master page, and thus its own headers and foo-

ters. 

 The page numbering can be reset (as needed) to any start value whatever in a 

chapter. Also, the format of the page numbers can be set separately for each in-

dividual chapter. 

 If you check the Different left and right pages option in the chapter format-

ting dialog, you can set up different headers, footers and master pages for the 

chapter’s left and right facing pages. 

 You can specify that a chapter should always begin on a left or right page. If 

you specify, for example, a right page, TextMaker will automatically insert an 
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empty page into the document as required to prevent the first page of the chap-

ter from falling on a left page. 

To the extent that it provides these possibilities, the division of a document into 

chapters makes sense in a variety of situations, not only when you are writing a 

long work that contains “chapters” in the ordinary sense. For example, it could be 

that you would want to change from portrait to landscape orientation in the middle 

of a document in order to better accommodate a wide table. 

To do that, you could insert a chapter break, set the paper orientation in the new 

chapter to Landscape and then lay out the table. Following the table, insert another 

chapter break and set the paper orientation back to Portrait, so that you can conti-

nue the writing the main text in portrait format.  

You will find details about working with chapters on the following pages. 

Inserting and removing chapters 

To start a new chapter, simply insert a chapter break in the text: 

1. Move the text cursor to the position at which the new chapter should begin. 

2. Invoke the Insert > Break > Chapter break menu command. 

TextMaker now inserts a chapter break. 

Note: TextMaker always performs a page break at the beginning of a new chap-

ter. 

Tip: The chapter in which the text cursor is currently positioned is displayed in the 

“Chapter” field in the status bar at the bottom of the TextMaker window. 

Removing a chapter break 

You can remove a chapter break by positioning the text cursor at the beginning of 

the first paragraph following the break and then pressing the Backspace key (æ__). 

The chapter lying before the break is then integrated into the chapter after the 

break and takes on the latter’s formatting. 
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Navigating among chapters 

You can navigate to a specific chapter with the Edit > Go to menu command. To 

do this, invoke the command, choose the Chapter option in the Go to list and then 

select the desired chapter. 

Chapters and page formatting 

Note: A different page format can be applied to each chapter of a document. 

To recapitulate – a page format includes: 

 Paper format, orientation and margins 

 Headers, footers and master pages 

 Page numbers (initial value, format) 

When you begin a new document, the document consists initially of a single chap-

ter. Accordingly, if you change something related to page formatting, your change 

affects the whole document. 

If you divide the document into chapters with the menu command Insert > Break 

> Chapter break, each new chapter assumes at first the page formatting of the 

original document. In general, the following holds: 

Important: When you insert a chapter break, the new chapter that is created 

takes on the page formatting and the master page layout of the current chapter. 

However, when you subsequently modify the page formatting and master page 

layout of the new chapter, your changes affect only that chapter. 

Thus, you can now set up different headers and footers for each chapter, set a diffe-

rent paper format for each chapter, etc. 

Chapter formatting 

Chapter formatting goes beyond the page formatting that can be applied to chap-

ters on a chapter-by-chapter basis, and involves formats that are specific to chap-

ters as such. 

To modify a chapter’s page formatting, use the commands described in chapter 

“Page formatting” beginning on page 107.  

To modify a chapter’s chapter formatting, proceed as follows: 
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1. Position the text cursor anywhere within the chapter of interest – or select se-

veral chapters to change the format for all of them at the same time. A selection 

can begin in any paragraph of the first chapter of interest and end in any para-

graph in the last chapter. 

2. Invoke the Format > Chapter menu command. 

  

3. Make the desired changes (see below) and confirm with OK. 

The dialog box for this command allows you to make the following settings: 

 Master pages 

 This section provides options related to the master page(s) of a chapter (see also 

section “Master pages”, beginning on page 117). 

 Different first page: When you check this option, the first page of the chapter 

will use a different master page. This is useful when you would like to have, for 

example, a different footer on the first page of the document (or chapter). 

 Different left and right pages: This option is useful when your document is to 

be printed double-sided (like a book, for example). When it is checked, diffe-

rent master pages (and thus also different headers and footers) can be set up for 

left and right facing pages. 
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Hint: In master page view, the type of master page is displayed in the top 

area of each master page. For example, if TextMaker displays “Chapter 7, 

right master page” there, the corresponding page is the master page for all 

right pages in chapter 7. 

 Borders and shading of master pages: Allows you to change the border and 

shading of a master page (and thus of all document pages in the chapter). When 

you click the Change button, a popup menu appears where you can select 

which type of master page to change. After that, the usual dialog for border 

lines and shadings is displayed. See also section “Changing the page back-

ground” (page 126). 

 Chapter starts on 

 Whenever you insert a chapter break, TextMaker adds a page break. Accordin-

gly, new chapters always begin on new pages. 

 Now, when you change the setting of Chapter starts on from Either page (the 

default) to Right page, for example, TextMaker makes sure that the chapter al-

ways begins on a right page by automatically adding a blank page as necessary 

at the end of the previous chapter.  

 For example, it is customary for every chapter in a printed book to begin on a 

right page. This allows the reader to page through the book quickly to find the 

beginning of any chapter of interest. 

 Vertical Alignment 

 Here you can change the vertical alignment of the body text on the page. 

 For example, when you choose Centered, the text is vertically centered on the 

page. When you choose Justified, the paragraphs are spaced equally in such a 

way that the text begins right below the top page margin and ends right above 

the bottom page margin. 

 Chapter number 

 TextMaker automatically numbers chapters incrementally. You can always see 

the number of the current chapter in the status bar. 

 When you change the Chapter number setting from Increment (the default) 

to Value, you can set the chapter number yourself by entering it in the value 

field. For example, if you enter “5” as the number for the third chapter, the 

chapters will have the numerical sequence 1, 2, 5, 6, 7 etc.  

 Tip: The chapter number can be inserted into the text (for example, in a header 

or footer) at any time with the Insert > Field menu command. 
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 Page numbers button 

 You can insert a Page number field into your document in order to display the 

current page number (e.g. in the header or footer). This button opens a dialog 

box allowing you can to change the format of the page numbers. Additionally, 

you can manually set the page numbering to a certain value. 

 For details, see the section “Page number format” below. 

 Page setup tab 

 The Page setup tab in this dialog can be used to change the page format (paper 

size, orientation, margins, etc.). More information on each option is available in 

the section “Page setup”, beginning on page 108. 

 Don’t forget that you can specify a different page format for each separate 

chapter. So, if you have divided a document into several chapters and you want 

to change the page formatting for the whole document, you must first select the 

entire document.  

Page number format 

The dialog box described in this section can be used to change the format of page 

numbers in the current chapter. Additionally, it allows you to manually set the page 

numbering to a certain value. 

In details: 

As described in the section “Inserting the page number, date, etc.” (page 112), the 

menu command Insert > Field allows you to insert a Page number field into your 

document in order to display the current page number. When you keep the default 

setting Use chapter settings in the Format list of the dialog, this Page number 

field follows the settings made in the dialog detailed below.  

This dialog can be invoked as follows: 

 Choose the menu command Format > Chapter and click on the Page num-

bers button. 

 Choose the menu command Insert > Field, select Page Number in the list, and 

click on the Settings button. (This button is only available when the Format 

option is set to Choose chapter settings.) 

Note: The options in this dialog box belong to the chapter format options. Ac-

cordingly, different settings can be applied to individual chapters. 
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Dialog options 

The following settings are available in the dialog box: 

 Numbering 

 TextMaker automatically numbers pages incrementally. The first page has the 

page number 1, the second page is page 2, etc.  

 However, you can always modify the page numbering manually by setting the 

page number for the first page in a chapter to a specific value. 

 To do so, change the Page number setting from Increment to Value and enter 

the desired value for the first page of the chapter in the adjacent field.  

 For example, if you enter “42”, the first page of the chapter will be page 42, the 

second page 43, etc. 

 Number format 

 Here you can modify the number format of the page numbers.  

 For example, you can choose if the page numbers should be rendered in Arabic 

numbers (1, 2, 3, ...), letters (A, B, C, …), or Roman numerals (I, II, III, …). 

 Include heading number, Heading level and Separator 

 When you activate the option Include heading number, the number from the 

numbering of the current heading will be added in front of the page number. 

Note: This feature only works when a numbering has been applied to the 

headings of your document. For details on how to achieve this, see the sec-

tion “Numbering headings” (page 426). 

 To choose which heading level to be displayed, select it under Heading level 

(Heading 1, Heading 2, etc.). 

 Additionally, the Separator option allows you to specify which character to 

display as a separator between the heading number and the page number. 

 An example: When you add a Page number field on page 42 of a document, 

and the corresponding level 1 heading (including its numbering) is “5. The 

Larch”, the following will be displayed: 5.-42. 

 Apply to 

 Determines what parts of the document will be affected by the settings you 

make in this dialog: the current chapter or the entire document. 
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 This option is only available when you invoked the dialog via the Insert > 

Field command.  

Changing the page background 

As mentioned in the section “Chapter formatting”, you can change the page back-

ground of your document’s pages using the Format > Chapter menu command. 

This allows you to add some background color to the pages, for example. 

There’s another command that does the same, but offers far more options to choose 

from: the Format > Page background menu command.  

FreeOffice: The Page background menu command is not included in SoftMaker 

FreeOffice. 

In this section, you will learn how these two commands work and what differences 

there are. 

Format > Page background 

You can use the Format > Page background menu command to change the page 

background for the entire document.  

Proceed as follows: 

1. Invoke the Format > Page background menu command. 

2. Use the Fill type list to determine the type of fill for the page background. You 

can choose to apply a solid color, a pattern, a picture (tiled), or different types 

of color gradients.  

3. Make the desired settings and confirm with OK. 

For more information on this dialog, see the section “Object properties, Filling tab” 

(page 275). This section describes the Filling dialog for objects, which is practical-

ly identical. 

Printing: Please note that this type of page background by default is displayed on 

the screen only – it will not appear in printouts. However, there is a document opti-

on that allows you to change this: When you activate the option Print page back-

ground in the dialog of the File > Properties menu command (View tab), the page 

background will also appear in printouts. 
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Format > Chapter 

The Format > Chapter menu command works in a slightly different way: 

You can use this command to change the page background for the current chapter 

(more precisely, its master page(s)).  

Proceed as follows: 

1. If you have divided your document into multiple chapters: Position the text 

cursor anywhere within the chapter of interest.  

2. Invoke the Format > Page background menu command. 

3. Next to Borders and shading of master pages, click on the Change button, 

and select which type of master page to change.  

4. Switch to the Shading tab. 

5. Choose the desired Type of filling. With this command, only color shades and 

patterns are available.  

6. Make the desired settings and confirm with OK. 

For more information on this dialog, see the section “Shading” (page 99). This 

section describes the Filling dialog for text paragraphs, which is practically identi-

cal. 

Please note that, if your document is divided into multiple chapters, changes made 

with this command affect only the current chapter (see also section “Dividing a 

document into chapters” beginning on page 119).  

Printing: This type of page background always appears in printouts. The 

document option Print page background mentioned above has no effect here. 





 

Manual TextMaker Styles  •  129 

Styles 

Styles are very useful aids for advanced word processing users. 

When you need a specific character or paragraph format frequently, it pays to crea-

te a style for it. You can then apply the style to any segment of text you like, and 

this text will be formatted as you have specified in the style definition. 

And: Using styles not only saves you time when you have to apply the same 

formatting repeatedly, but also ensures that your document will be formatted 

consistently. The reason: if you change the definition of a style, the formats of all 

text segments to which this style has been applied are changed accordingly! 

In practical terms, styles work like this: You set up a paragraph style named “Hea-

dings”, choosing for it a larger, bold type, a centered alignment, etc. Now, whene-

ver you want to make a paragraph into a heading, all you have to do is select this 

style for it and it will be formatted accordingly. 

You can define different styles for each document – they are saved in the 

document. 

In this chapter, you will find detailed information on using styles. The following 

topics are covered: 

 Character styles 

 In a character style, you can save a frequently needed character format (type-

face, size, emphasis, etc.) and apply it repeatedly to any characters you like. 

 Use the Format > Character Style menu command for this. 

 Paragraph styles 

 In a paragraph style, you can save a frequently needed paragraph format (in-

dentation, tab stops, alignment, etc.) and apply it repeatedly to any paragraph 

you like. 

 Use the Format > Paragraph style menu command for this. 

 Managing styles 

FreeOffice: The Style Manager is not included in SoftMaker FreeOffice. 

 TextMaker’s integrated style manager allows you to manage the styles of your 

documents. For example, you can copy styles from one document to another. 
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 Use the Format > Manage styles menu command for this. 

 Document templates 

 Styles that you want to use frequently can be stored in a document template.  

 Whenever you create a new document, TextMaker lets you select the document 

template to be used as the basis for the document. All styles stored in the 

document will also be available in your new document. 

For details, read the pages that follow. 

Character styles 

You can save a frequently needed character format (typeface, size, emphasis, etc.) 

in a character style and apply it repeatedly to any characters you like. 

For example, if you want some sections of a contract to be formatted in a special 

typeface and in a smaller size, simply create an appropriate character style – let’s 

call it “Fine print” – and apply the style to those sections. 

Note: The difference between character styles and paragraph styles (see section 

“Paragraph styles” beginning on page 138) is that character styles contain only 

saved character formats, while paragraph styles contain both saved character for-

mats and saved paragraph formats (indentation, tab stops, alignment, etc.).  

Accordingly, character styles are applicable to individual characters, while para-

graph styles are applicable only to complete paragraphs. 

On the next pages, you will find detailed information on working with character 

styles. The following topics are covered: 

 Creating character styles 

 Applying character styles 

 Modifying character styles 

 The scope of character styles 

 The character style Normal 

 Creating linked character styles 

 Character styles and the sidebar 
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Creating character styles 

To create a new character style, do the following: 

1. Invoke the menu command Format > Character Style. 

  

2. Click on the New button. 

3. Give the character style any name you like, and click on OK. 

4. A dialog box, very much like the dialog for the Format > Character menu 

command, appears. Here, you can specify the desired character formatting (see 

section “Character formatting” beginning on page 71). 

5. If you will need this style frequently, you can assign a keyboard shortcut to it 

(see below). 

6. When all the desired settings have been made, click on OK to define the style. 

7. Exit the dialog with Close. 

The style is now defined and ready for use. You will learn how to use it in a mo-

ment (section “Applying character styles”). 
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Creating character styles from existing text 

Alternatively, you can format some text first and then create a character style that 

uses exactly the same formatting options. For this purpose, use the New from text 

button instead of the New button. 

This method is useful when you have formatted text “by hand” and want to have a 

character style that has exactly the same formattings. 

Proceed as follows: 

1. Set up the character format (font face, font size, etc.) of any text segment to 

your liking. 

2. Place the text cursor inside that text (or select it; either will do). 

3. As described above, use the Format > Character Style menu command to 

create a new character style. However, in this case use the New from text but-

ton rather than the New button. 

A character style created this way will behave like any other character style. The 

only difference is that its original character format is based on the selected text. (Of 

course you can still change the style’s formatting options whenever you like, inde-

pendently from the text.) 

Using keyboard shortcuts 

If you need a format style very frequently, you can give it a keyboard shortcut. The 

advantage of doing that is that you can then apply the style very quickly, using a 

single key press. 

To assign a keyboard shortcut to a style, switch to the Style tab in the dialog for 

editing the style. There, position the text cursor in the Shortcut key edit box and 

press the desired key combination. 

Note: If you press a key combination that is already assigned, the current as-

signment is displayed below the Shortcut key edit box. In that case, you should 

press the Backspace key (æ__) to delete this key combination and then enter 

another one. Otherwise, you will overwrite the assignment for another style, or 

even for one of TextMaker’s commands. 

We recommend using key combinations that include the keys (Ctrl) and (Shiftª), 

since these are normally not assigned. 
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Applying character styles 

To apply a character style, do the following: 

1. Select the segment of text to which you want to apply the style. 

2. Invoke the menu command Format > Character Style. 

3. Choose the desired style. 

Hint: In the right half of the dialog, a preview of the currently selected style 

is presented. The preview can be turned on/off with the >> button and the << 

button anytime you wish. 

4. Click on Apply. 

The formatting of the selected text changes to correspond to the specifications for 

the character style. 

Tip 1: You also can use the sidebar to apply styles – or even modify them. See 

section “Character styles and the sidebar”, page 137. 

Tip 2: If you have assigned a keyboard shortcut to the format style you can apply 

the style even more quickly: Select the text to which you want to apply it and 

press the assigned key combination. 

To remove a style, apply the “Normal” character style to the text. Keep in mind 

that text to which a character style has been applied can always be given additional 

formatting (e.g. with the Format > Character menu command). 

Modifying character styles 

It goes without saying that you can modify character styles whenever you want. 

Important: When a character style is changed, the formatting of all text seg-

ments to which this style has been applied is automatically changed accordingly! 

However, this automatic reformatting is limited for any such text segments to 

which manual character formatting has also been applied (see next section). 

To edit a character style, proceed as follows: 

1. Invoke the menu command Format > Character Style. 

2. Select the style to be changed from the list. 
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3. Click on Edit. 

4. Make the desired changes in the style. 

5. Click on OK. 

6. Exit the dialog box with Close. 

Your modifications to the style are now effective. 

Choosing which styles to show in the list 

By default, the dialog mentioned above lists only styles that are in use or have been 

modified by the user. If you want it to display all styles available, choose All styles 

in the Show option. This will display all predefined styles as well. 

Updating a style to match existing text 

The Update from text button in the dialog can be used to update a style to match 

the currently selected text. As a result, the chosen style will be changed in a way 

that it uses exactly the same formatting options as that text. 

Proceed as follows: 

1. Set up the character format (font face, font size, etc.) of any text segment to 

your liking. 

2. Place the text cursor inside that text (or select it; either will do). 

3. Invoke the menu command Format > Character Style. 

4. Select the style to be changed from the list. 

5. Click on Update from text. 

The style will “forget” its previous settings and adopt the formatting options of the 

specified text. (Of course you can still change the style’s formatting options 

whenever you like, independently from the text.) 

Deleting or renaming styles 

To delete a style in the current document, select it in the dialog and then click on 

the Delete button. To give a style a new name, click on Rename and type the new 

name. 
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Note: The Delete button is not available for predefined styles. 

To delete or rename styles in a document template, open the document template, 

make the changes there and save the template. 

The scope of character styles 

You changed a character style, but the formatting of some of the text segments to 

which this style had been applied didn’t change accordingly? This happens when 

those segments had been reformatted manually. An example: 

Let’s assume that you define a style with the Arial font and apply it. If you subse-

quently change the style’s font to Times New Roman, all the text segments that are 

formatted in this style are reformatted accordingly. 

But: If you had manually selected a different font for a text segment, any changes 

you make to the character style thereafter will no longer be applicable to this text 

segment. That is to say, manually applied character formats take precedence over 

styles. 

If you want to “free” such a text segment of its manual formatting, invoke the 

menu command Format > Standard. The formatting specified for the applied cha-

racter style will then be restored to the segment. 

The character style Normal 

A character style named “Normal” is present by default in every document and has 

a special significance. It is the standard style for the text. When you start typing 

text in a new document, the text is automatically assigned the “Normal” style, un-

less and until you select another style, which becomes effective from the current 

position. 

If you change the “Normal” style, for example by specifying a new typeface for it, 

the new typeface is applied to the entire existing text (to the extent that no special 

typeface has been assigned to it manually). Moreover, it is applied to any text you 

enter subsequently, for by changing the “Normal” style in this way you are chan-

ging the default font. 
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Creating linked character styles 

When you create new character styles, as described at the beginning of this section, 

they are always based on the character style called “Normal”. Accordingly, if you 

change the “Normal” style, for example by selecting a different typeface for it, all 

the character styles based on it are changed as well (except for those styles where 

you have explicitly specified a different typeface). 

So: By default, all character styles are linked to the “Normal” style. However, 

when you create a new style, you can specify another character style as the basis 

for it in Based on. 

To create a character style and base it on a specific style other than “Normal”, do 

the following: 

1. Invoke the menu command Format > Character Style. 

2. Click on the New button. 

3. Give the style a name. 

4. Switch to the Style tab. 

5. Now comes the distinctive step: In Based on, select the style to which the new 

style is to be linked. 

6. Now you can enter the desired formatting, etc. 

An application example: 

Let’s assume that you want to use a bolded strong-featured font for the headings in 

your doctoral thesis. But you also want the headings to be in different sizes to re-

flect their hierarchical relationships. 

To accomplish this, you would proceed as follows: 

1. First, create a character style called “Headings1” for the highest level headings. 

At this point, select the special typeface you want, specify 24 points for the si-

ze, and enable bold. 

2. Next, add a style called “Headings2”, select the “Headings1” style in Based on 

and specify 18 points for the size. 

3. A character style called “Headings3”, based on “Headings2” and with 14 point 

type, can follow for the next lower level, etc. 
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Benefit: If it should occur to you later that a different font is better suited for the 

headings, you can reformat all the headings with the styles “Headings1” through 

“Headings3” in this font merely by changing the font specification for the “Hea-

dings1” character style. If you had based the heading styles on “normal”, you 

would have had to change the font specification for each style separately. 

Relative font sizes 

When you base one style on another, you can, if you wish, specify the font size in a 

relative manner. For example, you can specify that the font size for style X should 

always be 80% of the font size for style Y. 

You can do this as follows: 

1. Invoke the menu command Format > Character Style. 

2. Select a style and click on Edit. 

3. Switch to the Style tab. 

4. Enable the Scale option. 

5. Enter the desired factor as a percentage – for example 80. 

6. Confirm with OK. 

The font size for a style edited in this manner will always be 80% of the size spe-

cified for the style on which it is based. 

Character styles and the sidebar 

On the previous pages, you have learned how to create, apply, and modify charac-

ter styles. Alternatively, you can perform these tasks with the help of another very 

useful tool in TextMaker: the sidebar. 

The sidebar can, amongst other things, display a list of all character styles availab-

le. To format text in a specific style, simply select the text and then double-click on 

the character style in the sidebar. 

Apart from that, you can also use the sidebar for editing and managing character 

styles. All you have to do is enable the sidebar and activate its character styles 

function. This can be achieved as follows: 

1. If the sidebar is not displayed, enable it (e.g. by invoking the menu command 

View > Sidebar > Show at Right). 
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2. In the little toolbar displayed at the top of the sidebar, click on the  icon. 

This will switch to the character styles function of the sidebar. 

The sidebar now displays all character styles available in the document, allowing 

you to perform the following actions: 

 Applying a character style 

 First, select the characters to be formatted in your document. Then, double-

click on the desired style in the sidebar. 

 (Alternatively, select the style with a single click and then click on the Apply 

button at the bottom of the sidebar.) 

 Editing a character style 

 In the sidebar, select the style of interest with a single mouse-click. Then, click 

on the Edit button at the bottom of the sidebar. 

 Managing character styles 

 In the sidebar, select the style of interest with a single mouse-click. Then, click 

on the Organize button at the bottom of the sidebar.  

 A little menu with commands for managing styles pops up, allowing you to 

create styles, delete styles, rename styles, etc. Detailed information on each of 

these commands can be found in the section “Character styles” (beginning on 

page 130). 

 Hint: You can open this menu faster by right-clicking on a style in the sidebar. 

 Creating a new character style 

 In the sidebar, right-click on the style on which the new style should be based 

on. The menu mentioned above pops up. There, choose the New... command. 

Paragraph styles 

You can save a frequently needed paragraph format (indentation, tab stops, align-

ment, etc.) in a paragraph style and apply it repeatedly to any paragraph you like. 

For example, if you want the headings in your document to be in large bold type 

and centered, simply create a paragraph style called “Heading” and apply it to the 

desired paragraphs. 
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Note: The difference between character styles (see section “Character styles” be-

ginning on page 130) and paragraph styles is that character styles contain only sa-

ved character formatting (typeface, text styling, etc.), while paragraph styles con-

tain both character formatting and paragraph formatting. 

Moreover, character styles are applicable to individual characters, while paragraph 

styles are applicable only to complete paragraphs. 

On the next pages, you will find detailed information on working with paragraph 

styles. The following topics are covered: 

 Creating paragraph styles 

 Applying paragraph styles 

 Modifying paragraph styles 

 The scope of paragraph styles 

 The paragraph style Normal 

 Creating linked paragraph styles 

 Paragraph styles and the sidebar 

Creating paragraph styles 

To create a new paragraph style, do as follows: 

1. Invoke the menu command Format > Paragraph style. 
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2. Click on the New button. 

3. Give the paragraph style whatever name you like. 

4. A dialog box much like the one of the Format > Paragraph menu command 

appears. Here, you can specify the desired paragraph formatting (see section 

“Paragraph formatting” beginning on page 83). 

5. Tip: If you will need the paragraph style frequently, you can assign a keyboard 

shortcut to it (see below). 

6. When you have made all desired settings, click on OK to define the style. 

7. Exit the dialog box with Close. 

The style is now defined and ready for use. You will learn in a moment how to use 

it (section “Applying paragraph styles”). 

Creating a new paragraph style from selected text 

Alternatively, you can format some text first and then create a paragraph style that 

uses exactly the same formatting options. For this purpose, use the New from text 

button instead of the New button. 

This method is useful when you have formatted paragraphs “by hand” and want to 

have a paragraph style that has exactly the same formattings. 

Proceed as follows: 
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1. Set up the paragraph format (indents, line spacing, alignment, etc.) of one or 

more paragraphs to your liking. 

2. Place the text cursor inside one of these paragraphs (or select the paragraphs; 

either will do). 

3. As described above, use the Format > Paragraph style menu command to 

create a new paragraph style. However, in this case use the New from text but-

ton rather than the New button. 

A paragraph style created this way will behave like any other paragraph style. The 

only difference is that its original paragraph format is based on the selected text. Of 

course you can change its formatting options anytime. 

The “Next Style” option – or: Which style should be applied to the next 

paragraph? 

Whenever you close a paragraph by pressing the Enter key (¢), that paragraph’s 

style is automatically carried over to the next paragraph.  

This is the normal case; however, it is sometimes inconvenient. For example, hea-

dings usually consist of just a single line followed by normal text, and when you 

have typed a heading, you usually want to revert to the “Normal” style. 

Therefore, for every paragraph style you can specify the style to be applied to the 

next paragraph once the current paragraph is closed by pressing (¢). To do this, 

switch to the Style tab in the dialog for editing the style. There, select the desired 

following style in the Next Style option – according to our example it would be the 

“Normal” style. 

Using keyboard shortcuts 

If you need a format style very frequently, you can give it a keyboard shortcut. The 

advantage of doing that is that you can then apply the style very quickly, using a 

single key press. 

To assign a keyboard shortcut to a style, switch to the Style tab in the dialog for 

editing the style. There, position the text cursor in the Shortcut key edit box and 

press the desired key combination. 
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Note: If you press a key combination that is already assigned, the current as-

signment is displayed below the Shortcut key edit box. In that case, you should 

press the Backspace key (æ__) to delete this key combination and then enter 

another one. Otherwise, you will overwrite the assignment for another style, or 

even for one of TextMaker’s commands. 

We recommend using key combinations that include the keys (Ctrl) and (Shiftª), 

since these are normally not assigned. 

Applying paragraph styles 

To apply a paragraph style, do the following: 

1. Place the text cursor in the paragraph of interest (or select multiple paragraphs 

to be modified). 

2. Invoke the menu command Format > Paragraph style. 

3. Select the desired style. 

Hint: In the right half of the dialog, a preview of the currently selected style 

is presented. The preview can be turned on/off with the >> button and the << 

button anytime you wish. 

4. Click on Apply. 

The formatting of the selected paragraphs changes to the formatting specified for 

the paragraph style.  

Tip 1: You can also select paragraph styles from the list box displayed at the far 

left in the Formatting toolbar. 

Tip 2: If you assigned a keyboard shortcut to the format style, you can apply sty-

les even faster: simply press the assigned key combination. 

Tip 3: Additionally, you can use the sidebar to apply styles – or even modify 

them. See section “Paragraph styles and the sidebar”, page 146. 

Modifying paragraph styles 

Naturally, you can modify paragraph styles whenever you like. 
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Important: Changing a paragraph style automatically changes the formatting of 

all paragraphs to which that style is applied! However, this automatic reformat-

ting is limited for any paragraphs to which manual paragraph formatting has also 

been applied (see the next section). 

To edit a paragraph style, proceed as follows: 

1. Invoke the menu command Format > Paragraph style. 

2. Select the style to be modified from the list. 

3. Click on Edit. 

4. Make the desired changes in the style. 

5. Click on OK. 

6. Exit the dialog box with Close. 

The style is modified according to your edits. 

Choosing which styles to show in the list 

By default, the dialog mentioned above lists only styles that are in use or have been 

modified by the user. If you want it to display all styles available, choose All styles 

in the Show option. This will display all predefined styles as well. 

Updating a style to match existing text 

The Update from text button in the dialog can be used to update a style to match 

the currently selected text. As a result, the chosen style will be changed in a way 

that it uses exactly the same formatting options as that text. 

Proceed as follows: 

1. Set up the paragraph format (indents, line spacing, alignment, etc.) of one or 

more paragraphs to your liking. 

2. Place the text cursor inside one of these paragraphs (or select the paragraphs; 

either will do). 

3. Invoke the menu command Format > Paragraph style. 

4. Select the style to be changed from the list. 

5. Click on Update from text. 



 

144  •  Styles Manual TextMaker 

The style will “forget” its previous settings and adopt the formatting options of the 

specified text. (Of course you can still change the style’s formatting options 

whenever you like, independently from the text.) 

Deleting or renaming styles 

To delete a style in the current document, select it in the dialog and then click on 

the Delete button. To give a style a new name, click on Rename and type the new 

name. 

Note: The Delete button is not available for predefined styles. 

To delete or rename styles in a document template, open the document template, 

make the changes there and save the template. 

The scope of paragraph styles 

You changed a paragraph style, but the formatting of some of the paragraphs to 

which this style had been applied didn’t change accordingly? This happens when 

those paragraphs had been reformatted manually. An example: 

Let’s assume that you define a style specifying the paragraph alignment to be cen-

tered. If you subsequently change the style’s alignment to flush right, all the para-

graphs to which this style is applied are reformatted accordingly. 

But: If you had selected a different alignment for one of these paragraphs manual-

ly, any changes you make to the paragraph style thereafter will no longer be appli-

cable to this paragraph. That is to say, manually applied paragraph formats take 

precedence over styles. 

If you want to “free” such a paragraph of its manual formatting, simply select it 

and reapply the original paragraph style using the menu command Format > Pa-

ragraph style. The format of the paragraph will revert to that specified in the style, 

and subsequent changes to the style will be effective on the paragraph. 

The paragraph style Normal 

A paragraph style called “Normal” is present by default in every document. It has a 

special significance: it is the standard style of paragraph formatting for the 

document. When you start typing text in a new document, the “Normal” style is 

automatically assigned to the text, unless and until you select a different style, 

which becomes effective from the current position. 
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If you change the “Normal” style, for example by specifying a new line spacing for 

it, every paragraph in the document is reformatted accordingly (excepting those 

paragraphs formatted with a different line spacing manually). Moreover, para-

graphs you enter subsequently will have this new line spacing. 

Creating linked paragraph styles 

When you create new paragraph styles, as described at the beginning of this sec-

tion, they are always based on the paragraph style called “Normal”. Accordingly, if 

you change the “Normal” style, for example by selecting a different line spacing 

for it, all the paragraph styles based on it are changed as well (except for those sty-

les where you have explicitly specified a different line spacing). 

So: By default, all paragraph styles are linked to the “Normal” style. However, 

when you create a new style, you can specify another paragraph style as the basis 

for it in Based on. 

To create a paragraph style and base it on a specific style other than “Normal”, do 

the following: 

1. Invoke the menu command Format > Paragraph style. 

2. Click on the New button. 

3. Give the style a name. 

4. Switch to the Style tab. 

5. Now comes the distinctive step: In Based on, select the style to which the new 

style is to be linked. 

6. Now you can enter the desired formatting, etc. 

The print version of this manual serves as example of the use of linked paragraph 

styles. Here, the paragraph styles for all heading levels are based on a single para-

graph style that specifies, among other things, an increased spacing from the pre-

ceding paragraph. 

When we reviewed the printed proofs, we determined that the spacing we had cho-

sen was too small. To correct the problem, all we had to do was increase it in that 

one underlying style; immediately, the spacing of all the headings grew. Had we 

based the header styles on “Normal”, we would have had to change each of these 

styles separately. 
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Paragraph styles and the sidebar 

On the previous pages, you have learned how to create, apply, and modify para-

graph styles. Alternatively, you can perform these tasks with the help of another 

very useful tool in TextMaker: the sidebar. 

The sidebar can, amongst other things, display a list of all paragraph styles availab-

le. To format a paragraph in a specific style, simply place the cursor inside it and 

then double-click on the paragraph style in the sidebar. 

Apart from that, you can also use the sidebar for editing and managing paragraph 

styles. All you have to do is enable the sidebar and activate its paragraph styles 

function. This can be achieved as follows: 

1. If the sidebar is not displayed, enable it (e.g. by invoking the menu command 

View > Sidebar > Show at Right). 

2. In the little toolbar displayed at the top of the sidebar, click on the  icon. 

This will switch to the paragraph styles function of the sidebar. 

The sidebar now displays all paragraph styles available in the document, allowing 

you to perform the following actions: 

 Applying a paragraph style 

 First, place the cursor in the paragraph of interest (or select multiple para-

graphs). Then, double-click on the desired style in the sidebar. 

 (Alternatively, select the style with a single click and then click on the Apply 

button at the bottom of the sidebar.) 

 Editing a paragraph style 

 In the sidebar, select the style of interest with a single mouse-click. Then, click 

on the Edit button at the bottom of the sidebar. 

 Managing paragraph styles 

 In the sidebar, select the style of interest with a single mouse-click. Then, click 

on the Organize button at the bottom of the sidebar.  

 A little menu with commands for managing styles pops up, allowing you to 

create styles, delete styles, rename styles, etc. Detailed information on each of 

these commands can be found in the section “Paragraph styles” (beginning on 

page 138). 

 Hint: You can open this menu faster by right-clicking on a style in the sidebar. 
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 Creating a new paragraph style 

 In the sidebar, right-click on the style on which the new style should be based 

on. The menu mentioned above pops up. There, choose the New... command. 

Managing styles 

FreeOffice: The Style Manager is not included in SoftMaker FreeOffice. 

TextMaker’s integrated style manager allows you to manage the character styles 

and paragraph styles of documents. Its main purpose is to copy styles from one 

document to another. 

To open the style manager, choose the Format > Manage styles menu command. 

 

By default, the left list displays the styles of the current document, while the right 

list is empty. 

To operate the style manager, use the provided controls as follows: 
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Left list 

In the left list, all paragraph styles and character styles of the current document are 

displayed. Select one or more styles in the list and click on one of the buttons 

described below to perform the desired action. To select multiple styles, press and 

hold the (Ctrl) key and click each entry that you want to select. 

If you would like to open a different document in the list, click the Open button 

and select the desired file. 

Right list 

The right list can be used to open a second document, allowing you to copy styles 

between two documents. To open a second document, use the Open button located 

below the right list. 

>> and << buttons 

The two buttons labeled with >> and << can be used to copy styles between the 

two documents opened in the dialog. 

First select one or more styles in either list. Then, click on the >> button to copy 

styles from the left list to the right list, or click the << button to copy from the right 

list to the left. 

If you try to copy a style that already exists in the target document, TextMaker first 

asks you for permission to overwrite it. 

Rename button 

To rename a style, select it, click the Rename button and enter the new name. 

Note: The default style named “Normal” cannot be renamed. 

Delete button 

To delete styles, select them and click the Delete button. 

Note: The default style named “Normal” cannot be deleted. 
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Close button 

Use this button to close the style manager. 

Document templates 

As you learned from the previous sections, character and paragraph styles are sa-

ved in the document in which they were created. If you want to use certain styles in 

future documents as well, you should save them in a document template. 

Each time you invoke the menu command File > New, TextMaker allows you to 

select a document template as the basis for the new document. If, at this point, you 

select a document template that you have created, all character and paragraph sty-

les that you stored in the template will become available to you in the new 

document. 

Document templates can also include text – for example a letterhead. So, you can 

kill two birds with one stone: set up a document template with your letterhead and 

your favorite styles for letters, create another template for faxes, another for busi-

ness reports, and so forth. 

Templates linked to a database 

It gets even better: You can attach a database to a document template and then in-

sert database fields into it. Then, when you create a new document on the basis of 

this template, the TextMaker database appears automatically, allowing you to select 

a record and insert its fields into your letterhead, your fax form, etc. 

Creating a letter becomes child’s play: invoke the menu command File > New, 

choose the letter template, select the addressee – and the letterhead is completely 

filled out and ready. 

Tip: TextMaker comes with numerous prepared document templates for letters, 

faxes, etc. Try them out sometime – simply invoke the File > New menu com-

mand and select a template from one of the sub-folders. 

You will find more information about this topic in section “Importing individual 

addresses” beginning on page 362. 

For general information on working with document templates, see the next pages. 
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Creating document templates 

To create a new document template, proceed as follows: 

1. Start a new document or open a document or document template that you want 

to use as a basis for the new template.  

2. If the document template is to contain text, enter the desired text. 

3. Make any desired changes to the character and paragraph styles. 

4. If you like, you can even make changes to options in the dialogs of the File > 

Page setup and the File > Properties menu commands. All of these settings 

will also be stored in the document template. 

5. Invoke the menu command File > Save as. 

6. Select the entry Template from the Save as Type list box. 

7. At this point, TextMaker switches automatically to the folder where document 

templates are kept. 

8. Type a name for the template in the File name edit box. 

9. Confirm with OK. 

Organizing templates in several folders: You can use the New Folder button at any 

time to set up a new folder under the Templates folder, then switch to the new fol-

der and save the template there. In this way, templates can be stored in separate 

folders according to application. For example, the document templates supplied 

with TextMaker are organized under folders named Fax, Letter, etc. 

Applying document templates 

To make use of a document template, simply begin a new document with the menu 

command File > New. TextMaker automatically asks you what template you want 

to use as a basis for the new document. 

So, you do the following: 

1. Invoke the menu command File > New. 

2. A dialog appears, allowing you to select the desired document template from a 

list. 
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 You will see both templates and folders in the list. The folders can be opened 

by double clicking on them. They contain prepared document templates for wri-

ting letters, faxes, etc. 

3. Select a document template. 

Hint: In the right half of the dialog, a preview of the currently selected temp-

late is presented. The preview can be turned on/off with the >> button and the 

<< button anytime you wish. 

4. Confirm by clicking on OK. 

A new document is now set up from this template and all the character and para-

graph styles saved in the template become available to you. Additionally, all set-

tings made in the dialogs of the menu commands File > Page setup and File > 

Properties are also inherited from the document template. 

And: If the template also contains text, this text is displayed in the new document 

and can be edited just like normal text. 

Tip: TextMaker is distributed with various prepared document templates. These 

contain complete letterheads, fax forms, etc. and are linked with the address 

database TMW.DBF. They can lighten your daily writing load considerably – read 

about this in section “Importing individual addresses” beginning on page 362! 

Modifying document templates 

Modifying a document template is no different from editing a normal document. 

You open the template, make your changes and save the template. 

Important: Naturally, when you modify a document template, your modifica-

tions will affect all documents that are subsequently created on the basis of this 

template. 

To modify a document template, proceed as follows: 

1. Invoke the menu command File > Open. 

2. Select the entry Template from the Files of type list box. 

3. Find the template to be modified and confirm with OK. 

4. Make the desired changes in the text or in the character and paragraph styles. 

5. Invoke the menu command File > Save to save the modified template. 
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Of course, you could also save the template under another name, using the menu 

command File > Save as, if you did not want to overwrite the original. 

The document template Normal.tmvx 

The document template NORMAL.TMVX has a special significance: it is the default 

template for new documents. It contains no text, and only the default “Normal” 

character and paragraph styles, along with some styles for headings. 

Accordingly, the NORMAL.TMVX template is a suitable basis for creating a comple-

tely new template, starting from scratch. 

Important: As a rule, you should not modify the default template NOR-

MAL.TMVX. Nevertheless, if you want to do this, you ought to be aware that it 

contains the default values for page, paragraph and character formatting, as well 

as many additional defaults. Any modification will affect all documents that you 

subsequently create new on the basis of the default template NORMAL.TMVX. 

If you want to change a default format (for example, the typeface) so that the for-

mat will be applied by default to all documents that you create in the future on the 

basis of the NORMAL.TMVX template, open the template, make the change – in this 

case to the character formatting for the “Normal” paragraph style – and save the 

template. 

You can also choose a template other than NORMAL.TMVX to be the default for new 

files. To do this, invoke the menu command File > New, select the desired templa-

te, and click on Set Default. From now on, TextMaker will always offer this temp-

late as the default when you create a new document. 
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Multi-column page layouts 

In TextMaker it is possible to lay out text in multiple columns. Within a document, 

you can change the number of columns as often as you like. 

Entering text in a section of the document that has multiple columns is not much 

different than entering text in a single column section. The one difference: when 

you reach the end of the first column, your text is not continued on a new page; 

instead, it is continued in the next column on the same page. In other words: a co-

lumn break is automatically inserted. A page break is inserted only when you con-

tinue typing past the end of the last column. 

Manual column break: You can direct TextMaker to break a column above the point at 

which it would insert a break automatically by manually invoking the Insert > 

Break > Column break menu command at the desired place. TextMaker then 

breaks the column immediately. 

Detailed information about setting up multi-column text is given on the following 

pages. 

Changing the number of columns 

To reformat a section of single column text in e.g. three columns, all you have to 

do is select the text and change the number of columns with the Format > Section 

menu command.  

To do this, proceed as follows: 

1. Select the text you want to reformat. 

2. Invoke the menu command Format > Section. 
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3. Important: Make sure that the Apply to control is set to Selected text.  

4. Enter the desired number of columns in the Number field. 

5. TextMaker determines the optimum column widths automatically. However, 

you can specify manually both the column width and the spacing between co-

lumns in the Columns group box if you need to do so (see below). 

6. Confirm with OK. 

The selected text is now formatted in the specified number of columns. 

If you want to convert multi-columned text back to single-columned text, follow 

the procedure described above, but enter “1” for the number of columns. 

The dialog box for the Format > Section menu command also contains the follo-

wing options: 

Columns tab 

You specify the number of columns and their format on the Columns tab: 
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 Presets group box 

 Here you can select one of several pre-defined column layouts by clicking on it 

with the mouse.  

 Columns group box 

 Lets you specify the number, width and spacing of columns. 

 Enter the desired number of columns at Number. 

 Specify the width and spacing of the columns at Width and Spacing respec-

tively. If Equal column width is checked, all columns will have the same 

width and spacing. If this option is unchecked, you can specify a different 

width and spacing for each column. 

 Height 

 Let you specify the height of the columns: 

 Auto: When you select this setting, TextMaker automatically adjusts the height 

of the columns based on the length of the text, so the text is fitted into columns 

of equal height. 

 Page height: With this setting, the column height is set equal to the page height 

– independently of text length. 

 Fixed height: When you select this setting, you can specify a fixed column 

height. 

 Page break 

 If this option is checked, TextMaker inserts a page break at the beginning of the 

multi-column section. 

 Restart auto numbers 

 This option is does not affect the column layout but auto numbers. If it is che-

cked, the “Auto number” field is reset to one in the current section. You will 

find information about the use of auto numbers in section “Numbering with Au-

to numbers” beginning on page 195. 

 Text direction 

 For text in Arabic script, you can change the writing direction of a multi-

column text section with this option. When you set the direction to right-to-left, 

the column on the very right becomes the first column (instead of the column at 

the very left).  See also chapter “Working with Arabic text” (page 523). 
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 Margins button 

 Here you can specify the margins of the section, allowing you to change, for 

example, the amount of blank space TextMaker should insert above and below 

the section. 

 Gutter line button 

 With the help of the Gutter line button, you can direct TextMaker to display 

vertical lines between the columns of multi-column text. 

 When you click it, a dialog appears, allowing you to select the desired line sty-

le, thickness, etc. 

 If you want to remove gutter lines, simply select None as the Line style. 

 Apply to: 

 Determines what parts of the document will be affected by the settings you 

make in this dialog: 

 Whole document: the entire document. 

 This point forward: that part of the document beginning at the current position 

of the text cursor and ending at the end of the document. 

 Selected text: the text segment currently selected in the document. 

 Current section: the current section. A section is a segment of text with a uni-

form number of columns (see also the next section). 

 Selected sections: all sections included in the current selection. 

 To end of section: the segment of text beginning at the current position of the 

text cursor and ending at the end of the current section. 

Line numbers tab 

The options on the Line numbers tab do not affect the column layout. Rather, they 

allow you to direct TextMaker to number the lines of your text and add the line 

numbers in the left margin. You will find additional information about this in sec-

tion “Adding line numbers” beginning on page 196. 
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What are sections? 

The term “section” has been used several times in this chapter. But what are sec-

tions? Simply put, a section is a segment of text that has a uniform columnar lay-

out. 

An example: You have selected a segment of text in the middle of a single-column 

document and formatted it as double-column text. 

 

By doing this, you have created three sections: a single-column section at the be-

ginning of the document, a double-column section in the middle, and another sin-

gle-column section at the end. 

If you decide you want the middle section to be formatted in three columns instead 

of two, you can reformat it simply by moving the text cursor to a position anywhe-

re within the middle section and then invoking the menu command Format > Sec-

tion. Under Apply to, select Current section; then change the number of columns 

to 3. The double-column section is then reformatted in three columns. 

Entering a section break: You can use the Insert > Break > Section break menu 

command to divide a section into two sections. In this way, a document can be di-

vided into additional sections, and each section can be formatted with a different 

number of columns. 

Page breaks before sections: By default, TextMaker does not insert a page break 

between two sections, and it allows the text to flow without interruption from one 

section to the next. However, if you want to ensure that a given section will always 

start on a new page, you can position the text cursor within this section, invoke the 

Format > Section menu command and check the Page break option in the dialog 

box. 
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Searching and replacing 
In this chapter you will get acquainted with all the functions that have to do with 

searching and replacing text and formatting.  

 Searching and Replacing 

 You can search for terms in the text and, if required, replace them with other 

terms.  

 For example, if a text contained several occurrences of the name “Smith”, 

misspelled “Smithe”, you could direct TextMaker to replace all occurrences of 

“Smithe” with “Smith”. 

 In addition, it is possible to search and replace formatting such as the format-

ting for characters and paragraphs. 

 Bookmarks 

 Bookmarks provide another way to get quickly to specific points in the 

document. You can set a bookmark at any position in the document you wish. 

After giving the bookmark a name, you can use the Edit > Go to menu com-

mand to return to the bookmarked position any time you wish. You can insert as 

many bookmarks as you like in a document. 

 The Go to ... Command 

 The Edit > Go to menu command also allows you to move to specific positions 

in the document according to other criteria – for example, you can move to a 

specific page, a specific chapter, a specific object, etc. 

 Navigating documents with the sidebar 

FreeOffice: Navigating with the sidebar is not included in SoftMaker Free-

Office. 

 The sidebar provides an even faster way for navigating your documents. Dis-

played to the right of the document, and presents a list of all headings, book-

marks, objects, etc. When you click on one of these entries, TextMaker jumps 

to the corresponding place instantaneously. 

For detailed information, see the pages that follow. 
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Searching 

You can search a document for a specific term using the Edit > Search menu 

command. 

It is even possible to search for formatting – for example for all passages in bold 

characters (see section “Searching/replacing formatting” beginning on page 165). 

 

You perform a text search as follows: 

1. Invoke the Edit > Search menu command. 

2. Under Search for, enter the text for which you want to search. 

3. As necessary, check the options for the search (see section “Expanded search 

options” beginning on page 162). 

4. Click on the Search button to begin the search. 

When TextMaker finds the search text, it scrolls to its position in the document and 

selects it.  

You can then do either of the following: 

A) You can click on Search again, to proceed to the next occurrence of the search 

text. 

B) You can click on Close to end the search and close the search dialog.  

You can not only search for a specific text, but also replace it with something else. 

You will read about this in the next section. 
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Replacing 

Sometimes you want to do more than just find a term in the text. You want an easy 

way of exchanging it for another term. The menu command Edit > Replace is pro-

vided to meet this requirement. 

Proceed as follows: 

1. Invoke the Edit > Replace menu command. 

2. Under Search for, enter the text for which you want to search. 

3. Under Replace with, enter the text that is to replace the search text. 

4. As necessary, check the options for the search (see section “Expanded search 

options” beginning on page 162). 

5. Click on the Search button to begin the search. 

When TextMaker finds the search text, it scrolls to its position in the document and 

selects it. 

You can then do any of the following: 

A) You can click on Replace to have TextMaker replace the selected occurrence of 

the search term with the replacement term and jump to the next occurrence of 

the search term. 

B) You can click on Search again to have TextMaker jump to the next occurrence 

of the search term – without replacing the selected occurrence. 

C) You can click on Replace all to have TextMaker replace the selected occur-

rence of the search term and all subsequent occurrences it finds in the text. 

D) You can click on Close to end the search and close the search dialog. 

Repeating a search/replace 

To repeat a search or replace operation, or to continue a search or replace operation 

that was interrupted, you can use the menu command Edit > Search again or Edit 

> Replace again, or press the (F3) key. 

TextMaker continues the last search it was conducting. When it finds another oc-

currence of the search term, it displays that occurrence. 
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Hint: A search operation can also be continued using the following keys: 
(Ctrl)(PgDn¼) to jump to the next occurrence, (Ctrl)(PgUp½) to jump to the pre-

vious occurrence. 

Expanded search options 

When you click on the Enlarge button in the dialog of the Edit > Search or the 

Edit > Replace menu command, the dialog expands to offer additional options. 

Clicking on the Reduce makes the dialog contract and hide the additional options. 

Thus you can specify the appearance of the dialog according to your preference for 

having the most options at your disposal or for having as much of the text as pos-

sible visible while you are searching.  

The expanded search/replace dialog offers the following additional options: 

“Options” group box 

Here you can make settings for controlling the search operation as follows: 

 Case sensitive 

 By default, the case of letters in the search term is ignored. Thus, if you search 

for “house”, not only “house”, but also “House”, “HOUSE”, “HouSe”, etc. will 

be found.  

 However, if you check this option, only those occurrences of the search term 

will be found in which the cases of the letters correspond exactly to the cases of 

the letters in the search term. Thus, if you search for “house”, only “house” will 

be found.  

 Whole words only 

If you check this option, only those occurrences of the search term that are se-

parate words will be found. 

 Thus, if you search for “test”, it will be found only when it stands alone (as a 

separate word) and not when part of another word like “testament” or “protest”. 
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 Search from top 

 By default, TextMaker begins a search at the current position of the text cursor. 

However, if you check the Search from top option, TextMaker begins at the 

beginning of the document. 

 When the Search backwards option is checked, Search from top is replaced 

by Search from end, which works in a corresponding way. 

 Search backwards 

If you check this option, the search proceeds in the reverse direction, that is, 

from the current position of the text cursor towards the beginning of the text. 

 Search all frames 

 By default, TextMaker searches only in the text frame in which the text cursor 

is presently positioned. If the text cursor is in the body text, only the body text 

is searched. However, if you check this option, TextMaker searches the body 

text as well as all text frames present in the document (including headers and 

footers).  

“Reset” button 

The Reset button clears the contents of the Search for field or the Replace with 

field (including formatting) – depending on which of these fields contains the text 

cursor. 

“Format” button 

The Format button enables you to search a document for specific formatting – for 

example, for all segments of text in bold characters, or for all centered paragraphs. 

Click on this button and set the formatting for which you want to search. 

You will find more information about this function in the next section 

(“Searching/replacing formatting”). 

“Special” button 

The Special button enables you to search a document for special characters and to 

use wildcards for such things as “any character”: 
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 Any number (^#) – if you specify, for example, a search for “200^#”, TextMa-

ker will find occurrences of “2000” through “2009”. 

 Any letter (^$) – if you specify, for example, a search for “^$”, TextMaker will 

find occurrences of “a” through “z” and “A” through “Z” (including letters with 

accents). 

 Any character (^?) – searches for any character whatsoever (letter, number or 

punctuation sign). 

 Any Smart quote (^q) – searches for any kind of Smart quote. (Neutral quotes 

like " or ' will not be searched for.) 

 Caret (^^) – searches for “^” (caret). 

 Non-breaking space (^n) – searches for non-breaking spaces. 

 Tab (^t) – searches for tabs. 

 Line break (^z) – searches for manual line breaks (inserted with (Shiftª)(¢)). 

 Paragraph break (^a) – searches for the paragraph mark that is found at the 

end of every paragraph. 

 Page break (^p) – searches for manual page breaks (inserted e.g. with the In-

sert > Break > Page Break menu command). 

 Section break (^s) – searches for section breaks (inserted e.g. with the Insert > 

Break > Section Break menu command). 

 Chapter break (^c) – searches for chapter breaks (inserted e.g. with the Insert 

> Break > Chapter Break menu command). 

To include one of these symbols in the search term, click on the Special button and 

select the desired symbol with a mouse click. 

You can repeat and combine these symbols at will within the same search term. 

Moreover, you can use them together with normal text. A search for “^#^# gallons 

of ^$^$^$” would yield all occurrences of this form – for example “10 gallons of 

oil”, “42 gallons of gas”, etc. 



 

Manual TextMaker Searching and replacing  •  165 

Searching/replacing formatting 

The menu commands Edit > Search and Edit > Replace allow you to search not 

only for text, but also for formatting – and even to replace the specified formatting 

with other formatting as required.  

With this command you can, for example, replace a specific font with another font 

at all the points in the text where the former occurs. 

To search for formatting, proceed as follows: 

1. Invoke the menu command Edit > Search. 

2. If the Format button is not displayed in the dialog, click on the Enlarge button 

to expand the search dialog. 

3. Clear any old search term in the Search for field by clicking on the Reset but-

ton. 

4. Click on the Format button. 

5. Select the kind of formatting for which you want to search: character format-

ting, paragraph formatting, character style or paragraph style. 

6. In the new dialog box that appears, specify the format(s) for which you want to 

search. Then confirm with OK. 

7. Now you can start the search with the Search button. 

To search for formatting and replace it with other formatting, proceed as 

follows: 

1. Invoke the menu command Edit > Replace. 

2. Using the Format button, specify the formatting for which you want to search 

(see above) and confirm with OK. 

3. Click in the Replace with field. 

4. Again use the Format button to specify the formatting that is to replace the 

formatting specified above as the search term. Again confirm with OK. 

5. Now you can start the search with the Search button. 

When TextMaker finds an occurrence of the search term, it displays the occurrence 

in the document.  
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To continue searching, click on the Search again button. Alternatively, if you want 

to replace the present occurrence of the formatting, click on the Replace button. If 

you click on Replace all, TextMaker replaces the occurrence of the formatting it 

has just found and all subsequent occurrences that it finds in the text, with the new 

formatting. 

Tip: You can use this function to replace, for example, one font with another, 

wherever the former occurs in the document. However, experts would use styles 

to do this (see chapter “Styles” beginning on page 129), since they provide a 

much more elegant means of accomplishing this task. If you change the font in a 

style, all text segments that are formatted with this style are automatically modi-

fied accordingly. 

By the way, text and formatting can be searched in combination. Thus, you can 

search for a specific term in a specific format. For example, if you enter “TextMa-

ker” as the search term and also specify “bold” character formatting for the search, 

the search will find every occurrence of “TextMaker” in bold characters in the 

document. 

Bookmarks 

You can place text markers in TextMaker documents just as you do in books when, 

for example, you want to be able to return quickly to important passages. These 

text markers are called bookmarks. 

To insert a bookmark, invoke the menu command Insert > Bookmark at the desi-

red position in the text and give the bookmark a name. Once you have marked a 

position in the text in this way, you can jump to it at any time with the Edit > Go 

to command. 

Setting bookmarks 

To mark a position in the text, set a bookmark there using the following procedure: 

1. Move the text cursor to the position in the text that you want to mark. 

2. Invoke the Insert > Bookmark menu command. 

3. Enter whatever name you like for the bookmark. 

 Note: Bookmark names may contain only letters, numbers and underscores. Special characters are 

not allowed. The name must always begin with a letter. 
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4. Click on OK to set the bookmark. 

You can set as many bookmarks as you wish in each document. 

Using bookmarks 

To return to a bookmarked position in the text, do the following: 

1. Invoke the Edit > Go to menu command or press (F5). 

2. Select Bookmark from the Go to list. 

3. A list of all bookmarks in the document is displayed. Select the desired book-

mark from the list, or enter its name manually. 

4. Confirm with OK. 

TextMaker immediately moves the text cursor to the position at which the book-

mark was set. 

Deleting bookmarks 

When a bookmark is no longer needed, you can delete it using the following pro-

cedure: 

1. Invoke the Insert > Bookmark menu command. 

2. Select the bookmark you want to delete from the list, or enter its name manual-

ly. 

3. Click on Delete. 

Note: When you delete a passage of text containing a bookmark, the bookmark is 

deleted automatically. 

Displaying bookmarks in the document 

Normally bookmarks are invisible. However, you can make them visible by acti-

vating the option Display bookmarks in the document in the dialog of the Insert 

> Bookmark menu command. Bookmarks are then displayed in the text (surroun-

ded by angle brackets). 

(Note: This option is identical to the Show bookmarks option in the dialog of the 

File > Properties menu command, View tab.) 
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The Go to ... Command 

The menu command Edit > Go to ... is used to jump to a specific position in a 

document – to a specific page or bookmark, for example. 

To jump to a specific page, do the following: 

1. Invoke the Edit > Go to ... menu command. 

2. Select Page from the list of Go to options. 

3. Enter the desired page number. The page is then immediately brought into view.  

4. Click Close to close the dialog. 

You can perform a number of similar operations with this command by selecting 

other options from the Go to list, including those described in the following table: 

Option Function 

Page Jump to a given page (as described above) 

Chapter Jump to a given chapter 

Bookmark Jump to a given bookmark 

Footnote Jump to a given footnote 

Footnote text Jump to the footnote text for the given footnote 

Object Jump to the selected object (picture, table etc.) 

Table of contents Jump to the document’s table of contents 

Index Jump to the document’s index 

etc.  

Tip: Using the buttons at the bottom of the vertical scrollbar 

You can also perform Go to operations with the three buttons in the lower right 

corner of the document window. 

 

You use these buttons as follows: 
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 Click on the button with the red dot to bring up a small menu. Then select the 

type of Go to operation you want to perform from the menu. 

 Click on the button with the up arrow to jump to the target prior to the current 

position. For example, if “Page” was selected as the target type, clicking on this 

button will result in a jump to the previous page. 

 Click on the button with the down arrow to jump to the target following the 

current position – to the next page, for example. 

Navigating documents with the sidebar 

FreeOffice: Navigating with the sidebar is not included in SoftMaker Free-

Office. 

Apart from the Edit > Go to ... menu command (introduced in the previous sec-

tion), there’s another useful tool for navigating your documents: the sidebar. 

The sidebar can, amongst other things, display a list of all headings that exist in a 

document. To jump to a specific heading, simply click on the corresponding entry 

in the list. 

You can also let the sidebar list the bookmarks, objects, footnotes and other com-

ponents of a document for easy navigation. 

All you have to do is enable the sidebar and activate its navigation function. This 

can be achieved as follows: 

1. If the sidebar is not displayed, enable it (e.g. by invoking the menu command 

View > Sidebar > Show at Right). 

2. In the little toolbar displayed at the top of the sidebar, click on the  icon. 

This will switch to the navigation function of the sidebar. 

The sidebar now displays all headings of the document (unless you haven’t created 

any headings, naturally). To jump to a certain heading, simply click on the corres-

ponding list entry. 

You can not only navigate the headings but also several other components of your 

document. For this purpose, open the dropdown list Document content at the top 

of the sidebar and choose what you would like the sidebar to display. Options 

available: 
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Option Result 

Headings Sidebar displays all headings in the document 

Bookmarks Displays all bookmarks 

Tables Displays all tables 

Pictures Displays all pictures 

Objects Displays all objects (pictures, drawings, tables, etc.) 

Footnotes Displays all footnotes 

Footnote references Displays all footnote references (the footnote numbers in 

the text) 

Comments Displays all comments 

Captions Displays all captions (for images etc.) 

The list displayed in the sidebar changes its contents accordingly. If you click on 

any list entry, TextMaker jumps right to the corresponding place in the document. 
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Fields 
You can insert various kinds of “fields” in the text using the Insert > Field menu 

command. 

Fields are symbolic representations for the specific values or contents that are as-

signed to them depending on their types and placement in the text. The “Print date” 

field, for example, stands for the current date; the “Page number” field stands for 

the current page number, etc. The available fields even encompass fields from a 

database that are needed for form letters.  

Whenever a document is opened or printed, the contents of all its fields are updated 

automatically. Thus, if a document containing the “Print date” field were reprinted 

tomorrow, tomorrow’s date would appear automatically in the document wherever 

the “Print date” field had been inserted. If required, field contents can be updated 

manually at any time with the Tools > Update fields menu command. 

Fields can be formatted, deleted, copied and moved like normal text; however, 

their contents cannot be edited directly. 

For detailed information on fields, see the pages that follow. 

Inserting a field 

To insert a field in the text, move the text cursor to the desired position and invoke 

the Insert > Field menu command.  
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Select the type of field to be inserted from the Field type list.  

If you wish, you can also specify the field’s subtype or form of representation in 

the right half of the dialog. For example, you can specify whether a page number 

should be rendered in Arabic numerals (1, 2, 3, ...) or Roman numerals (I, II, III, 

...). 

When you have made your selection, click on Insert. 

The field is inserted into the text and its content is displayed there. By default, 

what is displayed is the result of replacing the field symbol with the data for which 

it stands. Thus, if you insert, for example, the “Print date” field, the current date 

will be shown in the text. 

List of all field types 

The following field types are available: 

 Creation date 

 The date on which the current document was created 

 Creation time 

 The time at which the current document was created 
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 Print date 

 The current date. This field – like all field types – is updated automatically 

when you print the document. 

 Print time 

 The current time. Automatically updated when the document is printed. 

 Date last changed 

 The date on which the current document was last modified (that is, saved) 

 Time last changed 

 The time at which the current document was last modified (that is, saved) 

 Database field 

 The content of a field from a database that has been attached to the document. 

The specific database field to be inserted is selected from the Field name list. 

See also chapter “Database” beginning on page 351. 

 Database info 

 Any of the following items of information about a database attached to the 

document: Database name only (file name of the database), Full database 

name (the same with the addition of the path name), Database record number 

(the record number of the current database record) and Record count (number 

of records in the database). 

 Page number 

 The page number of the current page. 

 Page count 

 The total number of pages in the document 

 Chapter number 

 The number of the current chapter. See also section “Dividing a document into 

chapters” beginning on page 119. 

 Sequence number 

 A sequential number, inserted automatically in captions. See section “Captions 

and tables of figures” beginning on page 437. 
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 Style reference 

 Searches the document backwards for text that is formatted in the specified 

paragraph style and displays the first text found. This allows you, for example, 

to display the current main heading (which is usually formatted in the para-

graph style “Heading 1”) in the text. See also section “Style references” begin-

ning on page 455. 

 File name 

 The file name of the current document, optionally including the complete path 

(e.g. C:\DOCUMENTS\TEST.TMDX) or without the path (e.g. TEST.TMDX)  

 Summary 

 Any of several items of information about the current document (Subject, Au-

thor, Keywords etc.). You can edit the contents of these fields by clicking on 

Settings. See also section “Document summary” beginning on page 503. 

 Last edited by 

 The name or initials of the user who last modified (that is, saved) the document.  

 To enter your name and initials, invoke the Tools > Options menu command, 

switch to the General tab, and click on the User info button. 

 User info 

 Any of several items of personal information that can be edited with the User 

info… button.  

 You can insert one of these fields in the text if you want your name, address, 

telephone number, etc. to appear in the document. These fields are used, for 

example, in the document templates supplied with the program. 

 Note: Alternatively, you can edit your user info by invoking the Tools > Opti-

ons menu command, switching to the General tab, and clicking on the User in-

fo button. 

 Auto number 

 Generates a serial number. There is more about this in chapter “Automatic 

numbering” beginning on page 181. 
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Editing fields 

If you want to edit an existing field, e.g. to change the date format it displays, 

simply select it in the text and invoke the Insert > Field menu command once 

again. 

The dialog for inserting fields will appear. Make the desired changes, confirm 

them, and the field in the text will be replaced accordingly. 

Updating fields 

Whenever a document is opened or printed, all the fields it contains are updated 

automatically. Accordingly, if you print a document containing the “Print date” 

field tomorrow, tomorrow’s date will appear in the field.  

You can update the fields manually at any time using the Tools > Update fields 

menu command or the (F9) key. All the fields and calculations in the document will 

then be brought up to date. 

Showing field names and shading fields 

When you want control over the fields contained in a document, you can check the 

Display field names option. Then, TextMaker displays the fields’ names in curly 

braces instead of their results – for example, {Print time} for the “Print time” field. 

To get to this option, invoke the File > Properties menu command and switch to 

the View tab. There check the Display field names option.  

This dialog box also contains an option called Shade fields. If you check this opti-

on, all fields are displayed with a light gray background so that they can be more 

easily distinguished from normal text. 

Note: These settings are effective only for the current document. 

Specifying your own date and time formats 

If none of the predefined formats in which the contents of date and time fields can 

be rendered suits you, you can specify your own formats in the dialog box for the 

menu command Insert > Field. First, select the date or time field you want to use; 

then, click on the New format button. 
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You can specify precisely the format in which the date or time is to be represented 

by entering abbreviations in the dialog box that appears. As you enter these abbre-

viations, TextMaker shows an example of the result. 

Any combination of the following abbreviations can be used in your format spe-

cification (pay attention to case!): 

Abbreviation Meaning Example 

d day 2 

dd day with two places 02 

ddd weekday abbreviated to three letters Mon 

dddd weekday spelled out Monday 

m month 4 

mm month with two places 04 

mmm name of the month abbreviated to three letters Apr 

mmmm name of the month spelled out April 

yy year with two places 18 

yyyy year with four places 2018 

   

h hour (12-hour format) 8 

hh hour with two places (12-hour format) 08 

H hour (24-hour format) 8 

HH hour with two places (24-hour format) 08 

M minute 5 

MM minute with two places 05 

S second 0 

SS second with two places 00 

am show am/pm following the hour am 

AM show AM/PM following the hour AM 

In addition to these abbreviations, you can use any punctuation characters (period, 

slash, etc.) you like in your entry. 
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Example: If you enter “dddd, d mmmm yyyy” as the format in the Format field, 

the date 4/26/2018 will be represented as “Wednesday, 26 April 2018”. 

Changing the language: You can change the Language of a text segment in the dialog 

for the Format > Character menu command. When use this command to format 

text in a given language, the names of months and days of the week that result 

from date fields are automatically changed accordingly (see also section “Setting 

the language” beginning on page 330). 

Inserting the date and time as text 

With the Insert > Date/time menu command, you can insert the current date or 

time into the document as fixed text. 

Unlike the command described on the preceding pages for inserting date and time 

fields, this command uses the current date or time to create a fixed text that will not 

be updated automatically. 

When you invoke the Insert > Date/time menu command, a dialog box appears. 

Here you can select either the date or the time as the basis for the creation of the 

text, and specify the format. 

If none of the predefined formats suits you, you can click on the New format but-

ton and type in your own format, using the abbreviations described in the previous 

section. 

If you want the date or time to be inserted as a field, rather than as fixed text, check 

the Insert as field option. TextMaker then creates a field (Print date or Print time). 

You will find details about the use of fields in the section above. 

Tip: Using keyboard shortcuts 

Keyboard shortcuts for inserting the current date/time are available as follows: 

 Insert date: (Ctrl)(.) (period) 

 Insert time: (Ctrl)(:) (colon) 

When you press one of these key combinations, the date/time will be inserted im-

mediately – without a dialog popping up. 
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Inserting special characters 

Some characters, such as the copyright sign, the degree sign, and the accented cha-

racters used in some languages, cannot be entered into text directly with the key-

board. Instead, TextMaker’s built-in character table provides a convenient means 

for inserting symbols and other special characters. 

You insert special characters as follows: 

1. Invoke the menu command Insert > Symbol. 

2. A dialog box appears, giving you access to every character that is available in 

the selected font. If you need a character from a different font, select it from the 

Font list at the top of the dialog. 

3. A font’s characters are organized into sets. If the character you want to use is 

not in the set immediately in view when you can jump to the set in which it is 

likely to be found by selecting it from the Set list. For example, you can select 

Cyrillic to view the font’s Cyrillic characters (provided the font contains such 

characters). 

 Note: Many fonts contain only a few of the character sets that are available. 

However, the fonts that are supplied with your operating system usually consti-

tute a huge reservoir of characters. These include, for example, the Arial, 

Tahoma and Times New Roman fonts supplied with Windows. 

4. Select the desired character by clicking on it. Then press the Enter key (¢) or 

click on the Insert button to insert the character into the text. Alternatively, you 

can double click on a character to select and immediately insert it. 

5. You can repeat the above described procedure to insert additional characters, as 

required. When you are finished, exit the dialog with the Close button. 

Tip for Windows users: Most Windows versions include two symbol fonts 

named Symbol and Wingdings. These fonts contain many symbols that could be 

useful (as bullets, for example). 

Using keyboard shortcuts 

If you need to insert a special character frequently, you can always give it a key-

board shortcut. The advantage of doing that is that you can then apply the character 

very quickly, using a single key press. 
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To assign a keyboard shortcut to a special character, proceed as follows: 

1. Invoke the menu command Insert > Symbol. 

2. Select the character that you want to assign a keyboard shortcut to. 

3. Click on the Change button next to the Shortcut key option. 

4. Another dialog opens. There, press the desired keyboard shortcut in the Please 

press accelerator input box. 

 We recommend using key combinations that include the keys (Ctrl) and 
(Shiftª), since these are normally not assigned. 

 Hint: If you make a typing mistake, you can always press the backspace key 
(æ__) to remove the keyboard shortcut you entered. 

5. Don’t forget: Click on Add to assign this shortcut to the character.  

6. Confirm with OK and exit the main dialog box with Close. 

From now on, you can insert this special character into the text by pressing the 

selected key combination. 

Note: The keyboard shortcut remembers only the selected character; the selected 

font is not remembered. 

For more information on changing the keyboard layout, see the section 

“Customizing keyboard shortcuts” (starting on page 592). Hint: The keyboard 

shortcuts for special character can be edited by opening the dialog for editing the 

keyboard mapping and choosing the entry Characters in the left list. 

Inserting special characters via their character code 

There’s yet another method for entering a special character: by typing in its hexa-

decimal character code (Unicode) and then pressing the key combination 
(Ctrl)(Alt)(Shiftª)(X). 

For example, when you type in 20AC and press this key combination, you will 

receive a euro sign, since the euro sign’s character code is 20AC in the Unicode 

character set table. 
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Automatic numbering 

TextMaker has several functions that generate enumerations automatically. This 

chapter will teach you everything you need to know about them. The following 

topics are covered: 

 Simple enumerations 

 The first section describes the Format > Bullets and numbering menu com-

mand. This command is helpful for numbering paragraphs. A number is inser-

ted to the left of each successive paragraph, and each paragraph is indented to 

accommodate the number.  

 Numbered lists 

 You can also create numbered lists with this command. The numbering scheme 

for a numbered list can be saved and reused. In addition, a numbered list can be 

organized hierarchically (1., 1.1, 1.1.1, etc.). 

 Numbered headings 

 You can also use numbered lists to apply numbering to the headings in a 

document automatically. You will find information about this in section 

“Numbering headings” beginning on page 426. 

 Numbering with Auto numbers 

 Besides the above mentioned methods for numbering paragraphs, TextMaker 

provides a general-purpose method for automatic numbering: you can insert in-

stances of an Auto number field anywhere in the text. Successive instances of 

this field are automatically numbered incrementally. 

 Adding line numbers 

 In addition, you can have TextMaker show line numbers alongside the 

document text. The line numbers are inserted in the left page margin, both for 

display and for printing.  

These topics are treated in detail on the following pages in the order listed. 
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Simple enumerations 

The section “Bulleted lists” beginning on page 94 describes how you can add 

bullets to paragraphs with the Format > Bullets and numbering menu command. 

This command is also suitable for enumerating paragraphs. TextMaker automati-

cally indents the paragraphs at the left to make room for the numbers and then 

numbers the paragraphs incrementally. 

 

Paragraphs with numbering 

You can use enumeration as many times as you wish within a single document. The 

numbering is automatically reset to one at the beginning of each new enumeration. 

Adding numbering 

To add numbering to a group of paragraphs, proceed as follows: 

1. Select the paragraphs of interest. 

2. Invoke the menu command Format > Bullets and numbering. 

3. Switch to the Bullets & Simple numbering tab. 

4. Under Type, select the option Numbering. 
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5. As required, set the desired options in the Numbering section (see the “Dialog 

options” section below). 

6. Confirm with OK. 

The selected paragraphs are now enumerated. 

Note: You can start as many enumerations as you wish within a document. The 

numbering is automatically reset at the beginning of every new group of numbered 

paragraphs. More precisely: whenever a numbered paragraph is preceded by a pa-

ragraph that is not numbered, the numbered paragraph’s number is automatically 

set to “1”. 

Skipping paragraphs in an enumeration 

You can interrupt an enumeration at a given paragraph and then continue the enu-

meration at a following paragraph. 

To do this, position the text cursor in the numbered paragraph that you want to 

exclude from the enumeration, invoke the menu command Format > Bullets and 
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numbering, switch to the Bullets & Simple numbering tab and check the Skip 

numbering option. 

The selected paragraph’s number is removed, and only its indentation is retained. 

The enumeration is continued at the immediately following numbered paragraph. 

Ending or removing an enumeration 

To end an enumeration of paragraphs or to remove a previously applied enumerati-

on, proceed as follows: 

1. Position the text cursor at the end of the last numbered paragraph and press the 

Enter key (¢) to begin a new paragraph.  

 Or: If you want to remove all numbers from a given group of numbered para-

graphs, select them. 

2. Invoke the Format > Bullets and numbering menu command. 

3. Switch to the Bullets & Simple numbering tab. 

4. Disable numbering by selecting None in the Type group box. 

5. Confirm with OK. 

Dialog options 

The Bullets & Simple numbering tab in the dialog box for the Format > Bullets 

and numbering menu command gives you access to the following options: 

 Type 

 Here you can specify either Numbering or a Bullet for the selected para-

graph(s). Select the Numbering option for numbering. (You can find informa-

tion relating to the Bullet option in section “Bulleted lists” beginning on page 

94.) 

 When you set the Type to None, existing bullets or numbers are removed. 

 You can always transform a numbered list into a bulleted list simply by chan-

ging the Type to Bullet. Naturally, you can proceed in the opposite direction as 

well.  
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 Before and After 

 As required, you can specify text to be added before and/or after the number 

that TextMaker will assign to the paragraph. For example, if you want the num-

bers surrounded by dashes (-1-, -2-, -3- etc.), select the Format “1, 2, 3, ...” and 

enter “-” in the Before as well as the After field.  

 Format 

 Here you specify the format for the numbering. Besides Arabic numbers (1, 2, 

3, ...) you can also select e.g. letters (A, B, C, ...) or Roman numerals (I, II, III, 

...). 

 Numbering starts with ... 

 By default, TextMaker starts every enumeration with “1”. If you want to use a 

different starting value, enter it here. 

 Skip numbering 

 It is often the case that a numbered list includes an individual item that needs to 

span more than a single paragraph. In such a case, only the item’s first para-

graph should be numbered; numbering should skip succeeding paragraphs that 

belong to that item and resume only with the paragraph that constitutes the 

following item.  

 TextMaker provides the Skip numbering option for such a situation. When 

numbered paragraphs that are to be grouped as one item with a preceding num-

bered paragraph have been selected, you can check this option to cause Text-

Maker to skip these paragraphs when assigning numbers.  

 Character button 

 You can click on this button to change the character formatting (font, size, em-

phasis, etc.) for the numbers. 

 Horizontal position 

 Allows you to specify how far the text should be indented to the right to make 

room for the numbers. 

 Vertical position 

 Allows you to specify the vertical position of the numbers. Negative values 

cause the numbers to be lowered; positive values cause them to be raised. 
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 Numbered lists tab 

 This tab provides control over the creation of numbered lists. A numbered list 

has special features that distinguish it from a simple enumeration: the layout of 

a numbered list can be saved and reused. In addition, a numbered list can have 

a hierarchical organization (1., 1.1., 1.1.1, etc.).  

 Information about numbered lists is presented in the next section. 

Numbered lists 

Advanced TextMaker users will already appreciate the advantages of paragraph 

styles, which are described in chapter “Styles”. You can save a frequently needed 

paragraph format in a paragraph style and then apply it over and over again to any 

paragraphs you wish. 

Something similar is available for enumerations: numbered lists. 

These work somewhat like paragraph styles: When you want to apply a certain 

kind of enumeration frequently in a document, set up a numbered list. When you do 

so, a dialog like the one for simple enumerated and bulleted lists will appear. It will 

allow you to specify precisely the kind of numbering and the number format you 

want. 

Afterwards, you can apply the layout of your numbered list to any paragraphs you 

like. The paragraphs will then be given a numbering exactly as you specified in 

your numbered list. 

A further advantage: If you subsequently change the formatting of the numbered 

list, the paragraphs formatted with this list will change accordingly. 

Using hierarchical lists 

Numbered lists have the additional advantage that they allow the creation of hie-

rarchical enumerations. 

While simple lists (like 1., 2., 3. etc.) have only one level, hierarchical lists can 

have several levels. For example, a hierarchical list might look like this: 

1. 

1.1. 

1.2. 
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2. 

3. 

etc. 

In the above example, the two paragraphs under 1. have second level numbering: 

1.1 and 1.2 

For details on creating numbered lists, see the next pages. 

Creating numbered lists 

To create a new numbered list, proceed as follows: 

1. If you want to apply the new numbered list immediately after creating it, first 

select the paragraphs to which you want to apply it. 

2. Invoke the Format > Bullets and numbering menu command. 

3. Switch to the Numbered lists tab. 

4. Click on the New button. 

5. Give the new numbered list whatever name you like and then confirm with 

OK. 

6. Select either Simple list (1., 2., 3. etc.) or Hierarchical list (1., 1.1, 1.1.1. etc.), 

depending on the type of list you want to create (see the introduction). 

7. Make any additional required settings for the numbering (see below). 

8. Confirm with OK. 

The new numbered list is now set up. If you want to apply it to the paragraphs cur-

rently selected in the text, click on Apply. Otherwise, click on Close. 

You will find additional information about the application of numbered lists in sec-

tion “Applying numbered lists” beginning on page 192. 

In the dialog box for setting up and editing numbered lists you can make the follo-

wing settings: 
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General options 

 Simple list or Hierarchical list 

 The option you select here determines the overall layout of the numbered list, 

for it controls the type of the list: 

 Select Simple list for a simple enumeration with only one level (thus 1., 2., 3. 

etc.) 

 Select Hierarchical list for a hierarchical enumeration with multiple levels (for 

example 1., 1.1., 1.1.1. etc.) 

 Use paragraph’s outline level as list level 

 Available only when the type of the numbered list has been set to Hierarchical 

list. 

 When this option is checked the outline levels of the paragraphs to which the 

numbered list is applied are used as the levels in the automatic numbering of 

the list. For example, if a paragraph has an outline level of 3 (is thus a third or-

der heading) it becomes a level 3 list item when the list is applied (thus “1.1.1”, 

for example). 

Note: When this option is checked, numbering is applied only to headings. 

Normal text (paragraphs with outline level zero) is not numbered. 

 You will find information about document outline levels in section “Outlines” 

beginning on page 418. 

 If the Use paragraph’s outline level as list level option is not checked, you 

can set the list level manually with the List level option in the main dialog (see 

also section “Applying numbered lists” beginning on page 192). 

 Level 

 Available only when the type of the numbered list has been set to Hierarchical 

list. 

 Here you can select with a mouse click the level of the list you want to modify. 

For example, if you click on “3”, you can change the settings for the third level. 

 Each level of a hierarchical list can have its own settings. For example, you can 

set the color for the numbers at level 1 to blue, and the colors of the numbers at 

all the other levels to black. 
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 Preview 

 The Preview field shows how the numbering will look with the current set-

tings.  

 In addition, it provides an alternative means of selecting the level you want to 

edit. You can make a selection in the Preview field in exactly the same way you 

make a selection in the Level field, by clicking on the desired level. 

 Display higher levels 

 Available only for list levels of 2 and above in hierarchical lists. 

 When this option is checked, the numbering applied to a list item at the selected 

level will fully represent the item’s hierarchical position. This numbering will 

include the item’s number in the sequence of items with which it is coordinate 

and the numbers of all the items to which it is subordinate. Thus, an item at list 

level 3, for example, will have a numbering in the form “1.5.9”. 

 When the option is not checked, the numbering will not include the numbers of 

any higher level items. Thus, the above example will not be numbered with 

“1.5.9” but just with “9”. 

 Don’t restart the level 

 Available only for list levels of 2 and above in hierarchical lists. 

 When this option is checked, the numbering of list items at the selected list le-

vel is not reset to 1 whenever a list item at this level follows an item at a higher 

level item. 

 For example, if you check this option for level 2, the result will be as illustrated 

below: 

Option unchecked: Option checked: 

1. 1. 

1.1 1.1 

1.2 1.2 

2. 2. 

2.1 2.3 

 As you can see in the last item of the above example, the 2nd level is continued 

with 2.3 instead of being reset to 2.1 when this option is checked. 
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 Reset button 

 If you should ever make a big mistake or completely change your mind while 

editing a numbered list, you can press the Reset button to make a fresh start. 

The Reset function returns all the options (for all list levels) to their original 

settings. 

The remaining options in this dialog allow you the change the way the numbered 

list will look, as described on the next pages. 

Note: As mentioned above, each level of a hierarchical list can have its own set-

tings. So, before setting any of these options, be sure to first select the level that 

you want to modify in the Level field. 

Options for bullets 

If you have selected the Bullet option in the Type group box, the following options 

appear in the dialog: 

 Bullet group box 

 Here you can select the bullet you want to use.  

 The Default row contains pre-defined bullets from which you can choose, whi-

le the Custom row contains user-defined bullets. If you click on one of the 

bullets in the Custom row and then click on the Change button at the end of 

that row, you can select any symbol to be used as a bullet. 

 Color (default bullets only) 

 You can select a color for the bullet from the Color dropdown list. If the pre-

defined colors presented in the list don’t suit you, you can always define new 

colors (see section “Document properties, Colors tab” beginning on page 564). 

 Tip: If you set the color to “Auto” TextMaker automatically uses the font color 

assigned to the paragraph at the right of the bullet. 

 Size (default bullets only) 

 Here you can change the size (in points) of the bullet. 

 Tip: When you select the “Auto” option TextMaker automatically uses the font 

size assigned to the paragraph at the right of the bullet. 
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 Character button (custom bullets only) 

 If you have selected a bullet from the Custom row, the two options mentioned 

above are replaced by a Character button. Click on this button if you want to 

change the character formatting (size, color, emphasis, etc.) of the bullet. 

 Tip: If you do not make any changes to the character format, the bullet will 

automatically use the character format of the paragraph at its right. 

 Horizontal position 

 Allows you to specify how far the text should be indented to the right to make 

room for the bullet. 

 Vertical position 

 Allows you to specify the vertical position of the bullet. Negative values cause 

the bullet to be lowered; positive values cause it to be raised. 

 Additional indent 

 You can use this option to indent the entire list item (including the bullet) to the 

right. 

Options for numbering 

If you have selected the Numbering option in the Type group box, the following 

options appear in the dialog: 

 Numbering text 

 With this and the following options, you can change the format of the num-

bering as required. 

 The Numbering text edit box is filled in automatically by the program. How-

ever, you can always make changes. {1}, for example, represents the list level 1 

component of the number, in the specified format (see the next option). If, for 

example, {1} is entered in this box, and the “1, 2, 3, ...” format is selected, level 

1 list items will have numbering in the form 1, 2, 3 etc. However, if -{1}- is en-

tered (dashes added before and after the placeholder), the level 1 list items will 

have numbering in the form -1-, -2-, -3- etc. 

 If the number has several level components, the edit box will contain a place-

holder for each of the components, for example {1}, {2}, {3} (for level 1, 2, 3) 

etc.. 
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 Format 

 This option allows you to specify the format for the numbering. Besides the 

usual “1, 2, 3, ...” you can select e.g. letters (A, B, C, ...) or Roman numerals (I, 

II, III, ...). 

 Numbering starts with ... 

 If you want the numbering to start with some value other than 1, you can enter 

the starting value here. 

 This option takes effect only when the numbering is beginning anew, or when it 

is reset with the Restart numbering option in the main dialog. 

 Character button 

 If you click on this button you can change the character formatting (font, size, 

emphasis, etc.) of the numbers. 

 Horizontal position 

 Allows you to specify how far the text should be indented to the right to make 

room for the number. 

 Vertical position 

 Allows you to specify the vertical position of the number. Negative values are 

used to lower the number; positive values to raise it. 

 Additional indent 

 You can use this option to indent the entire list item (including the number) to 

the right. 

Applying numbered lists 

Numbered lists are used much like paragraph styles: First, select the paragraphs to 

be formatted, then apply the numbered list. 

Thus, you do the following: 

1. Position the text cursor in the paragraph to which you want to apply the num-

bered list, or select multiple paragraphs. 

2. Invoke the Format > Bullets and numbering menu command. 

3. Switch to the Numbered lists tab. 
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4. Select the desired numbered list. 

5. Click on Apply. 

The paragraphs are now formatted with the numbering specified in the selected list. 

Note: When you apply a hierarchical list in which the Use paragraph’s outline 

level as list level option is checked, numberings will appear only on headings. 

Normal text (paragraphs with outline level zero) will have no numberings. 

Dialog options 

The options in the dialog box for this command are given below with their func-

tions: 

 List level 

 Here you can specify the list level for the paragraph to which a hierarchical 

numbered list is to be applied. For example, if you set this option to 1, the para-

graph will formatted as a list item at level 1 and will have a number of the form 

“1”, while if you set the option to 3, the paragraph will have a number of the 

form “1.1.1”, etc. 

 Note: The list level can not be specified if you have checked the Use para-

graph’s outline level as list level option, because in that case automatically u-

ses the paragraph’s outline level as the list level. 

 Restart numbering 

 Starts a new number sequence at the selected paragraph; in other words, resets 

the numbering of paragraphs at the current level to 1. 

 Note: If multiple paragraphs are selected when the command is invoked, the 

first selected paragraph becomes the basis for resetting the numbering. 

Changing list levels with the Formatting toolbar 

When working with paragraphs to which a hierarchical numbered list has been 

applied, you can use the following buttons in the Formatting toolbar to conve-

niently change the paragraph’s list levels: 

 Lowers the list level 

 Raises the list level 
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Modifying numbered lists 

You can modify a previously defined numbered list at any time. 

To do this, proceed as follows: 

1. Invoke the Format > Bullets and numbering menu command. 

2. Switch to the Numbered lists tab. 

3. With a mouse click, select the numbered list that you want to edit. 

4. Click on the Edit button. 

5. Make the desired changes. 

6. Confirm with OK. 

The numbered list is now modified in accordance with your new settings. If you 

want to apply the modified list to the paragraphs currently selected in the text, click 

on Apply. Otherwise, click on Close. 

Note: Changes to a numbered list affect all paragraphs that have been formatted 

with this list. 

Deleting and renaming numbered lists 

To delete a numbered list, select the list in the above mentioned dialog and then 

click on the Delete button. 

Note: When you delete a numbered list, the numbering is removed from all the 

paragraphs that were formatted with this list. 

To rename a numbered list, select it, click on the Rename button and enter the new 

name. 

Numbered headings 

Numbered lists can also be used for automatic numbering of all the headings in a 

document. You can read more about this topic in section “Numbering headings” 

beginning on page 426. 
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Numbering with Auto numbers 

You can create automatic enumerations, not only with the paragraph numbering 

functions described on the previous pages, but also manually, by inserting an Auto 

number field anywhere in the text. 

The “auto number” is a field that symbolizes a number in a series. The first in-

stance of the auto number in a document always yields the number “1”, the next 

instance yields “2”, etc.  

If you insert an additional auto number into the document, each successive instance 

of the auto number will be increased by one. If you delete a segment of text that 

contains an auto number, all the following auto numbers will be reduced by one. 

To insert an auto number, do the following: 

1. Invoke the Insert > Field menu command. 

2. Select the “Auto number” field from the Field type list. 

3. Click on Insert. 

The auto number now appears in the text. 

Resetting auto numbers 

If you need to use auto numbers to create several separate enumerations in a single 

document you can do so by resetting the auto number to one at the appropriate 

places. 

Proceed as follows: 

1. Move the text cursor to the place at which the numbering should be reset to 

begin a new sequence. 

2. Invoke the Insert > Break > Section Break menu command. 

3. Invoke the Format > Section menu command. 

4. Make sure that the Apply to option in the formatting dialog box is set to Cur-

rent section. 

5. Check the Restart auto numbers option. 

6. Confirm with OK. 
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It should not surprise you that most of the options in the Format > Section dialog 

have to do with text columns. “Sections” exist not merely to allow auto numbers to 

be reset, but also to facilitate multi-column layouts. 

Adding line numbers 

Apart from the various kinds of numbering functions described in the preceding 

sections, TextMaker provides a function that displays line numbers alongside a 

document’s text. The line numbers appear in the left margin, both on the display 

and on the printed page.  

To instruct TextMaker to show line numbers, proceed as follows: 

1. Select as necessary the text segment for which line numbers are to be shown. 

2. Invoke the Format > Section menu command. 

3. Switch to the Line numbers tab. 

4. Check the Show line numbers option. 

5. As necessary, make the required settings for the numbering (see below). 

6. Confirm with OK. 

The line numbers are now displayed.  

Deactivating or skipping line numbers 

In order to turn the display of line numbers off again, follow the above described 

procedure, unchecking the Show line numbers option at step 4. 

In case you just want to skip the numbering for certain paragraphs, select those 

paragraphs, invoke the menu command Format > Paragraph, switch to the Text 

Flow tab, and activate the option Suppress line numbers there. 

Dialog options 

In the dialog box for the Format > Section menu command, you can make settings 

that control the line numbering as follows: 
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 Show line numbers 

 Turns the display of line numbers on/off. 

 Options group box 

 Here you can set the following options: 

 First line number is the number with which the line numbering should begin. 

 Count by is the interval between numbered lines. For example, if you enter 5, 

line numbers will appear only at lines 5, 10, 15, 20 etc. 

 Distance to text is the amount of blank space TextMaker should leave between 

the line number and the left margin. 

 Position determines where the numbers are shown: in the left or right page 

margin, or in the inner or outer page margin (for documents with facing pages, 

like books). 

 Numbering group box 

 Allows you to specify whether and when the numbering should be reset: 

 Restart at the beginning of this section: The numbering is reset to 1 only at 

the beginning of the current section. Tip: You can define new sections with the 

Insert > Break > Section break menu command. 

 Restart on every page: The numbering is reset to 1 at the beginning of every 

page of the document. 

 Continuous: The numbering is not reset to 1. 

 The additional Skip empty paragraphs option has the following meaning: If it 

is checked, the numbering will skip all paragraphs that are empty. 

 Apply to: 

 Determines what parts of the document will be affected by the settings you 

make in this dialog: 

 Whole document: the entire document. 

 This point forward: that part of the document beginning at the current position 

of the text cursor and ending at the end of the document. 

 Selected text: the selected text. 
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 Current section: the current section. Tip: You can use the Insert > Break > 

Section break menu command to split up the document into as many sections 

as you want. 

 Selected sections: all sections included in the current selection. 

 To end of section: the segment of text beginning at the current position of the 

text cursor and ending at the end of the current section. 
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Tables 
Would you like to lay out certain parts of your document, including text, numbers, 

and/or pictures, in tabular form to make them more legible? Then simply insert a 

table into the document. 

 

This is an example of 

a table. 

As you can see, the text 

within a “table cell” is wrap-

ped automatically. 

The columns in a table can be of 

different widths. 

Each cell can have its 

own border. 

Each cell can be shaded in-

dividually. 

TextMaker automatically determines 

the optimum height for each row of 

cells. 

 

Of course you could also use tabs if you only want to set up a simple list, but tables 

offer the following advantages: 

 Within a table cell, text that does not fit on a single line is automatically broken 

into multiple lines and the height of the cell is adjusted automatically to ac-

commodate it. 

 You can delete, copy, move or format individual table cells (or complete rows 

or columns of cells). 

 Table cells can have borders, a grid and shaded or patterned backgrounds. 

 It is even possible to perform calculations on the contents of table cells (see 

chapter “Calculations in the text” beginning on page 395). 

In this chapter, you will find detailed information on working with tables. The 

following topics are covered: 

 Inserting a table 

 Editing tables 

 Selecting table cells and cell contents 

 Deleting, copying, moving cell contents 

 Deleting and inserting table cells 

 Splitting and merging table cells 

 Formatting tables 
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 Converting a table to text 

 Converting text into a table 

 Sorting tables 

 Sorting text 

 Tip: Using the Table toolbar 

See the next pages for details. 

Inserting a table 

To insert a table in the text, move the text cursor to the desired position and invoke 

the menu command Table > New table. 

A dialog box appears to allow you to specify the number of rows and columns the 

table should contain. 

 

You can also specify the inner margins for all table cells. 

When you confirm with OK, TextMaker inserts the table in the text. 

Editing tables 

You can enter, edit and format text within tables in the usual manner. When you 

insert a new table, TextMaker automatically places the text cursor in the first table 

cell, so that you can begin typing immediately. 

You can type multiple lines of text within a cell – the lines will be broken automa-

tically – and begin new paragraphs with the Enter key (¢). The heights of all the 
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cells in a row will be adjusted automatically to the height of the current cell as its 

height increases. 

You insert pictures into a table cell in the usual manner using the Object > New 

Picture menu command, which is described in chapter “Pictures” beginning on 

page 225. Of course you can also insert other types of objects – for example OLE 

objects, form objects, etc. 

To move the text cursor from one table cell to another, do the following: 

Keyboard: Press the (Tab) key to move to the next cell, or (Shiftª)(Tab) to move to 

the previous cell. To move the text cursor from row to row, use the arrow keys (¼) 

and (½). 

Mouse: Click in the desired cell. 

Note: As noted above, the (Tab) key is not available for inserting tab stops within 

table cells. In tables, you enter tab stops not with (Tab), but with the key combi-

nation (Ctrl)(Tab). 

Selecting table cells and cell contents 

Text selection within a table cell works just like normal text selection.  

To select complete table cells, including their content, click into the first cell to be 

selected, press and hold down the left mouse button and drag the selection to the 

last cell of interest. 

There is an alternative way to select complete rows or column of cells. When you 

invoke the menu command Table > Select, a sub-menu opens, where you can sel-

ect the current row, the current column, or the entire table. 

You can also select complete rows or column with your mouse: To select a column, 

click into the area right above the column. To select a row, click into the area left of 

the row. 

Occasionally, you will want to select only a single table cell. To do this, you have 

to use the following “trick”: With the left mouse button pressed, drag the mouse 

pointer from the cell of interest to a neighboring cell and then back. 
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Deleting, copying, moving cell contents 

To delete, copy or move the contents of table cells, select the cells and then use the 

familiar commands in the Edit menu: 

Command Explanation 

Delete The Edit > Delete menu command deletes the contents of all the 

currently selected cells. 

Cut The Edit > Cut menu command cuts the contents of the selected 

cells and holds them in the clipboard. 

Copy The Edit > Copy menu command copies the contents of the selected 

cells into the clipboard. 

Paste The Edit > Paste menu command inserts the contents of the clip-

board. Before using this command, position the text cursor in the 

desired cell. 

Note: Notice that these commands apply only to the contents of the cells. So, 

when you select some cells and invoke, for example, the Edit > Delete menu 

command, only the contents of the cells are removed; the cells themselves 

remain as they were. You will find information about deleting/inserting complete 

table cells (including their contents) in the next section. 

Deleting and inserting table cells 

In the previous section you learned how to delete, copy or move the contents of 

table cells. 

This section describes how you can completely remove cells from a table and insert 

additional cells into a table. 

Topics covered: 

 Deleting cells from a table 

 Inserting cells in a table 
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Deleting cells from a table 

To completely remove cells (including their contents) from a table, do the follo-

wing: 

1. Select the cells to be deleted. 

2. Invoke the menu command Table > Delete cells. 

 Hint: Don’t just press the (Del) key, because this only deletes the contents of the 

table cells, not the table cells themselves. 

3. From the submenu displayed, select which cells to delete: 

 Delete rows: deletes all rows within the selection 

 Delete columns: deletes all columns within the selection 

 Delete table: deletes the entire table 

 Delete cells: deletes only the currently selected cells 

The cells, together with their contents, are now removed. 

Inserting cells in a table 

To add new cells to a table, do the following: 

1. Position the text cursor in the cell before or after which the new cells are to be 

inserted. 

2. Invoke the Table > Insert cells menu command. 

3. From the submenu displayed, choose what exactly to insert: 

 Insert row above: inserts a row above the current cell 

 Insert row below: inserts a row below the current cell 

 Insert column left: inserts a column to the left of the current cell 

 Insert column right: inserts a column to the right of the current cell 

 Insert cells...: displays a dialog with additional options (see below) 

The cells are now added to the table. 
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Options 

If you select the option Insert cells... in this procedure, a dialog box appears, allo-

wing you to specify the way the cells are to be inserted.  

 

The dialog presents the following options: 

Option Meaning 

Entire rows Complete rows of cells are inserted. 

Entire columns Complete columns of cells are inserted. 

Single cells Cells are inserted on a cell by cell basis, depending on the 

current selection. For example, if you selected 4x4 cells prior 

to invoking the command, 4x4 cells are inserted. 

In addition, the Number option allows you to specify the number of cells to be 

inserted. If, for example, you select Entire rows and then set the Number to 10, 

ten rows will be inserted instead of only one. 

Make your choice, and then click on Insert above to insert the new cells before the 

current cell – or on Insert below to insert them after the current cell. 

Tip: Appending an additional row with just one keystroke 

You can also add a new row of cells at the bottom of a table simply by pressing the 
(Tab) key when the text cursor is in the last cell of the table. TextMaker then auto-

matically extends the table by adding a new row. 

Splitting and merging table cells 

This section describes how to split and merge table cells or entire tables. 

Topics covered: 
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 Splitting table cells 

 Merging table cells 

 Splitting tables 

 Merging tables 

Splitting table cells 

You can split table cells any time you wish; that is, you can break them into multip-

le cells. 

You do this as follows: 

1. Position the text cursor in the cell that you want to split. 

2. Invoke the Table > Split cells menu command. 

3. A dialog box appears. Enter the number of rows and columns into which the 

cell should be split in this dialog. 

4. Confirm with OK. 

The cell is now split according to your specifications. 

Splitting several cells at once 

Optionally, you can select multiple neighboring cells before invoking the Table > 

Split cells menu command. When you do this, all the selected cells are split in a 

single step. 

Notice that the above described dialog presents a Join selected cells before split-

ting? option if multiple cells are selected. It offers the following options: 

 If you choose Treat the selection as one cell and split it, the selected cells are 

combined into a single cell before the splitting operation is carried out.  

 If you choose Each selected cell will be split individually, each of the selec-

ted cells is split into the specified number of rows and columns. 
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Merging table cells 

You can merge together neighboring table cells any time you wish. That is, you can 

combine them to make a single cell. 

You do this as follows: 

1. Select the cells to be merged. 

2. Invoke the Table > Merge cells menu command. 

The cells are now combined. 

In this process, the contents of the original cells are not lost; they are combined in 

the resulting cell: The content of each original cell is placed in a separate para-

graph. 

Splitting tables 

With the help of the menu command Table > Split table you can split a table hori-

zontally. The result is two separate tables. 

To split a table, do the following: 

1. Position the text cursor in any cell of the row at which the table is to be split. 

2. Invoke the Table > Split table menu command. 

The table is now split into two separate tables. 

Merging tables 

To merge two tables into one, do the following: 

1. Delete (or move away) any text between the two tables – until only a blank 

paragraph is left between them. 

2. Position the text cursor in that empty paragraph. 

3. Press the (Del) key. 

The two tables are now combined into one table. 
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Formatting tables 

The sections that follow will acquaint you with the commands available for format-

ting tables:  

 Row properties 

 Use the menu command Table > Row properties to change the formatting of 

the rows in a table, including their row height and options that change the be-

havior of a row at page breaks. 

 Cell properties 

 Use the menu command Table > Cell properties to format individual table 

cells. With it, you can modify the width and margins of cells and change their 

borders and shading. 

 Changing the overall properties of tables 

 Use the menu command Table > Table properties to change the formatting of 

entire tables. For example, it can be used to set the borders and shading of an 

entire table at once. Additionally, the command allows you to make changes to 

the positioning of a table. 

 Table style 

FreeOffice: The Table style feature is not included in SoftMaker FreeOffice. 

 The Table > Table style menu command can be a real time saver: it provides 

pre-defined “table styles” that can be used to format an entire table with the 

push of a button. 

See the next pages for details. 

Row properties 

The Table > Row properties menu command is for modifying the formatting of 

complete rows in tables. 

Before invoking this command select the rows whose format is to be changed. If 

you do not select any rows, the changes will be applied only to the row in which 

the text cursor is positioned. 
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The dialog box for this command offers the following options: 

Height 

Here you can modify the height of table rows by selecting from among the follo-

wing options: 

 Auto 

 This is the default setting. When it is selected, TextMaker determines the opti-

mum height for the rows automatically (by adapting it to the space actually 

needed by the cell contents). 

 Exact 

 When you select this option, you can specify exactly the height you want the 

rows to be. However, in this case the height of the rows will be fixed; it will not 

be automatically adjusted – even when it is not sufficient to accommodate the 

contents of the cells. 

 At least 

 This option represents a combination of the two options above. If you enter “1 

in” here, for example, the height of the rows will be set to exactly 1 inch, pro-

vided that this height is sufficient for the contents of the cells. However, if you 

enter more text in a cell than can be accommodated in 1 inch, TextMaker will 

automatically increase the row height. 

Keep together with next row 

When this option is checked, the selected rows and (!) the row immediately follo-

wing are always kept together. If TextMaker determines that an automatic page 

break should fall between any of these rows, it will insert the break before them, 

ensuring that they will remain together on one page. 
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Page break at row 

When this option is checked, TextMaker inserts a page break before the selected 

row, ensuring that this row will always be at the beginning of a new page. 

Allow page break in row 

When you check this option, TextMaker is allowed to insert a page break within 

the selected row. Thus, if an automatic page break should fall within this row, one 

part of the row’s contents will remain on the current page, while the rest will 

appear on the following page. 

However, by default, this option is unchecked, meaning that TextMaker will insert 

the break before this row in such a case. 

Repeat as header row 

This option is only available in the first rows of a table. 

It affects only tables that extend over more than one page. When it is checked, 

TextMaker repeats the selected rows at the beginning of every subsequent page. 

This is useful, for example, when the first two rows of the table contain headers 

that you want to appear at the beginning of every page of the table. To do this, sel-

ect the first two rows and activate this option for them. 

Cell properties 

The appearance of the current table cell can be modified with the Table > Cell 

properties menu command.  

It goes without saying that you can select more than one cell, or even complete 

rows and columns, before you invoke this command in order to change the proper-

ties of several cells at once. 
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The dialog box for this command offers the following options: 

Size 

Here you can change the Width of the selected cells by choosing among the follo-

wing options: 

 Fixed 

 When you select this option you can specify the width exactly by entering the 

desired value in the field to the right of the Width list. 

 Percent 

 When you select this option you can specify the width you want as a percentage 

of the overall table width. 

 By default, the cells in a table are of equal width, and the width is set to 100% 

divided by the number of cells in a row. For example, each cell in a table of 

three columns has a default width of 33.3%. If you wanted the first column to 

be twice as wide as the other two columns you would set the widths of all the 

cells in this column to “50” and the widths of all the cells in the second and 

third column to “25”. 



 

Manual TextMaker Tables  •  211 

 Auto 

 When you select this option, TextMaker automatically determines an appropria-

te width. In this case, the cell widths will be automatically distributed over the 

space available. 

Any of these three options can be applied in any combination within the same tab-

le. Thus, you can set up, for example, tables where the cells in the first column 

have a fixed width, while those in the remaining columns have widths set to “Au-

to”. If you set up such a table and subsequently increased the width of the first co-

lumn, the widths of the remaining columns would automatically decrease proporti-

onally. 

Tip: Cell widths can also be changed with the mouse. To do this, drag the right 

border of a cell left or right with your mouse. If you have not selected any cells, 

the width of all the cells in the current column is changed. If you have selected 

some cells, only the width of the selected cells is changed. 

Vertical alignment 

This setting determines how the content of cells will be aligned with respect to the 

top and bottom edges of the cell: 

Option Explanation 

Top The cell content will be aligned flush against the top edge of the cell. 

(This is the default setting.) 

Centered The cell content will be centered between the top and bottom edges 

of the cell. 

Bottom The cell content will be aligned flush against the bottom edge of the 

cell. 

Justified The lines of text within the cell will be equally spaced, in such a way 

that the top line will be flush against the top edge of the cell and the 

bottom line flush against the bottom edge. 

Rotate by... 

Here you can specify the angle of rotation for the cells contents. 
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Margins 

Here you can change the interior margins of cells. 

Options 

If the Text locked option is checked, no modifications of the contents of the selec-

ted cells will be allowed when the document is edited in Form mode. 

By default, this option is not checked; accordingly, the cells will remain editable in 

Form mode. 

You will find more information about this in section “Protecting contents of form 

objects” (beginning on page 326). 

Borders tab 

Here you can specify border lines for the selected cells. 

The options accessible on this tab are the same as those for the Format > Borders 

menu command (see section “Borders and lines” beginning on page 100). 

Note: If you have selected multiple cells, not only outer border lines but also grid-

lines between the cells can be added.  

Tip: You can also use the  icon in the Table toolbar to change the borders 

of cells. Select the desired cells and then click the arrow right of the icon (not the 

icon itself). A menu with several pre-defined border styles will open. Click on 

the desired style to apply it. 

If you want to apply the same border style to other cell ranges thereafter, simply 

select them and click the icon itself (not the arrow). TextMaker will apply the last 

chosen border style once more. 

Shading tab 

Here you can specify a shaded or patterned background for the selected cells.  

The options accessible on this tab are the same as those for the Format > Shading 

menu command (see section “Shading” beginning on page 99). 
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Changing the overall properties of tables 

You can make additional settings for tables in the dialog box of the Table > Table 

properties menu command. Changes made with this command affect the table as a 

whole, allowing you to change e.g. the borders and the shading of the entire table. 

Additionally, the positioning of the table can be modified. 

To change the properties of a table, first position the text cursor in any cell in the 

table. Then invoke the Table > Table properties menu command to bring up the 

associated dialog. 

Note: This dialog can also be invoked with the Object > Properties menu com-

mand – the two commands are identical. 

The following settings can be made in this dialog: 

Properties tab 

On this tab, you can change some general settings for the table. For descriptions of 

these settings see section “Object properties, Properties tab” beginning on page 

281. 

Note: The Text locked option mentioned in the section referenced above is not 

present for tables, because protection for table cells is set on a cell by cell basis 

using the Table > Cell properties menu command (see the description of the Text 

locked option in section “Cell properties” beginning on page 209). Of course, you 

can always protect an entire table by selecting all its cells and then checking the 

Text locked option for them. 

Text direction: For text in Arabic script, you can also change the writing direction of 

the table. When you set the direction to right-to-left, the column on the very right 

becomes the first column (instead of the column at the very left). See also chapter 

“Working with Arabic text” (page 523). 

Layout tab 

This tab allows you to modify the positioning of the table. Options available: 

 Alignment 

 Here you can change the alignment of the table – from left-aligned (which is 

the default setting) to centered or right-aligned.  
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 Left indent 

 Here you can add a left indent to the table. 

 Wrapping 

 Here you can specify if the body text in your document should float around the 

table or not. Options available: 

 None: This is the default setting: The body text is broken above the table and 

continued below it.  

 Surrounding: When you switch to this setting, the body text will flow around 

the table – just like text floating around a text frame. 

 Additionally, choosing the option Surrounding has the following effects: 

 1. An icon with four arrows is displayed at the top left corner of a table whene-

ver the text cursor is inside the table. This icon allows you to move the table: 

Simply click on this icon and, with the left mouse button still pressed, drag the 

table to the desired position. 

 2. Apart from that, the Position button becomes available in the dialog. Cli-

cking on it opens another dialog offering extended options for the positioning 

of the table, as follows: 

 Horizontal and Vertical: Here you can specify the exact horizontal and 

vertical position of the table. Hint: Apart from entering fixed values into this 

text field, you can also open its dropdown list and choose one of the pre-

defined settings. For example, the entry “Right” will position the table 

right-aligned with the right page margin. 

 Distance from surrounding text: Here you can change the outside margins 

of the table (i.e. the distance between the table and the text that surrounds 

it). 

 Move with text: When you insert a table, it is automatically anchored to 

the paragraph located below its top left corner. “Anchored” means: The tab-

le will always appear on the page in which the paragraph with its anchor is 

found. Thus, if you move this paragraph to the next page, the table also mo-

ves there. If you turn this option off, on the other hand, the table will always 

stay on the page where it is right now. 

Borders tab 

Here you can specify border lines for the entire table. 
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The options accessible from this tab are the same as those for the Format > Bor-

ders menu command (see section “Borders and lines” beginning on page 100). 

Note: In tables, not only outer border lines but also gridlines between the cells can 

be added.  

Shades tab 

Here you can specify a shaded or patterned background for the entire table.  

The options accessible on this tab are the same as those for the Format > Shading 

menu command (see section “Shading” beginning on page 99). 

Table style 

FreeOffice: The Table style feature is not included in SoftMaker FreeOffice. 

The Table > Table style menu command can be a real time saver: it provides pre-

defined “table styles” that can be used to format an entire table with the push of a 

button. 

Simply put the text cursor into the desired table and invoke this command. 

A dialog presenting a list of all available table styles pops up. With the small pre-

view images in the list, you can preview the desired appearance of the table and 

apply it to the table.  

Selecting another table style changes the complete appearance of a table with re-

gard to the coloring and structure of the table. Select the desired style and confirm 

with OK. The entire table will be reformatted accordingly. 

The options at the bottom of the dialog can be used to adjust more specifically how 

the table style should be applied: 

 Header row 

 Turns the Header row for the column title at the top of the table on/off. 

 Total row 

 Turns the Total row at the bottom of the table on/off. 

 Banded rows and Banded columns 

 Enables/disables alternating background colors for every second row/column. 
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 First column and Last columns 

 When you activate this option, the first and/or the last column in the table will 

be emphasized. 

You can see the effect of these options right with the small preview images. For 

example, when you deactivate the Total row option, the last row in the table looses 

its special formatting. It will be formatted like any other “ordinary” table cells. 

Tip: If you miss the familiar AutoFormat for tables from previous versions, you 

can still add it to your individual user interface and use it. See section 

“Customizing toolbars” (page 573).  

Converting a table to text 

FreeOffice: Convert table to text is not included in SoftMaker FreeOffice. 

With the Table > Convert table to text menu command, you can transform a table 

into text. 

An example: You want to turn a table with 2x2 cells into a list, in which the con-

tents of the cells will be separated by semicolons. 

To do this, proceed as follows: 

1. Position the text cursor in any cell of the table. 

2. Invoke the Table > Convert table to text menu command. 

3. Select the desired Separator character, in this case the Semicolon. 

4. Confirm with OK. 

The contents of the table are now converted into normal text – from left to right 

and top to bottom. 

So, if you convert a table like this one ... 

Cell1 Cell2 

Cell3 Cell4 

... you will get text like this: 
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Cell1;Cell2 

Cell3;Cell4 

Each row becomes a separate paragraph. The Separator is inserted between the 

contents of each cell in every row. Depending on the separator you select, you will 

get the following results: 

Separator Result 

Paragraph break Here a new paragraph is started for each separate cell in the 

table. 

Tabs A new paragraph is started at the end of every row in the 

table. The contents of the cells in each row are separated by 

tabs. 

Semicolon A new paragraph is started at the end of every row. The con-

tents of the cells in each row are separated by semicolons (;). 

User defined Here you can specify the separator yourself. To do this, enter 

the desired character in the edit box. You can enter more than 

one character if desired. 

 For example, if you enter a comma followed by a space as 

the separator, the cell contents of every line will be separated 

by a comma and a space accordingly. 

It is also possible to proceed in the opposite way: you can convert text in tabular 

form into a table (see the next section.) 

Converting text into a table 

FreeOffice: Convert text to table is not included in SoftMaker FreeOffice. 

The previous section described how to convert a table into paragraphs of text. It is 

also possible to proceed in the opposite direction: with the Table > Convert text to 

table menu command you can convert text in tabular form into a table. 

To do this, proceed as follows: 

1. Select the paragraphs of text that you want to convert into a table. 

2. Invoke the Table > Convert text to table menu command. 
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3. First, select the Separator that is used to delimit the entries in the text (see be-

low). 

4. Next, specify the number of rows and columns the table should have. (TextMa-

ker automatically attempts to suggest appropriate values.) 

5. Confirm with OK. 

The text is now transformed into a table. Each line of text becomes a row in the 

table. 

An example: You want to turn the following list of addresses into a table: 

Peter;Miller;24 Main Street;12345;Whitneyville, AK 

Thomas;Meyer;1733 University Drive;54321;Knoxville, TN 

When you invoke the Table > Convert text to table menu command, select semi-

colon as the Separator, you will get the following result: 

Peter Miller 24 Main Street 12345 Whitneyville, AK 

Thomas Meyer 1733 University Drive 54321 Knoxville, TN 

Dialog options 

The options in the dialog box for this command are as follows: 

 Rows and Columns 

 Normally, you don’t have to worry about these settings. Provided you specify 

the separator correctly, TextMaker can determine the number of rows and co-

lumns the resulting table should have automatically and fill in these fields with 

the appropriate values. 

 However, you can enter your own values. 

 Separator 

 This is the most important setting: Here you specify the character TextMaker is 

to use to recognize the separate entries in each line of text. 

 You can choose among the following: 

 Paragraph break: Each entry is in its own paragraph. 

 Tabs: The entries are separated by tabs. 

 Semicolon: The entries are separated by semicolons (;). 
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 Besides one of these, you can choose any other character for the separator by 

entering it in the User defined field. You should use this field if your entries are 

delimited by slashes or commas, for example. It is also possible to enter multip-

le characters here. 

 Note: The separator must not occur within an entry; if it does, TextMaker will 

of course treat it as such and divide the entry in two. 

 Remove quotation marks 

 If you check this option, TextMaker will remove all surrounding quotation 

marks from the text entries when they are converted. 

 This is useful when, for example, you want to convert a list in which all the 

entries are enclosed in quotation marks ("Henry"; "Meyer"; ...). Many database 

programs generate lists of this type. 

 Remove trailing/leading spaces 

 If you check this option, TextMaker will remove all leading and trailing spaces 

from the text entries when they are converted. (Spaces within a particular text 

entry will not be removed.) 

Note: It is also possible to proceed in the opposite direction: you can convert tables 

into text (see the previous section.) 

Sorting tables 

FreeOffice: The Sort table menu command is not included in SoftMaker Free-

Office. 

You can let TextMaker sort the rows of a table using the Table > Sort table menu 

command. 

Note: This command is applicable only to tables. If you want to sort ordinary 

text paragraphs, please read section “Sorting text” beginning on page 221. 

To have TextMaker sort the rows of a table, proceed as follows: 

1. Position the text cursor in any cell of the table. 

 Or: If you want to have only a part of the table sorted, select the rows to be 

sorted. 
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2. Invoke the Table > Sort table menu command. 

3. In the dialog box, choose the column whose contents are to be used as the basis 

of the sort. If desired, you can specify multiple columns as sort criteria (see be-

low). 

4. Confirm with OK. 

The table rows are now sorted according to the contents of the selected column(s). 

The dialog box for this command presents the following options: 

Sort by: 

Here you specify the column whose contents are to be the basis of the sort. 

In addition, you can specify the sort order: Ascending (A..Z) or Descending 

(Z..A). 

Type 

Normally, you can keep the default setting Text for this option. However, if the 

column contains numbers, you should switch to Number. If it contains dates, 

choose Date. 

Note: When a column contains, for example, dates and you choose the Date opti-

on, the program will automatically extract day, month and year to determine the 

correct sort order. 

Then sort by: 

You can specify more than one sort criterion as required.  

For example, if the first column contains last names, and the second column con-

tains first names, you can select the first column for Sort by: and the second co-

lumn for Then sort by. As a result, the rows of the table will be sorted by last na-

me and those rows containing the same last name will then be sorted by first name. 

First row contains headings 

If the first row of your table contains headings, you should check this option to 

prevent TextMaker from including the first row in the sort. 
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Example: A table contains addresses. The first row contains headings like “Name”, 

“Street”, “City”, etc. In a case like this, you should check this option to ensure that 

the headings will remain in the first row and will not be mixed up in the sort. 

Case sensitive 

If you check this option, sort terms that begin with lowercase letters will be placed 

above terms beginning with uppercase letters. Otherwise, all sort terms that begin 

with the same letter will be grouped together, regardless of the cases of the first 

letters. 

Example: 

Off: Apples, bananas, Cherries. On: bananas, Apples, Cherries.  

Include cell formats 

Determines if cells should be sorted including their formatting. 

Off: Only the cell contents are sorted; the original formatting of the table is retai-

ned. 

On: Cells that are moved to another place due to the sorting take their formatting 

(shading, margins, orientation, rotation) with them. 

Sorting text 

FreeOffice: The Sorting text menu command is not included in SoftMaker 

FreeOffice. 

You can sort not only the contents of a table, as described in the previous section, 

but also paragraphs of normal text. To do this, you use the Edit > Sort menu com-

mand. 

Proceed as follows: 

1. Select the paragraphs of text to be sorted. 

2. Invoke the Edit > Sort menu command. 

3. Select either an ascending or descending sort order. 
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4. Confirm with OK. 

The paragraphs are now sorted in accordance with your settings. 

The dialog box for the sort command allows you to set basic criteria and provides 

some additional options that can be set as needed. The options include: 

Sort by: 

Normally, all you need to specify here is the sort order: Ascending (A..Z) or 

Descending (Z..A). 

The specification of a column as the basis for the sort makes sense only when the 

selected paragraphs are organized like a table – that is, when they contain elements 

delimited by tabs or other separator characters (see the Separator option). 

Then sort by: 

If required, you can specify more than one sort criterion.  

For example, if the selected paragraphs are in columnar form, and if the first co-

lumn contains last names and the second column contains first names, you can sel-

ect the first column for Sort by: and the second column for Then sort by. The 

paragraphs will be sorted first by last name. In addition, paragraphs containing the 

same last name will be sorted by first name. 

Separator 

You don’t have to set the Separator unless you are sorting paragraphs organized in 

tabular form. 

If the paragraphs contain, for example, names, street addresses, city names, etc. 

delimited by separator characters, you can tell TextMaker how to recognize the 

separate parts of each address by checking one of the following options: 

 Spaces 

 Tabs 

 User defined (here you can enter the separator yourself) 

An example: 

You want to sort the following three paragraphs: 
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Peter Miller(Tab)5 University Ave.(Tab)Pleasantville, NY 12345 

Thomas Chris Howe(Tab)24 Park Drive(Tab)Cambridge, NJ 21220 

Claudia Fisher(Tab)1024 13th Street(Tab)Forest Park, IL 98765 

In this case you should set the Separator option to Tabs, since the separate ele-

ments of each address (name, street, city) are delimited by tabs. 

Advantage: Now you can make use of the Sort by: option available in the sort 

command dialog to specify a sort by Column 1, Column 2 or Column 3. Column 1 

stands for the names, Column 2 for the streets, Column 3 for the cities. 

If you selected Spaces instead of Tabs as the separator, TextMaker would see 

every word in a paragraph as belonging to a separate “column” and would produce 

an unwanted result. 

First paragraph contains headings 

If the first of the selected paragraphs contains headings, you should check this op-

tion so that TextMaker will not include the first paragraph in the sort. 

Example: The selected paragraphs contain addresses. The first paragraph contains 

headings like “Name”, “Street”, “City”, etc. that identify the different parts of the 

addresses. In this case, you should check this option to ensure that the headings 

will not be incorrectly sorted along with the parts of the addresses to which they 

refer, but will remain in the first paragraph. 

Case sensitive 

If you check this option, sort terms that begin with lowercase letters will be placed 

above terms beginning with uppercase letters. Otherwise, all sort terms that begin 

with the same letter will be grouped together, regardless of the cases of the first 

letters. 

Example: 

Off: Apples, bananas, Cherries. On: bananas, Apples, Cherries.  

Tip: Using the Table toolbar 

Apart from the menu commands, TextMaker provides a very useful aid for editing 

tables: the Table toolbar. 
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The Table toolbar 

This toolbar appears automatically when you position the text cursor in a table. Its 

icons represent the following functions (from left to right): 

 Insert a table (into the current cell) 

 Edit table properties 

 Edit row properties 

 Edit cell properties 

 Insert cells 

 Delete cells 

 Merge cells 

 Split cells 

 Split table 

 Sort table 

 Insert entire row(s) 

 Insert entire column(s) 

 Delete entire row(s) 

 Delete entire column(s) 

 Table style 

 Change borders of the selected cells 

 Change shading of the selected cells 

 Change orientation of the selected cells 

For details on each of these functions, see the chapter “Tables” beginning on page 

199. 
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Pictures 
You can insert pictures into your document whenever you wish. Their sizes are 

fully adjustable; their positioning depends on whether you simply insert them di-

rectly into the body text or as a so-called “picture frame”: 

 Inserting pictures into the text 

 You can insert pictures directly into the body text with the Object > New Pic-

ture menu command. 

 TextMaker treats a picture that has been inserted with this command as if it 

were a character within the text. It becomes part of the body text. Thus, if you 

type something just before the picture, the picture will be shifted to accommo-

date it, just as a character would. 

 Inserting picture frames 

 Alternatively, pictures can be inserted in the form of picture frames, using the 

Object > New picture frame menu command.  

 Picture frames are anchored at fixed positions on the page; thus, they do not 

move when text is added or deleted above them. This sort of behavior is useful, 

for example, for documents in newspaper style.  

This chapter covers only the insertion of pictures directly into the text. You will 

find information about picture frames in chapter “Frames and drawings” beginning 

on page 259. 

The following topics are covered in this chapter: 

 Inserting a picture into the text 

 Scanning in pictures 

 Inserting pictures from the gallery (Android) 

 Changing position and size of a picture 

 Changing the properties of pictures 

 Using the Picture toolbar 

See the next pages for details. 
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Inserting a picture into the text 

To insert a picture directly into the body text, do the following: 

1. Move the text cursor to the desired position. 

2. Invoke the menu command Object > New Picture. 

3. A dialog box appears, allowing you to select the picture to be inserted. Choose 

a picture file and confirm with OK. 

The picture is now inserted into the text. 

Picture not visible? If you can’t see the picture in the document after you have inser-

ted it, that is probably because you have disabled the display of pictures – in other 

words, checked the Use placeholders option for pictures. To re-enable the display 

of pictures, invoke the menu command File > Properties, switch to the View tab 

and check the Show pictures option. 

Picture frames: As explained in the introduction, there is an alternative way of inser-

ting pictures using picture frames. These are anchored at fixed positions on the 

page; thus, they do not move when text above them is inserted or deleted. You will 

find more information about this topic in section “Picture frames” beginning on 

page 291. 

Dialog options 

The options in the dialog box for this command are as follows: 

 Save within document 

 If this option is checked, TextMaker saves a copy of the picture in the 

document and uses this copy instead of the original. 

 Otherwise, TextMaker saves only a reference to the original picture file in the 

document. 

 Copy to document’s folder 

 If this option is checked, TextMaker creates a copy of the picture file in the 

folder in which the document itself resides and uses this copy instead of the 

original. 

 This option is available only when the document has already been saved before, 

since otherwise TextMaker would not yet know in which folder the document 

will be stored. 
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Scanning in pictures 

Note: Scanning pictures directly into a document is possible only with the 

Windows version of TextMaker. 

FreeOffice: Scanning pictures directly into a document is not included in Soft-

Maker FreeOffice. 

TextMaker for Windows supports scanning printed matter directly into a document. 

To make use of this function, you must have connected a scanner to your computer 

and installed the scanner software. The scanner software must be TWAIN compa-

tible (as it is with almost all scanners). 

To scan a picture directly into the text, do the following: 

1. Power up the scanner and insert the document to scan. 

2. Move the text cursor to the position in the document where you want to insert 

the result of the scan. 

3. Invoke the File > Acquire menu command. 

At this point TextMaker activates your scanner’s software. Normally, this software 

presents a dialog box where you can make any settings you want to make and then 

start the scanning process (see the manual for your scanner). When the process has 

been completed, an image of the original will appear as a picture in the document. 

Scanning into a picture frame 

The procedure just described inserts the scanned picture right into the text. Alterna-

tively, you can insert the picture into a freely movable picture frame. To do this, 

simply switch to Object mode (using e.g. the View > Object mode menu com-

mand) before you invoke the File > Acquire menu command. 

The difference: Frames are anchored at fixed positions on the page; thus, they do 

not move when text is added or deleted above them. This sort of behavior is useful, 

for example, for documents in newspaper style.  

You will find more information about picture frames in section “Picture frames” 

beginning on page 291. 



 

228  •  Pictures Manual TextMaker 

Selecting other sources 

When several scanners are connected to your PC, you can switch among them with 

the File > Select source menu command.  

To switch scanners, invoke the command, select the desired device, and confirm 

with OK. 

Inserting pictures from the gallery (Android) 

Note: This feature is available only in the Android version. 

With the Android version you can also insert pictures using the Gallery application 

on your device. 

Proceed as follows: 

1. Move the text cursor to the desired position. 

2. Invoke the Object > New picture from gallery menu command. 

3. Your Android device opens its Gallery app. Choose the image to insert by tap-

ping on it. 

The picture is now inserted into the text. 

Inserting as a picture frame 

The procedure just described inserts the picture right into the text. Alternatively, 

you can insert the picture into a freely movable picture frame. To do this, simply 

use the Object > New picture frame from gallery menu command instead of the 

New picture from gallery command. 

The difference: Picture frames are anchored at fixed positions on the page; thus, 

they do not move when text is added or deleted above them. This sort of behavior 

is useful, for example, for documents in newspaper style.  

You will find more information about picture frames in section “Picture frames” 

beginning on page 291. 
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Changing position and size of a picture 

The position of a picture can be changed in either of the following ways: 

 Cut and Paste 

 You can cut and paste embedded pictures exactly like text segments: First select 

the picture and cut it using e.g. the Edit > Cut menu command. Set the text 

cursor to the desired target position, then apply the Edit > Paste menu com-

mand. 

 Using the mouse 

 Alternatively, you can use the mouse to move a picture: Select the picture with 

a mouse click and drag it to the desired target position (with the mouse button 

held down). 

The size of a picture can be changed as follows: 

 Dragging the handles on the selection frame 

 Click on the picture to select it. A blue selection frame will be displayed around 

the object, including several round “handles”. When you drag one of these 

handles with the mouse, the size of the picture is changed accordingly. 

 Entering values manually 

 You can also enter precise numeric values for the size of a picture. To do this, 

select the picture with a mouse click and then invoke the Object > Properties 

menu command. A dialog box appears to facilitate changes to the object’s pro-

perties (see also the next section). Switch to the dialog’s Format tab and enter 

the desired measurements in the Size section.  

Changing the properties of pictures 

The Object > Properties menu command gives you access to a dialog where all 

the properties of an object can be edited. An object’s properties include, for examp-

le, its size and margins, along with numerous other properties that you can set.  

To modify the properties of a picture, first select the picture with a mouse click. 

Then invoke the Object > Properties menu command to bring up the associated 

dialog. 
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Tip: This command can also be invoked by double-clicking on the picture. 

The following settings can be made in this dialog: 

Layout, Format, Filling, etc. tabs 

The tabs listed below are present for almost all object types. They allow you to 

modify the following settings: 

 Layout: On this tab, the only settings that apply to pictures are those for outside 

margins. The other options are available only for picture frames. See section 

“Object properties, Layout tab” beginning on page 268. 

 Format: For changing the size of the picture. See section “Object properties, 

Format tab” beginning on page 274. 

 Filling: For changing the filling. Only visible in pictures that have transparent 

areas. See section “Object properties, Filling tab” beginning on page 275. 

 Lines: For adding border lines. See section “Object properties, Lines tab” begin-

ning on page 277. 

 Shadow: For adding a shadow. See section “Object properties, Shadow tab” be-

ginning on page 278. 

 Effects: For adding various types of effects. See section “Object properties, 

Effects tab” beginning on page 280. 

 Properties: For modifying common object settings. Also displays some informa-

tion on the picture. See section “Object properties, Properties tab” beginning on 

page 281. 

For pictures, there is an additional tab with further options: 

Picture tab 

On the Picture tab, you can change settings that are specific to pictures. 

Tip: Some of these setting can also be modified using the Picture toolbar that 

appears automatically when you select a picture. See section “Using the Picture 

toolbar” (page 232). 

Options available on this tab: 
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 Variants 

 In this list, a number of pre-defined variations of the picture are presented – for 

example different color modes (grayscaled, black & white, etc.) as well as colo-

rized variants of the image. 

 To choose one of these variants, simply click on it, and the options in the dialog 

will be adjusted accordingly. 

 Settings group box 

 Here you can change brightness, contrast, saturation and gamma (color balance, 

with an effect on brightness). 

 More button 

 This button opens a dialog with the following additional options: 

 When you activate the Mix with color option and choose a color below, the 

picture will be colorized accordingly. 

 The options in the Cropping group box can be used to crop the picture. This is 

useful when you need only a segment of the picture. For example, if you want 

to cut off the upper forth of the picture, enter “25” (percent) at Top.  

 Transparency group box 

 Lets you modify the transparency settings of the image. Options available: 

 Detect automatically: Reads the transparency settings stored in the picture file 

and displays the image accordingly. Note: Only files in GIF or PNG format can 

contain transparency settings. 

 No transparency: Ignores the transparency settings stored in the picture file. 

Even pictures containing transparent areas will not be displayed transparently. 

 Color: Lets you choose the color to be displayed transparently. For example, if 

you select white, all white areas of the picture will become transparent. 

 File button 

 To use a different picture file, click this button and choose a new file. 

 Export button 

 Available only for pictures that are saved in the document.  

 You can use this button to export the picture, that is, to save a copy of it on your 

hard disk. 
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 If you check the Create link to file option in the Export dialog, TextMaker first 

copies the picture from the document to a file and then removes the picture 

from the document, replacing it with a reference to the new file. Thus, the pic-

ture is no longer saved in the document. 

Using the Picture toolbar 

Some of the properties of pictures can also be changed using the Picture toolbar. 

 

The Picture toolbar 

This toolbar appears automatically when you select a picture in the document. 

From left to right, its icons represent the following functions: 

 Invoke the Object > Properties menu command for this image 

 Add a photo frame effect to the image (not available in SoftMaker FreeOffice) 

 Use the original colors of the image 

 Reduce the colors to shades of gray 

 Reduce the colors to black and white 

 Increase brightness 

 Decrease brightness 

 Increase contrast 

 Decrease contrast 

 Increase gamma 

 Decrease gamma 

 Rotate 90 degrees clockwise 

 Rotate 90 degrees counter-clockwise 

 Revert all changes made with this toolbar 

 Enter/exit Crop mode. In this mode, additional handles are displayed on the 

borders of the picture. Drag these handles around to crop the picture. (not in-

cluded in SoftMaker FreeOffice.) 

Note: These settings can also be changed using the dialog of the Object > Proper-

ties menu command. See section “Changing the properties of pictures” (page 229). 



 

Manual TextMaker Charts  •  233 

Charts 

FreeOffice: In SoftMaker FreeOffice, charts can only be displayed (e.g. when 

you open a document that contains a chart). Creating new charts and editing 

charts is not supported. 

TextMaker’s integrated charting module allows you to present numbers vividly in 

charts. 

In this chapter, you will learn everything you need to know about charts. Topics 

covered: 

 Inserting charts 

 The first section is about inserting charts. There are two ways to do this: a) cre-

ating a chart inside the spreadsheet application PlanMaker and then copying it 

into your TextMaker document – or b) simply creating an empty chart and fil-

ling in its data by hand. 

 Editing charts 

 In this section, you will learn how to enter/edit the data that is presented in a 

chart, how to work with the different chart elements (data rows, axes, legends, 

etc.) and how to modify the overall chart properties. 

See the next pages for details. 

Hint: Basic information on charts can also be found in the manual for the 

spreadsheet application PlanMaker, chapter “Charts”. 

Inserting charts 

FreeOffice: In SoftMaker FreeOffice, charts can only be displayed (e.g. when 

you open a document that contains a chart). Creating new charts and editing 

charts is not supported. 

There are two ways to insert a chart into a document: 



 

234  •  Charts Manual TextMaker 

 Inserting charts via PlanMaker 

 The most comfortable way: Create or open a chart inside the spreadsheet appli-

cation PlanMaker and copy it into the clipboard. Then switch to TextMaker and 

paste it there. 

 Inserting charts manually 

 Alternatively, you can simply create a new, empty chart using the Object > 

New chart menu command in TextMaker. After that, enter the numbers to be 

presented in the chart using the Object > Chart > Edit data menu command. 

See the next pages for details. 

Inserting charts via PlanMaker 

The most comfortable way to insert a chart leads over a little “detour”: Use the 

spreadsheet application PlanMaker to create the chart. When done, copy it to the 

clipboard and paste it into TextMaker. 

The advantage: PlanMaker simply suits perfectly for entering data and creating 

charts. It has tools and features for this that only a spreadsheet application can of-

fer. 

(Of course you need to have PlanMaker installed to use this method.) 

Proceed as follows: 

1. In PlanMaker (not in TextMaker!), enter the numbers that you want to be 

presented in the chart. 

 (Or alternatively open a document that already contains these values.) 

2. Select the cells containing these numbers and invoke the Object > New chart 

frame menu command to create a chart from them. (Detailed instructions on 

this can be found in the PlanMaker manual, chapter “Charts”.) 

 (Or alternatively open a document that already contains the desired chart.) 

3. In case the chart isn’t already selected, select it by clicking on it. 

4. Use the Edit > Copy menu command to copy the chart to the clipboard. 

5. Switch to TextMaker. 

6. Move the text cursor to the position where you want the chart to be inserted. 
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7. Use the Edit > Paste menu command to place the chart. 

The chart now appears in your document. 

Note: A chart inserted this way will not be converted into an image, it will remain a 

chart, with all its functionalities – meaning that you can e.g. change its chart type, 

edit its data, or modify other chart properties anytime later. 

Inserting as a chart frame 

The procedure just described inserts the chart right into the text. Alternatively, you 

can insert the chart into a freely movable chart frame. To do this, simply switch to 

Object mode (using e.g. the View > Object mode menu command) before you 

issue the Edit > Paste menu command. 

The difference: Frames are anchored at fixed positions on the page; thus, they do 

not move when text is added or deleted above them. This sort of behavior is useful, 

for example, for documents in newspaper style.  

For more information on frames, see chapter “Frames and drawings” (page 259). 

Inserting as an OLE object 

When you copy and paste a chart from PlanMaker, it will loose any connection to 

the original chart. So, when you later alter the original chart in PlanMaker, this will 

have no effect on its copy in TextMaker. 

If you want to insert a chart that keeps a connection to the original chart in Plan-

Maker, you must insert it as an OLE object. To do so, invoke the Object > New 

OLE object menu command and choose “PlanMaker Chart” from the list of 

available object types. 

For more information on working with OLE objects, see the chapter “OLE objects” 

(page 249). 

Inserting charts manually 

The previous section described how you insert a chart by creating it in PlanMaker 

and then copying it into a TextMaker document. As an alternative, you can simply 

create an empty chart in the TextMaker document and then fill it with data by hand. 

Proceed as follows: 
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Step 1: Insert an empty chart 

First, insert an empty chart, as follows: 

1. In your TextMaker document, move the text cursor to the desired position. 

2. Invoke the Object > New chart menu command. 

3. In the resulting dialog box, select the desired Chart type and Subtype to spe-

cify how the chart will look.  

 (More information on chart types can be found in the PlanMaker manual, 

keyword “chart type”.) 

4. Confirm with OK. 

The chart is now inserted into the document. 

Step 2: Enter the data to be presented 

When you insert a new chart, it is filled with the values 1, 2, 3, 4 by default. These 

values are just sample values, to make sure that the chart isn’t displayed comple-

tely empty. You should of course replace these numbers with your own values. 

To do so, proceed as follows: 

1. In case the chart isn’t still selected, select it with a mouse click. 

2. Invoke the Object > Chart > Edit data menu command. 

3. A dialog box appears. In the Y values column, enter the numbers to be 

presented in the chart. 

 Don’t worry about the other columns and options; they are irrelevant for most 

chart types. (For detailed information on this dialog, see the section 

“Entering/editing the data of a chart”, page 238.) 

4. When you have finished entering the values, confirm with OK. 

The chart now updates and presents the values that you have entered. 

You can modify these values anytime later by selecting the chart and invoking the 

Object > Chart > Edit data menu command once more. 
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Inserting as a chart frame 

The procedure just described inserts the chart right into the text. Alternatively, you 

can insert the chart into a freely movable chart frame. To do this, simply use the 

Object > New chart frame menu command instead of the New chart command. 

The difference: Chart frames are anchored at fixed positions on the page; thus, they 

do not move when text is added or deleted above them. This sort of behavior is 

useful, for example, for documents in newspaper style.  

For more information on frames, see chapter “Frames and drawings” (page 259). 

Editing charts 

FreeOffice: In SoftMaker FreeOffice, charts can only be displayed (e.g. when 

you open a document that contains a chart). Creating new charts and editing 

charts is not supported. 

On the next pages you will learn how to edit existing charts. Topics covered: 

 Entering/editing the data of a chart 

 The first section covers the Object > Chart > Edit data menu command. It 

allows you to edit the data of a chart – i.e. to enter or change the values that are 

presented in the chart. 

 Working with chart elements 

 Charts consist of various components (data series, axes, legend, etc.), referred 

to as chart elements. Each of these chart elements can be selected and modified. 

Read this section to learn how. 

 Changing common chart properties 

 Apart from the properties of specific chart elements, there are also common 

chart properties that you can modify. This includes various layout options, the 

chart type, setting related to the data series, etc. To change the chart properties, 

use the Object > Properties menu command detailed in this section. 

See the next pages for details. 

Hint: Basic information on charts can be found in the manual for the spreadsheet 

application PlanMaker, chapter “Charts”. 
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Tip: Using the Chart toolbar 

When you select a chart, a toolbar named Chart toolbar will automatically appear. 

 

The Chart toolbar 

This toolbar provides icons helpful for working with charts. From left to right: 

 Change chart type 

 Change chart subtype (available only for certain chart types) 

 Dropdown list of all chart elements (open the list and click on an element to 

select it in the chart) 

 Edit properties of the current chart element 

 Edit common chart properties 

 Add trend line 

 Edit chart data 

 Legend on/off 

 Vertical gridlines on/off 

 Horizontal gridlines on/off 

Entering/editing the data of a chart 

FreeOffice: In SoftMaker FreeOffice, charts can only be displayed. Creating 

and editing charts is not supported. 

When you insert a new chart, it is filled with the values 1, 2, 3, 4 by default. These 

values are just sample values, making sure that the chart isn’t displayed completely 

empty.  

You should of course replace these numbers with your own values, using the Ob-

ject > Chart > Edit data menu command. 

Proceed as follows: 

1. Select the chart with a mouse click. 

2. Invoke the Object > Chart > Edit data menu command. 

3. A dialog box appears. In the Y values column, enter the numbers to be 

presented in the chart. 
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 Don’t worry about the other columns and options; they are irrelevant for most 

chart types.  

 (For detailed information on this dialog, see below.) 

4. Confirm with OK. 

The chart now updates and presents the values you have entered. 

Note: You can also open this dialog by selecting the chart, invoking the Object > 

Properties menu command, switching to the Series tab and clicking on the Edit 

button. 

Dialog options 

The dialog box mentioned above has the following options: 

 Series 

 For charts with more than one data series, this list allows you can choose which 

series to display in the dialog. 

 Hint: You can manage the data series of a chart by selecting the chart, invoking 

the menu command Object > Properties, and switching to the Series tab. On 

this tab, you can add, delete, and edit data series. 

 Rename button 

 Renames the data series that is currently selected in the Series list. 

 Hint: This name is also displayed in the legend of a chart. 

The largest part of the dialog is occupied by a table where you can enter the values: 

 X values 

 The left column represents the x values. These values are required only by a 

few chart types (e.g. XY charts). For all other types, this column is by default 

set to Automatic (using the checkbox located above this column). 

 Y values 

 The middle column represents the y values. Here you usually type in the values 

to be displayed in the chart. 
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 Bubble sizes 

 The right column is not used for most chart types. It represents the bubble sizes 

in bubble charts. 

 Insert Row button 

 Inserts an additional row above the current row. 

 Append Row button 

 Appends an additional row below the last row. 

 Delete Row button 

 Deletes the current row. 

 Paste button 

 Overwrites the values in the current data series with the content of the clip-

board. 

 Copy the desired values to the clipboard beforehand. Use a new line for each 

value. 

 See also notes below. 

Some notes on using the Paste button: 

 The Paste button can fill only one data series at a time. This means that you 

cannot copy e.g. a whole table to the clipboard and then paste it as multiple data 

series. 

 Hint: You can still achieve this by taking a little “detour”: Paste the table con-

tents into the spreadsheet application PlanMaker (as table cells), create a chart 

from them, copy and paste the chart into your TextMaker document. See also 

section “Inserting charts via PlanMaker” (page 234). 

 In case you want to paste x and y values with the Paste button, first disable the 

Automatic checkbox above the X values column. Also make sure that the clip-

board contains two values per row: x and y. The two values have to be separa-

ted either by a tab character or your system’s list separator character (usually a 

comma or a semicolon). 

 For bubble charts, the clipboard should contain 3 values: x, y, and the bubble 

size. 
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 Text strings in the clipboard normally return the value 0 (zero). However, if a 

text string contains numbers, the first valid number is extracted. 

 Examples: 

 “dollars” returns 0. 

 “50 dollars” returns 50. 

 “dollars 50” returns 50. 

 “50 dollars, 20 cents” also returns 50. (Only the first number is extracted.) 

Working with chart elements 

FreeOffice: In SoftMaker FreeOffice, charts can only be displayed. Creating 

and editing charts is not supported. 

Charts consist of various components (data series, axes, legends, etc.), referred to 

as chart elements. 

The picture below illustrates all chart elements: 

 

Series 1, Series 2, etc. represent the chart’s data series. 

Three-dimensional charts types contain some additional chart elements (walls, 

floor, etc.). 
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Each of these chart elements can be selected and modified. 

Selecting chart elements 

To select a chart element, first click on the chart itself to select it (if it isn’t already 

selected). Then, click on the desired chart element. For example, to select a data 

series, click on any value in this series. 

Note: To select a single value within a data series, first click on the data series to 

select the entire series, and then click on the desired value. 

Hint: Alternatively, open the chart elements dropdown list in the middle of the 

Chart toolbar and select the desired element. 

 

Changing position and size of chart elements 

Some chart elements can be moved or resized – for example, the legend. To move 

an element, select it and drag it to the desired position. To change its size, drag one 

of the round handles surrounding the element. 

Modifying chart elements properties 

As described in the section “Changing common chart properties” later on, charts 

have common properties that you can modify whenever needed. Apart from those 

common properties, you can also change the properties of single chart elements. 

For example, to change the properties of the legend displayed in a chart, proceed as 

follows: 

1. Select the chart by clicking on it. 

2. Right-click on the legend to open its context menu. 

 Android: In the Android version, you can also open the context menu with your 

finger: Just tap on the screen and hold your finger there for about a second. 

3. In the context menu, choose the Legend: Properties command (not the Chart: 

Properties command).  

This command will open a dialog containing legend-specific properties. 
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Hint: Clicking the  icon in the Chart toolbar or double-clicking a chart ele-

ment will also access the element’s properties dialog. 

A different dialog appears for each type of chart element. For example, axes allow 

you to modify their scale, legends allow you to choose a different font, etc. 

For detailed information on all chart elements and their individual properties, see 

the manual for the spreadsheet application PlanMaker, keyword “chart ele-

ments”. 

Changing common chart properties 

FreeOffice: In SoftMaker FreeOffice, charts can only be displayed. Creating 

and editing charts is not supported. 

The previous sections discussed how to change the properties of specific chart ele-

ments. The following section details the common chart properties. This includes 

layout options, the chart type, settings related to the data series, etc. 

To modify the common properties of a chart, select the chart and choose the Ob-

ject > Properties menu command. 

Hint: Clicking the  icon in the Chart toolbar will also access the Object Pro-

perties dialog. 

In this dialog, the following options are available: 

Layout tab 

On the Layout tab, you can set the outside margins of a chart. For chart frames, 

you can additionally modify the position and the text wrapping.  

For details, see section “Object properties, Layout tab”, page 268. 

Format tab 

Use this tab to change the size of the chart.  

For details, see section “Object properties, Format tab”, page 274. 
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Properties tab 

Here you can modify common object settings.  

For details, see section “Object properties, Properties tab”, page 281. 

Chart Type tab 

Here you can change the chart type.  

First, select a chart type on the left. Then, choose a sub-type on the right. 

For details on chart types, see the manual for the spreadsheet application PlanMa-

ker, keyword “chart type”. 

Series tab 

Data series are the most important chart elements. They represent the data to be 

displayed in a chart. For example, in a column chart, the height of each column 

stands for the size of the corresponding value. 

The Series tab allows you to modify settings related to the data series of a chart. 

You can even enter or change the values contained in a data series (using the Edit 

button). 

Before making any changes, make sure you have selected the desired data series in 

the Series list. 

Options available:  

 Series 

 The Series list contains a list of all data series defined in the current chart.  

 The arrow buttons change the order of data series.  

 The Add and Delete buttons add/delete a series. 

 The Edit button can be used to enter/edit the values contained in the selec-

ted data series. See also section “Entering/editing the data of a chart”, page 

238. 

 Data sources group box 

 Allows you to specify which values are used to build up the selected data se-

ries.  
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 The fields in this section are filled in automatically, and there is usually no need 

to change them. 

Note: It is not recommended to modify these fields by hand. Use the Edit 

button instead (located below the Series listbox). It opens a dialog where you 

can enter/edit these values in a more comfortable way. (More information on 

this dialog can be found in the section “Entering/editing the data of a chart”, 

page 238.) 

 Fields in this section: 

 Name: The name of the data series. If you leave this field empty, the data series 

will be assigned an automatically generated name (Series 1, Series 2, etc.). 

 Y values: The y values of the data series. To modify them, do not enter values 

directly but use the Edit button (located below the Series listbox). 

 Annotation: With most chart types, the y values represent the data to be dis-

played in the chart. For example, in a column chart, the y values determine 

the height of the columns.  

 X values: The x values of the data series. To modify them, do not enter values 

directly but use the Edit button (located below the Series listbox). 

 Annotation: With most chart types, the x values are irrelevant and therefore 

set to “Auto” (= automatic). All they do is providing labels for the category 

axis (x axis). Exception: E.g. in XY scatter charts and bubble charts, the x 

and y values determine the coordinates of the data points. 

 Bubble size: The bubble sizes of the data points (only in bubble charts). To 

modify them, do not enter values directly but use the Edit button (located be-

low the Series listbox). 

 Display this series as group box 

 Allows you to modify the way the selected data series is displayed in the chart. 

For example, in a column chart, you can change the appearance of one or more 

data series to lines instead of columns. 

 Use secondary axis for this series 

 If you check this option, the selected data series will be displayed using a se-

condary value axis (y axis). Secondary axes can have a different scale than pri-

mary axes. 
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 Annotation: Using a secondary axis is helpful if one or more data series 

require a completely different scale on the axis because they contain values 

many times larger or smaller than the other data series. 

Elements tab 

Use the Elements tab to show/hide certain chart elements or to add captions to 

them. 

Options available:  

 Chart title 

 Lets you enter a title for the chart. The title will be displayed above the chart. 

 Primary Axes group box  

 Allows you to configure the primary axes: 

 The checkbox in front of the axis determines if it will be displayed in the chart. 

 The text box to the right lets you enter a caption for the axis. 

 The options Major grid and Minor grid determine if a grid will be displayed 

in the background of the chart.  

 Secondary Axes group box  

 Allows you to configure the secondary axes (only available for charts that con-

tain a secondary axis). 

 Legend 

 Allows you to change the position of the legend. A legend is a small box indi-

cating which colors/patterns are assigned to the data series displayed in the 

chart.  

3D View tab 

Note: This tab is only available for three-dimensional chart types. 

Use the 3D View tab to modify the 3D effect settings for the chart. 

Options available:  
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 Rotation angle and Elevation angle 

 Lets you modify the viewing position. Rotation angle rotates the chart around 

the vertical axis; Elevation angle changes the height of the viewing position. 

 Perspective 

 To display the chart with perspective distortion, check this option and choose 

the amount of distortion (0 to 100 percent). 

 Height and Depth 

 Lets you modify the height and depth of the chart (as a percentage of its origi-

nal size). 

Radar tab 

Note: This tab is only available for Radar charts.  

Use the Radar tab to modify settings specific to Radar charts. 

Options available:  

 Starting angle 

 Rotates the chart by the specified angle. 

 Orientation 

 Specifies if the data points are arranged clockwise or counterclockwise. 

 Round chart 

 If this option is checked, circle segments are drawn between the axes instead of 

lines. 

 Polar coordinates 

 If this option is checked, polar coordinates are used instead of Cartesian coor-

dinates. Only available if Round chart is checked. 

 If Angle between axes is set to x, an axis is plotted every x degrees.  

 If Angle between axis descriptions is set to x, an axis label is plotted every x 

degrees.  
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 Limit plot area to radar 

 If this option is checked, only the area inside the radar will be filled. If it is not 

checked, the rectangle surrounding the radar will be filled as well. 
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OLE objects 

Note: The use of OLE objects is possible only with the Windows version of 

TextMaker. 

With TextMaker for Windows, you can embed objects created with other applica-

tions (drawings, pictures, etc.) in your document. 

An example: From TextMaker, you can use the menu command Object > New 

OLE object to start Windows’ Paint program and then draw something. When you 

exit Paint, the drawing appears in the TextMaker document. It is now embedded in 

the document. 

Advantage: To edit the drawing in the TextMaker document all you have to do is 

double click on it – Paint is then restarted automatically. When you have finished 

editing and closed Paint, your changes are imported by TextMaker.  

For this to work, the application invoked from TextMaker must support OLE. OLE 

stands for “Object Linking and Embedding”. The object that is imported from the 

other application into TextMaker is called an OLE object. 

In this chapter, you will learn everything you need to know about OLE objects. It 

covers the following topics: 

 Inserting OLE objects 

 Editing OLE objects 

 Editing links to OLE objects 

 Changing position and size of an OLE object 

 Changing the properties of OLE objects 

 Using the SoftMaker Equation Editor 

See the next pages for details. 

Inserting OLE objects 

Note: The use of OLE objects is possible only with the Windows version of 

TextMaker. 
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The Object > New OLE object menu command allows you to embed an OLE 

object into the document.  

The command opens a dialog box containing a list of all applications that are able 

to create OLE objects. The entries displayed in the list depend on the OLE-capable 

programs installed on your system.  

Selecting “Paintbrush Picture”, for example, will open Windows’ Paint program 

(called Paintbrush in older versions of Windows). There you can create a picture. 

Simply exit Paint, and the picture will be embedded into your document. It is dis-

played in the text, and you can edit the picture whenever you wish. To do so, 

simply double click on the picture. 

Step by step, the procedure for embedding an OLE object is as follows: 

1. Move the text cursor to the position in the document where you want to embed 

the object. 

2. Invoke the Object > New OLE object menu command. 

3. A dialog box appears. From the Object type list displayed in this window, sel-

ect the type of OLE object that TextMaker should embed in the text. 

4. When you confirm with OK, TextMaker starts the application that is appropria-

te to the type of object selected. 

5. Create the object in the application. 

6. Exit the application. 

7. At this point, it is possible that the application will ask you if you want to insert 

the object into the TextMaker document. Confirm with “Yes”. 

The OLE object created in the other application is now embedded in the TextMaker 

document.  

Inserting as an OLE object frame 

An OLE object that has been embedded in the text is treated by TextMaker as if it 

were a character within the text. Thus, it is bound up within the flow of the text.  

Instead of being embedded, an OLE object can be inserted as an OLE object frame 

that will remain at a fixed position on the page. You will find more information 

about this in section “OLE object frames” beginning on page 295. 
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Acquiring an OLE object from a file 

If you don’t want to create a new OLE object, but want to embed as an OLE object 

a document that already exists in the form of a file created previously in another 

application, you still invoke Object > New OLE object menu command, but in 

this case, instead of choosing the option Create new in the dialog, you select the 

Create from file option. 

With this selection, the look of the dialog changes: Instead of the Object type list, 

a File entry field is displayed. Here, enter the full file name of the document file, or 

click on the Browse button to bring up a dialog box that will enable you to search 

your hard disk for the file. 

When you have specified a file and confirmed with OK, the file is inserted as an 

OLE object.  

When the OLE object is being inserted, Windows checks the file name extension to 

see if it is associated with a program that can be started. If the file name extension 

is not registered, the embedded file is merely represented by a symbol. On the 

other hand, if Windows can relate the file name extension to an OLE-capable pro-

gram, the content of the embedded file is displayed. 

Creating a link to the original file 

The dialog box described above provides an additional option that allows you to 

specify whether the object to be inserted from the file should be embedded in or 

linked to the document. If you leave the Link option unchecked, TextMaker inserts 

a copy of the file into the document as an OLE object and saves this copy in the 

document – thus, the object is embedded in the usual way. 

On the other hand, if you check the Link option, TextMaker inserts the OLE object 

in the form of a link to the original file. In this case, if you should ever modify the 

original file with another application and then reopen the TextMaker document that 

contains the link to this file, the OLE object will appear modified accordingly – 

thus, the OLE object remains linked to the original file. 

Editing OLE objects 

OLE objects can be modified as follows: 
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Tip: To edit an OLE object, simply double click on it. The object will be opened 

immediately in its native application, where it can be edited. 

Alternatively, you can use the menu to edit an OLE object. Proceed as follows: 

1. Click on the OLE object to select it. 

2. Open the Edit menu. At the bottom of the menu, you will find an item that re-

fers to the object by name (for example, Bitmap object). Selecting this menu 

item opens a sub-menu containing all the OLE commands that are available for 

this object. There is an Edit command for editing the object. Invoke this com-

mand. 

3. The application associated with the OLE object now starts. Make the desired 

changes there. 

To return to TextMaker, simply exit the object’s source application.  

When exiting some applications, you will be asked if you want to update the object 

in the TextMaker document. Answer “Yes” – otherwise your changes will be dis-

carded. 

Editing links to OLE objects 

If you acquire an OLE object from a file with the Link option checked, you can 

edit the resulting link to the source file with the Edit > Link menu command.  

When you invoke this command, a dialog box appears and displays a list of all the 

existing links in the current document. When you select a link from the list, the 

name and type of the source file to which the link refers are displayed in the lower 

part of the dialog box. 

The dialog’s buttons allow you to perform the following functions: 

Button Function 

Update Now Updates the OLE object. Use this button if the source file has 

been modified by another program and the changes are not 

visible in the TextMaker document.  

Open Source Starts the application associated with the OLE object, allo-

wing you to edit the object in the application. Tip: Double 

clicking on the object has the same effect. 
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Change Source Lets you select a different file as the source for the OLE 

object. 

Break Link Cuts the link to the source file. As a result, the object is em-

bedded permanently in the TextMaker document. Changes to 

the source file no longer have any effect on the document. 

However, the object can still be edited by double clicking on 

it. 

Changing position and size of an OLE object 

The position of an OLE object can be changed in either of the following ways: 

 Cut and Paste 

 You can cut and paste embedded OLE objects exactly like text segments: First 

select the object and cut it using the Edit > Cut menu command. Set the text 

cursor to the desired target position, then apply the Edit > Paste menu com-

mand. 

 Using the mouse 

 Alternatively, you can use the mouse to move an object: Select the object with a 

(single!) mouse click and drag it to the desired target position (with the mouse 

button held down). 

The size of an OLE object can be changed as follows: 

 Dragging the handles on the selection frame 

 Click on the object to select it. A blue selection frame will be displayed around 

the object, including several round “handles”. When you drag one of these 

handles with the mouse, the size of the object is changed accordingly. 

 Entering values manually 

 You can also enter precise numeric values for the size of an OLE object. To do 

this, select the object with a mouse click and then invoke the Object > Proper-

ties menu command. A dialog box appears to facilitate changes to the object’s 

properties (see also the next section). Switch to the dialog’s Format tab and en-

ter the desired measurements in the Size section.  
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Changing the properties of OLE objects 

The Object > Properties menu command gives you access to a dialog where all 

the properties of an object can be edited. An object’s properties include, for examp-

le, its size and margins, along with numerous other properties that you can set.  

To modify the properties of an OLE object, first select it with a mouse click. Then 

invoke the Object > Properties menu command to bring up the associated dialog. 

The following settings can be made in this dialog: 

Layout, Format, Filling, etc. tabs 

The tabs listed below are present for almost all object types. They allow you to 

modify the following settings: 

 Layout: On this tab, the only settings that apply to OLE objects are those for 

outside margins. The other options are available only for OLE object frames. 

See section “Object properties, Layout tab” beginning on page 268. 

 Format: For changing the size of the object. See section “Object properties, 

Format tab” beginning on page 274. 

 Filling: For changing the filling of the object. Not supported by all OLE applica-

tions. See section “Object properties, Filling tab” beginning on page 275. 

 Lines: For adding border lines. See section “Object properties, Lines tab” begin-

ning on page 277. 

 Shadow: For adding a shadow. See section “Object properties, Shadow tab” be-

ginning on page 278. 

 Effects: For adding various types of effects. See section “Object properties, 

Effects tab” beginning on page 280. 

 Properties: For modifying common object settings. See section “Object proper-

ties, Properties tab” beginning on page 281. 

For OLE objects, there is an additional tab with further options: 

Picture tab 

On the Picture tab, you can change settings that affect the graphical representation 

of the OLE object. 
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Note: Depending on the application associated with the OLE object, some of the 

options may be not supported. 

Options available: 

 Variants 

 In this list, a number of pre-defined variations of the object are presented – for 

example different color modes (grayscaled, black & white, etc.) as well as colo-

rized variants of the object. 

 To choose one of these variants, simply click on it, and the options in the dialog 

will be adjusted accordingly. 

 Settings group box 

 Here you can change brightness, contrast, saturation and gamma (color balance, 

with an effect on brightness). 

 More button 

 This button opens a dialog with the following additional options: 

 When you activate the Mix with color option and choose a color below, the 

object will be colorized accordingly. 

 The options in the Cropping group box can be used to crop the object. This is 

useful when you need only a segment of the object. For example, if you want to 

cut off the upper forth of the object, enter “25” (percent) at Top.  

 Export button 

 You can use this button to export a copy of the graphical representation of the 

object, that is, to save an image of the object on your hard disk. 

Using the SoftMaker Equation Editor 

FreeOffice: The Softmaker Equation Editor is not included in SoftMaker Free-

Office. 

Note: The SoftMaker Equation Editor is available only for Windows and is not 

included in all versions of TextMaker. 
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The SoftMaker Equation Editor allows you to display mathematical formulas in 

graphical form. 

TextMaker communicates with the Equation Editor via OLE, as described in the 

previous sections. Thus, to add a graphical representation of a formula to your 

document, you insert an OLE object, and choose the Equation Editor as the source 

application.  

To do this, proceed as follows: 

1. Move the text cursor to the desired position in the document. 

2. Invoke TextMaker’s Object > New OLE object menu command. 

3. Select the entry SoftMaker Equation Editor from the Object type list. 

4. Confirm with OK to start the Equation Editor. 

5. Create the desired formula. 

6. When you have finished building the formula, simply exit the Equation Editor. 

The formula is now embedded in the TextMaker document as an OLE object. 

You can edit objects created with the Equation Editor by double clicking on them. 

Following a double click, the Equation Editor is restarted and the formula object is 

opened in it. After you made the desired changes, simply close the Equation Editor 

again. 

Moreover, you can change the properties of an Equation Editor object by selecting 

the object with a (single!) mouse click and then invoking the Object > Properties 

menu command. 

Information from the creators of the Equation Editor 

The SoftMaker Equation Editor is a special version of the MathType program from Design Science. If 

you make frequent use of formulas in your documents, you might find that MathType itself is even 

better suited to your needs than the SoftMaker Equation Editor. While just as easy to use as the Equati-

on Editor, MathType has a number of additional functions that can help you be more productive and 
create more complex formulas. 

MathType is available in English, French, German, and other languages. You can obtain information 

about the purchase of MathType from your software distributor or directly from Design Science. 

Design Science, Inc. 

140 Pine Avenue, 4th Floor 

Long Beach, CA 90802 

USA 

Phone (USA): +1 (562) 432-2920 (for international customers) 
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 +1 (800) 827-0685 (for customers within the USA and Canada) 

Fax (USA): +1 (562) 432-2857 

E-mail (English): sales@dessci.com 

Internet: www.dessci.com 
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Frames and drawings 

In the preceding chapters you learned how to insert pictures and other objects di-

rectly into the body text. There is an alternative way to insert such objects. They 

can be inserted in the form of frames – pictures, for example, as picture frames. 

The difference: 

Frames occupy fixed positions on the page. You can adjust their positions, of cour-

se; but unless you do so deliberately, they remain at their fixed positions on the 

page. This means that a frame does not move when you add or delete text above it. 

Thus, frames are useful whenever you want to include text boxes, pictures, or simi-

lar objects in your document and you want those objects to remain at specified po-

sitions on their pages. 

A frame can be inserted right on top of existing body text. The existing text is then 

automatically reformatted in such a way that it flows around the frame. 

In this chapter you will learn everything you need to know to become familiar with 

frames and drawings. The chapter covers the following topics: 

 Frames – basic functions (page 260) 

 Here you will get acquainted with basic operations such as inserting, selecting 

and editing frames and other objects. 

 Frames – advanced functions (page 284) 

 This section is for advanced users. Here you will learn, for example, how to 

hide and group frames and other objects. 

After each of these topics is discussed, the individual types of frames are intro-

duced in detail: 
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 Text frames (page 287) contain boxed text. 

 Picture frames (page 291) contain pictures. 

 OLE object frames (page 295) contain OLE objects. 

 Drawings (page 298) are frames that contain drawing objects including lines, 

rectangles, and other shapes. 

Frames – basic functions 

In this section you will find basic information about working with frames, dra-

wings, and other objects: 

 Inserting frames 

 Selecting objects 

 Object mode 

 Changing the position, size and margins of objects 

 Rotating and flipping objects 

 Aligning and distributing frames 

 Duplicating objects 

 Changing the properties of objects 

Functions for advanced users are described in the next section (“Frames – advan-

ced functions”). 

Inserting frames 

As you learned in the introduction to this chapter, pictures and other objects don’t 

have to be inserted directly into the body text; they can be inserted in the form of 

frames. Thus, for example, instead of inserting a picture directly into the text, you 

can insert a picture frame. 

The difference: 

A frame occupies a fixed area on the page. As long as you don’t deliberately move 

it, it remains always at a fixed position on the page. A frame does not move when 

you enter or delete text above it. 

To insert a picture frame, for example, you do the following: 

1. Invoke the Object > New picture frame menu command. 



 

Manual TextMaker Frames and drawings  •  261 

2. A dialog box appears, allowing you to select the picture to be inserted. Choose 

a picture file and confirm with OK. 

3. The picture frame is inserted. 

 In case you want to modify its position or size, do the following: 

 To change the position, click on the picture frame and (while still holding the 

mouse button down) drag it to the desired position. 

 To adjust its size, drag on one of the round handles surrounding the frame. 

The process for inserting other types of frames is similar. You will find detailed 

information about the individual kinds of frames in the sections “Text frames”, 

“Picture frames” etc. (beginning on page 287). 

Selecting objects 

Before you can edit an object you must first select it. To do this, simply click on 

the desired object. A frame will appear around the object to indicate that it is now 

selected.  

Note: This does not work with text fields, text frames and other objects that have 

transparent fills. To select such an object you can click on its border, if it has one. 

Otherwise, you must switch to Object mode (see the next section). There, you 

can select any kind of object with a simple click of the mouse. 

You cannot modify the normal text while an object is selected; only the selected 

object can be edited. When you want to return to the text to continue editing it, 

simply click with the mouse at the desired position in the text. This action will de-

select the object. 

Object mode 

Object mode provides the simplest way to work with frames, drawings and all 

other objects. 

Normally, you work with TextMaker in Edit mode. In this mode you can enter, edit, 

format, etc. text. 

When you switch to Object mode, you can no longer edit text. However, this mode 

provides many functions that ease working with objects. Thus, in Object mode, you 

can, for example, select any type of object with a simple mouse click.  
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Important: While in Object mode, only commands related to inserting and mo-

difying objects are available. This means you cannot enter text, and menu com-

mands not related to objects are grayed out. 

Android: A hint for Android users: When you want to scroll through the document in 

Object mode, swipe over the screen with two fingers – not just one. 

Switching between Edit mode and Object mode 

There are several ways to switch between Edit mode and Object mode: 

 Invoke the View > Object mode menu command to enter Object mode. Invoke 

the command again to return to Edit mode. 

 Click on the  icon in the Formatting toolbar to switch to Object mode. Click 

on the icon again to return to Edit mode. 

 You can also click anywhere in the document with the right mouse button to 

open a context menu, from which you can select Object mode or Exit Object 

mode, depending on the current mode. 

 The following is the fastest method: Point the mouse at any free position within 

the document and double click with the right mouse button to switch between 

Edit and Object mode. 

 Also, when in Object mode, you can return to Edit mode quickly by double-

clicking on any position in your document where no object is located.  

The Object toolbar 

When you enable Object mode, the Formatting toolbar is replaced by the Object 

toolbar. 

 

The Object toolbar 

This toolbar provides icons for inserting and editing objects. From left to right, the 

icons are associated with the following functions: 

 Toggle between Object mode and Edit mode 

 Insert text frame 

 Insert picture frame 

 Insert chart frame 
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 Insert OLE object frame (available under Windows only) 

 Insert OLE object frame with a SoftMaker Equation Editor* object 

 Insert OLE object frame with a PlanMaker object 

 Insert OLE object frame with a PlanMaker chart object 

 Insert OLE object frame with a Presentations object 

 Insert line or curve 

 Insert rectangle 

 Insert rounded rectangle 

 Insert ellipse or circle 

 Insert AutoShape 

 Insert TextArt object 

 Group selected objects 

 Link selected text frames 

 Modify object properties 

 Object list (a dropdown list of all objects in the document, see below) 

* Not all versions of TextMaker have this feature. 

Object list: At the very right of the object toolbar, a dropdown list with the names of 

all objects existing in the current document is displayed. Open this list and when 

you click on the name of an object, the corresponding object will be selected. 

You can refer to the section on “Changing the names of objects” beginning on page 

286 to learn why objects have names and how these names can be changed. 

Selecting objects in Object mode 

In Object mode you can select any type of object simply by clicking on it with the 

mouse. 

This is very useful, especially for objects with transparent fills (e.g. text frames). In 

Edit mode, an object of this type can be selected only by aiming at its border and 

then clicking. In Object mode, such an object can be selected simply by clicking 

anywhere on it. 

In Object mode you can also select multiple objects at once, provided they are fra-

mes or drawings. To do this, draw a rectangle around the desired objects with the 

mouse. Alternatively, you can click successively on several objects while holding 

down the Shift key (ª) to select them together. 
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Changing the position, size and margins of objects 

On the next pages you will learn how to change the position, size and outside mar-

gins of an object. 

Changing the position of objects 

Objects can be moved as desired. Simply select the object with a mouse click and 

then do the following: 

 With the mouse: While holding down the mouse button, drag the selected ob-

ject to the desired position. 

 With the keyboard: With frames and drawings, you can alternatively use the 

arrow keys to move the currently selected object. 

 Under dialog control: With frames and drawings, you can also invoke the Ob-

ject > Properties menu command and switch to the Layout tab in the dialog 

box, where you can specify the precise position for the object.  

 Tip: This tab also gives you access to a number of expanded options. You can, 

for example, set the position of the frame relative to the page margin. See sec-

tion “Object properties, Layout tab” beginning on page 268. 

Note: An object’s “anchor” determines the page on which it is displayed 

Note: This section applies only to frames and drawings. 

When you insert a frame or a drawing, you will notice that an anchor is displayed 

along with it, to the left of the paragraph below the object: 

 

The anchor for this object is displayed at the upper left. 

An object’s anchor determines the page on which the object is displayed. More 

precisely: 
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Important: A frame or drawing that is anchored to a paragraph always appears 

on the page on which the corresponding paragraph is located. 

Accordingly, if you insert so much text above this paragraph that the new text 

forces the paragraph to the next page, the object that is anchored to this paragraph 

is forced to the next page along with it.  

An object’s anchor can be moved at any time. To move an object’s anchor, select 

the object and then drag the anchor to another paragraph with your mouse.  

Setting an anchor to a fixed page 

You can disable the above described behavior for any object, so that the object will 

always remain on a specific page: 

To do this, select the object, invoke the menu command Object > Properties, 

switch to the command dialog’s Layout tab, and select Fix on page in the Object 

group box. Then, enter the number of the page on which you want to fix the object. 

The object is then no longer anchored to a paragraph and will remain always on the 

specified page. When you select the object, a non-moveable anchor will appear at 

the upper left corner of the page. 

You will find information about the functions of the other anchor options on this 

dialog in the section “Object properties, Layout tab” beginning on page 268. 

Changing the size and margins of objects 

You can change the sizes and the margins of objects as follows: 

 Click on the object to select it. A blue selection frame will be displayed around 

the object, including several round “handles”. When you drag one of these 

handles with the mouse, the size of the object is changed accordingly. 

 For frames and drawings, it is also possible the change the outside margins: 
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 The inside (solid) lines of the selection frame represent the object’s size.  

 The outside (dashed) lines represent the object’s outside margins. When you 

drag one of these lines, the corresponding margin is modified. 

Preventing changes in an object's position and size 

By locking an object you can prevent it from being moved or resized with the 

mouse or the keyboard arrow keys. 

To lock an object, first select it. Then invoke the menu command Object > Pro-

perties, switch to the Properties tab and check the Locked option. 

Now the object can no longer be moved with the mouse and its size cannot be 

changed by dragging its border. Nor is it any longer possible to move the object 

with the keyboard arrow keys. The only way to change the object’s position or size 

is to enter values in the dialog box of the Object > Properties menu command. 

By unchecking the Locked option, you can re-enable changes to the object’s posi-

tion and size with the mouse. 

Rotating and flipping objects 

Note: Rotation and flipping can be performed only on drawings and pictures.  

When you select an object that can be rotated, an additional green handle will 

appear on the selection frame surrounding it. To rotate the object, drag this handle 

with the mouse. 
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Alternatively, you can set the angle of rotation manually. For this purpose, select 

the object, invoke the Object > Properties menu command, switch to the Format 

tab and enter the desired angle under the Rotation option. 

You can also rotate and flip (mirror) objects by invoking the Object > Rotate or 

flip menu command and choosing one of the commands offered in its submenu. 

Aligning and distributing frames 

Note: Only frames and drawings can be aligned and distributed; these operations 

are not possible on objects embedded in the text. 

To align or equally distribute two or more frames or drawings, select them and 

invoke the menu command Object > Align or distribute.  

A sub-menu appears, from which you can select the desired alignment or distribu-

tion: 

 Align left 

 Align center 

 Align right 

 Align top 

 Align middle 

 Align bottom 

 Distribute horizontally 

 Distribute vertically 

The last two commands work only when at least three objects are selected. These 

commands are used to distribute the selected objects evenly within the area they 

occupy, so that the spacings between them are equal. 
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Duplicating objects 

To obtain a duplicate of an object, you can copy it to the clipboard the usual way 

and then reinsert it. 

Alternatively, you can use the Edit > Duplicate menu command. This command 

immediately creates a copy of the selected object. 

Tip: Duplicating an object is even faster with the mouse: when you drag an ob-

ject while holding down the (Ctrl) key you obtain a duplicate of the object. 

However, this works only with frames and drawings.  

Changing the properties of objects 

An object’s properties include its size, fill style, line style, etc. The Object > Pro-

perties menu command provides one place to access all properties for editing or 

viewing. 

To modify the properties of an object, first select the object with a mouse click 

(text frames can be selected by clicking on the object’s border only). Then invoke 

the Object > Properties menu command to bring up the associated dialog. 

Tip: For most types of objects, double clicking on the object (or its border) pro-

vides a quick alternative way to invoke this command. 

The dialog contains several tabs. On the next pages, you will find detailed informa-

tion on each tab and the options it contains. 

Object properties, Layout tab 

On the Layout tab, you can set the outside margins for any type of object. For fra-

mes and drawings, you can, in addition, modify the position and the text wrapping. 

Options available: 

 Horizontal Position group box 

 These options are available only for frames and drawings. 

Note: You can change the positions of objects (e.g. pictures) that have been 

inserted directly into the text only by cutting them and then pasting them 

elsewhere. 
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 With frames and drawings, on the other hand, you can specify here where the 

object should be placed. 

 Normally, all you need to do is enter the desired spacing from the left page 

edge in the Offset field. For example, if you set the Offset to “2 in” the left 

edge of the object will appear 2 inches from the left edge of the page. But you 

can also set the alignment to be rightward, rather than leftward. If you do that, 

the object’s right edge will appear 2 inches from the right page edge. 

 The options for Position and Relative to provide additional control over the 

positioning when that is required. You can, for example, set the position relative 

to the page margin, rather than to the page edge. If you do that, the object’s po-

sition will move to the right as you widen the left margin and to the left as you 

shrink it, with similar results for altering the right margin on a rightward alig-

ned object.  

 Each of the various horizontal position options is given below, together with a 

description: 

 Position: With the Position options, you specify how the object is to be aligned: 

Option Effect 

Left The object is positioned from the left. Accordingly, the 

offset is from the left page edge, page margin, etc. to the 

left edge of the object. For example, the object’s left 

edge would appear 2 in from the left page edge. 

Centered The object is positioned from the center of the page, 

page margins, etc. For example, if Offset is set to 0 in, 

the object is centered horizontally on the page. If the 

offset is 2 in, the center of the object is positioned 2 in 

to the right of the center of the page, etc. 

Right The object is positioned from the right. For example, the 

right edge of the object would appear 2 in from the right 

page edge. 

Inside The object is positioned from the left if it falls on a right 

hand page (odd page number) – or from the right if it 

falls on a left hand page.* 

Outside The object is positioned from the right if it falls on a 

right hand page (odd page number) – or from the left if 

it falls on a left hand page.* 
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 * These two options work as described above only when 

the option Different left and right pages has been che-

cked in the dialog of the Format > Chapter menu 

command. Otherwise, TextMaker treats all pages as 

right hand pages. 

 Relative to: With the Relative to options you specify the document element that 

should serve as a reference for the Offset: 

Option Effect 

Page The offset is relative to the page (more precisely to the 

page edges). The page margins are not taken into ac-

count. 

Page borders The offset is relative to the page margins. If you in-

crease or decrease the margins, the object moves ac-

cordingly. 

Paragraph The offset is relative to the position of the paragraph to 

which the object is anchored. The indentation of this 

paragraph is not taken into account. 

 Note: If this paragraph falls, for example, in the right 

column of a double columned document, the object 

anchored to this paragraph is also moved to the right 

column. 

Indent Like Paragraph, except that the paragraph’s indentation 

is taken into account. 

 Thus if Position is set to Left, for example, and you 

increase the left indent of the paragraph by 0.5 in, the 

object will move to the right by 0.5 in. 

Left margin, 

Right margin, 

etc. 

The offset is relative to the respective page margin. For 

example, if you set Offset to 0, Position to Left, and 

choose Right margin here, the object’s left edge would 

appear where the right page margin begins. 

 If necessary, you can review the description of anchors in the section 

“Changing the position of objects” beginning on page 264. 

 Offset: Finally, you can set the desired spacing in the Offset field. 

 Example: If Position is set to “Left”, Relative to “Page borders” and Offset to 

2 in, the left edge of the object will appear 2 in from the left page margin. If this 

margin is 1 in wide, the left edge of the object will be 3 in from the left page 

edge. 
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 Vertical Position group box 

 This option is available only for frames and drawings. 

 The same goes for setting the vertical positioning as for setting the horizontal: 

You can use the default settings and simply enter the distance from the top of 

the page at which you want the object to be positioned in the Offset field. 

 Alternatively, you can make use of the expanded options to specify the positi-

on: 

 Position: The Position options allow you to specify how the object is to be alig-

ned: 

Option Effect 

Top The object is positioned from the top. If the offset is 2 

in, for example, the top of the object will be positioned 

2 in from the top edge of the page, top page margin, etc. 

Centered The object is positioned from the center. For example, if 

the offset is 0 in, the object is centered on the page. If 

the offset is 2 in, the center of the object is positioned 2 

in below the center of the page, etc. 

Bottom The object is positioned from the bottom. If the offset is 

2 in, for example, the bottom of the object will be posi-

tioned 2 in from the bottom of the page, bottom page 

margin, etc. 

 Relative to: With the Relative to options you specify the document element that 

should serve as a reference for the Offset: 

Option Effect 

Page The offset is relative to the page (more precisely, to the 

page edges). The page margins are not taken into ac-

count. 

Page borders The offset is relative to the page margins. If you in-

crease or decrease the margins, the object will move 

accordingly. 

Paragraph The offset is relative to the position of the paragraph to 

which it is anchored. 

 Note: When you select this option, the object moves 

with the paragraph. If you insert a new line of text 

above the paragraph the object also drops down a line. 
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Top margin, 

Bottom margin, 

etc. 

The offset is relative to the respective page margin. For 

example, if you set Offset to 0, Position to Top, and 

choose Bottom margin here, the object’s top edge 

would appear where the bottom page margin begins. 

 If necessary, you can review the description of anchors in the section 

“Changing the position of objects” beginning on page 264. 

 Offset: Finally, you can set the desired spacing in the Offset field. 

 Example: If Position is set to “Top”, Relative to to “Page borders”, and Offset 

to 2 in, the top of the object will be positioned 2 in below the top page margin. 

If this margin is 1 in wide, the top of the object will be positioned 3 in below 

the top edge of the page. 

 Wrap Margins group box 

 Here you can change the object’s outside margins. 

 Tip: The outside margins can also be changed by dragging the outer (dashed) 

lines that appear around the object when it is selected. 

 Text Wrapping group box 

 The options in this group box are available only for frames and drawings. 

 With these options you can specify how the body text surrounding the frame (or 

drawing) should behave. 

 Available options (from left to right): 

Option Meaning 

Line The body text is broken above the frame and continued 

below it. 

Square The body text flows around the rectangular borders of 

the frame. (This is the default setting.) 

Contour The body text flows around the object contained within 

the frame, following the object’s contours as closely as 

possible.  

Note: This works only with graphics that contain trans-

parencies, as well as drawings. 

Behind text The body text flows right through the frame and appears 

to lie behind the object in the frame. 



 

Manual TextMaker Frames and drawings  •  273 

In front of text The body text flows right through the frame and appears 

to lie above of the object in the frame. 

 Note: This option is not available for objects whose anchor is placed inside a 

table cell. 

 Contour group box 

 This group box is available only for frames and drawings. 

 When you have selected either the Square or the Contour option for Text 

wrapping, you can specify here the side(s) of the frame around which the text 

should wrap. 

 The available options are (from left to right): 

Option Meaning 

Both The body text flows around both sides of the frame. 

Left It flows only around the left side. 

Right It flows only around the right side. 

Larger side It flows only around that side of the frame on which 

there is the most room. 

 Object group box 

 The options in this group box are available only for frames and drawings. 

 When you insert a frame or a drawing, the object is automatically anchored to 

the paragraph in which is inserted, and the “anchor” is placed to the left of that 

paragraph. 

 An object always appears on the page in which its anchor is found. Thus, if you 

move the paragraph to which the object is anchored to the next page, the object 

also moves to the next page. 

 This is how TextMaker handles objects when the default setting Move with 

text is in effect. On the other hand, if you select the Fix on page option, Text-

Maker always leaves the object on the page determined by the page number 

you specify. 

 You will find additional information about the use of anchors in the section 

“Changing the position of objects” beginning on page 264. 
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 When object is moved group box 

 The options in this group box are available only for frames and drawings. 

 When you have selected the option Move with text in the Object group box 

(see above), you can specify how the object’s anchor should behave when you 

move the object: 

 When the default setting Move anchor to the nearest paragraph is selected, 

the anchor moves with the object. Accordingly, when you move the object to 

another place, the object’s original anchor is removed and a new anchor is set to 

the paragraph left of the object’s target position. 

 On the other hand, if you select the Keep anchor at current paragraph opti-

on, the object’s anchor always remains attached to the paragraph at which it 

was previously set – even when you move the object. 

Object properties, Format tab 

Use the Format tab to modify the size of objects, rotate objects, or flip objects. 

Options available: 

 Size group box 

 Here you can alter the size of the object. To do so, enter the desired Width and 

Height. 

 For objects that contain text (e.g. text frames), you can either specify exactly a 

fixed width and height, or you can allow TextMaker to adjust the size of the 

frame automatically as required to accommodate the text that it contains. To do 

the latter, select the Growing option for Width or Height and enter the desired 

minimum and maximum values. 

 Scaling group box 

 Alternatively you can change an object’s size by specifying the width as a per-

centage of the original width in Horz. Scaling, and the height as a percentage 

of the original height in Vert. Scaling.  

 If the Keep aspect ratio option is checked, modifying the object’s height ad-

justs its width automatically, keeping the object proportional (and vice versa 

when modifying the object’s width). 

 For OLE objects, an additional option named Keep scaling is available. When 

enabled, any changes made to the object’s size inside its source application are 
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automatically adopted by the object in your TextMaker document. When it is 

disabled, the object in TextMaker won’t change its size. (Note: Not all OLE 

servers support this feature.) 

 Rotation group box 

 Available only for drawings and pictures. 

 Here you can rotate the object. To do this, enter the angle about which the ob-

ject is to be rotated (positive values correspond to clockwise rotation). 

 Flip group box 

 Available only for drawings and pictures. 

 Here you can flip the object vertically or horizontally. 

Object properties, Filling tab 

Note: This tab is available only for certain types of objects. When applied to pic-

tures, the filling will be visible only in pictures that contain transparent areas. 

Use the Filling tab to modify the filling of objects as follows: 

First, select the desired type of filling in the Fill type list. Based on the fill type 

selected, a series of options will be displayed. You can then change those settings 

for the chosen fill type, as desired. 

The following fill types and settings are available: 

 No Filling 

 If you select the first fill type in the list, the object is not filled and thus remains 

transparent. 

 Color 

 Fills the object using a uniform color shade. To change the color, select it in the 

Colors list. 

 If none of the existing colors suits you, you can always compose your own co-

lors. To do this, click on the More colors button and proceed as described in 

the section “Document properties, Colors tab” beginning on page 564. 

 If desired, you can also change the Transparency of the fill. You can enter any 

value between 0% (no transparency) and 100% (full transparency). For examp-



 

276  •  Frames and drawings Manual TextMaker 

le, if you set the Transparency value to 25, the filling will have 25% transpa-

rency. 

 Pattern 

 Fills the object using a pattern. To specify the pattern, select the type of pattern 

from the Patterns list. Then, select the desired colors for foreground and back-

ground. 

 If desired, you can also change the Transparency of the fill. Values between 

0% (no transparency) and 100% (full transparency) are permitted.  

 Picture 

 Fills the object using a picture file. To select the picture file to be used, click the 

Open button to bring up a file selection dialog. Tip: The most recently used 

picture files are presented in the Images list and can be selected with a single 

mouse click. 

 Additional options: 

 Rotate with object: If you activate this option, the image will be rotated as 

well whenever you rotate the object to be filled. 

 Mirror: Allows you to mirror the picture horizontally or vertically. 

 Transparency: If desired, you can also change the transparency of the fill. Va-

lues between 0% (no transparency) and 100% (full transparency) are permitted.  

 Tile as texture: If this option is enabled, multiple copies of the picture are ar-

ranged like tiles to fill the object. 

 The options in the Tile options section then allow you to change the size and 

position of the tiles: X scale and Y scale change the size (in percent), while X 

offset and Y offset change the position. The Alignment option can be used to 

determine to which edge of the object the tiles should be aligned. 

 If the Tile as texture option is not enabled, only Offsets (relative to the edges 

of the object) can be set for the image. 

 Save: You can use this button to export the currently selected picture, that is, to 

save a copy of it on your hard disk. 

 Linear Gradient, Rectangular Gradient etc. 

 The lowermost five fill types in the list allow you to fill the object using a gra-

dient. First, open the Fill type list and select the desired type of gradient. Then, 

select one of the subtypes in the Variants list. 
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 In the Options section, the following additional settings can be made: 

 X offset and Y offset can be used to move the center of the gradient. Angle 

rotates the gradient.  

Hint: You can also modify these settings by moving or rotating the cross-hair 

displayed in the Sample field using the mouse. 

 If you check the Double gradient option, for example, a black-white gradient 

will become a black-white-black gradient. 

 In the Colors section, the colors can be adjusted as follows: 

 If you want to change the gradient colors, click one of the triangles below the 

bar representing the gradient. Then, select a color from the Color list. 

  

 Use the triangle on the left to change the start color and the triangle on the right 

to change the end color. 

 If desired, you can also change the Transparency of the selected color. Values 

between 0% (no transparency) and 100% (full transparency) are permitted.  

 Additional colors can be added to the gradient by double-clicking on the desi-

red position in the bar and selecting a color. To remove a color, double-click the 

triangle representing that color. 

Object properties, Lines tab 

Note: This tab is available only for certain types of objects. 

Use the Lines tab to modify the lines that encompass the object or its border lines. 

When applied to drawings, these settings affect the lines used to paint the object 

itself. When applied to other types of objects, the border lines surrounding the ob-

ject are affected. 

Options available: 

 Line variants 

 Offers some pre-defined line styles to choose from. 

 The entries in the list are merely samples. If required, you can specify the 

appearance of the lines more precisely with the options listed below. 
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 Color 

 Lets you change the color of the lines. 

 Dashed 

 Lets you determine if solid or dashed lines will be used. 

 Thickness 

 Lets you change the width of the lines (in points). 

 Transparency 

 If desired, you can also change the Transparency of the lines. You can enter 

any value between 0% (no transparency) and 100% (full transparency). For 

example, if you set the Transparency value to 25, the lines will have 25% 

transparency. 

 Begin and End 

 Available only for lines, curves and connectors. 

 If you select one of the symbols displayed here, it will be painted at the starting 

point or end point of the line. For example, if you select an arrow symbol for 

the end point, the line will look like an arrow. Width and Height settings are 

used for changing the width and/or height of the symbol. 

Object properties, Shadow tab 

Note: This tab is available only for certain types of objects. 

Use the Shadow tab to add a shadow to the object. 

Options available: 

 Shadow variants 

 Offers a variety of pre-defined shadow styles to choose from. 

 The entries in the list are merely samples. If required, you can specify the way 

the shadow will appear more precisely with the options listed below. 

 Scaling 

 Lets you change the size of the shadow (relative to the size of the object). 
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 Offset 

 Lets you change the position of the shadow (relative to the object). 

 Perspective 

 Lets you change the Skew angle of the shadow. 

 For certain types of perspective shadows, you can also change the distance of 

the Horizon. Note: If Horizon is a positive value, the shadow will be painted 

in front of the object, and if it is negative, the shadow will be painted behind 

the object. 

 Color 

 Lets you change the color of the shadow. 

 Blur 

 If you enter a value greater than zero here, a blur effect is added to the shadow. 

The larger the value, the softer the edges of the shadow are painted. 

 Transparency 

 Allows you to change the Transparency of the shadow. You can enter any va-

lue between 0% (no transparency) and 100% (full transparency). For example, 

if you set the Transparency value to 25, the shadow will have 25% transpa-

rency. 

Object properties, 3D tab 

Note: This tab is available only for text frames and drawings. 

Use the 3D tab to add a three dimensional effect to the object. 

Options available: 

 3D effect variants 

 Offers a variety of pre-defined 3D effect settings to choose from. 

 The entries in the list are merely samples. If required, you can specify the way 

the effect appears more precisely with the options listed below. 

 Options group box 

 Lets you modify the depth of the 3D object and the angles about which it is 

rotated on the horizontal and vertical axes. 
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 3D surface group box 

 Side faces: By default, the color used for the side faces of the object is deter-

mined automatically. To use a different color, activate the Side faces option and 

select the desired color from the list. 

 Affect front side: If this option is checked, the front side of the object will also 

be lightened or darkened according to the lighting of the 3D effect. To change 

the lighting, click the More button. 

 Wire frame: If you check this option, the object is rendered as a wire frame 

model. 

 More button 

 Click the More button to change the lighting of the 3D effect. An additional 

dialog box will appear. To change the position of the light source, click the cor-

responding position in the Lighting field. The other two options let you change 

the Intensity of the light source and the type of Surface to be simulated.  

Object properties, Effects tab 

Note: This tab is available only for certain types of objects. 

On the Effects tab, you can add various effects to the object. 

The following effects and settings are available: 

 Reflection 

 When you check the Use reflection effect option, the object is rendered as if it 

was standing on a reflecting surface. 

 Options: 

 Visible part of object: Specifies how many percent of the object will be visible 

in the reflection. 

 Starting transparency: The reflection is smoothly faded out towards its bot-

tom. This value specifies how transparent the reflection will be at its top (in 

percent). 

 Y offset: Moves the reflection upwards or downwards. 
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 Soft edges 

 When you check the Use soft edges effect option, the borders of the object will 

be rendered with a blur effect. 

 Options: 

 Width: Specifies the width of the blur effect. 

 Glow 

 When you check the Use glow effect option, the borders of the object will be 

surrounded by a glow effect. 

 Options: 

 Width: Specifies the width of the glow effect. 

 Color: Specifies the color of the glow effect. 

Object properties, Properties tab 

The Properties tab can be used to modify common object settings. 

Options available: 

 Name 

 TextMaker automatically assigns a unique name to every object in a document. 

Rectangles, for example, might be named Rectangle1, Rectangle2, Rectangle3, 

etc. 

 If you wish, you can give the object a different name by entering it here. 

 You will find detailed information about the uses of names for objects in the 

section “Changing the names of objects”, page 286. 

 Visible 

 This option is checked by default. If you deactivate it, the object will no longer 

be visible on the screen. See also section “Hiding objects”, page 284. 

 Printable 

 This option is checked by default. If you deactivate it, the object will no longer 

print. See also section “Hiding objects”, page 284. 
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 Locked 

 This option is NOT checked by default. If enabled, the size of the object and its 

position (in the case of frames and drawings) cannot be altered with the mouse 

or keyboard. It is still possible, though, to open the dialog of the Object > Pro-

perties menu command and make changes there. 

 Tab stop 

 Available only for form objects (e.g. text fields and text frames, checkboxes 

and dropdown lists). 

 In Form mode, you can jump back and forth among form objects with the (Tab) 

key or the (F11) key (see also section “Changing the tab order”, page 326). 

 However, if an object’s Tab stop option is unchecked, that object is skipped. 

 Text locked 

 Available only for objects that contain text (e.g., text fields and text frames). 

 When this option is checked, text contained in the object cannot be changed 

while the document is edited in Form mode. 

 However, the default setting is unchecked, allowing the text in the object to be 

edited even in Form mode. 

 You will find more information about this in section “Protecting contents of 

form objects”, page 326. 

 Link 

 Here you can enter a hyperlink – to a web page in the Internet, for example. To 

do this, click on the Select button, select the type of link and specify the desired 

target. The target is opened when the user clicks on the object.  

Additionally, for pictures, some information on the picture is displayed in the right 

half of the dialog (resolution, color depth, etc.). 

Additional tabs 

With some object types, the dialog of the Object > Properties menu command 

displays additional tabs containing more options. To learn more about these tabs, 

see the sections referring to each particular object type. 
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Changing the default settings for objects 

You can change the default settings for objects (drawings, images, etc.) anytime.  

For example, if you don’t like the default setting for the line width of drawings, 

simply set it to a different value. You can also alter other default settings – e.g. the 

default filling for drawings as well as the settings for shadows and 3D effects. 

Note: Changes to the default settings solely affect objects that you will insert la-

ter on. Existing objects remain untouched. 

To modify the default settings for objects, use the Default button in dialog of the 

Object > Properties menu command. 

For example, to change the default line width for drawings, proceed as follows: 

1. Insert a new drawing (or click on an existing drawing). 

2. Invoke the Object > Properties menu command. 

3. Adjust the settings to your liking. For example, to change the default setting for 

the line width, switch to the Lines tab and simply choose the desired value in 

the Thickness field. 

4. Now comes the distinctive step: Instead of clicking on OK, click on the 

Default button. 

5. Another dialog pops up, allowing you to control exactly which settings to adopt 

as new default settings. Normally, there is no need to change anything in this 

dialog. 

6. When you confirm with OK, the settings you just specified in the properties 

dialog will from now on be used as the default settings for new drawings. 

7. To exit the dialog, click on OK once more. 

When you insert a new drawing now, it will be painted in the given line width. 

Note: The default settings for objects are stored inside the document, allowing 

you to specify different settings for each individual document. 
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Frames – advanced functions 

The next pages present some less commonly needed functions for working with 

frames and other objects. The following topics are covered: 

 Converting between frame and embedded object 

 Hiding objects 

 Changing the order of frames 

 Grouping frames 

 Changing the names of objects 

Converting between frame and embedded object 

You can convert an object that is in a frame (e.g. a picture frame) into an embedded 

object (e.g. a picture) whenever needed. 

Proceed as follow: 

1. Select the desired object. 

2. Right-click on the object to open its context menu. 

 Android: In the Android version, you can also open the context menu with your 

finger: Just tap on the screen and hold your finger there for about a second. 

3. In the context menu, choose the command Convert to Embedded Object.  

This will convert the picture frame into an “ordinary” picture (embedded into the 

text). 

Of course the opposite way is possible as well: When you select an embedded ob-

ject (e.g. a picture) and choose the context menu command Convert to Object 

Frame, the picture will become a picture frame. 

Hiding objects 

If necessary, you can hide an object so that it will not appear on the screen and/or 

on the printed page. 
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To hide an object, select it, invoke the Object > Properties menu command, 

switch to the Properties tab and do the following: 

 Uncheck the Visible option if you don’t want the object to be displayed on the 

screen. 

 Uncheck the Printable option if you don’t want the object to appear in the 

printed document. 

Tip: If you should ever make an object invisible by accident, you can always invo-

ke the menu command File > Properties and check the Show invisible objects 

option on the Options tab to make all hidden objects visible again. Then you can 

select the mistakenly hidden object and check its Visible option to make it visible 

again. 

Changing the order of frames 

When two or more frames overlap, you can change the display order of these ob-

jects (which of the objects to display in the foreground, which in the background, 

etc.).  

This can be accomplished as follows: 

1. Select the desired object. 

2. Invoke the Object > Order menu command and choose an option from its sub-

menu: 

 Bring to front: Brings the object in front of all other objects. 

 Send to back: Sends the object behind all other objects. 

 Bring forward one level: Brings the object forward by one level. 

 Send backward one level: Sends the object back by one level. 

Grouping frames 

When you group several frames or drawings, you connect them together to form a 

unit that can be selected and manipulated as if it were a single object. 

For example, when you select an object that is part of a group of objects, the whole 

group will be selected. When you move this object, the whole group will move. 

To group objects, you do the following: 
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1. Select the frames or drawings to be grouped. 

 To do this, click on each of them in turn while holding down the Shift key (ª) 

– or switch to Object mode and draw a rectangle around all the objects to be 

grouped. 

2. Click the  icon in the Object toolbar or invoke the Object > Group menu 

command. 

Ungrouping objects 

To ungroup objects, do the following: 

1. Select the group by clicking on one of the objects in it. 

2. Click the  icon in the Object toolbar again or invoke the Object > Ungroup 

menu command. 

Changing the names of objects 

Every object in a document must have a unique name. This is necessary so that you 

can, for example, perform calculations on the contents of table cells or text fields. 

Normally, you don’t need to concern yourself with these names, since TextMaker 

assigns them automatically: If you insert a rectangle in an empty document, the 

rectangle is automatically named “Rectangle1”. If you insert a picture, it is named 

“Picture1”. A second picture would be named “Picture2”, etc. 

However, you can change the names of objects whenever you wish. For example, if 

you have created a form that contains a text field where an address can be entered, 

the name “Address” would naturally suggest itself for this field. To change its na-

me, select the field, invoke the Object > Properties menu command, switch to the 

Properties tab and change the entry in the Name field.  

Remember that names must be unique. If you attempt to assign a name to an object 

that is already in use for another object, TextMaker will reject it and present an 

error message. 

The purpose of names 

But what is the sense in giving all objects in a document unique names? 
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In the first place, these names are necessary for calculations on the contents of ob-

jects. For example, to multiply the content of cell C3 in table “Table1” by two, you 

must reference the table by its name in your calculation, entering the following: 

Table1.C3 * 2 

You will find detailed information about performing calculations with objects in 

the section “Objects in calculations” beginning on page 403. 

 

This concludes the general description of frames and drawings. The following sec-

tions present the various types of frames in detail: 

 Text frames (beginning on page 287) 

 Picture frames (beginning on page 291) 

 OLE object frames (beginning on page 295) 

 Drawings (beginning on page 298) 

 Form objects in detail (beginning on page 317) 

Text frames 

With the help of text frames you can insert text boxes into a document. For examp-

le, you can highlight especially important information by placing it in such a box. 

A text frame, like all types of frames, occupies a fixed position on the page. Thus, 

it does not move when you add or remove body text above it. By default, the nor-

mal body text is automatically broken at the boundary lines of the frame – it 

“flows” around the frame. 

In this section, you will find detailed information on working with text frames. The 

following topics are covered: 

 Inserting text frames 

 Changing the properties of text frames 

 Linking text frames 

See the next pages for details. 
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Inserting text frames 

To insert a text frame, do the following: 

1. Invoke the Object > New text frame menu command. 

 If you have activated Object mode, you can alternatively click on the  icon 

in the Object toolbar. 

2. The text frame is inserted. 

 In case you want to modify its position or size, do the following: 

 Important: To change the position, click on the border of the text frame and 

then (while still holding the mouse button down) drag the frame to the desired 

position. 

 To adjust its size, drag on one of the round handles surrounding the frame. 

After that, you can immediately begin entering text in the text frame by simply 

starting to type.  

Note: When TextMaker displays a red bar at the lower margin of a text frame, 

this indicates that the frame cannot completely accommodate the text that has 

been entered. In this case you must either enlarge the frame or reduce the amount 

of text. 

To move from a text frame back to the normal body text, click anywhere in the 

body text. To move from the body text back to the text frame, click in the frame. 

No special action is required to insert a text frame over existing body text – this 

text is automatically reformatted in such a way that it flows around the new frame. 

Changing the properties of text frames 

To modify the properties of a text frame, first select the frame. To do this, click on 

the border that surrounds it, or, if you are in Object mode, simply click on the fra-

me. Then invoke the Object > Properties menu command to bring up the associa-

ted dialog. 

Tip: This command can also be invoked by double-clicking on the border of the 

text frame. 

The following settings can be made in this dialog: 
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Layout, Format, Filling, etc. tabs 

The tabs listed below are present for almost all object types. They allow you to 

modify the following settings: 

 Layout: On this tab, you can change the position and outside margins of the fra-

me and specify how the body text should flow around it. See section “Object 

properties, Layout tab” beginning on page 268. 

 Format: For changing the size of the object. See section “Object properties, 

Format tab” beginning on page 274. 

 Filling: For changing the filling of the object. See section “Object properties, 

Filling tab” beginning on page 275. 

 Lines: For adding border lines. See section “Object properties, Lines tab” begin-

ning on page 277. 

 Shadow: For adding a shadow. See section “Object properties, Shadow tab” be-

ginning on page 278. 

 3D: For adding a 3D effect. See section “Object properties, 3D tab” beginning 

on page 279. 

 Effects: For adding various types of effects. See section “Object properties, 

Effects tab” beginning on page 280. 

 Properties: For modifying common object settings. See section “Object proper-

ties, Properties tab” beginning on page 281. 

For text frames, there are additional tabs with further options: 

Inner text tab 

Use this tab to change settings affecting the text in the text frame. 

Options available: 

 Inner margins group box 

 Lets you modify the margins between text frame and inner text. If you check 

the Automatic option, TextMaker will calculate suitable settings automatically. 

 Overlapping objects group box 

 These settings determine what happens when the text frame overlaps another 

object.  
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 With the default setting Ignore object, TextMaker does nothing. Thus, in the 

region of overlap, the contents of both frames are rendered on top of one 

another. 

 If, on the other hand, you check the Wrap text option, TextMaker automatical-

ly reformats the text in this frame so that it flows around the area of overlap. 

 Rotate by ... group box 

 Lets you rotate the inner text in 90 degrees increments. 

 Vertical alignment group box 

 Lets you change the vertical alignment of the inner text as follows: 

Option Meaning 

Top Align inner text at the top of the frame 

Centered Vertically center text between top and bottom of the frame 

Bottom Align inner text at the bottom of the frame 

Justified Vertically justify text (so that it is evenly distributed 

between top and bottom of the frame) 

AutoShapes tab 

A text frame is actually an AutoShape that has been filled with text. AutoShapes are 

drawings with a pre-defined shape (for example, rectangles, arrows, banners, 

callouts, etc.). 

By default, the AutoShape used for text frames is a simple rectangle. To use a dif-

ferent shape, select it on the AutoShapes tab. 

Note: Text frames have no border lines by default. Therefore, when you select a 

different AutoShape here, the shape will not be visible until you add border lines. 

To do this, select the line style of your choice on the Lines tab. 

To learn more about AutoShapes, refer to the section “Drawings” (page 298). 

Linking text frames 

With TextMaker you can let text flow through multiple text frames that are linked 

together – just as you could with a desktop publishing program. If two frames are 
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linked, text that exceeds the limits of the first frame is automatically continued in 

the second frame. 

Let’s assume that you have created two text frames on one page and that you want 

text to flow from one to the next. You would link these frames as follows: 

1. Click on the  icon in the Formatting toolbar or invoke the View > Object 

mode menu command to activate Object mode. 

2. Select the  icon for Link text frames in the Object toolbar. 

3. Click on the text frame in which the text should begin. 

4. Click on the text frame you want to link to the initial frame. Important: This 

text frame must be empty! 

5. Finally, click again on the  icon or invoke the View > Object mode menu 

command again to exit Object mode. 

Now, when you enter text in the first frame to the extent that it overflows that fra-

me, the text will be continued in the second frame. 

You can even link together more than two frames. To do this, first link the first 

frame with the second, then the second with a third, etc. 

To remove an existing link, click on the first of two linked frames with the Link 

text frames tool. TextMaker will then ask you if you want to remove the link. 

Picture frames 

A picture frame differs from a picture that is inserted directly into the text (see the 

chapter “Pictures” beginning on page 225) in the following way:  

Picture frames, like all other types of frames, occupy a fixed position on the page. 

Thus, they do not move when you add or remove text above the frame. 

In this section, you will find detailed information on working with picture frames. 

The following topics are covered: 

 Inserting picture frames 

 Changing the properties of picture frames 

See the next pages for details. 
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Inserting picture frames 

To insert a picture frame, proceed as follows: 

1. Invoke the Object > New picture frame menu command. 

 If you have activated Object mode, you can alternatively click on the  icon 

in the Object toolbar.  

2. A dialog box appears, allowing you to select the picture that you want to be 

displayed in the frame. Choose a picture file and confirm with OK. 

3. The picture frame is inserted. 

 In case you want to modify its position or size, do the following: 

 To change the position, click on the picture frame and (while still holding the 

mouse button down) drag it to the desired position. 

 To adjust its size, drag on one of the round handles surrounding the frame. 

No special action is required to insert a picture frame on top of existing body text – 

the text is automatically reformatted in such a way that it flows around the frame. 

Dialog options 

The options in the dialog box for this command are as follows: 

 Save within document 

 If this option is checked, TextMaker saves a copy of the picture in the 

document and uses this copy instead of the original. 

 If this option is unchecked, TextMaker saves only a reference to the picture file 

in the document. 

 Copy to document’s folder 

 If this option is checked, TextMaker creates a copy of the picture file in the 

folder where the document resides and uses this copy instead of the original. 

 This option is available only after the document is initially saved. 
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Changing the properties of picture frames 

To modify the properties of a picture frame, first select the frame with a mouse 

click. Then invoke the Object > Properties menu command to bring up the 

associated dialog. 

Tip: This command can also be invoked by double-clicking on the picture frame. 

The following settings can be made in this dialog: 

Layout, Format, Filling, etc. tabs 

The tabs listed below are present for almost all object types. They allow you to 

modify the following settings: 

 Layout: On this tab, you can change the position and outside margins of the fra-

me and specify how the body text should flow around it. See section “Object 

properties, Layout tab” beginning on page 268. 

 Format: For changing the size of the object. See section “Object properties, 

Format tab” beginning on page 274. 

 Filling: For changing the filling of the picture. Only visible in pictures that have 

transparent areas. See section “Object properties, Filling tab” beginning on pa-

ge 275. 

 Lines: For adding border lines. See section “Object properties, Lines tab” begin-

ning on page 277. 

 Shadow: For adding a shadow. See section “Object properties, Shadow tab” be-

ginning on page 278. 

 Effects: For adding various types of effects. See section “Object properties, 

Effects tab” beginning on page 280. 

 Properties: For modifying common object settings. Also displays some informa-

tion on the picture. See section “Object properties, Properties tab” beginning on 

page 281. 

For pictures, there is an additional tab with further options: 

Picture tab 

On the Picture tab, you can change settings that are specific to pictures. 



 

294  •  Frames and drawings Manual TextMaker 

Tip: Some of these setting can also be modified using the Picture toolbar that 

appears automatically when you select a picture. See section “Using the Picture 

toolbar” (page 232). 

Options available on this tab: 

 Variants 

 In this list, a number of pre-defined variations of the picture are presented – for 

example different color modes (grayscaled, black & white, etc.) as well as colo-

rized variants of the image. 

 To choose one of these variants, simply click on it, and the options in the dialog 

will be adjusted accordingly. 

 Settings group box 

 Here you can change brightness, contrast, saturation and gamma (color balance, 

with an effect on brightness). 

 More button 

 This button opens a dialog with the following additional options: 

 When you activate the Mix with color option and choose a color below, the 

picture will be colorized accordingly. 

 The options in the Cropping group box can be used to crop the picture. This is 

useful when you need only a segment of the picture. For example, if you want 

to cut off the upper forth of the picture, enter “25” (percent) at Top.  

 Transparency group box 

 Lets you modify the transparency settings of the image. Options available: 

 Detect automatically: Reads the transparency settings stored in the picture file 

and displays the image accordingly. Note: Only files in GIF or PNG format can 

contain transparency settings. 

 No transparency: Ignores the transparency settings stored in the picture file. 

Even pictures containing transparent areas will not be displayed transparently. 

 Color: Lets you choose the color to be displayed transparently. For example, if 

you select white, all white areas of the picture will become transparent. 

 File button 

 To use a different picture file, click this button and choose a new file. 
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 Export button 

 Available only for pictures that are saved in the document.  

 You can use this button to export the picture, that is, to save a copy of it on your 

hard disk. 

 If you check the Create link to file option in the Export dialog, TextMaker first 

copies the picture from the document to a file and then removes the picture 

from the document, replacing it with a reference to the new file. Thus, the pic-

ture is no longer saved in the document. 

OLE object frames 

Note: OLE objects can be used only in the Windows version of TextMaker. 

In the chapter “OLE objects” (page 249) you learned what OLE objects are and 

how to insert them directly into the text. OLE objects can also be inserted in the 

form of frames.  

The difference:  

An OLE object frame, like all types of frames, occupies a fixed position on the 

page. Thus, it does not move when you add or delete text above it. 

In this section, you will find detailed information on working with picture frames. 

The following topics are covered: 

 Inserting OLE object frames 

 Changing the properties of OLE object frames 

See the next pages for details. 

Inserting OLE object frames 

Note: OLE objects can be used only in the Windows version of TextMaker. 

To insert an OLE object frame, do the following: 

1. Invoke the Object > New OLE object Frame menu command. 
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 If you have activated Object mode, you can alternatively click on the  icon 

in the Object toolbar.  

2. A dialog box appears and presents an Object type list. Select the Object type 

corresponding to the application from which TextMaker is to obtain the OLE 

object. 

3. Confirm with OK to start the application for the selected object type. 

4. Create the object in this application. 

5. Exit the application. 

6. When closing, the application might ask you whether you want to update the 

object in the TextMaker document. If it does, answer “Yes”. 

7. The OLE object frame is inserted. 

 In case you want to modify its position or size, do the following: 

 To change the position, click on the OLE object frame and (while still holding 

the mouse button down) drag it to the desired position. 

 To adjust its size, drag on one of the round handles surrounding the frame. 

The OLE object created in the other application is now embedded in the TextMaker 

document.  

No special action is required to insert the frame on top of existing body text – the 

text is automatically reformatted so that it flows around the frame. 

Instead of creating a new object for insertion into the frame, you can use an object 

that already exists in a file. You do this at step 3 in the above described procedure 

by selecting the Create from File option and then specifying the file to be linked 

in, rather than by selecting an object type.  

You will find additional information about working with OLE objects in the chap-

ter “OLE objects” beginning on page 249. 

Changing the properties of OLE object frames 

To modify the properties of an OLE object frame, first select the frame with a 

mouse click. Then invoke the Object > Properties menu command to bring up the 

associated dialog. 

The following settings can be made in this dialog: 
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Layout, Format, Filling, etc. tabs 

The tabs listed below are present for almost all object types. They allow you to 

modify the following settings: 

 Layout: On this tab, you can change the position and outside margins of the fra-

me and specify how the body text should flow around it. See section “Object 

properties, Layout tab” beginning on page 268. 

 Format: For changing the size of the object. See section “Object properties, 

Format tab” beginning on page 274. 

 Filling: For changing the filling of the object. Not supported by all OLE applica-

tions. See section “Object properties, Filling tab” beginning on page 275. 

 Lines: For adding border lines. See section “Object properties, Lines tab” begin-

ning on page 277. 

 Shadow: For adding a shadow. See section “Object properties, Shadow tab” be-

ginning on page 278. 

 Effects: For adding various types of effects. See section “Object properties, 

Effects tab” beginning on page 280. 

 Properties: For modifying common object settings. See section “Object proper-

ties, Properties tab” beginning on page 281. 

For OLE objects, there is an additional tab with further options: 

Picture tab 

On the Picture tab, you can change settings that affect the graphical representation 

of the OLE object. 

Note: Depending on the application associated with the OLE object, some of the 

options may be not supported. 

Options available: 

 Variants 

 In this list, a number of pre-defined variations of the object are presented – for 

example different color modes (grayscaled, black & white, etc.) as well as colo-

rized variants of the object. 

 To choose one of these variants, simply click on it, and the options in the dialog 

will be adjusted accordingly. 
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 Settings group box 

 Here you can change brightness, contrast, saturation and gamma (color balance, 

with an effect on brightness). 

 More button 

 This button opens a dialog with the following additional options: 

 When you activate the Mix with color option and choose a color below, the 

object will be colorized accordingly. 

 The options in the Cropping group box can be used to crop the object. This is 

useful when you need only a segment of the object. For example, if you want to 

cut off the upper forth of the object, enter “25” (percent) at Top.  

 Export button 

 You can use this button to export a copy of the graphical representation of the 

object, that is, to save an image of the object on your hard disk. 

Drawings 

TextMaker provides tools to create drawings in your documents. The following 

types of drawings are available: 

 Lines and curves (lines, arrows, connectors, curves) 

 Rectangles and ellipses 

 AutoShapes (pre-defined shapes) 

 TextArt objects (text effects) 

Drawings behave like frames: they always remain at the same place on the page, 

even when you delete or insert lines of text above them. The normal body text is 

automatically formatted in such a way that it breaks at the boundaries of the objects 

– it “flows” around the drawing. 

In this section, you will find detailed information on working with drawings. The 

following topics are covered: 

 Inserting drawings 

 Adding text to AutoShapes 

 Changing the properties of drawings 
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See the next pages for details. 

Inserting drawings 

To insert a drawing, for example, a rectangle, proceed as follows: 

1. Invoke the Object > New drawing menu command. A sub-menu opens. From 

the sub-menu, select a drawing tool – in this case the Rectangle tool. 

 If you have activated Object mode, you have the alternative of clicking on the 

corresponding icon in the Object toolbar. 

  

2. With some of the drawing tools, additional action is required (see below). 

However, this is not the case with rectangles. 

3. The drawing is inserted. 

 In case you want to modify its position or size, do the following: 

 To change the position, click on the drawing and (while still holding the mouse 

button down) drag it to the desired position. 

 To adjust its size, drag on one of the round handles surrounding the drawing. 

The method of producing a drawing object varies according to the drawing tool 

used. Accordingly, all the available types of drawing objects are listed below toge-

ther with tips for manipulating them: 

Lines and curves 

Use the Line tool  in the Object toolbar to draw lines and curves.  

When you click on this icon, a list of available line and curve tools opens. Select a 

tool by clicking on it, then proceed as follows: 

 Lines 

 The first category in the list offers tools for drawing straight lines and arrows. 

 To use one of these tools, select it, then press and hold the left mouse button 

and simply draw a line in the document. 
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 Tip: When you hold down the Shift key (ª) while drawing, the direction of the 

line is variable only in increments of 45 degrees. 

 Note: Arrows are simply lines with an arrowhead chosen for the Start and/or 

End option in the object properties, Lines tab. 

 Connectors (straight, elbow and curved) 

 The tools in the next three categories allow you to draw connecting lines 

between two objects. You can see the differences among these three kinds of 

connectors in the following illustration: 

  

 To use one of these tools, select it and then drag the mouse pointer from one 

object to another, holding down the mouse button.  

 Tip: When you move the mouse pointer over an object, small blue boxes appear 

at various points on the object. These boxes indicate where the connector line 

can “dock” to the object. 

 Curves 

 Use the tools in this category to draw curves, as follows: 

 The Curve tool  allows you to draw Bezier curves. 

 To draw a curve, click on the position where you want to have its starting 

point; then click on as many other points as you like. The curve will auto-

matically follow your clicks. 

 To quit drawing, you can either a) click on the curve’s starting point (which 

will automatically make it a closed curve) or b) double-click on any other 

position to set it’s end point there (which will make it an open curve). 
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 The Freehand form tool  allows you to draw irregular curves as you would 

be able to do by hand with a pencil. 

 To draw freehand, move the mouse to the starting point, press and hold the 

left mouse button, and start drawing as if using a pencil. To draw a straight 

line, release the mouse button and click on the desired position. 

 To quit drawing, you can either a) click on the curve’s starting point (which 

will automatically make it a closed curve) or b) double-click on any other 

position to set it’s end point there (which will make it an open curve). 

Rectangles, rounded rectangles and ellipses/circles 

Use one of the Rectangle, Rounded Rectangle and Ellipse/Circle tools 

 to insert rectangles, rounded rectangles, or ellipses. 

Every time you click on one of these tools, the corresponding drawing object is 

inserted in a standard size. You can change its position by dragging it with your 

mouse. To change its size, drag one of the round handles on its corners. 

In the case of rounded rectangles, you can additionally change the rounding of the 

corners. To do this, select the rectangle. A yellow handle will then appear at one of 

its corners. By dragging this handle you can change the rounding accordingly. 

AutoShapes 

Use the AutoShape tool  to insert AutoShapes. AutoShapes are ready-made 

drawings appropriate for a wide variety of applications, including standard shapes 

like rectangles as well as flow chart symbols, stars, speech balloons, etc. 

As soon as you choose the desired AutoShape, it is inserted in a standard size. If 

necessary, you can change its position by dragging it with your mouse. To adjust its 

size, drag one of the round handles on its corners. 

Note: With some types of AutoShapes, yellow handles appear on the object when it 

is selected. If you drag on one of these handles, a parameter controlling the shape 

of the object is changed. For example, stars have handles that let you change the 

size of their tines. 

Tip: If you wish, you can even enter text in an AutoShape – just as you can in a 

text frame. You will find information about this in the section “Adding text to Au-

toShapes” beginning on page 302. 
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TextArt 

Use the TextArt tool  to insert TextArt objects. TextArt objects are used to crea-

te text effects. 

When you activate this tool a dialog appears. Enter your text in the dialog’s Text 

field and then click on Variants to choose one of the ready-made effects to be ap-

plied to the text. Confirm with OK to leave the dialog.  

Adding text to AutoShapes 

You can add text to an AutoShape, if desired. The text is then displayed inside the 

AutoShape – exactly as it would be in a text frame. 

To add text to an AutoShape, do the following: 

1. Select the desired AutoShape. 

2. Right-click on it to open its context menu. 

3. Choose the Add Text command. 

You can now type text inside the AutoShape. 

Hint: There’s a much faster way to add text to an AutoShape: First select the Au-

toShape with a mouse click, then simply start typing. 

When you have finished editing the text, click anywhere outside the object. If you 

want to return to this text later to edit it, you can do so by reselecting the AutoSha-

pe, right-clicking to obtain the context menu and selecting Edit Text from this 

menu. 

Important: When TextMaker displays a red bar in the margin below the text, this 

indicates that the area available for text within the AutoShape is not large enough 

to accommodate all the text that has been entered. In this case, you must either 

enlarge the object or reduce the amount of text. 

Note: Text frames, which are described in an earlier section of this chapter, are re-

ally nothing more than AutoShapes (in this case simple rectangles) to which text 

has been added. Thus, all the information in the section “Text frames” (beginning 

on page 287) applies with equal validity to text frames and to AutoShapes contai-

ning text. 
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Changing the properties of drawings 

To modify the properties of a drawing, first select it with a mouse click. Then in-

voke the Object > Properties menu command to bring up the associated dialog. 

Tip: This command can also be invoked by double-clicking on the drawing. 

The following settings can be made in this dialog: 

Layout, Format, Filling, etc. tabs 

The tabs listed below are present for almost all object types. They allow you to 

modify the following settings: 

 Layout: On this tab, you can change the position and outside margins of the 

drawing and specify how the body text should flow around it. See section 

“Object properties, Layout tab” beginning on page 268. 

 Format: For changing the size of the object. See section “Object properties, 

Format tab” beginning on page 274. 

 Filling: For changing the filling of the object. See section “Object properties, 

Filling tab” beginning on page 275. 

 Lines: For modifying the lines used to draw the object. See section “Object pro-

perties, Lines tab” beginning on page 277. 

 Shadow: For adding a shadow. See section “Object properties, Shadow tab” be-

ginning on page 278. 

 3D: For adding a 3D effect. See section “Object properties, 3D tab” beginning 

on page 279. 

 Effects: For adding various types of effects. See section “Object properties, 

Effects tab” beginning on page 280. 

 Properties: For modifying common object settings. See section “Object proper-

ties, Properties tab” beginning on page 281. 

For certain types of drawings additional tabs will appear on the dialog, giving you 

access to more options (as described on the following pages). 
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AutoShapes tab (available only for AutoShapes) 

Note: This tab appears only for AutoShapes. 

The AutoShapes tab allows you to change the shape of an AutoShape. For examp-

le, you can turn a rectangle into a speech balloon or any other shape you like. 

To change the shape, simply click on the desired AutoShape in the list. 

Inner Text tab (available only for AutoShapes with text added) 

Note: This tab appears only for text frames and AutoShapes containing text (see 

the section “Adding text to AutoShapes” beginning on page 302). 

Use the Inner Text tab to change settings affecting the text inside the AutoShape. 

Options available: 

 Inner margins group box 

 Lets you modify the margins between AutoShape and inner text. If you check 

the Automatic option, TextMaker will calculate suitable settings automatically. 

 Overlapping objects group box 

 These settings determine what happens when the object overlaps another ob-

ject.  

 With the default setting Ignore object TextMaker does nothing. Thus, in the 

region of overlap, the contents of both objects are rendered on top of one 

another. 

 If, on the other hand, you check the Wrap text option, TextMaker automatical-

ly reformats the text in this object so that it flows around the area of overlap. 

 Rotate by ... group box 

 Lets you rotate the inner text in 90 degrees increments. 

 Vertical alignment group box 

 Lets you change the vertical alignment of the inner text as follows: 

Option Meaning 

Top Align inner text at the top of the object 

Centered Vertically center text between top and bottom of the object 
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Bottom Align inner text at the bottom of the object 

Justified Vertically justify text (so that it is evenly distributed 

between top and bottom of the object) 

Text tab (available only for TextArt objects) 

Note: This tab appears only for TextArt objects. 

Use the Text tab to select the desired TextArt effect and to edit or format the text to 

be displayed. 

Options available: 

 Text 

 Here you can edit the text to be displayed. 

 Variants 

 Here you can choose which TextArt effect to apply. 

 Font group box 

 Here you can change the font and apply the text styles Bold and Italic. 

 If you check the Same height option, all letters (including lower case letters) 

will be stretched to a uniform height. 

 Spacing group box 

 The Character option affects the spacing between characters. Values below 

100% produce spacings that are closer together than normal, values above 

100% produce spacings that are wider apart. 

 The Line option affects the spacing between lines. This setting is effective only 

for text that consists of multiple lines. 

 Alignment group box 

 Here you can change the alignment of the text. This setting is effective only for 

text that consists of multiple lines. 

 Placement group box 

 If you check the Vertical text option, the letters will be rotated by 90 degrees. 
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Deformation tab (available only for TextArt objects) 

Note: This tab appears only for TextArt objects. 

Use the Deformation tab to change the type of shaping effect to be applied to the 

characters. To do this, click the desired type of deformation. 
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Forms 

FreeOffice: Inserting form objects is not supported in SoftMaker FreeOffice, 

meaning that you will not be able to create new forms there. (Using existing 

forms is possible.) 

Forms are documents to be “filled out”. 

For example, you could prepare an application form for vacations. Then, when one 

of your coworkers wanted to apply for a vacation, he would simply open this form, 

enter his name and the dates on which he wanted to begin and end his vacation and 

print the form. He would then have a completed vacation application to submit. 

Creating a form is no more complicated than this: you simply insert form objects at 

the places in the document where someone must later enter something – for exa-

mple, you insert text fields for text entries. 

 

Whenever you want to fill out a prepared form you should activate Form mode. In 

this mode, only form objects can be filled out – access to the rest of the document 

and to most of TextMaker’s functions is blocked. This prevents users from chan-

ging those parts of the form that shouldn’t be changed. 

In this chapter you will learn how to work with forms: 
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 Filling out forms 

 The first section explains how a prepared form is filled out. 

 Creating forms 

 In the following section, you will learn everything you need to know to be able 

to create your own forms. 

 To create a form, you insert form objects at all the places where something is to 

be filled in later: for example, text fields and text frames for text entries, check-

boxes for items to be checked off and dropdown lists for selections from among 

several given options. 

 Form objects in detail 

 In this section the available types of form objects are described in detail. 

 Forms – advanced functions 

 In the last section, you will get acquainted with some functions for advanced 

users: functions for changing the tab order, for protecting forms from being 

changed and for performing calculations. 

Filling out forms 

First we will apply ourselves to the filling out of prepared forms. The creation of 

forms will be described thereafter (in the section “Creating forms” beginning on 

page 311). 

Forms differ from other documents only in one respect: they contain form objects 

at the places where something is to be filled out.  
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In the following list, you will learn about the different types of form objects that 

can be present in a form and about how they are to be filled out: 

 Text fields and text frames (for entering text) 

 To fill out a text field or frame you simply position the text cursor in it and type 

the desired text. 

 Dropdown lists and dropdown list frames (for menus of selectable items) 

 When you click on a dropdown list it opens. You can then select one of the ent-

ries with a mouse click. 

 Checkboxes and checkbox frames (for items to be checked off) 

 When you click on the box with the mouse, a little check mark appears in it, 

indicating that the associated item has been checked. When you click on it a se-

cond time, the check mark is removed. 

Moving the text cursor in forms 

You can move the text cursor within forms as follows: 

 You can move the text cursor to the desired position in the usual way, by using 

the arrow keys or clicking with the mouse. 

 You can use the (F11) key to jump to the next form object and (Shiftª)(F11) to 

jump to the previous object. 
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 In Form mode (see below) the text cursor can be moved only between form 

objects. In this mode you can use the keys (Tab) and (Shiftª)(Tab) to jump back 

and forth between form objects. 

Form mode 

It is recommended that you always activate Form mode when you want to fill out a 

form. This will save you a great deal of work. 

Form mode can be activated and deactivated with the View > Form mode menu 

command. 

You will know whether Form mode is activated or not from the program’s title bar. 

If “(Form mode)” is displayed there after the name of the document, the mode is 

activated. 

In Form mode TextMaker’s behavior changes as follows: 

 You can use the keys (Tab) and (Shiftª)(Tab) to jump from one form object to 

the next. 

 Form objects can be filled out, but the normal text is no longer editable. 

 Most of the menu commands are “grayed out” and thus no longer available. 

The purpose of this is to prevent changes to those parts of the form that are not 

intended to be filled out. 

Thus, when using Form mode you can fill out a form with the same degree of con-

venience that you experience when you use a database program’s input mask. 

Note: When you open a document that was in Form mode when it was last sa-

ved, Form mode is reactivated automatically.  

Form mode cannot be deactivated? 

You will encounter some forms in which the author has blocked the deactivation of 

Form mode by protecting it with a password. This has been done to prevent un-

authorized persons from changing those parts of the form that are not intended to 

be altered. 

If a form is protected in this manner, an attempt to deactivate Form mode will re-

sult in a prompt for a password. You will be able to deactivate Form mode only by 

entering the correct password. 
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Creating forms 

FreeOffice: Inserting form objects is not supported in SoftMaker FreeOffice, 

meaning that you will not be able to create new forms there. (Using existing 

forms is possible.) 

To create a form, first lay out the document just as you would with any normal 

document. Then, insert form objects at the places where something should be filled 

in later. 

All further information on creating forms is provided in this section. It covers the 

following topics: 

 Types of form objects 

 Inserting form objects 

 Editing form objects 

 Preparing an example form 

See the next pages for details. 

Types of form objects 

The following types of form objects can be used in forms: 

Form object Description 

Text fields Text fields are intended for text entries such as “na-

me”, “address”, etc. The user who fills out the form 

can enter whatever text he or she likes in them. 

Text frames Like text fields, but confined within frames (see 

below). 

Checkboxes Checkboxes are appropriate for yes/no entries. If the 

user clicks on a checkbox, a check mark is displayed 

in it. If he clicks on it again, the check mark is remo-

ved. 

Checkbox frames Like checkboxes, but confined within frames (see 

below). 
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Dropdown lists When the user clicks on a dropdown list, the list 

opens and he or she can select one of the predefined 

items in the list. Manual entry of an item is not pos-

sible. 

Dropdown list frames Like dropdown lists, but confined within frames (see 

below). 

In addition to these types of objects there are two types of form objects that cannot 

be filled out, and are intended for captioning. 

Labels Labels can contain any captions or legends that 

should appear in the form. 

Groupboxes Groupboxes are rectangles to which captions can be 

added at the upper left. They can be used for the 

visual grouping of related parts of a form. 

Of course forms are not limited to containing just the above described form ob-

jects. They can also contain all other types of objects as well as normal text. 

You will find detailed information about the individual types of form objects in the 

section “Text fields” and in following sections of this chapter (beginning on page 

317). 

With or without frames? 

As you might have noticed, you can insert most types of form objects with or wit-

hout frames: 

 Text fields and text frames 

 Checkboxes and checkbox frames 

 Dropdown lists and dropdown list frames 

The difference between normal objects and objects in frames: 

Normal Objects (e.g. dropdown lists) are inserted directly into the text. They are 

integrated into the text flow – just like a letter. Such objects are simpler to manipu-

late and therefore the best choice for most kinds of forms. 

Objects in frames (e.g. dropdown list frames) on the other hand are freely positio-

nable on the page. They can always be moved with the mouse, but once positioned 

they remain fixed in place on the page – even when text lines are added or deleted 

above them. 
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Inserting form objects 

FreeOffice: Inserting form objects is not supported in SoftMaker FreeOffice, 

meaning that you will not be able to create new forms there. (Using existing 

forms is possible.) 

To insert a form object into the text, do the following: 

1. Invoke the Object > New Form Object menu command.  

2. A sub-menu opens. There, select the desired object type. 

3. For some types of objects a dialog appears at this point to enable you to make 

various settings for the object. After you have made the necessary settings con-

firm with OK. 

The object will now be inserted. 

You will find detailed information about each individual type of form object in the 

sections “Text fields” and following (beginning on page 317). 

Using the Forms toolbar 

You can also use the Forms toolbar to insert form objects. To activate or deactivate 

this toolbar, invoke the View > Toolbars menu command and click on the check-

box in front of Forms. 

 

The icons in this toolbar represent the following functions (from left to right): 

 Insert text field 

 Insert checkbox 

 Insert dropdown list 

 Insert text frame 

 Insert checkbox frame 

 Insert dropdown list frame 

 Insert label 

 Insert groupbox 

 Enable/disable the shading of form fields (emphasizes all text fields, checkbo-

xes and dropdown lists in the text with gray shading) 

 Activate/deactivate Form mode (corresponds to the menu command View > 

Form mode) 
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Editing form objects 

Like all other types of objects, form objects can be edited after being selected with 

a mouse click. You can delete, move and copy them, change their properties with 

the Object > Properties menu command, etc. 

Tip: In addition, using the Object > Tab order menu command you can change 

the order of the form objects which is applied when the user jumps from one ob-

ject to another in Form mode using the (Tab) key (see the section “Changing the 

tab order” beginning on page 326). 

Note: General information about working with objects can be found in the section 

“Frames and drawings” (beginning on page 259). 

Preparing an example form 

We come now to a practical example: we will prepare a form for gathering client 

data. The form should contain some text fields for the entry of the client’s address, 

beyond those a dropdown list for recording the client’s gender and a checkbox that 

is to be checked in case the client is new. 

 

Start a new document with File > New menu command. And we’re on our way: 
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Text fields for unrestricted text entries 

The first line of the form should contain a text field for the entry of the client’s 

name. The best way to proceed is first to provide a description of what is to be en-

tered in this field – for example “Name:” – and then to insert the text field itself to 

the right of this description. 

So do the following: 

1. Type “Name:” and then insert a tab with the (Tab) key. 

2. Insert a text field with the menu command Object > New form object > Text 

field. 

3. At this point the text cursor is positioned in the text field. Press the (Æ) key to 

return it to the main text. 

4. Press the Enter key (¢) twice. 

The first line of the form is now complete. Use the same procedure to add two ad-

ditional lines with the labels “Address:” and “City:”. 

Dropdown lists 

Next, a dropdown list is to be inserted below the three text fields. Dropdown lists 

allow users to choose among several alternatives. 

Proceed as follows: 

1. Type “Gender:” and then press (Tab). 

2. Invoke the menu command Object > New form object > Dropdown. 

3. Now you must enter the items that are to appear in the list. Enter “male” in the 

New Entry field and click on Add; then enter “female” and again click on 

Add. 

4. Exit the dialog with OK. 

5. Press the Enter key (¢) twice. 

Checkboxes for yes/no entries 

Lastly, a checkbox is to be inserted. Checkboxes can be used for yes/no entries. If 

the box is checked it means “yes”. If the box is not checked it means “no”. 



 

316  •  Forms Manual TextMaker 

Accordingly, we will add a checkbox that should be checked only when the client 

is new: 

1. Type “New client?” and then press (Tab). 

2. Invoke the menu command Object > New form object > Checkbox. 

3. In the dialog that appears at this point you can – if required – enter additional 

text that will appear next to the checkbox. For this example, type “yes”. 

4. Exit the dialog with OK. 

5. Press the Enter key (¢) twice. 

To align the form objects vertically you should now select all the lines you have 

entered and then use the Format > Tab menu command to set a tab stop at the ap-

propriate place – for example at 1.2 inch. 

 

Our form is now complete. 

You can now save the document and test it (see also the section “Filling out forms” 

beginning on page 308). The best way to test the form is to invoke the menu com-

mand View > Form mode to activate Form mode. 
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Form objects in detail 

FreeOffice: Inserting form objects is not supported in SoftMaker FreeOffice, 

meaning that you will not be able to create new forms there. (Using existing 

forms is possible.) 

In this section we describe in detail the individual types of form objects. The 

following objects are covered: 

 Text fields 

 Text frames 

 Checkboxes 

 Checkbox frames 

 Dropdown lists 

 Dropdown list frames 

 Labels and groupboxes 

Text fields 

You insert a text field with the Object > New form object > Text field menu 

command. 

FreeOffice: Inserting form objects is not supported in SoftMaker FreeOffice. 

Text fields are used frequently in forms. They allow the entry of unrestricted text; 

accordingly, they are suitable for entries of names, addresses, etc. 

Usage of text fields 

To fill out a text field you simply click in the field to position the text cursor there 

and enter the text. 

Changing the properties of text fields 

After positioning the text cursor in a text field or selecting the text field with a 

mouse click in Object mode, you can invoke the menu command Object > Pro-

perties to modify the properties of this field. The properties of a text field include 

its size, margins and a number of other settings. 

The following options are available: 
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Format tab 

On this tab, you can change the format of the text field: 

 Size group box 

 Here you can change the Size of the text field. 

 You can either specify the width and height exactly or allow the text field to 

expand automatically as necessary to accommodate text as it is entered. To do 

the latter, select the Growing option for Width and Height and enter the desi-

red minima and maxima. 

 Vertical alignment group box 

 Lets you change the vertical alignment of the text inside the field as follows: 

Option Meaning 

Top Align inner text at the top of the text field 

Centered Vertically center text between top and bottom of the text 

field 

Bottom Align inner text at the bottom of the text field 

Justified Vertically justify text (so that it is evenly distributed 

between top and bottom of the text field) 

Margins tab 

On this tab, you can modify the margins of the text field: 

 Wrap margins group box 

 Here you can change the outside margins. 

 Margins group box 

 Here you can change the inside margins. 

Properties tab 

On this tab, you can change settings that affect general properties. On this topic, 

see the section “Object properties, Properties tab” beginning on page 281. 
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Borders tab 

With this tab, you can give the text field a full border or individual border lines. 

The options on this tab correspond to those for the Format > Borders menu com-

mand (see the section “Borders and lines” beginning on page 100). 

Shades tab 

With this tab, you can apply shading to the text field using a color or a pattern. 

The options on this tab correspond to those for the Format > Shading menu com-

mand (see the section “Shading” beginning on page 99). 

Text frames 

You insert a text frame with the Object > New text frame menu command. 

A text frame is filled out the same way a text field is filled out (see the preceding 

section): you simply position the text cursor in the field and start typing. 

The difference between a text frame and a text field: A text frame, like all other 

types of frames, has a fixed position on the page. Thus, it does not move when you 

add or delete text above it. The normal body text is automatically formatted so that 

it breaks at the boundaries of the frame – it “flows” around the frame. 

You will find information about text fields in the preceding section. Additional in-

formation about text frames is given in the section “Text frames” beginning on 

page 287. 

Checkboxes 

FreeOffice: Inserting form objects is not supported in SoftMaker FreeOffice. 

You insert a checkbox with the Object > New form object > Checkbox menu 

command. 

Checkboxes can be used in forms for yes/no entries. The box is checked to re-

present “yes”; when unchecked it means “no”. 
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Usage of checkboxes 

Simply click on the box (not the text!) to put a checkmark in it – that is, to check it. 

If you click on it again, the check mark is removed. 

Changing the properties of checkboxes 

To modify the properties of a checkbox, first select it with a mouse click. Then 

invoke the Object > Properties menu command. 

A dialog window with the following options will appear: 

Layout tab 

Available only for checkbox frames.  

On this tab, you can change the object’s position, outside margins and other layout 

related properties. See section “Object properties, Layout tab” beginning on page 

268. 

Format tab 

Available only for checkbox frames. 

On this tab, you can change the size of the object. See section “Object properties, 

Format tab” beginning on page 274. 

Properties tab 

On this tab, you can modify common object settings. See section “Object proper-

ties, Properties tab” beginning on page 281. 

Form Object tab 

On this tab, you can make settings that are specific to checkboxes: 

 Text 

 Here you can enter the text that is displayed to the right of the checkbox. 
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 Value 

 Here you can specify the initial state of the checkbox, whether it should appear 

checked or unchecked in the document. 

 3D effect 

 If you check this option, the checkbox is drawn with a 3D effect. 

With checkbox frames you can also specify the character formatting (font, size, 

color, etc.) for the text. 

Checkbox frames 

FreeOffice: Inserting form objects is not supported in SoftMaker FreeOffice. 

You insert a checkbox frame with the Object > New form object > Checkbox 

frame menu command. 

The usage and behavior of a checkbox frames correspond to those for checkboxes 

(see the previous section). 

The difference: A checkbox frame, like all types of frames, has a fixed position on 

the page. Thus, it does not move when you insert or delete text above it. The nor-

mal body text is automatically formatted in such a way that it breaks at the bounda-

ries of the frame – it “flows” around the frame. 

Dropdown lists 

FreeOffice: Inserting form objects is not supported in SoftMaker FreeOffice. 

You insert a dropdown list with the Object > New form object > Dropdown menu 

command. 

You encounter dropdown lists in many dialog boxes. They offer several alternati-

ves, from which you can select only one. Such lists are ideal for forms, since they 

reduce the amount of typing needed when forms are filled out and prevent typing 

errors. 
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Usage of dropdown lists 

To open a list, you click on the small arrow to the right. Now you can select an 

entry by clicking on it. 

Changing the properties of dropdown lists 

To modify the properties of a dropdown list, first select it with a mouse click. Then 

invoke the Object > Properties menu command. 

A dialog window with the following options will appear: 

Layout tab 

Available only for dropdown list frames. 

On this tab, you can change the object’s position, outside margins and other layout 

related properties. See section “Object properties, Layout tab” beginning on page 

268. 

Format tab 

Available only for dropdown list frames. 

On this tab, you can change the size of the object. See section “Object properties, 

Format tab” beginning on page 274. 

Properties tab 

On this tab, you can modify common object settings. See section “Object proper-

ties, Properties tab” beginning on page 281. 

Form Object tab 

On this tab, you can make settings that are specific to dropdown lists: 

 List entries group box 

 Here you specify the items that should appear in the dropdown list. You do this 

as follows: 
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 To add an item: Enter the name of the item in the New entry field and press the 

Enter key (¢) or click on the Add button. 

 To remove an item: Select the item in the list of entries and click on the Remove 

button. 

 To change an item: Remove the item and reinsert it. 

 To change the order: Select one of the items in the list and click on one of the 

small arrows to the right of the list to move the item up or down. 

 Lines (max.) 

 Available only for dropdown list frames. Determines the maximum number of 

lines to be displayed when the list is opened. 

 Use additional inner margins 

 Available only for dropdown lists. By default, the size of a dropdown list is 

calculated in a way that their text content exactly fits in. If you check this opti-

on, some small inner margins are added, making the object slightly larger. 

 3D effect 

 If you check this option, the borders of the list are drawn with a 3D effect. 

With dropdown list frames you can also specify the character formatting (font, si-

ze, color, etc.) for the list items. 

Dropdown list frames 

FreeOffice: Inserting form objects is not supported in SoftMaker FreeOffice. 

You insert a dropdown list frame with the Object > New form object > 

Dropdown frame menu command. 

The usage and behavior of a dropdown list frame correspond to those for a 

dropdown list (see the previous section). 

The difference: A dropdown list frame, like all types of frames, has a fixed positi-

on on the page. Thus, it does not move when you insert or delete text above it. The 

normal body text is automatically formatted in such a way that it breaks at the 

boundaries of the frame – it “flows” around the frame. 
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Labels and groupboxes 

FreeOffice: Inserting form objects is not supported in SoftMaker FreeOffice. 

Besides the form objects described on the preceding pages, there are two additional 

types of form objects that are intended not to be filled in, but to be used merely for 

captions: 

 Labels 

 Any caption or legend that should appear in the form can be entered in a label. 

 Groupboxes 

 A groupbox is a rectangle with a caption at its upper left. Groupboxes can be 

used for the visual grouping of related parts of a form. 

To insert a label or a groupbox invoke the Object > New form object > Label or 

the Object > New form object > Groupbox menu command.  

The corresponding form object is inserted in a standard size. If necessary, you can 

always change its position by dragging the object with your mouse. To adjust its 

size, drag on one of the round handles surrounding the object. 

Usage of labels and groupboxes 

In contrast to all other types of form objects, labels and groupboxes cannot be fil-

led in. They can be used only to add (non-editable) captions or legends to the form. 

Changing the properties of labels and groupboxes 

To modify the properties of a label or a groupbox, first select it with a mouse click. 

Then invoke the Object > Properties menu command. 

A dialog window with the following options will appear: 

Layout tab 

On this tab, you can change the object’s position, outside margins and other layout 

related properties. See section “Object properties, Layout tab” beginning on page 

268. 
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Format tab 

On this tab, you can change the size of the object. See section “Object properties, 

Format tab” beginning on page 274. 

Properties tab 

On this tab, you can modify common object settings. See section “Object proper-

ties, Properties tab” beginning on page 281. 

Form Object tab 

On this tab, you can make settings for the text that is displayed in the label or 

groupbox: 

 Text group box 

 Here you can enter the text to be displayed. 

 3D effect 

 Available only for groupboxes. If you check this option, the groupbox is drawn 

with a 3D effect. 

You can also specify the character formatting (font, size, color, etc.) for the text. 

Forms – advanced functions 

This concluding section of the chapter on forms describes some forms functions for 

advanced users, as follows: 

 Changing the tab order 

 Protecting contents of form objects 

 Protecting forms 

 Calculating with form objects 

See the next pages for details. 
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Changing the tab order 

As mentioned earlier in the section “Filling out forms”, you can jump back and 

forth between form objects with the (F11) key: (F11) takes you to the next form 

object and (Shiftª)(F11) takes you to the previous one. 

In Form mode you have the alternative of using (Tab) and (Shiftª)(Tab) to perform 

these functions. 

The order in which you jump among the form objects can be specified with the 

menu command Object > Tab order. 

To set the tab order invoke this command and select from the list of Objects the 

form object whose position in the tab order you want to change. Then click on one 

of the arrow buttons to the right of the list to raise move the object to a lower or 

higher position in the list. The position of the object in the tab order changes ac-

cordingly. 

Protecting contents of form objects 

In certain situations it is desirable for forms to contain form objects whose contents 

cannot be modified in Form mode – for example, text frames containing explanato-

ry material.  

This objective can be realized by checking the Text locked option in the form ob-

ject’s properties dialog. If this option is activated, the contents of the object can no 

longer be altered in Form mode. In addition, it is no longer possible to click on it in 

Form mode or to jump to it with the (Tab) key. 

To lock the contents of a form object, do the following: 

1. If Form mode is currently activated, exit this mode with the menu command 

View > Form mode. 

2. Select the object to be protected with a mouse click.  

3. Invoke the Object > Properties menu command. 

4. Switch to the Properties tab. 

5. There check the Text locked option. 

6. Confirm with OK. 

The contents of the object are now locked.  



 

Manual TextMaker Forms  •  327 

Special considerations for tables 

With tables you can specify a locked or unlocked state, applicable in Form mode, 

for every single table cell. To lock the contents of table cells, select them, invoke 

the Table > Cell properties menu command, switch to the Format tab and check 

the Text locked option. 

Once locked, the cells’ contents can no longer be edited in Form mode and they are 

skipped when the (Tab) key is pressed to jump to the next cell. 

Naturally, you can lock not only the contents of individual cells but whole tables. 

For this purpose, simply select the whole table and then use the procedure descri-

bed above. 

Protecting forms 

Before you put a newly created form to use, you should protect it from being chan-

ged. When a form is ready for use, the form itself should no longer be subject to 

change, and only the objects in the form that are intended to be filled in should be 

changeable. 

The following methods for protecting forms are available to you: 

Using Form mode 

When you activate Form mode (see section “Filling out forms”) the form objects 

can still be filled in, but other parts of the document can no longer be edited, and 

most TextMaker commands are no longer available. 

Form mode can be activated and deactivated with the menu command View > 

Form mode. 

Note: Keep in mind that users who fill in the form can deactivate Form mode at 

any time unless you prevent them from doing so by locking Form mode with a 

password (see below). 

Saving the form in Form mode 

Tip: When you save a document in Form mode, Form mode is automatically reac-

tivated the next time the document is opened. 
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Locking Form mode with a password 

As required, you can prevent other users from deactivating Form mode by locking 

it with a password. 

To do this, invoke the File > Properties menu command and switch to the Forms 

tab. Activate Form mode by checking the Form mode activated option. Then, 

enter a Password to deactivate Form mode and confirm with OK. Finally, save 

the document. 

When a user subsequently opens the document and attempts to deactivate Form 

mode, he or she will be prompted for the password. Thus, the user will be able to 

deactivate Form mode only if he or she has the correct password. 

Tip: Saving forms as document templates 

It is generally recommended that you save forms as document templates. This will 

always guarantee that the original file cannot be changed. When you have saved a 

form as a document template you can use menu command File > New to create 

new documents based on the content of this template without opening the template 

itself for editing. 

You will find additional information about using document templates in the section 

“Document templates” beginning on page 149. 

Calculating with form objects 

You can reference the contents of form objects and perform calculations on these 

contents using the Insert > Calculation menu command. For example, the formula 

“Textbox1.Value * 2” references the current numeric value in the text field named 

“Textbox1” and multiplies it by two. 

You will find additional information about this topic in the section “Objects in cal-

culations” beginning on page 403. 
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Language tools 

TextMaker offers a spell check feature, a hyphenator, a thesaurus, and other power-

ful language tools. (Depending on your chosen language, you may have only the 

hyphenation feature, or the hyphenation and spell check features.) 

This chapter provides information on working with these tools, as follows: 

 Setting the language 

 The default language for spell checker, hyphenator and thesaurus can be set 

with the menu command Tools > Options (Language tab). 

  In addition, with Format > Character you can designate a segment of text to 

be in any other language you like. You can do this, for example, when you use a 

Spanish language citation in a document you are writing in English. 

 Spell checking 

 The spell checker examines the text in your document for spelling mistakes. 

When it finds mistakes, it suggests corrections. 

 Hyphenation 

 The hyphenator hyphenates long words at the ends of lines. This is performed 

automatically in the background – right as you type.  

 Thesaurus 

FreeOffice: The Thesaurus is not included in SoftMaker FreeOffice. 

 The thesaurus is a tool that lets you quickly find terms in a synonym dictionary 

with equivalent or similar meanings of the word you are looking for. This fea-

ture helps you express yourself precisely and avoid repetition. 

 Berlitz translation dictionaries 

 Only in SoftMaker Office Professional: In this variant of SoftMaker Office, 

TextMaker includes Berlitz translation dictionaries, enabling you to translate 

words between five languages (English, French, German, Italian, and Spanish) 

with the push of a button. 

 SmartText 

FreeOffice: The SmartText feature is not included in SoftMaker FreeOffice. 
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 With TextMaker’s SmartText feature, you can have your “favorite” typing er-

rors corrected automatically and create short-cuts for frequently needed phra-

ses, for example “sd” for “sales department.” 

Setting the language 

If you have installed more than one language, you can change the language for the 

spell checker, hyphenator and thesaurus whenever required. 

To change the language, you have the following two options: 

 Setting the default language 

 On the one hand, with the menu command Tools > Options you can set the 

default language. The spell checker, hyphenator and thesaurus normally use the 

default language. 

 Formatting text in another language 

 On the other hand, with the command Format > Character you can format 

any segment of text in another language as needed. 

In simple terms: Normally, the whole document is formatted in the default langu-

age, and the spell checker, hyphenator and thesaurus use the default language set in 

the dialog of the Tools > Options menu command. However, if you format a seg-

ment of text in another language, the spell checker, hyphenator and thesaurus refer 

to that language instead. 

For detailed instructions, see the following pages. 

Setting the default language 

By setting the default language, you specify which language the spell checker, 

hyphenator and thesaurus will use by default. So you should set your native langu-

age here. 

To do this, proceed as follows: 

1. Invoke the Tools > Options menu command. 

2. Switch to the Language tab. 

3. Select the desired language from the Default Language list. 
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When you compose new documents they are automatically formatted in the default 

language. If you never write documents in which other languages occur, you don’t 

need to concern yourself with any of what follows. 

Formatting text in another language 

In the last section you learned how to set the default language that TextMaker is to 

use in the normal case for the spell checker, hyphenator and thesaurus. 

Beyond that, you can format any segments of text you like in another language – 

for example, if you want to use a Spanish language citation in a document that is 

for the most part in English. 

To do this, proceed as follows: 

1. Select the segment that contains foreign language text. 

2. Invoke the command Format > Character. 

3. Switch to the Font tab. 

4. Choose the desired language from the Language list. 

Now the spell checker, hyphenator and thesaurus know that this segment of text is 

in another language and they produce the appropriate results. 

The Language list contains two entries with special meaning: 

 The language “Default” 

 This is the default setting. 

 Normally, all the documents you compose are formatted in the default langu-

age. As you have learned in the preceding section, the default language can be 

selected with the menu command Tools > Options. 

 The language “No language” 

 If you format a segment of text with “No language”, it will be ignored by the 

spell checker. In addition, no hyphenation will be applied. 

Application examples 

Some application examples in summary: 
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When you write documents exclusively in your native language: 

Simply set the desired standard language in the dialog of the Tools > Options 

menu command, Language tab – and you’re done. 

When you occasionally write documents in a foreign language: 

In this case it is not advisable to change the standard language setting to the foreign 

language. This would lead to the desired result, but it would not be very effective: 

You would have to switch to the appropriate language every time you open a for-

eign-language document and switch it back to your native language afterwards. 

Instead, it makes more sense to select the entire document, invoke Format > Cha-

racter, and change Language from Default to the desired foreign language there. 

This way, TextMaker will know the document’s language both now and in the fu-

ture. 

When you occasionally write documents with foreign language citations: 

Simply select the part that is in the foreign language, invoke Format > Character 

and set Language to the desired language. 

Note: You can change the language in a document as often as you like, and even 

mix several languages. 

Spell checking 

FreeOffice: SoftMaker FreeOffice does not include any of the premium Soft-

Maker dictionaries normally shipped with SoftMaker Office. Its spell checker 

supports solely the use of Hunspell dictionaries. 

In a standard installation, only Hunspell dictionaries for English and German are 

installed. If you want to add additional languages, refer to the section “Installing 

Hunspell dictionaries”.  

The spell checker examines the text in your document for spelling mistakes. When 

it finds mistakes, it suggests corrections. 

This section describes the different spell checking tools in detail. It covers the 

following topics: 
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 Manual spell checking 

 The manual spell checker lets you check and correct the spelling of the entire 

text in a document, word by word. 

 Background spell checking 

 The background spell checker constantly checks the text for spelling errors. 

Incorrectly written words are underlined in red and can be corrected manually 

or with the aid of a context menu. 

 Conversion to new German spelling 

 If you compose documents in German, the above-mentioned background spell 

checker can also help you adopt the new “reformed” German spelling rules.  

 Editing user dictionaries 

 When you teach the spell checker new words, they are added to your user dic-

tionary. You can edit this dictionary at any time in order to, for example, delete 

incorrect entries. 

See the following pages for detailed information. 

Manual spell checking 

FreeOffice: SoftMaker FreeOffice does not include any of the premium Soft-

Maker dictionaries normally shipped with SoftMaker Office. Its spell checker 

supports solely the use of Hunspell dictionaries. 

In a standard installation, only Hunspell dictionaries for English and German are 

installed. If you want to add additional languages, refer to the section “Installing 

Hunspell dictionaries”.  

You activate the manual spell checker with the Tools > Check spelling menu 

command.  

This checks the text word for word for spelling errors. If an unrecognized word is 

found, the spell checker stops and displays the word in a dialog box.  
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You can then choose to correct the word, add it to the dictionary, or simply ignore 

the supposed error. Additionally, in the list under Change to, some suggestions for 

the correct spelling of the word are presented (if any are found). 

Use the dialog buttons to specify what to do with the unknown word, as follows: 

Button Function 

Change Lets you correct the word. Before you use this button, type the 

correct spelling in the Change to input field or select one of the 

suggested words from the list. 

Change All Works like the Change button, but changes all further instances 

of the word (from here to the end of the document). 

Ignore Ignores the supposed spelling error and continues with the 

spelling check. 

Ignore All Ignores all further instances of this word. 

 Note: Use Ignore or Ignore All only for words that are correctly 

written but are not to be added to the dictionary. When you exit 

TextMaker, it forgets the list of ignored words. 

Add Advises TextMaker to add the word to the user dictionary and in 

this way to enlarge its vocabulary. 

 Note: Use this option for correctly spelled words that TextMaker 

does not yet know. TextMaker remembers these words perman-

ently. 

If you want to exit the spell checker before it reaches the end of the document, 

click on Close. 
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Spell checker not working correctly? If the spell checker classifies many words as in-

correctly spelled when in fact they are not, it is likely that the text segment in 

which they occur is formatted in the wrong language. In this case, select the text 

segment, invoke Format > Character and set the Language option on the Font 

tab to “Default” (or to the language in which the segment was composed.) 

Background spell checking 

FreeOffice: SoftMaker FreeOffice does not include any of the premium Soft-

Maker dictionaries normally shipped with SoftMaker Office. Its spell checker 

supports solely the use of Hunspell dictionaries. 

In a standard installation, only Hunspell dictionaries for English and German are 

installed. If you want to add additional languages, refer to the section “Installing 

Hunspell dictionaries”.  

The background spell checker constantly checks the text for spelling errors. In-

correctly written words are underlined in red and can be corrected manually or 

with the aid of a context menu. 

Activating background spell checking 

To activate background spell checking, invoke the menu command Tools > Opti-

ons, switch to the Language tab and enable the option Use background spell che-

cking.  

TextMaker now examines the entire document for spelling errors on an ongoing 

basis. It not only recognizes existing spelling errors in the document, but also im-

mediately examines changes and additions to the text for correct spelling. 

Correcting misspelled words 

Misspelled words are highlighted on the screen with red underscores. This allows 

you to see, at a glance, all misspelled words so that you can either correct them 

immediately or at a later time. 

To correct one of these underlined words, either simply change its spelling by hand 

or click with the right mouse button on the word to bring up the spelling correction 

context menu.  

Android: In the Android version, you can also open the context menu with your fin-

ger: Just tap on the screen and hold your finger there for about a second. 
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The context menu includes the following items: 

Item Function 

List of  

suggestions 

When TextMaker finds suggestions for the correct spelling 

of the word, it presents them in the upper part of the menu. If 

you click on one of them, it will replace the word in the text. 

 If TextMaker finds a large number of suggestions, an additi-

onal menu item called Additional Suggestions appears. If 

you click on it, a dialog with all the suggestions found will 

appear. 

Ignore Word Ignores the spelling error (for all instances of this word) and 

removes the red marking. 

 Use this option for words that are, in fact, correctly spelled 

but are not to be added to the dictionary. When you exit 

TextMaker, it forgets the list of ignored words. 

Add Word Advises TextMaker to add the word to the user dictionary 

and in this way to enlarge its vocabulary. 

 Use this option for correctly spelled words that TextMaker 

does not yet know. TextMaker remembers these words per-

manently. 

Create SmartText  

Entry 

Creates a SmartText entry from the word. You will learn 

more about this feature in the section “SmartText” beginning 

on page 346. 

As soon as you correct the spelling (or allow TextMaker to ignore or add the 

word), the red underscore disappears. 

Is the spell checker working incorrectly? If the spell checker frequently underlines 

words that in fact are correctly spelled, it is likely that the text segment in which 

they occur is formatted in the wrong language. In this case, select the text segment, 

invoke Format > Character, and set the Language option on the Font tab to 

“Default” (or to the language in which the segment was composed.) 

Tip: Jumping to the previous/next spelling error 

When the background spell-checker has been activated, the three buttons in the 

lower right corner of the document window can also be used to jump to the previ-

ous/next spelling error. 
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First, click on the button with the red dot to bring up a small menu. Select the opti-

on Spelling error from it. 

After that, you use these buttons as follows: 

 Click on the button with the up arrow to jump to the previous spelling error. 

 Click on the button with the down arrow to jump to the next spelling error. 

More information on these three buttons can be found in the section “The Go to ... 

Command” (page 168). 

Conversion to new German spelling 

Note: This whole section applies to text in German language. If you never work 

with documents composed in German, you can safely skip it and continue rea-

ding in the section “Editing user dictionaries”, beginning on page 340. 

In 1996, the governments of the German-speaking countries Germany, Austria, 

Liechtenstein, and Switzerland signed an agreement concerning a reform of Ger-

man spelling, attempting to simplify German orthography and make it easier to 

learn. 

TextMaker’s Background spell checking feature (discussed in the last section) can 

help you apply the reformed spellings for text composed in German language: 

At your command, it underlines in blue all German words that conform to the old 

German spellings and that should be spelled differently in accordance with the new 

German spellings. 

If you click with the right mouse button on such a word, the approved spelling is 

presented to you in a context menu. In addition, you can call up information as to 

why this word is now written differently. 

For detailed information on this topic, read the following pages. 

Activating conversion to the new German spelling 

To activate checking for and conversion to the new spellings in texts composed in 

German, you must take the following steps: 
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1. Invoke the menu command Tools > Options. 

2. Switch to the Language tab. 

3. Turn on the Use background spell checking option. 

4. Additionally, activate the Underline old German spelling in blue option. 

5. Confirm with OK. 

Note: The Underline old German spelling in blue option only works with text 

formatted in the language “German (Germany)”, “German (Austria)”, or “Ger-

man (Switzerland)”. 

From now on, in the background, TextMaker examines the document for German 

words that should be written differently following the German spelling reform. 

These are underlined in blue. On the next page you can learn how to convert these 

words to the new spellings. 

Correcting words with old German spellings 

As explained in the last section, if you have turned on the Underline old German 

spelling in blue option, German words whose spellings were changed by the Ger-

man spelling reform are indicated with a blue underline. 

To correct one of these underlined words, simply change its spelling manually or 

click with the right mouse button on the word in order to bring up the context 

menu of the spell checker. 

Android: In the Android version, you can also open the context menu with your fin-

ger: Just tap on the screen and hold your finger there for about a second. 

The context menu contains the following items: 

Item Function 

List of  

suggestions 

All spellings that are correct (according to the reformed German 

spelling rules) are displayed in the upper part of the menu. If you 

click on one of them, TextMaker will replace the word in the text 

with it. 

Info Opens a dialog box with additional options and information (see 

section “The Info command of the spell checker”). 

Ignore Word Ignores the mistake and removes the blue underline. 
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 Use this option for words that are in fact correctly spelled but are 

not to be added to the dictionary. When you exit TextMaker, it 

forgets the list of ignored words. 

Add Word Advises TextMaker to add the word to the user dictionary. 

 TextMaker remembers such words permanently; they are no 

longer underlined in blue (see note!) 

Note: Use the command Add Word only for those German words underlined in 

blue that are in fact correctly spelled according to the new German spelling rules. 

If you allow words with old spellings, rather than new spellings, to be added, you 

will be supplying TextMaker with incorrectly spelled words. 

The Info command of the spell checker 

When you invoke the spell checker’s context menu as described in the previous 

section, an additional item appears for German words in the old spelling: the Info 

command. This command refers to additional options and shows information about 

the rule governing the change in the word’s spelling under the German spelling 

reform. 

This command’s dialog box provides the following functions: 

Item Function 

List of  

suggestions 

Here all spellings that are correct (according to the reformed 

German spelling rules) are displayed. If you click on one and 

then push the Change button, TextMaker replaces the word in 

the text with it. 

Change Lets you correct the word after you have chosen the correct 

spelling from the list of suggestions. 

 If TextMaker should ever make a suggestion that is in fact 

wrong, you can enter the correct spelling in the Change to field 

manually. 

SmartText Lets you define a SmartText entry. See section “SmartText” be-

ginning on page 346. 

Ignore Ignores the mistake and removes the blue underline. 

Ignore All Ignores all further instances of this word. 
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 Note: Use Ignore or Ignore All only for words that are correctly 

written but are not to be added to the dictionary. When you exit 

TextMaker, it forgets the list of ignored words. 

Add Advises TextMaker to add the word to the user dictionary. 

 TextMaker remembers such words permanently; they are from 

now on not underlined in blue (see note!) 

Close Closes the dialog box without applying a change. 

Note: Use the Add command only for those German words underlined in blue 

that are in fact correctly spelled according to the new German spelling rules. If 

you allow words with old spellings, rather than new spellings, to be added, you 

will be supplying TextMaker with incorrectly spelled words! 

Editing user dictionaries 

When you teach the spell checker new words, they are added to your user dictiona-

ry. You can edit this dictionary at any time in order to, for example, delete incorrect 

entries. 

To do this, invoke the menu command Tools > Edit user dictionaries. A dialog 

opens, providing the following controls: 

 Language 

 Every language has its own user dictionary. You can select the user dictionary 

to be edited from the Language dropdown list. 

 Entries 

 This list contains all words that have been added to your user dictionary (for the 

selected language). 

 “Close” button 

 This button closes the dialog. 

 “Add” button 

 This button enables you to add a word to your user dictionary manually. A dia-

log appears, allowing you to enter the word.  

 Words added this way are treated exactly the same way as words that have been 

added using the Add button in the spell checker. 
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 “Change” button 

 Use this button to edit the word that is currently selected in the list. This is 

useful for misspelled words that you have added to your user dictionary ac-

cidentally. Clicking on the button opens a dialog that allows you to correct the 

spelling of the word. 

 “Delete” button 

 This button removes the selected word from your user dictionary – thus, the 

spell checker will now view this word as incorrectly spelled, as it did before the 

word was added. 

Hyphenation 

The purpose of hyphenation is to regularize the right margin of text by breaking up 

long words that occur at the ends of lines. 

Hyphenation is performed completely automatic and takes effect as you type. So, 

ordinarily you do not need to concern yourself with it at all. 

However, you do need to make sure that you have set the language correctly. Natu-

rally, the hyphenator will not produce correct results if you let it separate, for exa-

mple, Spanish words according to English hyphenation rules.  

Setting the language 

Detailed instructions on setting the language for spell checker and hyphenation 

were given at the beginning of this chapter (section “Setting the language”, page 

330).  

Here’s a brief summary: 

 Setting the default language 

 By setting the default language, you specify which language the spell checker 

and hyphenator will use by default. So you should set your native language he-

re. 

 To do this, invoke the menu command Tools > Options, switch to the Langu-

age tab, and choose the desired language from the Standard language list. 
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 Formatting text segments in another language 

 Apart from that, you can set the language of any text segment to a language 

different from the standard language whenever required. This is useful if a 

document contains a segment of foreign language text – for example a citation 

in Spanish. 

 To do this, invoke the menu command Format > Character, switch to the 

Font tab, and choose the respective language from the Language list. 

 You can change the language within a document as often as you like; and of 

course you can format a whole document in a foreign language. 

Setting the hyphenation frequency 

If desired, you can specify how often the hyphenator should break words – or you 

can turn the hyphenator off. You can do this separately for each individual para-

graph as follows: 

Select the paragraph(s) of interest, invoke the menu command Format > Para-

graph, switch to the Text flow tab, and select an option in the Hyphenation 

dropdown list. 

The following options are available: 

Setting Effect 

None No hyphenation is performed. 

Always Hyphenation is attempted in successive lines without limit. This 

is the default setting. 

Every 2 Lines Hyphenation is attempted only in every second line. 

Every 3 Lines Hyphenation is attempted only in every third line. 

Thus, with None you turn hyphenation completely off for the selected paragraph. 

With Always, on the other hand, you allow hyphenation to be performed whenever 

possible on any line of the paragraph. 

In some cases, it is not always a good idea to hyphenate at every point possible, 

and this is where the other two options come in handy. For example, text that is in 

narrow columns could lead to a broken word at the end of almost every line and 

consequently, to a reduction of the document’s legibility. Therefore, instead, you 

may want to use the Every 2 Lines or Every 3 Lines option to direct TextMaker to 

attempt hyphenation only in every second or third line. 
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Deactivating hyphenation for an entire document 

Apart from the options mentioned above, you can activate or deactivate hyphenati-

on for the current document completely. 

This can be achieved via the Tools > Automatic hyphenation menu command. 

By default, automatic hyphenation is enabled. This is indicated by a checkmark 

displayed in front of the Automatic hyphenation command in the Tools menu. If 

you invoke this command, the hyphenator will be turned off, and the checkmark 

disappears. Automatic hyphenation is now completely disabled (for the current 

document). Hyphens will no longer be inserted automatically, and the existing ones 

are removed. 

If you invoke this command once more, automatic hyphenation will be enabled 

again. 

Note: This setting is a document option. This means that it affects only the cur-

rent document and its state is saved in the document. Thus, you can decide sepa-

rately for each document if automatic hyphenations should be performed in it or 

not. 

By the way, the same option is also available in the dialog of the Tools > Options 

menu command, on the Language tab. Activating or deactivating the Use automa-

tic hyphenation option there is identical to invoking the Tools > Automatic hy-

phenation menu command. 

Deactivating hyphenation for a word or any other text segment 

You can also deactivate hyphenation for a specific text segment, for example, a 

certain word.  

To do so, select the desired text segment, invoke the Format > Character menu 

command, switch to the Font tab, and set the Language option to No language. 

Hint: Please note that this will also deactivate the spell-checker in the selected 

text segment. 

Inserting “soft hyphens” 

TextMaker’s hyphenation module performs incorrect hyphenations only in very 

rare cases. If the hyphenator should actually fail to hyphenate a word at the desired 

position, you can always correct it by inserting a soft hyphen. 
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To do this, place the text cursor at the position where you want the word to be hy-

phenated and press the key combination (Ctrl)(-). From now on, TextMaker will 

hyphenate the word only at this position. 

Note: If a word contains multiple syllables, you can insert more than just one soft 

hyphen (for example, one after each syllable), whenever needed. 

Tip: By default, soft hyphens are not displayed in the document. If you want 

them to become visible, choose the menu command Tools > Options, switch to 

the View tab, and enable the option Soft hyphens. This will display all soft hy-

phens as hyphens with a gray background. 

Inserting “non-breaking hyphens” 

When a word (or a number) that contains a hyphen is located at the end of a line, 

TextMaker might use this hyphen to hyphenate the word. In certain cases, this is 

not desirable. 

For example, for a phone number like 936386-0, it is not advisable to separate the 

zero from the rest of the number through hyphenation. The phone number would 

be more legible if it was not distributed over two lines, but instead moved to the 

next line as a whole. 

If you want to prevent TextMaker from performing hyphenation at a hyphen that a 

word contains, insert a non-breaking hyphen instead of a regular hyphen. You can 

do this by pressing the key combination (Ctrl)(Shiftª)(-) (minus key). 

Non-breaking hyphens look exactly like regular hyphens; however, the hyphenator 

will never break a word at a non-breaking hyphen. 

Thesaurus 

FreeOffice: The Thesaurus is not included in SoftMaker FreeOffice. 

With the menu command Tools > Thesaurus, you can have TextMaker search for 

a word's synonyms (terms with equivalent or similar meanings). 

This function can help you express yourself precisely and avoid repetition. Even if 

you command a vocabulary that is larger than average, the thesaurus may still find 

alternative words. This function is especially useful with foreign languages. 
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Using the thesaurus 

To open the thesaurus, type a word or move the text cursor to a word you have al-

ready typed. Then invoke the menu command Tools > Thesaurus. 

 

TextMaker now searches for the word in the Thesaurus. 

If the word is not found, words with similar spellings are presented for selection. 

Otherwise, synonyms for the word are shown. 

Note: If a word has several meanings, several items are presented in the Mean-

ing list. First choose the meaning of interest to you, and then view the corres-

ponding synonyms in the Synonyms list. 

Now, with a mouse click, you can select a word from the Synonyms list. Then you 

can choose one of the following functions by using the buttons: 

Button Function 

Look up Looks for alternatives to the selected synonym. 

Replace Replaces the word in the text with the selected synonym. 

Close Exits the thesaurus. 

Berlitz translation dictionaries 

Note: This feature is included only in SoftMaker Office Professional (available 

for Windows, Mac, and Linux). 
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In SoftMaker Office Professional, TextMaker comes with a very useful tool for 

writing foreign language documents: Its integrated Berlitz translation dictionaries 

allow you to translate words between five languages (English, French, German, 

Italian, and Spanish) with the push of a button. 

Using the Berlitz translation dictionaries 

To obtain the translations of a word, first place the text cursor on it. The word’s 

language doesn’t matter – it is recognized automatically by TextMaker. Then invo-

ke the Tools > Berlitz menu command. 

TextMaker now searches for the word in the Berlitz translation dictionaries. 

If the word is not found, a list of words with similar spellings is displayed. Other-

wise, its translations are presented. 

The buttons in the dialog box displayed have the following functions: 

Button Function 

Languages Lets you choose the target languages. For example, if you need 

translations between English and Spanish only, you can turn all other 

languages off. 

Look up Looks up another word in the translation dictionaries. Enter the word 

of interest in the Word input field beforehand. 

Close Closes the dialog box. 

SmartText 

FreeOffice: The SmartText feature is not included in SoftMaker FreeOffice. 

TextMaker’s SmartText feature can save you a lot of work: you can define Smart-

Text entries for frequently needed phrases and then call them out in your text 

quickly and easily. 

For example, define a SmartText entry named “sd” containing “sales department”. 

Now you can call out this SmartText entry at any time. Simply type “sd” and then 

press the space bar, the Enter key (¢) or a punctuation character key. Immedia-

tely, “sd” is replaced with “sales department”. 
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In this way, you can use TextMaker to put together a personal “computer short-

hand” and save significant typing time. 

In this section, you will learn details about TextMaker’s SmartText feature, inclu-

ding the following: 

 Creating SmartText entries 

 SmartText entries can be created either with the Insert > SmartText menu 

command, the background spell checker, or the on-the-fly spell checker. You 

give the SmartText entry a name (e.g., “sd”) and then enter the desired content 

(e.g., “sales department”). 

 Inserting SmartText entries 

 To call up a SmartText entry, simply type its name and then press the space bar, 

the Enter key (¢), or a punctuation character. The name will be immediately 

replaced by the content of the SmartText entry. 

 Alternatively, SmartText entries can be inserted manually using the menu 

command Insert > SmartText. 

 Editing SmartText entries 

 You can create new SmartText entries with the menu command Insert > 

SmartText, and you can edit, format, rename and delete existing entries.  

Detailed information is provided on the following pages. 

Creating SmartText entries 

To create a new SmartText entry, choose one of the following methods:  

A) Using the Insert > SmartText dialog 

To create, for example, a SmartText entry with the name “sd” containing “sales 

department”, proceed as follows: 

1. Invoke the menu command Insert > SmartText. 

2. Click on the New button to create a new SmartText entry. 

3. Give the SmartText entry a name (“sd” in our example). 

 Later, the SmartText entry can be called up by using the specified name. 
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4. Confirm with OK, which takes you back to the main dialog. 

5. Type in the text of the SmartText entry in the large input field (“sales depart-

ment” in our example). 

6. If you want TextMaker to remember the formatting of the entry, you must enab-

le the Apply formatting option. Now you can use the miniature formatting 

toolbar above the input field to set the font, text emphasis and color. 

7. Click on Save to save your new SmartText entry. 

8. Exit the dialog by clicking on the Close button. 

The SmartText entry has now been created. In the next section (“Inserting Smart-

Text entries”) you will learn how to use your new SmartText entry. 

B) Using the background spell checker 

If you have activated the background spell checker, SmartText entries can alterna-

tively be created as follows: 

1. Make sure that the Use background spell checking option on the Language 

tab in the dialog box of the Tools > Options menu command is checked. 

2. Type “sd” and press the space bar. 

3. TextMaker now underlines “sd” in red, since it is an unknown word. Click on 

this word with the right mouse button to open the context menu. 

 Android: In the Android version, you can also open the context menu with your 

finger: Just tap on the screen and hold your finger there for about a second. 

4. Select the Create SmartText Entry command from the context menu. 

5. Type “sales department”. 

6. Confirm with OK. 

The result is the same: the SmartText entry “sd” has now been created. 

If you want to learn more about the background spell checker, see section 

“Background spell checking” beginning on page 335. 
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Inserting SmartText entries 

Once you define a SmartText entry, you can use it anytime as you compose your 

documents. 

Type the name of the SmartText entry (“sd” in our example) in the text, and then 

press the space bar, the Enter key (¢) or a punctuation character. TextMaker im-

mediately replaces “sd” with the content of the SmartText entry, in our example, 

“sales department”. 

Note: If this does not work, the Expand SmartText entries option might be 

disabled. If so, invoke the menu command Tools > Options, switch to the Lan-

guage tab, and turn on this option. 

Alternatively, you can use a dialog to insert SmartText entries in the text by invo-

king the menu command Insert > SmartText, choosing the desired entry, and then 

clicking the Insert button. 

The Apply formatting option has the following meaning in this context: 

Off: Normally, this option is turned off. The SmartText entry is accordingly inser-

ted without formatting – it is rendered in the currently active font. 

On: On the contrary, if this option is turned on, the entry is inserted with the font 

type and size that you set in the dialog when you defined the SmartText entry. Text 

styles and font color are also reproduced. 

Editing SmartText entries 

You can edit SmartText entries that you have previously defined with the menu 

command Insert > SmartText as follows: 

 Creating a new SmartText entry 

 To create a new SmartText entry, click the New button (see section “Creating 

SmartText entries” beginning on page 347). 

 Deleting a SmartText entry 

 To delete an entry, select it from the SmartText entries list and then click on 

the Delete button. 
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 Renaming a SmartText entry 

 If you want to change the name of an entry, select it from the list and click on 

the Rename button. A dialog box appears, and you can enter the new name the-

re. 

 Editing a SmartText entry 

 To edit an entry, select it from the list and then click in the large input field. 

Now you can modify the content of the SmartText entry. 

 Furthermore, you can change the formatting by using the miniature formatting 

toolbar above the input field. Of course, the Apply formatting option must be 

enabled before you can do this. 

 When you have made the desired changes, click on the Save button. 

 Inserting a SmartText entry 

 To insert a SmartText entry into the text, select it from the list and click on the 

Insert button (see also section “Inserting SmartText entries” beginning on page 

349). 

To exit the dialog, click the Close button. If the active SmartText entry has been 

changed and not yet saved, TextMaker will ask automatically if it should save the 

changes. 
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Database 

TextMaker provides an easy to use dBase compatible database module. It is seam-

lessly integrated into the word processor and provides all the functions needed to 

manage addresses and other information. You can enter and edit data, search for 

specific items, and much more. 

In this chapter you will learn everything you need to know to work with databases 

in TextMaker. 

 Opening a database 

 In the first section you will learn how to open a database. You use the menu 

command Tools > Edit database for this. 

 Using the database module 

 Next, you will get acquainted with the powerful database module that is in-

tegrated into TextMaker. This module allows you to edit databases and also in-

cludes several expanded database functions – for selecting, sorting and deleting 

records, for example. 

 Importing individual addresses (via document templates) 

 Here you will learn how simple it can be to write everyday documents with 

TextMaker: You invoke the menu command File > New and choose one of the 

letter or fax templates supplied with the program. Now the database appears. 

Simply choose the desired address, click on Insert, and TextMaker sets up a 

letterhead with the address filled in. 

 Lists and labels 

FreeOffice: This feature is not included in SoftMaker FreeOffice. 

 It is almost as easy to create lists and labels with TextMaker. Address labels, for 

example: You choose the address database, place its fields in a large edit con-

trol, and select the label format from a list. That’s it – printing can begin. 

 Printing envelopes 

FreeOffice: This feature is not included in SoftMaker FreeOffice. 

 You can also print the address of sender and recipient of a letter on an envelope. 

All you have to do is to choose the paper format of the envelope and to specify 

the placement of the address database fields. 
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 Creating a new database 

 Although the database TMW.DBF supplied with the program is all that many 

users need to manage their addresses, TextMaker lets you define a new data-

base any time you want. Here you learn how. 

 Modifying the structure of a database 

 Apart from that, you can also modify the structure of existing databases. For 

example, you can add/remove fields and alter the properties of fields (name, ty-

pe length, etc.). 

 Importing a Thunderbird address book 

FreeOffice: The Thunderbird address book is not included in SoftMaker 

FreeOffice. 

 The command Convert Thunderbird address book enables you to convert an 

address book of the Thunderbird e-mail client into a database that can be used 

with TextMaker. 

 Form letters (covered in the next chapter) 

FreeOffice: Printing form letters is not included in SoftMaker FreeOffice. 

 Creating form letters in TextMaker is easy: you set up a letter in the normal 

way, place database fields in it and select the database records to be used. The 

form letter can then be printed. You will find information about this in the chap-

ter “Form letters” beginning on page 383. 

Opening a database 

To open a database in TextMaker, invoke the menu command Tools > Edit data-

base. A dialog box appears and TextMaker asks for the name of the database to be 

edited. Type the name or select a file from the list of databases displayed. 

Databases with the following formats are supported: 

File format Description 

dBase/DOS Database with DOS character set. This is the default format – 

see note below! 

dBase/Windows Database with Windows character set 
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dBase/Unicode Database with Unicode character set. This is a special variant 

of the dBase format, developed by SoftMaker, that supports 

complex scripts (Asian scripts, for example). However, apart 

from SoftMaker Office, only few programs support this for-

mat. 

To select a database format, open the Files of type list in the dialog mentioned 

above. 

Note: Most databases are stored in dBase/DOS format. Even most Windows 

database programs utilize the DOS format instead of the Windows format. 

If you are not sure whether a database contains the DOS or the Windows format, 

open the file as dBase/DOS and check if characters with accents (e.g. ‘ê’ or ‘ä’) are 

displayed correctly. If they are not, close the database and reopen it in 

dBase/Windows format. 

Using the database module 

When you open a database, as described in the previous section, TextMaker’s 

database module appears.  

The database module not only allows you to edit your databases, but also includes 

several expanded database functions. This section acquaints you with all the func-

tions this powerful module has to offer. 

Topics covered: 

 The database module’s main window 

 List and form view 

 Browsing through data records 

 Calling up a data record by its record number 

 Searching a database 

 Adding and editing data records 

 Deleting and restoring data records 

 Sorting a database 

 Closing a database 

See the next pages for details. 
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The database module’s main window 

Let’s assume that you open the database TMW.DBF (format dBase/DOS) that was 

supplied with the program. Under Windows, this file can be found in the SOFTMA-

KER folder under your documents folder. 

You are presented with a database window that looks something like this: 

 

The example database tmw.dbf (in form view) 

If a tabular list of data records appears instead of a form like the one pictured 

above, you can invoke the menu command View > Form to switch to the form 

view. 

If you like, you can use the example database TMW.DBF as your personal address 

database right away. It includes all the database fields needed to store addresses: 

SALUT_ADDR Form of address (e.g. “Mr.”) 

SALUT_BODY Salutation in a letter (e.g. “Dear Mr. Smith”) 
NAME1 First line for names (e.g. the last name) 

NAME2 Second line for names (e.g. the company name) 

FIRSTNAME First name 
STREET Street and number 

STATE_ZIP State and zip code  

CITY City 
PHONE Telephone number 

FAX Fax number 
REMARK1 First line for remarks 



 

Manual TextMaker Database  •  355 

REMARK2 Second line for remarks 

REMARK3 Third line for remarks 

What you now see on the screen is the first record in the database. It consists of 

several fields. A field is an individual part of a record, containing an item of infor-

mation, for example a first name. Together, the fields make up the record, which 

contains a person’s complete address. 

In the status bar (at the bottom of the program window) you can see the following 

information: 

 First, the number of the active data record (the record number) and the total 

number of records in the database are shown (“Record 1 of x”). 

 To the right of the record number, the following status information is displayed: 

 Deleted, if the record is marked for deletion 

 Selected, if the record is selected 

 For more information on selecting records, see section “Selecting data records” 

beginning on page 389. 

 At the very right, you can read the active field’s field type, which determines 

what entries are allowed in the field: 

Field type Allowed entries 

Character Any 

Numeric Numbers 

Date Date entries in the form MM/DD/YY (e.g., “06/24/18”) or 

in the form MM/DD/YYYY (e.g., “06/24/2018”) 

Logical Only (Y) for yes or (N) for no 

Memo Notes – these can be edited after pressing the (F9) key. 

 The maximum length of the field is displayed after the field type. 

 Which century? Notice when filling in a date field: if you enter the year as two 

digit number between 0 and 29, TextMaker automatically prefixes “20”. For 

year numbers between 30 and 99, TextMaker prefixes “19”. 

 Thus, the entry “01/01/29” is interpreted as 1/1/2029, the entry “01/01/30” as 

1/1/1930. 
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List and form view 

The database module can display databases in two different ways: 

 The list view offers the best overview of the database. Here you see several data 

records listed one after another in tabular form. 

 The form view is better suited to the inspection of individual data records. Here, 

the fields of a single data record are displayed in a form. 

Important: In list view, no data can be entered. This is possible only in form 

view. 

To switch between list and form view, invoke the menu command View > Form. If 

the form view is active, a check mark appears in front of this menu item. Otherwi-

se, list view is active. 

Tip: You can switch very quickly between these two views with the (F2) key. 

Moreover, a double click on a data record in list view displays the record in form 

view. 

Browsing through data records 

Both keys and icons are available for moving among the data records of a database: 

Key Icon Function 

(PgUp½) 
 Go to the previous data record (in list view: to the pre-

vious page) 

(PgDn¼) 
 Go to the next data record (in list view: to the next 

page) 

(Ctrl)(Alt)(PgUp½) 
 Go to the previous selected data record 

(Ctrl)(Alt)(PgDn¼) 
 Go to the next selected data record 

(Ctrl)(PgUp½) 
 Go to the first data record 

(Ctrl)(PgDn¼) 
 Go to the last data record 
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Calling up a data record by its record number 

The Data record number (record number for short) is a simple counter. The first 

data record has the number 1, the tenth 10, etc. The record number of the active 

data record is displayed at the lower left in the status bar. 

You can call up a data record in the database module directly by means of its re-

cord number. To do this, use the menu command Go to > Record number. 

A dialog box appears; you enter the number of the desired record there and confirm 

with OK. The corresponding data record is then brought up. 

 

This is even quicker if you click with the mouse on the record number shown in the 

toolbar and simply type in the number of the desired record. 

Searching a database 

With the help of the menu command Edit > Search you can search for an item in 

the database currently opened in the database module. 

The search function can also be invoked with the  icon in the Standard toolbar. 

 

When you enter a search term and confirm with OK, TextMaker begins searching. 

As soon as the term is found in a data record, TextMaker displays the record and 

terminates the search process. 
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Continuing the search 

To display the next record in which the term is found, click the  icon in the 

toolbar or invoke the menu command Edit > Search again. 

Notes on search terms 

Date fields: If you want to search for date entries in data records, you must enter 

them in the format MM/DD/YYYY – so for e.g. September 25, 2018, you must 

type 09/25/2018.  

Memo fields: Memo fields cannot be searched. 

Wildcard searches with “?”: By entering one or more question marks within the se-

arch term you can widen the search. The question mark represents any character. 

Thus, in a search for “Me?er”, for example “Meier” and “Meyer” will be found. 

Options in the Search dialog 

You can modify the search with the options in the Search dialog, as follows: 

 In Field 

 Select the All fields option when all fields in the database are to be searched. 

Alternatively, you can select a specific field, when only this field is to be sear-

ched. 

 Search from beginning 

 If this switch is activated, TextMaker begins the search at the first data record; 

thus it will search the complete database. Otherwise the search begins with the 

active data record. 

 Search backwards 

 If this switch is activated, the database is searched in reverse record order. 

 Case sensitive 

 If this switch is activated, the search engine takes account of the case of the 

characters in the search term. Thus, in a search for “House,” only “House” 

would be found – not “HOUSE,” “house,” etc. 
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 Search only selected records 

 If this switch is activated, only the selected data records are searched; otherwise 

all are searched (see also section “Selecting data records” beginning on page 

389). 

 Accuracy 

 Specifies how closely the content of a field must agree with the search term: 

 Search term anywhere in the field: Finds all data records in which the search 

term occurs anywhere in the fields being searched. 

 Field begins with the search term: Finds only those data records in which the 

search term occurs at the beginning of the search fields. So, if you search for 

“Fish”, only records with “Fish” at the beginning of a field are found (inclu-

ding, for example, records in which a field begins with “Fisher”, but excluding 

records in which a field contains “Ralph Fisher”). 

 Field matches the search term: Here, the search function finds only data re-

cords in which the field content corresponds completely with the search term. 

So, if you search for “Fish”, only records with fields containing just “Fish” are 

found; records with fields containing “Fisher” are not. 

Adding and editing data records 

Important: Data records can be changed only in the database module’s form 

view. To switch between list and form views invoke the menu command View > 

Form. If form view is active, a little check appears in front of this menu item; 

otherwise, list view is active. 

To edit a data record, simply position the text cursor in the desired data field and 

make your changes. You can move to the next field with the (Tab) key, to the previ-

ous field with (Shiftª)(Tab). 

Note: To save changes to a data record, you do not have to invoke any special 

command, because changes to the active data record are saved automatically 

when you page to another record or exit the database. 

Adding a new data record 

If you want to expand your database to include an additional entry, invoke the 

database module menu command Edit > Append record. 
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This command can also be invoked with the  icon in the Database toolbar. 

TextMaker adds an empty data record to the database and positions the text cursor 

in the first field of the record. You can immediately begin filling in the record. 

New records are always added after already existing records. 

Duplicating a data record 

With the menu command Edit > Duplicate record you can create the duplicate of 

a data record. To do this, page to the desired record and then invoke the command. 

Duplicated data records are always added at the end of the database, just like newly 

defined data records. 

Deleting and restoring data records 

Data records that are no longer needed can be deleted at any time in the database 

module. 

Deleting a data record 

To delete a data record, invoke the menu command Edit > Delete current record. 

This function can also be invoked with the  icon on the Standard toolbar. 

Please note that the data record is not immediately deleted, but only marked for 

deletion. Deletion of all data records marked for deletion actually takes place when 

the database is compressed with the menu command Edit > Compress database 

(see below). 

Deleting all selected data records 

With the menu command Edit > Delete selected records you mark all currently 

selected records for deletion. This is useful when you want to delete a large number 

of records. 

Working with selections is described in section “Selecting data records” beginning 

on page 389. 
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Show deleted records? 

By default, the option View > Show deleted records in the menu is turned on, 

meaning that even data records marked for deletion are viewable. As a visual indi-

cation that a record is deleted, the word Deleted appears in the status bar. 

However, you can deactivate the option View > Show deleted records at any time 

to hide all records that are marked for deletion. 

Restoring deleted data records 

If you have marked a data record for deletion by mistake, simply apply the menu 

command Edit > Delete current record to it a second time to remove the deletion 

marking. The disappearance of the word Deleted in the status bar indicates the 

removal of the marking. 

You can remove the deletion marking on all data records currently marked for de-

letion with the menu command Edit > Restore deleted records. 

Permanently removing deleted data records (“compressing” a database) 

If you want to actually remove all the data records marked for deletion, have 

TextMaker compress the database. The menu command Edit > Compress data-

base is responsible for this. After querying you, it permanently removes all the 

records marked for deletion from the database file. 

Sorting a database 

If you want to sort a database, invoke the menu command Edit > Sort database in 

the database module. 

This function can also be invoked with the  icon on the Standard toolbar. 
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Normally, you choose just one field as the basis for the sort; however, you can also 

sort on two fields. For example, to sort the all the records by last name, and the 

records containing the same last names by first name, select NAME1 under Field 1 

and FIRSTNAME under Field 2. 

As soon as you confirm with OK, the data records are sorted and the database is 

saved in the new order. 

Note: When sorting a database, the data records are physically reordered in the 

database. This action cannot be undone. 

Closing a database 

When you want to close the currently opened database, invoke the menu command 

File > Close. The database is automatically saved and then closed. 

Alternatively, you can use the menu command File > Copy record and close, 

which does the same thing, except that it first copies the contents of the active data 

record into the clipboard. 

The menu command File > Insert record and close is only available when the 

database was invoked through a document template, a topic covered in section 

“Importing individual addresses” beginning on page 362. 

Importing individual addresses 

What is a word processor most often called on to do? To quickly write letters or 

faxes. You have purchased TextMaker precisely for such routine work, and you 

will find it to be an especially efficient helper. 



 

Manual TextMaker Database  •  363 

All you need for such tasks is a suitable document template – that is, a document 

template to which an address database is assigned to, and in which database fields 

are inserted. Several such templates (for letters, faxes, memos, etc.) and a suitable 

database come with TextMaker. 

When you start a new document (e.g. with the File > New menu command) and 

select such a template, TextMaker automatically displays the database. Page 

through it to find the desired recipient and click on Insert. The rest happens auto-

matically. TextMaker replaces the database fields in the template with the contents 

of the fields from this record – in other words: the address is inserted into the text. 

The result is, for example, a complete letterhead with the recipient’s address al-

ready filled in. 

On the following pages you will find detailed explanations of these procedures. 

Preparing a document template 

Note: To compose a letter or fax as quickly as possible, you don’t have to pre-

pare a document template from scratch. Numerous document templates with let-

terheads, fax forms and memo forms are already supplied with TextMaker. Read 

the section “Using document templates” on page 364 to learn how you can try 

them out without further ado. 

To prepare a new document for the insertion of individual addresses, proceed as 

follows: 

1. Invoke the menu command File > New and select the template NORMAL.TMVX 

to start a new document. 

2. Fill the document with the desired text – for example, prepare a letterhead, a 

fax form, etc. 

3. Assign the desired database to the document using the menu command Tools > 

Set database – for example the address database TMW.DBF supplied with the 

program. 

4. At the desired positions in the document, invoke the menu command Insert > 

Field to insert database fields from the assigned database (see also section 

“Inserting database fields” beginning on page 386). 

5. Invoke the menu command File > Save as. 

6. Select the Template entry from the Save as Type list. 

7. TextMaker changes automatically to the folder for document templates. 
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8. Type a name for the template in the File name edit box, and confirm with OK. 

In general, you proceed as if you wanted to create a form letter (but without ente-

ring the text of the letter), and then save the letter as a document template. 

If you want to learn more about document templates, read through the basic in-

structions in section “Document templates” beginning on page 149. To view an 

example, you can open one of the document templates supplied with the program. 

Using document templates 

The use of a document template with a database assigned is very simple: begin a 

new document (e.g. by invoking the menu command File > New). TextMaker will 

ask you what template to use as a basis for the document. 

If, at this point, you select a template that has a database assigned to it, TextMaker 

displays this database and lets you choose the data record to be inserted into your 

text. You page to the desired record and then click on the Insert button. 

Here is the step by step procedure: 

1. Invoke the menu command File > New. 

2. Choose one of the document templates that have a database attached – either a 

template that you have prepared or one of the templates supplied with the pro-

gram. Then, click on the OK button. 

3. A dialog displaying the respective database opens. 
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 Tip: The two options in the bottom right of the dialog allow you to switch 

between List and Form view. 

4. Browse to the data record for the recipient. 

 You can also enter a new address by first clicking the Append button to append 

a new record and then typing in the address. 

 (For detailed instructions on this dialog see below.) 

5. Click on the Insert button. 

At each place in the template where there is a database field, TextMaker now inse-

rts the content corresponding to that field from the chosen data record. 

The result is, for example, a letterhead completely filled out with the address of the 

letter’s recipient. All you have to do now is write the text of the letter and then 

print the document. To do this, invoke the menu command File > Print – not File 

> Print merge. 

Tip: In the dialog box for the menu command File > New you will see some fol-

ders. Any of them can be opened with a double click. They contain preformatted 

document templates for writing letters, faxes, etc. Most of these templates are 

associated with the example database TMW.DBF that is supplied with the program. 
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Detailed instructions on the database dialog 

In detail, the database dialog mentioned above has the following functions: 

Data display 

The largest part of the window is devoted, of course, to the display of data. You can 

work with data either in tabular form, using the list view, or in more detail using 

the form view. To switch between these two views, use the options List and Form 

in the lower part of the window. 

You can use the usual keys to navigate.  

Note: Please note that editing of data is possible only in the form view. 

To save changes to a data record, you do not have to invoke any special command, 

because changes to the active data record are saved automatically when you page 

to another record or exit the database. 

Filter 

You can filter the data records as necessary. To do this, enter a search term in the 

Filter input field and click the Apply button. The display of data changes immedi-

ately: only those data records are displayed that contain the search term (in any of 

their fields). 

So, if you filter for “Miller”, only records containing “Miller” will be displayed. 

“Insert” button 

Inserts the content of the active record into the document. Only available when the 

database was invoked through a document template, as described above. 

“Close” button 

Saves all changes made to the database and exits the database module. 
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“Search” button 

Invokes a search dialog, with which you can search for specific data more precisely 

than you can with a filter (see above). You will find information about this dialog 

in section “Searching a database” beginning on page 357. 

“Find next” button 

Displays the next record containing the search term. 

“Append” button 

Adds a new record to the database. 

List/Form 

With the options List and Form you can switch between list view (several data 

records in sequence) and form view (one complete record in detail). 

Lists and labels 

FreeOffice: This feature is not included in SoftMaker FreeOffice. 

With the Insert > List/Label menu command, you can easily prepare list and la-

bels of all kinds. In most cases, this command is used to create address labels filled 

with addresses stored in a database. (For general information on working with 

databases, see the first sections of the chapter “Database”, beginning on page 351). 
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Apart from labels, you can also use this command to create lists and tables in order 

to display the contents of a database. The differences: 

 Labels: For producing labels, for example, address labels containing one 

address (from a database) per label.  

 Lists: For producing lists, for example, address lists containing one address per 

line – e.g. “Thomas Jones, 42 Park Avenue, Sun City, ....”.  

 Tables: Similar to lists, with the data distributed over the cells of a table (one 

address per cell). 

Working with lists and labels is easy. To create e.g. address labels, invoke the 

List/Label command. In its dialog, first specify the database to use (i.e. the data-

base containing the addresses). Then add its database fields to the large edit control 

in the dialog – in exactly the way they should later appear in the printout (see 

screenshot above). Finally, select the label format from a predefined list. That’s it – 

printing can begin. 
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Tip: The Manage button in the dialog allows you to save label definitions (that 

is, all settings made in the dialog) and retrieve them any time later. This also 

works with lists and tables.  

Creating lists/labels 

To create e.g. labels, proceed as follows: 

1. Invoke the Insert > List/Label menu command. 

2. Under Output as, choose what to create: Label, List, or Table. In our example, 

you would select Label. 

3. If you would like your labels to contain the contents of a database, click on the 

Database button and choose the desired database– for example the address 

database TMW.DBF supplied with the program. 

4. The large edit field found in the upper part of the dialog serves as a “mask” for 

designing the label. Use it to add database fields and/or any regular text – ar-

ranged as they should appear later when the labels are rendered.  

 To insert a database field, click on the Database field button. A list of all fields 

in the database will be displayed. Click on a field in the list to insert it. 

 The miniature formatting toolbar above the edit field allows you to change the 

text format (font, text emphasis, color, etc.). Select the text of interest before-

hand. 

 When you have finished filling out the edit field, proceed as follows: 

5. Only when creating labels: Click on the Format button and choose the format 

of the labels to be created. The button opens another dialog where you can sel-

ect the manufacturer and product number of the label from pre-defined lists. 

 In case you are using a label that is not included in the lists, you can specify a 

new label format by clicking on the New button and entering the measurements 

of the label. (For details, see the section explaining the individual dialog opti-

ons below.) 

6. Set up the other dialog options to your liking (see below). 

7. When done, press one of the following buttons: 

 Print: Prints the labels. (The usual Print dialog will appear.) 
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 New document: Creates a new document with the (filled out) labels instead of 

printing them. 

 Manage: This button allows you to save label definitions (that is, all settings 

made in this dialog) and retrieve them any time later. This also works with lists 

and tables. (More information on this can be found at the very end of this sec-

tion.) 

Lists and tables can be created the same way; however, some of the dialog options 

are available only for labels. Also, the Print button will be replaced by an Insert 

button here. This button will insert the list/label into the document at the current 

position of the text cursor. 

Dialog options 

In detail, the dialog box for this command contains the following options: 

 Large edit field  

 The large edit field in the upper part of the dialog allows you to specify what to 

display on the label (or list/table). The screenshot at the beginning of this sec-

tion shows an example. 

 You can add text by simply typing it in.  

 Database fields can be inserted as well (given a database has been chosen al-

ready, using the Database button). To insert a field, click on the Database field 

button and choose the desired field. Alternatively, simply type in the field’s 

name with enclosing curly braces (e.g. {CITY}).  

 The miniature formatting toolbar above the input field can be used to change 

the text formatting. Select the text of interest beforehand. 

 Output as 

 Here you can specify if the command should create labels, a list, or a table.  

 Format 

 With labels only: In this section, the currently selected label format is display-

ed (manufacturer, product name, number of rows/columns). 

 To choose a different format, click on the Format button and pick the label’s 

manufacturer and product name from the lists. If required, you can also modify 

the margins to be left blank on each (individual) label. 
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 In case you are using labels that are not contained in the lists, click on the New 

button to create a user-defined label format. If known, specify the manufacturer 

name and product name/number. Then, use a ruler to measure the labels and en-

ter the resulting values into the dialog. 

 The picture below shows how some of the values are related: 

  

 The Edit button allows you to modify existing user-defined label formats. The 

pre-defined formats are not available for editing. However, you can always cre-

ate a new user-defined label format based on an existing format by selecting the 

format in the list and clicking the New button. 

 The Delete button deletes the selected user-defined format. 

 “Database” button 

 Lists and labels are often used to output the contents of a database. When you 

click on the Database button, you can specify which database to use – for exa-

mple the address database TMW.DBF that was supplied with the program. 

 “Database field” button 

 For adding database fields. Clicking this button opens a list of all database 

fields available in the selected database. When you click on one of these fields, 

it is inserted into the large edit field located in the upper part of the dialog. 

 “Database” section 

 In this section, the name and path of the currently selected database is displayed 

(see Database button above).  

 Below you can select which database records to appear in the result: All, only 

the Selected records (see section “Selecting data records” beginning on page 

389) or a Range of records that you specify with the record numbers for the 

first and last records in the range. 
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 “Options” section 

 This section changes depending on the chosen Output as option: 

 Label: 

 With labels, this section contains options related to outputting the labels, 

including: 

 Full page with the current label: When you activated this option, a whole 

sheet of labels will be output for each individual label, containing identical 

copies of the label. This is useful for simple labels with fixed text (not using 

a database) when you want to print whole sheets of one label at once. 

 Copies: Determines how many copies of each individual label to generate. 

 Start row/column: Here you can specify in which row/column on the first 

sheet of labels the output should start. This is useful when reusing label 

sheets where some labels have already been used. 

 List: 

 There are no options for lists. 

 Table: 

 For tables, the following options are available: 

 Row height: Here you can set the height of the table rows: Auto (determine 

optimum height automatically), Exact (specify the exact height), or At least 

(specify the minimum height, but allow each row to grow automatically if 

more space is needed). 

 Columns: Here you can specify the number of columns the table should 

contain.  

 “Print” button, or “Insert” button 

 When creating labels, a Print button will be available in the dialog. Pressing it 

gets you directly to the print dialog where you can the start printing the labels. 

 When creating lists or tables, this button is replaced by a button named Insert. 

Pressing it inserts the list/label into the current document. 

 “New document” button 

 Pressing this button will create a new document containing the filled out labels 

(or list/table) – exactly like they would appear in the printout. 
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 “Manage” button 

 This button allows you to save label definitions (i.e. all settings made in this 

dialog) and retrieve them any time later. It will open a dialog with the following 

buttons: 

 Save: Saves the label definition (i.e. all settings made in this dialog), after as-

king you to give it a name.  

 Load: Retrieves the label definition currently selected in the list. 

 Delete: Deletes the selected label definition. 

 Rename: Allows you to enter a new name for the selected label definition. 

 The above of course not only works with labels but also with lists and tables. 

Printing envelopes 

FreeOffice: This feature is not included in SoftMaker FreeOffice. 

In order to address a letter, you can either create an address label (see the previous 

section) or you can let TextMaker print the address directly on the envelope. 

To do this, proceed as follows: 

1. Invoke the Insert > Envelope menu command. 

2. Click on the Paper settings button, specify the paper format of the envelope, 

and click on OK. 

3. In the Sender field, enter your own address. 

4. In the Recipient field, enter the recipient’s address.  

 You can type the address in manually or use database fields from your address 

database. To insert a database field, click the Database field button to open a 

field list, and then choose the field to insert. 
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5. When finished, click one of the following buttons: 

 Create new document: Creates a new document containing the envelope. 

 Append to document: Appends the envelope to the end of the current 

document. 

 Print envelope: Just prints the envelope and discards it afterwards. 

6. If you have inserted database fields, TextMaker now displays the address data-

base. Browse to the desired recipient and click the Insert button. 

The envelope will now be created and filled out. 

Note that the above settings have to be specified just once. From now on, TextMa-

ker remembers the paper format and the placement of the database fields. Of cour-

se you can change these settings whenever you like. 

In detail, the following options are available in the Envelope dialog: 

Sender 

Use this field to enter the sender’s address. 

The  icon displayed above the field can be used to change the font that will be 

used to print the address. 
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Recipient 

Use this field to enter the recipient’s address. 

Hint: It is recommended to use database fields from your address database for 

this. To insert a database field, click the Database field button to open a field 

list, and then choose the field to insert. 

If you have not yet selected the database to use, you first have to click the Data-

base button and select the desired database. 

The  icon displayed above the field can be used to change the font that will be 

used to print the address. 

Sender position 

Here you can change the position of the sender’s address on the envelope (relative 

to the top left corner). 

Recipient position 

Here you can change the position of the recipient’s address. 

Recipient margins 

Here you can change the right and the bottom margin of the recipient’s address. 

Paper settings button 

This button opens an additional dialog where you can specify the paper format of 

the envelope. 

Options available: 

 Use the Envelope type list to specify the paper size of the envelope. The list 

contains all paper sizes supported by the current printer. If you want to specify 

a size that is not listed, enter its dimensions manually in the Width and Height 

fields. 
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 If your printer has multiple paper trays, you can use the Paper bin option to 

select which one to use when the envelope is printed. (This option is available 

under Windows only.) 

 Under Envelope orientation, specify how envelopes have to be inserted in 

your printer’s tray (left-aligned, centered or right-aligned; rotated or not ro-

tated). 

 If required, you can also specify an Additional offset (in case the printout is 

not placed exactly where it should). 

Hint: When you have saved an envelope that you created with this command as a 

document, you can always edit these settings: Choose the File > Page setup menu 

command, switch to the Page Format tab, and click on the Envelope Settings 

button at the very bottom of the dialog. 

Creating a new database 

With TextMaker you can not only use existing databases, but also create new data-

bases. 

To do this, proceed as follows: 

1. Invoke the menu command Tools > Create database. 

2. In the associated dialog, define the first database field. 

 To do this, give the field a unique Name, select the appropriate field Type and 

the desired Length, and (only for numeric fields) enter the desired number of 

decimal places at Decimals. Explanations of the available choices are given 

further down. 

3. When you have made all the specifications for a field, click on Append to add 

the field after the last field you defined.  

 If other fields are already defined, you can instead click on Insert to insert the 

new field ahead of the currently active field. 

4. Repeat the last two steps for every additional field that the database is to com-

prise. You can set up as many as 256 fields, provided that the lengths of all of 

them do not exceed 4000 characters in total. 

5. When all the fields have been entered to your satisfaction, click on the Create 

button. 
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6. Another dialog appears, asking you to specify the filename and location for the 

database to be created.  

7. When done, confirm with OK. 

The database will now be created and opened.  

Tip: If you have made a mistake while entering the definition of a field and you 

recognize it after already having clicked the Append button, you can go back and 

correct the error. To do this, double click in the Fields list on the affected field, 

make the correction and click on Replace. With Delete you can completely remove 

a field that has been entered incorrectly. 

Notes about the field type 

With the field type, you specify what kind of data can be entered into the field. The 

field types are as follows (the allowed length for each field is given in parenthe-

ses): 

Field type (length) Allowed input 

Character (1 to 254) Character fields allow any type of input. 

Numeric (1 to 19) Numeric fields accept only numbers as input. You can set 

the desired number of decimal places with Decimals. 

You can perform calculations on the contents of such 

fields (see chapter “Calculations in the text” beginning 

on page 395). 

Date (always 8) Date fields are intended for date entries. 

Logical (always 1) Logical fields are intended for yes/no entries. The allo-

wed entries are limited to (Y) for “Yes” or (N) for “No”. 

Memo (always 10) Memo fields are a bit different compared to “normal” 

fields. They accept any type of input and allow you to 

enter additional notes for a data record. However, what 

you enter in these fields can only be viewed and edited in 

the database module – you can neither insert such fields 

into a document, nor print them out. The width is always 

given as 10, but in fact you can enter up to 4000 charac-

ters. 
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Tip: For numeric entries like telephone numbers, zip codes, etc. select “Charac-

ter” rather than “Numeric”. Here, numeric fields provide no advantages – on the 

contrary: If you try to enter a telephone number like “001-555-55555” in a nu-

meric field, TextMaker will not allow the “-”, since only numerals are allowed; 

also, the leading zeros will be automatically removed. 

Notes on the supported database formats  

Databases that you create with TextMaker are stored in dBase format, a widespread 

database format supported by many database applications. 

The dBase format comes in different variants. When you use the Tools > Create 

database menu command, you can choose the desired variant by selecting it in the 

Files of Type list in the file dialog displayed as soon as you click on the Create 

button. 

The following variants are supported: 

File format Description 

dBase/DOS Database with DOS character set. This is the default format – 

see note below! 

dBase/Windows Database with Windows character set 

dBase/Unicode Database with Unicode character set. Please note that this 

format is not dBase compatible (see below)! 

Note: Most databases are stored in dBase/DOS format. Even most Windows 

database programs utilize the DOS format instead of the Windows format. 

Note on the dBase/Unicode format 

Besides the common dBase/DOS and dBase/Windows format, TextMaker also 

supports databases in dBase/Unicode format. 

This is a special dBase format, developed by SoftMaker, that supports complex 

scripts (Asian scripts, for example). Thus, you can store e.g. Chinese text in this 

format (which is not possible with dBase/DOS and dBase/Windows format). 

However, please note the following limitation of the dBase/Unicode format: 
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Important: Databases in dBase/Unicode format are not dBase compatible. Apart 

from SoftMaker Office, only few programs support this format. Therefore, you 

should use this format only if you need to create a database that supports the 

Unicode character set (because you want to enter, for example, Asian characters) 

and intend to use it with SoftMaker Office only. 

Modifying the structure of a database 

The previous section provided information on how to create new databases. In this 

section, you will learn how to modify the structure of existing databases. For exa-

mple, you can add/remove fields and alter the properties of fields (name, type, 

length, etc.). 

To do this, proceed as follows: 

1. It is always a good idea to create a backup copy of your database before making 

changes to its structure.  

2. Invoke the menu command Tools > Modify database structure. 

3. A file dialog appears. Choose the database of interest and confirm with OK. 

4. A dialog very similar to the dialog of the Create database command opens, 

presenting all fields contained in the database. Use this dialog to make the desi-

red changes to the structure of your database. (For details, see below.) 

5. When finished, click on the Save as … button. 

6. Another file dialog appears, allowing you to alter the filename and location of 

the resulting database. By default, the filename and location of the original 

database is suggested. 

Note: If you proceed without changing the default settings given in this dia-

log, the original database will be overwritten.  

7. Confirm with OK. 

Your changes will now be applied. 
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Note: When changing the structure of a database, it is recommended to open the 

database afterwards and do a quick check of the results. Whenever you apply a 

huge number of changes of all types to a database at once, it might happen that 

the contents of certain fields are not transferred. In that rare case, restore the ba-

ckup copy of your database and apply your changes once more – but this time, 

do this in multiple steps instead of performing all changes at once. 

Operating the “Modify database structure” dialog 

Hint: A list of all available field types, together with their properties, can be 

found in the section “Creating a new database” (page 376). 

The dialog of the Modify database structure command allows you to perform the 

following actions: 

 Adding a field 

 To add a field to the database, type in a unique Name for the field, select the 

appropriate field Type and the desired Length, and (only for numeric fields) 

enter the desired number of decimal places at Decimals.  

 When you have made all the specifications for a field, click on Append to add 

the new field below the last field. Alternatively, click on Insert to insert the 

field above the current field. 

 Modifying a field 

 To modify the properties of a field (name, type, length, etc.), double-click on 

the field in the Fields list. Its properties will be transferred into the controls 

displayed at the bottom of the dialog, where you can edit them. When finished, 

click on Replace to apply your changes. 

 Deleting a field 

 To delete a field, select it in the Fields list and click on Delete. 

Importing a Thunderbird address book 

Note: This feature is not available in the Android version. 
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FreeOffice: The Thunderbird address book is not included in SoftMaker Free-

Office. 

The command Convert Thunderbird address book enables you to convert an 

address book of the Thunderbird e-mail client into a database that can be used with 

TextMaker. For example, you can open the resulting database in TextMaker’s data-

base module, use it with form letters, etc. 

Proceed as follows: 

1. Invoke the menu command Tools > Convert Thunderbird address book in 

TextMaker. 

2. A dialog box appears, in which you can change some settings related to the 

conversion (see below).  

When you confirm, TextMaker converts the address book into a database file and 

stores it in the specified folder. 

If you have set the output format to “dBase (*.dbf)”, you will be able to open the 

resulting database in TextMaker’s database module (using the Tools > Edit data-

base menu command). Also, you can choose this file as the source database for 

form letters, lists, labels, etc. 

Dialog options 

The options in the dialog box for this command are as follows: 

 Location of the Thunderbird address book (abook.mab) 

 Here you can specify the location of the Thunderbird address book file to be 

converted. 

Hint: If Thunderbird is installed on your device, TextMaker will find the cor-

rect path and filename of this file automatically. In that case you can simply 

adopt the suggested setting. 

 Alternatively, you can specify a path and filename manually.  

 Hint: If necessary, you can use the command Help > Troubleshooting Infor-

mation in Thunderbird to find out the location of the user profile folder for the 

current user profile. The address book file abook.mab is found in the same fol-

der.  
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 Include fields that are empty 

 This option has the following effect: 

 Off: If the option is turned off, fields that are empty in the entire address book 

will automatically be omitted during the conversion. 

 On: If the option is turned on, even such empty fields will appear in the output 

file. 

 Output format 

 Allows you to change the output format of the resulting file: 

 dBase (*.dbf): If you choose this option, the result of the conversion will be 

stored in a dBase database file. The dBase format is the standard format for 

databases in TextMaker. 

 Note: The resulting database will be created in “dBase/Unicode” format. This is 

a special variant of the dBase format, developed by SoftMaker, that supports 

complex scripts (Asian scripts, for example). However, apart from SoftMaker 

Office, only few programs support this format. If you open such a file in 

another application, accented characters may be displayed incorrectly. 

 Text file (*.csv): If you choose this format instead, a plain text file in CSV 

format will be created. CSV stands for “comma separated values”, meaning that 

a comma will be inserted as a separator between each of the database fields. 

 Name of the destination file 

 Use this option to change the folder and file name of the output file. 
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Form letters 

FreeOffice: Printing form letters is not included in SoftMaker FreeOffice. 

You find form letters in your mailbox almost every day – among them: advertise-

ments from lotteries, mail-order companies, etc. 

 

A form letter – the addresses will appear in the fields {FIRSTNAME}, {NAME1}, etc. 

Of course form letters can also be used for other things. How would you go about 

sending written invitations to all the members of your bowling team, for example? 

Normally, you would type the text of the letter, type the first member’s address in 

the letterhead, and print the letter. Then you would put in the next member’s 

address and print it again, etc. 

It is precisely this repeated manual entry of the addresses that TextMaker can take 

over when you create a form letter for the invitation. 

In general, you create a form letter as follows (you will find detailed information 

on the following pages): 

1. If you have not yet recorded the addresses of the recipients in a database, create 

or open a database and enter the addresses in it. The database TMW.DBF that is 



 

384  •  Form letters Manual TextMaker 

included with the program is very well suited for recording addresses; however, 

you can use any database you wish. 

2. Start a new document. 

3. Use the menu command Tools > Set database to assign the address database to 

the document. This is necessary so that TextMaker knows what addresses it 

should merge in later. 

4. Compose the text of the letter. 

5. Use the menu command Insert > Field > Database field to insert fields from 

the database (e.g. name, street, city, etc.) at the places where the address should 

appear in the printed document. 

6. If you don’t want to write to all the addressees: Open the database with the 

Tools > Edit database menu command and select the addresses you want in-

cluded. 

7. Print the letter using the File > Print merge menu command. 

When it prints, TextMaker replaces the database fields with the data from the data-

base – record by record. Accordingly, the data from the first data record are used 

for the first letter, the data from the second record for the second letter, etc. 

The following sections describe each of the required steps in detail, from the crea-

tion of a form letter to the sending of the completed document to a printer. The 

following topics are covered: 

 Assigning a database to a document 

 Inserting database fields 

 Viewing test records in the text 

 Practice letter 

 Selecting data records 

 Printing form letters 

Assigning a database to a document 

Before you insert the fields of a database into a form letter, you must tell TextMa-

ker which database is being referenced by assigning a database to the document. 
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To do this, invoke the menu command Tools > Set database. A dialog box appears, 

allowing you to select the database. Type the name of the desired database or choo-

se a file from the list of databases displayed. 

Databases with the following formats are supported: 

File format Description 

dBase/DOS dBase database with MS-DOS character set. This is the stan-

dard format – see note below! 

dBase/Windows dBase database with Windows characters set 

dBase/Unicode dBase database with Unicode characters set 

Text file Text file in which each line contains a data record and the 

field contents of each record are separated by semicolons 

Text file/DOS Also a text file, but with an MS-DOS character set rather 

than a Windows character set 

You specify the file format by opening the dialog’s Files of type list box and choo-

sing the desired format from the list. 

Note: Most databases are stored in dBase/DOS format. Even most Windows 

database programs utilize the DOS format instead of the Windows format. 

If you are not sure whether a database contains the DOS or the Windows format, 

open the file as dBase/DOS and check if characters with accents (e.g. ‘ê’ or ‘ä’) are 

displayed correctly. If they are not, close the database and reopen it in 

dBase/Windows format. 

As soon as you have selected a database and confirmed with OK, TextMaker 

knows the database from which you want to insert fields, and you can proceed as 

described in the next section. 

TextMaker remembers which database has been assigned to the document as soon 

as you save it. The next time you open the document this database is again assig-

ned to it. Of course, you can assign a different database to the document any time 

you like. 

Detaching a database 

You can detach a database by invoking the menu command Tools > Set database 

and clicking on Clear database. 
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Inserting database fields 

Once you have decided how you want to position the relevant database fields in 

your form letter, you can insert them in the text with the menu command Insert > 

Field. When the letter is printed, these fields will be replaced with the actual con-

tents of the fields from the database, record by record. 

Specifically, you proceed as follows to insert a database field: 

1. Move the text cursor to the desired position. 

2. Invoke the menu command Insert > Field. 

3. In the list box Field type, select the item Database field.  

4. Now you can select the field to be inserted from the list box Field name. 

5. When you click on Insert, TextMaker inserts the field into the text and displays 

the field name in curly braces – {NAME}, for example. 

Proceed in exactly the same way to insert additional database fields at other places 

in the text until the form letter has the desired appearance. 

Database fields can be formatted like normal text; so, you can give them different 

fonts, sizes, etc. any time you like. 

When the form letter is later printed, TextMaker will automatically wrap lines with 

database fields correctly, taking into account that the actual text of the field varies 

from record to record. 

Viewing test records in the text 

Normally, TextMaker displays database fields that have been inserted into the text 

in the form of a field name enclosed by curly braces – for example: 

{NAME} 

To see how the form letter will really look when it is printed, you can instruct 

TextMaker to display the content of the field from any database record you like, 

rather than the field name – provided that a database has first been assigned to the 

document with the menu command Tools > Set database. 

Once this has been done, invoke the File > Properties menu command and switch 

to the dialog’s View tab. Make sure that the option Display field names is not che-
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cked. Then check Show merge record and next to it enter the number of the data-

base record whose field contents are to be displayed. 

Note: If you now invoke the File > Print merge menu command, the letter will 

be rendered using all the selected data records, just as before. On the other hand, 

if you invoke the File > Print menu command, TextMaker will print only a sin-

gle letter, using the address in the record you selected for display. 

Using the Mail Merge toolbar 

Displaying test data records is substantially easier if you enable the Mail merge 

toolbar. To do this, invoke the menu command View > Toolbars and activate the 

Mail merge toolbar in the Toolbars list box. 

The Mail merge toolbar is brought up in response. 

 

You can use this toolbar as follows: 

 To page from record to record, click on the arrows at right and left . 

 To display a specific record, enter its record number in the edit box in the midd-

le and press the Enter key (¢). 

 When you want to see the field names again, instead of the test data records, 

page to data record 0 or enter a “0” in the edit box and press the Enter key (¢). 

In response, TextMaker unchecks the Show merge record option. 

Tip: When you move the mouse pointer over one of the icons (without clicking) 

a text box appears, indicating the function of the icon. 

Practice letter 

Practice makes perfect. Therefore, in this section we want to create a form letter for 

practice. 

Before you begin, start a new document with the menu command File > New. As-

sign the example database TMW.DBF that was provided with the program to this 

document, using the menu command Tools > Set database. Under Windows, this 

file can be found in the SOFTMAKER folder under your documents folder. 
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Then, type the following text. Naturally, you are free to abbreviate it, or to type 

something completely different. What matters is simply this: 

Important: Do not type those parts of the text that are enclosed in curly braces – 

they represent database fields. Instead, whenever you get to one of them, invoke 

the menu command Insert > Field, select the item Database field in the Field 

type list box, select the field name in the Field name list box and then click on 

Insert. In this way, the database fields will be entered into the text. 

The Society of Calligraphers 

  

  

  

{FIRSTNAME} {NAME1} 

{STREET} 

{CITY}, {STATE_ZIP} 

  

  

  

{SALUT_BODY}, 

  

We are pleased to announce that the Society of Calligraphers 

will no longer have to rely on handwriting for its official 

communications. 

  

We have decided to convert everyone in the office to 

personal computers. We are now using TextMaker, which has an 

integrated database, allowing us to send personalized form 

letters to all our members. 

  

All in all, TextMaker provides enormous savings in time and 

cost – not to mention quills and ink... 

  

With best regards, 

Now you have created a “template” that TextMaker can fill in with the field con-

tents from the database records when it prints the form letters. 

Bring up the example database TMW.DBF and enter a few data records. Naturally, it 

is up to you to choose the names and addresses. When you have entered the re-

cords, exit the database with the menu command File > Close. 

All the basic steps have now been taken, and your form letter is now ready for 

printing. In the rest of this chapter, you will learn how to choose the addressees of 

a form letter – and how to actually print form letters. 

FreeOffice: Printing form letters is not included in SoftMaker FreeOffice. 



 

Manual TextMaker Form letters  •  389 

Selecting data records 

If desired, you can specify exactly those addressees to whom a form letter is to be 

sent. To do this, open the database containing their addresses and select the desired 

data records. 

Note: TextMaker saves the selection permanently. It remembers which data re-

cords are selected even after you exit and restart TextMaker. 

There are three ways to select data records, and they can be used in combination, 

as you choose. You can, for example, first select data records by means of a condi-

tion and then manually exclude some data records from the selection. 

The following selection methods are available in the database module: 

 Selecting single records manually 

 With the menu command Select > Current record you include the current data 

record in the selection, or exclude it. If you invoke this command when the re-

cord is not selected, it is selected, and vice versa. 

 With the menu commands Select > Select all records and Select > Deselect all 

records, all data records can be either selected or deselected at once. 

 Selecting by record numbers 

 With the menu command Select > By number you enter a range of record 

numbers to be selected or deselected. 

 Selecting by condition 

 The menu command Select > By condition lets you apply selection conditions 

like “select all Smiths” or “select all recipients living in Paris”. 

Detailed information about this selection method is given on the pages immedia-

tely following. 

Navigating between selected records 

With the menu commands Go to > Previous selected record and Go to > Next 

selected record you can jump to the previous or next selected data record. 

Alternatively, you can use the icons  and  in the toolbar or the keyboard 

shortcuts (Ctrl)(Alt)(PgUp½) and (Ctrl)(Alt)(PgDn¼) to do this. 
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Tip: Furthermore, with the View > Show only selected records menu command, 

you can hide all data records that are not selected. 

Selecting single records manually 

With the menu command Select > Current record you select or deselect the data 

record currently displayed in the database module. 

If you invoke this command when the current record is not selected, it is selected. 

If you invoke the command when the current record is already selected, the record 

is excluded from the selection. 

Tip: In list view, data records can also be selected or deselected by clicking with 

the mouse to check or uncheck the checkbox to the left of the data record. 

With the menu commands Select > Select all records and Select > Deselect all 

records you can select and deselect all the records in the data base at once. 

Display in the status bar: The status bar at the bottom of the window also shows whe-

ther a data record is selected or not: the word Selected appears here for a selected 

data record. 

Selecting by record numbers 

The data record number (record number for short) is the number representing the 

record’s sequential position in the database. The first data record has the number 1, 

the tenth 10, etc. The record number is always displayed in the status bar of the 

program window. 

The menu command Select > By number allows you to select or deselect a range 

of records delimited by record numbers. 

A dialog box appears, allowing you to enter the desired range. The range of the 

entire database is shown initially. For example, if you want to select the records 10 

through 20 inclusive, enter “10” and “20” here. 

If you then click on the Select button, all data records in this range will be selected; 

on the other hand, if you choose Deselect, they will be deselected, that is, excluded 

from the selection. 
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Selecting by condition 

With the menu command Select > By condition you can make a selection by me-

ans of a condition – for example, “select all records that contain ‘Smith’ in the 

NAME1 field”. All records that fulfill this condition will then be included in the 

selection. 

Hint: It is necessary only that the content of the field begins with the search 

term. Thus, continuing our example, if the NAME1 field of a given record con-

tained ‘Smithfield’, TextMaker would select this record, too. 

You can combine several conditions as required – for example, NAME1=Smith 

and CITY=London to select all Smiths living in London. 

When you invoke the menu command Select > By condition, the following dialog 

appears: 

 

To select, for example, all data records containing “Smith” at the beginning of the 

NAME1 field, you would proceed as follows: 

1. Select the desired field from the dropdown list box Database field – NAME1, 

following the above example. 

2. Enter the value you are seeking in the edit field Content – “Smith” following 

the above example. 

Note: The search is case-sensitive. If you search for “Smith”, records contai-

ning “SMITH” or “smith” will not be found. 

3. Click on the Add button to complete the definition of the condition. It will then 

be displayed in the Conditions list box. 
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 You can now add additional conditions by repeating the three steps above. 

4. Click on Select to add all the data records that fulfill the condition(s) you have 

defined to the selection. Or click on Deselect to exclude these records from the 

selection. 

So, if you now click on Select, all the data records in which the field NAME1 

begins with “Smith” will be added to the selection. 

With the help of the Delete and Delete all buttons in the dialog box, you can delete 

previously defined selection conditions when you no longer need them.  

Note: Be aware that once data records have been selected they remain selected 

until they are explicitly deselected. So, if you select records, first with NA-

ME1=Smith and then with NAME1=Jenkins, all records with the name Smith or 

Jenkins will be selected. If in fact only the Jenkins are to receive letters, you 

must deselect all data records by invoking the menu command Select > Deselect 

all records before you apply the condition NAME1=Jenkins. 

Operators available 

Apart from the equal sign described above, the dialog allows to choose from sever-

al other operators to build conditions. The following operators are available (in the 

dropdown list right of the field name): 

Operator Explanation 

= The search field must exactly match the search term or at least start with 

it. 

<> The search field must not match the search term or start with it. 

< Less than (for use with numeric fields) 

> Greater than (for use with numeric fields) 

<= Less than or equal to (for use with numeric fields) 

>= Greater than or equal to (for use with numeric fields) 

~ The search field must contain the search term at any position. 

For example, the condition NAME1~Smith selects all records where this 

field has a content like “Smith” or “Smithfield”, as well as “Miller, 

Smith & Company”. 
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Printing form letters 

FreeOffice: Printing form letters is not included in SoftMaker FreeOffice. 

Once you have created a form letter and selected the desired records from the data-

base, you can let TextMaker merge the two and print the form letter. 

To do this, don’t invoke the usual File > Print menu command, but instead use the 

File > Print merge command. 

For details on this command, see the section “Printing a form letter” (page 490). 

Automatic suppression of superfluous white spaces 

If, when printing, TextMaker comes upon two database fields that are separated by 

one or more space characters, and the first of these fields is empty, TextMaker au-

tomatically suppresses the space characters. 

An example: You have inserted fields for first and last names into the text and se-

parated them with a space character: 

{FIRSTNAME} {NAME1} 

At this point, TextMaker normally prints the first name, the space character and the 

last name. However, if the {FIRSTNAME} field of a given data record is empty, 

TextMaker prints only the last name and removes the space character, since in this 

case it is superfluous. 

Automatic suppression of empty lines with database fields 

If a text line contains only database fields and separating space or tab characters, 

and if, for some data record, none of these fields has any content, the entire line is 

suppressed. 

An example – your form letter contains the following text segment: 

{FIRSTNAME} {NAME1} 

{NAME2} 

{STREET} 

{CITY}, {STATE_ZIP} 
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If, for some data record, the {NAME2} field is empty, TextMaker automatically 

removes the resulting empty line. Thus, it prints the first and last names and then 

prints the street on the immediately following line. 

If both {FIRSTNAME} and {NAME1} were empty, this line would be entirely 

suppressed. 

Preventing the automatic suppression of white spaces 

In certain cases TextMaker’s automatic suppression of empty spaces and lines may 

not be desirable. To prevent such suppression, use protected space characters in 

place of normal space characters. You can insert them with the key combination 
(Ctrl)(Shiftª)(Space). 

An example – your form letter contains the following text segment: 

{FIRSTNAME}<protected space character>{NAME1} 

Here, the space character is printed even if {FIRSTNAME} is empty. Moreover, 

the line is not suppressed even if both fields are empty. 
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Calculations in the text 

With TextMaker you can easily perform calculations in your documents: 

 You can insert calculations directly into the text; the results are displayed and 

printed.  

 You can even use variables in calculations – so you can obtain partial results 

and use these in further calculations. 

 You can use both database fields and the contents of objects in calculations. For 

example, Table1.A1 represents the content of cell A1 in table “Table1”. 

You perform calculations with the Insert > Calculation menu command. The dia-

log box that appears when you invoke this command facilitates the entry of formu-

las; it contains lists of all variables, database fields, functions and operators 

available. 

What makes the calculation capabilities especially useful is the fact that they allow 

the contents of database fields to be included in the calculations. Writing an in-

voice? No problem: if your database has fields for quantity and price you can have 

TextMaker calculate formulas like QUANTITY * PRICE and easily print invoices 

as form letters. 

In addition, you can reference the contents of objects in calculations. For example, 

the formula “Textbox1.Value * 2” references the current numeric value in the text 

field named “Textbox1” and multiplies it by two. 

Detailed information about the topic of calculations is given on the next pages. The 

following topics are covered: 

 Inserting calculations 

 Formatting and rounding calculations 

 Updating calculations 

 Conditional text 

 Simple calculations with the press of a button 

 Formulas and functions 
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Inserting calculations 

Calculations can be inserted into the text with the menu command Insert > Calcu-

lation. 

When this command is invoked, a dialog box appears and lets you enter the formu-

la for the calculation. The formula may contain up to 255 characters. After your 

OK, the result of the calculation (maximum 100 characters) is placed in the text. 

Options: You can specify the format of the result with the options Decimals, 

Thousands separator and Hide result. You can read about this in the section 

“Formatting and rounding calculations” beginning on page 404. 

Inserting calculations 

A simple example of the use of the calculation command: 

You want to calculate the volume of a swimming pool that measures 23x13x7 feet. 

Accordingly, you proceed as follows: 

1. Type e.g. the text “The volume is: “. 

2. Invoke the menu command Insert > Calculation or press (F2). 

3. Enter “23*13*7” in the Formula field and confirm with OK. 

The result is now inserted into the text: 2093. 

The number “2093” can be edited and formatted like normal text, but it is in fact a 

field, that is, a symbolic place holder for the calculation “23*13*7”. You see this 

when you enable the Display field names option on the View tab in the dialog of 

the menu command File > Properties. Then {Formula: 23*13*7} appears in the 

text instead of 2093. 

Editing calculations 

The formula for the calculation can be changed at any time. To do this, select the 

result “2093” and again invoke the menu command Insert > Calculation. The 

formula 23*13*7 is displayed in the dialog box. If the swimming pool had different 

measurements, you could simply change the formula accordingly. Following your 

OK, the result would be recalculated and placed in the text. 
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More information 

For more detailed information on inserting calculations, read the next pages. Topics 

covered: 

 Variables in calculations 

 Table cells in calculations 

 Database fields in calculations 

 Objects in calculations 

Variables in calculations 

You can save the result of a calculation for reference in other calculations by assig-

ning it to a variable. 

Note: The names of variables may contain only letters, numbers and under-

scores. Special characters are not allowed. The name must always begin with a 

letter. A maximum of 16 characters is allowed. The cases of letters are ignored. 

To use variables in calculations, do the following: 

1. Invoke the menu command Insert > Calculation. 

2. Type the variable’s name followed by an equal sign and then a value or formula 

– for example: “VOLUME=23*13*7”.  

Important: When you confirm with OK, two things happen: 

 The calculation is performed and the result is displayed in the text. 

 At the same time, the result is saved in the variable VOLUME. 

Now the variable VOLUME can be used in other calculations: for example, the 

formula VOLUME+10 would produce the result 2093+10, that is, 2103. 

You can also just call out the content of the variable VOLUME at another place in 

the text. Simply move the text cursor to the desired position, invoke the menu 

command Insert > Calculation and type just the variable name VOLUME in the 

Formula box. When you confirm with OK, the content of the variable will appear 

in the text. 

If you look at the Insert > Calculation dialog box a little more closely, you will 

discover that every variable that is currently valid is displayed in the Variab-
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le/Field list box. Any of them can easily be inserted into the formula by double 

clicking on them. 

Important: A variable is valid only from the position in the text at which it is de-

fined. So, if you insert the formula VOLUME=23*13*7 in the third paragraph of 

your document and then try to call out its content or reference it in a formula in 

the second paragraph, TextMaker will respond with the error message “Unknown 

variable name”. 

An application example 

A tennis center wants to write invoices for the rentals of its courts. The computer 

should calculate the total amount and add 19% tax. Such an invoice would be writ-

ten more or less in this (much abbreviated) form: 

I N V O I C E 

  

  

? hours                    @ ??.?? 

                             ------------ 

Total                      = ??.?? 

                             ------------ 

+ 19% tax                  = ??.?? 

Amount due                 = ??.?? 

                             ------------ 

Those places indicated by question marks would have to be filled by hand after 

calculating the amounts with a pocket calculator. TextMaker takes away this labor. 

Let’s assume that the tennis players have rent a court for 2 hours and that each hour 

costs $10.00 plus tax: 

1. Delete the question mark before “hours” and enter the calculation HOURS=2 

there (using the Insert > Calculation menu command). 

 (This has the following result: Firstly, you have now assigned the variable 

HOURS a value of 2; secondly, you have caused the content of this variable (2) 

to appear in the text.) 

2. To the right, in place of the question marks after “@”, enter the calculation 

PRICE=10. 

 (The same goes here: Firstly, you have now assigned the variable PRICE a 

value of 10; secondly, you have caused the content of this variable (10) to 

appear in the text.) 
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3. The formula that you have to enter in place of the question marks after “Total” 

is: TOTAL=HOURS*PRICE. 

 (The result of the calculation HOURS times PRICE has now been assigned to 

the variable TOTAL, and this result is shown in the text. What matters here is 

that if you later change the value of HOURS or PRICE, the content of the vari-

able TOTAL will change accordingly.) 

4. After “+ 19% tax” insert the formula TAX=TOTAL*19/100 with the Insert > 

Calculation menu command to calculate some tax of 19%. 

 (This formula uses the total just calculated as a basis for a further calculation. 

Here too, what counts is that the result for TAX is automatically corrected for 

whenever the result for TOTAL changes.) 

5. Finally, calculate the “Amount due” as TOTAL+TAX.  

 (In the last step we opt not to define another variable. We just want to get the 

result into the text; we don’t need to reference it anywhere else.) 

If you check the Display field names option on the View tab in the dialog of the 

File > Properties menu command, the formulas in the text will become visible. 

The invoice then ought to look something like this: 

I N V O I C E 

  

  

{Formula: HOURS=2} hours   @ {Formula: PRICE=10} 

                             ------------ 

Total                      = {Formula: TOTAL=HOURS*PRICE} 

                             ------------ 

+ 19% tax                  = {Formula: TAX=TOTAL*19/100} 

Amount due                 = {Formula: TOTAL+TAX} 

                             ------------ 

When you uncheck Display field names, you will see the results in the text again. 

To write an invoice for another customer, all you have to do now is change the va-

lue of HOURS. To do this, select the 2 before “hours”, invoke the Insert > Calcu-

lation menu command and simply replace the 2 in the formula with the desired 

number of hours. After your OK, TextMaker carries out the recalculation. 

Decimal places: You might find it more desirable to show the amounts with two de-

cimal places. You can make the necessary change immediately: for each amount, 

select the corresponding calculation field, invoke the menu command Insert > 

Calculation, choose the Fixed option for Decimals and enter a “2” beside it. 
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Table cells in calculations 

You can also use the cells in tables for calculations – almost like in a spreadsheet 

application! 

Take a look at the status bar at the bottom edge of the program window. When you 

move from cell to cell in a table, the coordinates of the active cell in the table are 

shown there. 

TextMaker designates the rows of a table with numbers; the columns are assigned 

the letters A, B, C, etc. 

  

A1 B1 C1 ... 

A2 B2 C2 ... 

A3 B3 C3 ... 

... ... ... ... 

So, the first cell in a table has the coordinates “column A” and “row 1”, or for 

short: A1. 

To perform calculations on the contents of the cells of a table, invoke the menu 

command Insert > Calculation and simply enter the coordinates, preceded by # 

signs. So the correct formula for “add the contents of cells A1 and A2” would be:  

#A1 + #A2 

The # sign tells TextMaker that it should treat the content of the cell as a number. If 

the cell’s content is to be treated as text, use the dollar sign ($) – for example, $A1. 

Please note that calculations with short cell references (e.g. #A1 + #A2) are possib-

le only within a table. If you would like to refer to table cells outside a table, put 

the table’s name and a period in front of the cell address. For example, if the table’s 

name was “Table1” you could write: 

Table1.#A1 + Table1.#A2 

See also section “Objects in calculations” (page 403). 
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Calculating the sum over a range of table cells 

The SUM function is especially useful for adding numbers in table cells. Simply 

enter the first and last cells as parameters; TextMaker adds the values in all the 

cells in the range. 

For example, you can add the contents of cells B2 through B5 with the formula 

SUM(#B2;#B5). 

Calculating with adjacent cells made easy 

Tip: In some arithmetic functions (e.g. SUM), you can use symbolic cell references 

in order to reference all cells directly adjacent to a cell. 

The following types of symbolic cell references are available: 

 ABOVE (represents the cells above the current cell) 

 BELOW (represents the cells below the current cell) 

 LEFT (represents the cells to the left of the current cell) 

 RIGHT (represents the cells to the right of the current cell) 

For example, the formula SUM(ABOVE) calculates the sum of the cells directly 

above a cell. 

The following arithmetic functions support symbolic cell references: 

AVG, COUNT, MIN, MAX, PROD, SUM 

(For detailed information on each function, see the section “Computational func-

tions”, page 412.) 

Database fields in calculations 

Fields from a database can also be entered in calculations, provided that a database 

has first been assigned to the document with the menu command Tools > Set 

database. 

You do not even have to enter the field names manually. If you have a look at the 

dialog of the Insert > Calculation menu command, you will see that the names of 

all the database fields are shown in the Variable/Field list box as soon as you as-

sign a database to the document. They can be entered in the formula with double 

clicks. 
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As an example, we want to create an invoice form that can be easily printed as a 

form letter. For this, all we need is a database whose fields contain the customers’ 

personal data (name, address, etc.). Beyond that – we’ll simplify things and allow 

only one item per invoice – the database should contain a QUANTITY field for the 

order quantity, an ITEM field for item designators and a PRICE field for the unit 

price. 

Proceed as follows: 

1. Create a new document with the menu command File > New. 

2. Assign an appropriate database to it with the menu command Tools > Set 

database (see below for an example). 

3. Next, create a normal form letter, as described in chapter “Database”. Insert the 

database fields containing the relevant customer data (address, etc.) at the pro-

per places in the letterhead. 

4. Now design the invoice itself according to your tastes. Enter fields from your 

database with the menu command Insert > Field > Database field – for exa-

mple, the QUANTITY field for the order quantity. 

5. And now the main point: You can calculate with the database fields. For exa-

mple, the formula QUANTITY*PRICE calculates the total for the current data-

base record. So, using the menu command Insert > Calculation, insert approp-

riate calculations at the desired positions. 

6. When everything has been entered, you can save the document. Next, select 

some database records and print your invoices with the menu command File > 

Print merge. 

FreeOffice: Printing form letters is not included in SoftMaker FreeOffice. 

Example 

You will find an example for this in the samples folder for SoftMaker Office: the 

files INVOICE.TMDX and INVOICE.DBF. 

To locate this folder, proceed as follows: 

 Under Windows, navigate to your DOCUMENTS folder. There, go to the folder 

SOFTMAKER\SAMPLES. 

 Under macOS or Linux, navigate to your home folder. There, go to the folder 

SOFTMAKER/SAMPLES. 
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 On an Android device, go to the folder SOFTMAKER/SAMPLES on your SD 

card. 

Tip: After opening INVOICE.TMDX, you check the Display field names option on 

the View tab in the dialog of the File > Properties menu command. This will make 

the document display the formulas themselves visible, rather than the results they 

give, and you will better understand how this self-calculating form letter works. 

Objects in calculations 

Certain types of objects can also be used in calculations. So, for example, you can 

create a form that contains text fields and use the contents of these text fields in 

calculations. 

All the objects in a document have distinctive names, as described in section 

“Changing the names of objects” beginning on page 286. You can address each 

individual object by its name. For example, Textbox1 references the content of the 

text field “Textbox1”. 

You evaluate the contents of objects in calculations as follows: 

 Text fields and text frames 

 Textbox1.Text (or Textbox1 for short) returns the content of the text field with 

the name “Textbox1” as text (without any formatting). 

 Textbox1.Value on the other hand interprets the content of the text field as a 

number and returns it. 

 Tables 

 Table1.A1 returns the content of cell A1 in Table1. 

 Table1.#A1 interprets the content of this cell as a number and returns it. 

 Table1.$A1 interprets the content of this cell as text and returns it. 

 Table1 returns the sum of the contents of all cells in Table1. 

 Checkboxes and checkbox frames 

 Checkbox1.Sel (or Checkbox1 for short) returns 1 if the checkbox is checked, 

or 0 if not. 

 Checkbox1.Text returns the text for this checkbox if it is checked, otherwise an 

empty text string. 
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 Dropdown lists and dropdown list frames 

 Dropdown1.Text returns the text of the selected item in Dropdown1. 

 Dropdown1.Sel (or Dropdown1 for short) returns the number of the selected 

item. 

An example: The formula “Textbox1.Value * 2” references the current numeric 

value in the text field named “Textbox1” and multiplies it by two. 

Formatting and rounding calculations 

With the menu command Insert > Calculation, you can not only enter new calcu-

lations (see section “Inserting calculations”) and edit existing ones, but also specify 

the format of the calculation’s result. 

You can set the format already when you enter a new calculation, or you can do 

this at any time afterwards by selecting the calculation and invoking the menu 

command Insert > Calculation. 

The following options in the dialog box determine the format of the calculation: 

 Thousands separator 

 If you enable this option, numbers 1000 and above are represented with 

thousands separators. For example, 1230000 is shown as 1,230,000. 

 Hide result 

 If you choose this option, the result of the calculation is not visible in the text. 

This makes sense when, for example, you want to perform intermediate calcu-

lations with variables and do not want to show the results. 

 Note: To make a hidden calculation visible again, invoke the menu command 

File > Properties, change the View tab and activate the Display field names 

option. Now you can select the calculation again, invoke the menu command 

Insert > Calculation and disable the Hide result option. 

 Decimal places 

 With the default setting Floating, as many decimal places are shown as are 

required to represent fully the result of the calculation. You can select instead 

the Fixed option and enter a fixed number of decimal places to be shown. For 

monetary amounts, for example, the number of decimal places should be fixed 

at 2. 
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 Attention: The value is not actually rounded by setting a fixed number of deci-

mal places; only its representation is rounded (see below)! 

Actually rounding variables 

It is essential to note that the option for setting the number of decimal places just 

described changes only the way the results of a calculation are displayed. In reality, 

the variable retains its original precision. 

In practice, this means that if you assign a value of 2.5 to variable A and set the 

number of decimal places to 0, it will be shown as 3, but if you multiply A by 2, the 

result shown will be 5, not 6. 

Therefore, TextMaker also comes with a function called ROUND for real 

rounding. It can be applied as in the following example: 

A = ROUND ( 2.5 ; 0 ) 

The function’s arguments are the value to be rounded and the number of decimal 

places to which it is to be rounded, separated by a semicolon. In the example above 

the value of 3 is assigned to the variable A. 

You will find detailed information about all TextMaker’s computational functions 

in section “Formulas and functions” beginning on page 408. 

Updating calculations 

When you enter or edit a calculation with the menu command Insert > Calculati-

on and then confirm with OK, TextMaker automatically updates all the calculati-

ons in the document. 

However, in certain situations the results of calculations can appear “outdated”. For 

example, if you paste from another document a segment of text containing variab-

les that are also used in the current document, TextMaker inevitably displays false 

results on the screen. 

The menu command Tools > Update fields is provided for such situations. When 

you invoke it, TextMaker updates all the calculations and fields in the document. 
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Note: It is only necessary to use this command in the situations described above 

when you want to update the screen display of the calculations. Before printing a 

document, TextMaker updates all calculations and fields automatically. TextMa-

ker ensures that you will never print a document with results that are out of date. 

Conditional text 

TextMaker also allows you to work with conditional expressions, using the func-

tion IF. By this means you can, for example, use “conditional text” in your 

documents. 

A typical case: You have an address database with a field called GENDER, and the 

record for each person contains either an “M” for male or an “F” for female in that 

field, indicating the person’s gender. Using the following IF expression, you could 

have TextMaker form a salutation according to gender: 

IF (GENDER="M" ; "Dear Madam" ; "Dear Sir") 

If you use this calculation in a form letter, TextMaker looks at each data record to 

see if the GENDER field contains an “M”. If it does, TextMaker outputs “Dear 

Sir”, as the replacement for the formula given above; otherwise, it outputs “Dear 

Madam”. 

Simple calculations with the press of a button 

There is an alternative to the Insert > Calculation menu command described in 

the previous sections: the command Edit > Evaluate. 

The difference: 

Insert > Calculation is suitable for calculations of any complexity using variables, 

etc. 

Edit > Evaluate is suitable only for more simple calculations, but it is much easier 

to handle: You enter and select a formula directly in the text, invoke Edit > Evalu-

ate and immediately see the result in the text. 

An example: 

1. Type “The total is: 90+55+220”. 



 

Manual TextMaker Calculations in the text  •  407 

2. Select “90+55+220”. 

3. Invoke the menu command Edit > Evaluate or press the (F8) key. 

4. The formula “90+55+220” is calculated and the result is inserted in the text. 

It doesn’t get any easier or faster: select a calculation and simply press (F8) to have 

it calculated. 

Important: In contrast to calculations with Insert > Calculation, here the result 

is not entered as a field but inserted into the document as plain text. 

Associative rule: Multiplication and division operators have precedence over additi-

on and subtraction operators, so that multiplication and division are always per-

formed before addition and subtraction. Accordingly 2+3*4 gives 14. You can in-

fluence the way operations are performed with parentheses: (2+3)*4 gives 20. 

Using functions: Not only basic operators, but also functions are allowed in expres-

sions (see section “Formulas and functions” on page 408): If you type “SQRT(2)”, 

select it and invoke the Edit > Evaluate menu command, you will get the square 

root of 2 as a result. 

One line limit: The selected calculation must be within one line of text. If you select 

several lines of text, the Edit > Evaluate menu command is not available and is 

grayed out in the menu. For lengthy expressions use the Insert > Calculation 

menu command. 

Summing the contents of table cells 

Such calculations can be performed in tables as well. There is yet another feature in 

connection with tables: 

 If you have selected a calculation that is within a table cell, you can get its re-

sult using the Edit > Evaluate menu command, as described above.  

 On the other hand, if you select several complete table cells, the command Sum 

cells will become available in the Edit menu. If you invoke it, TextMaker com-

putes the sum of the values in the selected cells. 

 A window then appears and tells you the result. If you want simply to learn 

what it is and make no further use of it, click on Close. Alternatively, you can 

click on the Copy button. TextMaker then copies the result of the calculation to 

the clipboard. Now you can insert the value at any position you like in the 

document with the Edit > Paste menu command. 
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Formulas and functions 

On the next pages you will learn about the rules you have to observe when 

constructing formulas. Then all of TextMaker’s computational functions will be 

described to you. 

Note: This section deals with the formulas for computation (for performing cal-

culations in the text). If you are looking for information about the SoftMaker 

Equation Editor (for graphical representations of mathematical formulas) you 

will find it in the Equation Editor’s online help. 

The structure of a formula 

Formulas may contain up to 255 characters. Results are limited to 100 characters. 

You can construct formulas from the following components: 

Constant values 

A formula presents itself in its simplest form as a constant value – as in the follo-

wing examples: 

 Text strings 

 Example: "Good morning!" 

 A formula with this content always gives the text string “Good morning!”. 

 (A text string is a sequence of letters, numbers or other characters.) 

 Text strings may be up to 100 characters long. 

 Important: When you enter a constant text string (e.g., "Good morning!") di-

rectly into a formula, you must enclose it in "double quotation marks". Other-

wise, TextMaker will try to interpret it as the name of a function or variable. 

 Numerical values 

 Example: 42.50 

 Of course a constant value can also be a numerical value – i.e., a number. This 

formula always returns the number 42.5. 
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 Date entries 

 Example: "04/20/18" 

 This formula represents the date 4/20/2018. 

 Notes on entering dates in formulas: 

 When entering dates in a formula, please note the following: 

 1. When you enter dates in formulas you must enclose them in "double quotati-

on marks". 

 2. Month and day must be given as two place numbers. Thus, "04/20/18" is 

correct, while "4/20/18" is incorrect (the month has only one place). 

 3. The year can be given as a two or four place number, as you prefer. Thus, 

"04/20/18" and "04/20/2018" are equally valid. 

 4. When you enter a year as a two place number between 0 and 29, TextMaker 

automatically prefixes 20. When you enter a number between 30 and 99, Text-

Maker prefixes 19. Thus, the date "01/01/29" is interpreted as 1/1/2029, while 

"01/01/30" is interpreted as 1/1/1930. 

Database fields, table cells and objects 

You can also use the contents of database fields, table cells and objects in formulas. 

You will find information about this in the sections “Table cells in calculations”, 

“Database fields in calculations” and “Objects in calculations” beginning on page 

400. 

Calculations 

A formula can contain various kinds of calculations. 

Example: 6*5 

Always returns the constant value 30, and is, in fact, a constant value – not a calcu-

lation. 

Example: 5*NUMBER 

In this formula, the constant value 5 is multiplied by the value of the variable 

NUMBER. If NUMBER has the value of 10, the formula gives 50. 
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Beyond that, TextMaker puts a number of computational functions at your dispo-

sal. Detailed descriptions can be found in the section “Computational functions” 

(page 412). To start with, here are a few examples: 

Example: TODAY() 

The function TODAY() returns the current date. For example, on September 16, 

2018 it would return 09/16/18. 

Example: MONTH(TODAY()) 

Here one function is applied to another. The function TODAY() returns the current 

date. But this result is immediately evaluated by the MONTH() function, which 

returns only the month of the date (as a number). So, on September 16, 2018 the 

formula would produce the value 9. 

Example: INT(B/1000) 

Here, the function INT, which converts a floating point number to an integer by 

removing its fractional part, is applied to the calculation B/1000. If B has the value 

3752.70, the formula gives the value 3. 

In summary, the arguments of functions can be other functions, any sorts of calcu-

lations, database fields, table cells references, or any combination of these. 

Variables 

The result of a formula can be assigned to a variable. 

Tip: All variables that are defined at a given moment appear in the Variable/Field 

list box in the dialog box for the Insert > Calculation menu command. You can 

insert any one of them in the formula by double clicking on it. 

Example: PRICE=17.99 

Here, the “formula” is just the constant value 17.99. The entry as a whole defines 

the variable PRICE and sets it to 17.99. Its value is valid from the position in the 

text at which you insert it to the end of the text – unless you assign another value to 

the PRICE variable farther down in the text. 

Note: Whenever you assign a value or a calculation to a variable, the value of the 

variable appears at the active position in the text. If you don’t want this – for 

example, because you only want to perform an intermediate calculation whose 

result should not be shown – enable the Hide result option in the dialog box for 

the Insert > Calculation menu command. 
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Example: MY_MONTH=MONTH(TODAY()) 

Here, the month of today’s data is calculated and shown. At the same time, the re-

sult is saved in the variable MY_MONTH. 

Naturally, you can insert such a variable in other formulas. 

Example: PRICE*1.19 

This formula gives the current value of the PRICE variable multiplied by 1.19. 

Operators 

The following operators can be used in formulas: 

Operator Function 

+ Addition (with numbers) or concatenation* (with text strings) 

– Subtraction 

* Multiplication 

/ Division 

% Modulo (remainder after division) 

* The plus sign is used not only to add numeric values but also to concatenate text strings. For example, 

the formula "Text"+"Maker" gives “TextMaker”. 

An associative rule applies. Multiplication and division operators take precedence 

over addition and subtraction operators, so that multiplication and division are per-

formed before addition and subtraction. 2+3*4 gives 14. 

The order of operations can be modified by using parentheses: (2+3)*4 gives 20. 

In addition, there are comparative and logical operators that are needed, for examp-

le, for the IF function: 

Operator Function 

= Is equal? 

< > Is not equal? 

> Is greater than? 

>= Is greater than or equal to? 
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< Is less than? 

<= Is less than or equal to? 

& Logical “and” 

| Logical “or” 

! Negation 

Some notes on comparisons 

 When two text strings are compared with “=”, the result is “true” only when the 

strings are exactly the same and have the same length. The cases of letters are 

taken into account in this comparison. 

"Henry"="Henry" is true. 

"Henry"="henry" is false. 

"Henry"="Henry’s" is false. 

 If you construct a complex comparison that has several “ands” and “ors”, you 

should always enclose the individual conditions in parentheses.  

Computational functions 

In TextMaker you can use the computational functions described below. The argu-

ments required by the functions are always given in parentheses: 

 n represents a number 

 t represents a text string 

 d represents a date 

So, for example, INT(n) is a function requiring a numeric argument. It can be a 

numeric constant or the numeric result of a calculation – for example, INT(3.14) or 

INT(1+SQRT(2)). 

Important: When several arguments are required, they must be separated from 

one another by semicolons (;). 
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Function Explanation 

ABS(n) Returns the absolute value of the numeric argument n, i.e. remo-

ves its sign – ABS(3) gives 3; ABS(-3) gives 3. 

ASC(t) Returns the numeric code of the character t in the character table 

– ASC("A") gives 65. 

AT(t1;t2) Returns the position of the first occurrence of text string t2 in 

text string t1 as a numeric value –AT("London";"on") gives 2.  

AVG(n1;n2) Returns the average value of the values contained in the cells of 

a table in a rectangular region with coordinates n1 (upper left 

corner) and n2 (lower right corner). The coordinates must be 

preceded by # signs. Example: AVG (#B2;#C5). See also the 

section “Table cells in calculations” beginning on page 400. 

CHR(n) Returns the character at position n in the character table – 

CHR(65) gives “A”. 

COUNT(n1;n2) Returns the number of values contained in the cells of a table in 

a rectangular region with coordinates n1 (upper left corner) and 

n2 (lower right corner). Only numbers are counted – empty cells 

and cells containing text are not counted. The coordinates must 

be preceded by # signs. Example: COUNT (#B2;#C5). See also 

the section “Table cells in calculations” beginning on page 400. 

DAY(d) Returns the day part of date d (as a number) – DAY("09/25/18") 

gives 25. 

DTON(d) Converts the date d to a date serial number, needed to calculate 

the difference in days between two dates: DTON ("11/12/18") - 

DTON ("10/20/18") gives 23 (days). 

IF IF(condition;value1;value2) returns value1 when the condition is 

true; otherwise value2. Example: IF(GENDER="F" ; "Dear Ma-

dam" ; "Dear Sir"). Value2 can also be omitted – see the section 

“Conditional text” beginning on page 406. Value1 and value2 

can be of any type (also, for example, numeric). 

INT(n) Returns the number n truncated to integer form (without 

rounding), so that the fractional value after the decimal point is 

suppressed – the formula INT(3.90) would give the result 3. 

LEFT(t;n) Returns the first n characters in the text string t – 

LEFT("TextMaker";4) gives “Text”. 

LEN(t) Returns the length of text string t – LEN("fish") gives 4. 
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LOWER(t) Converts the text string t to lowercase – LOWER("James") gives 

“james”. 

LTRIM(t) Returns text string t with all leading space characters removed – 

LTRIM("  Text  ") gives “Text  “. 

MAX(n1;n2) Returns the maximum value of the values contained in the cells 

of a table in a rectangular region with coordinates n1 (upper left 

corner) and n2 (lower right corner). The coordinates must be 

preceded by # signs. Example: MAX (#B2;#C5). See also the 

section “Table cells in calculations” beginning on page 400. 

MIN(n1;n2) Returns the minimum value of the values contained in the cells 

of a table in a rectangular region with coordinates n1 (upper left 

corner) and n2 (lower right corner). The coordinates must be 

preceded by # signs. Example: MIN (#B2;#C5). See also the 

section “Table cells in calculations” beginning on page 400. 

MONTH(d) Returns the month part of date d (as a number) – 

MONTH("09/25/18") gives 9. 

NTOD(n) The opposite of DTON, which returns a date serial number – 

NTOD converts such a date serial number n back to a date. 

POW(n1;n2) Returns the result of raising the number n1 to the power of n2 – 

POW(2;8) gives 256. 

PROD(n1;n2) Returns the product of the values contained in the cells of a table 

in a rectangular region with coordinates n1 (upper left corner) 

and n2 (lower right corner). The coordinates must be preceded 

by # signs. Example: PROD (#B2;#C5). See also the section 

“Table cells in calculations” beginning on page 400. 

RIGHT(t;n) Returns the last n characters of the text string t – 

RIGHT("TextMaker";5) gives “Maker”. 

ROUND(n1;n2) Returns the number n1 rounded to n2 decimal places – 

ROUND(2.44;1) gives 2.4 and ROUND(2.45;1) gives 2.5. 

RTRIM(t) Returns text string t with any trailing space characters removed – 

RTRIM("  Text  ") gives “  Text”. 

SQRT(n) Returns the square root of the number n – SQRT(4) gives 2. 

STR(n) Converts the number n to a text string – STR(17) would produce 

the string “17”. 

STRING(t;n) Returns a text string consisting of n repetitions of the text string t 

– STRING("Text";3) gives “TextTextText”. 
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SUBSTR(t;n1;n2) Returns a text string consisting of n2 characters extracted from 

text string t beginning at position n1 – SUB-

STR("TextMaker";2;3) gives “ext”. 

SUM(n1;n2) Returns the sum of the values contained in the cells of a table in 

a rectangular region with coordinates n1 (upper left corner) and 

n2 (lower right corner). The coordinates must be preceded by # 

signs. Example: SUM (#B2;#B5). See also the section “Table 

cells in calculations” beginning on page 400. 

TODAY() Returns today’s date in the form MM/DD/YY – the empty pair 

of parentheses following the function name must be entered. 

TRIM(t) Returns the text string t with all leading or trailing spaces remo-

ved – TRIM("  Text  ") gives “Text”. 

TRUNC(n1;n2) Returns the number n1 truncated to n2 decimal places (without 

rounding) – TRUNC(1.2345;2) gives 1.23. 

UPPER(t) Converts the text string t to uppercase – UPPER("James") gives 

“JAMES”. 

USER() Returns the user name under which you are logged in to your 

computer. The empty pair of parentheses after the function name 

must be entered. 

VAL(t) Converts the text string t to a number. The string may include 

non-numeric characters. In that case, TextMaker takes the first 

occurrence of a number within the string: VAL("3") gives 3. 

VAL("3 eggs") and VAL("Can I have 3 eggs and 1 roll?") li-

kewise give 3. However, VAL("eggs") gives 0, since this string 

contains no number. 

YEAR(d) Returns the year part of a date as a number (with two places) – 

the formula YEAR("09/17/18") gives 18. 
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Working with large documents 
TextMaker provides some very useful features for working with large documents: 

 Outlines 

FreeOffice: Outline view is not included in SoftMaker FreeOffice. 

 Large documents are often organized according to an outline – that is to say, a 

hierarchical structure of headings. TextMaker’s Outline view allows you to 

view and edit a document in outline form. You can change heading levels and 

move headings (together with subordinated text) with a click of the mouse. 

 Tables of references (TOC, index, etc.) 

 TextMaker contains functions that make the creation of tables of references 

(table of contents, index, etc.) significantly easier. The following types are sup-

ported: 

  Indices 

  Tables of contents 

  Captions and tables of figures 

  Bibliographies 

FreeOffice: In SoftMaker FreeOffice, only indices and tables of contents 

are supported. 

 See the corresponding sub-section for details.  

 Cross references 

FreeOffice: The Cross reference feature is not included in SoftMaker Free-

Office. 

 You can also insert Cross references to specific text elements or objects – for 

example: “see the picture on page 12”. 

 Style references 

 A style reference field searches the document backwards for text that is for-

matted in the specified paragraph style and displays the first text found. This al-
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lows you to display e.g. the current main heading (which is usually formatted in 

the paragraph style “Heading 1”) in the text. 

 Footnotes 

 Finally, you can insert footnotes that TextMaker controls automatically. 

Outlines 

You should use outlines to organize large documents. An outline presents the entire 

subject matter of the document in summary form as a structure of major and minor 

topics. This structure is based on headings that you give to different parts of the 

body text. The headings break the text into manageable segments. An outline pro-

vides an overview of the document and allows you to easily easy manipulate 

document segments to obtain the desired organization of the text. 

Once you have invoked the View > Outline menu command, you will be able to 

use TextMaker’s Outline view to perform these tasks. 

FreeOffice: Outline view is not included in SoftMaker FreeOffice. 
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The Outline view is nothing more than a different form of representation for the 

document. Let’s take a closer look at what it contains: 

First, notice that the document’s text segments are indented to different degrees. 

Major headings are displayed flush left. Headings immediately subordinate to them 

(those whose outline level is one lower) are displayed a little further to the right, 

etc. 

In addition, the Formatting toolbar has disappeared and has been replaced by the 

Outline toolbar. As its name implies, this toolbar provides access to functions 

useful for outlining documents. 

When you invoke the Outline view for the first time the entire document will al-

ways be visible. You will obtain a better view of the document’s structure when 

you hide the normal text and allow only the headings to be displayed (provided the 

document contains headings). To do this, use the Text button in the Outline toolbar. 

Beyond that, you can specify which levels of headings should be displayed with 

buttons 1 through 9. Clicking on button 3, for example, results in the display only 

of headings with outline levels one through three. The All button provides a means 

of making all the levels visible again. 

The Outline view is suitable not only for viewing the document’s structure, but also 

for editing it. You can use the Outline toolbar for this purpose, too: with the help of 

the arrow buttons you can raise or lower the outline levels of headings or promote 

paragraphs of normal text to headings. 

Numbering headings: Headings are often numbered. TextMaker can take care of this 

numbering for you automatically. You can read about this in section “Numbering 

headings” beginning on page 426). 

For detailed information on working with outlines, see the pages that follow. The 

following topics will be covered: 

 Using the Outline view 

 Formatting headings 

 Expert tip: Managing headings with paragraph styles 

 Practical outlining 

 Numbering headings 

 Outlined documents and chapters 
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Using the Outline view 

FreeOffice: Outline view is not included in SoftMaker FreeOffice. 

As mentioned in the introduction, TextMaker puts at your disposal a special display 

mode for editing a document’s outline: the Outline view. 

To switch to Outline view, invoke the View > Outline menu command. You can 

return from Outline view to the normal view any time you wish with the View > 

Standard menu command. 

In Outline view, you see the document as a structure whose parts are organized 

according to major and minor headings. First level headings (major headings) are 

aligned flush left. Each lower level heading is indented to the right by an amount 

corresponding to its level.  

In the following sections you will learn all about what you can do in Outline view. 

Changing the outline levels of paragraphs 

To give a document an outline or to edit an existing outline, switch to Outline view 

and there simply change the outline levels of the paragraphs that contain headings. 

By default, when you enter text into a document, the text paragraphs are assigned 

to outline level 0. If you subsequently assign a specific paragraph for example to 

outline level 1, you promote it to a level one heading. 

Thus, you specify the document’s major headings by assigning the corresponding 

paragraphs to outline level 1. If you want to add subheadings under the major hea-

dings, you assign the corresponding paragraphs to outline levels 2, etc. 

To change the outline level of a paragraph, do the following: 

1. Invoke the Outline view with the View > Outline menu command. 

2. Position the text cursor in the paragraph of interest. 

3. Click on one of the following icons in the Outline toolbar, or use one of the 

following keyboard shortcuts: 

Icon Function 

 
Raises the paragraph’s outline level by 1. 

Keyboard shortcut: (Alt)(Shiftª)(æ) 
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Lowers the paragraph’s outline level by 1. 

Keyboard shortcut: (Alt)(Shiftª)(Æ) 

 
Lowers the paragraph’s outline level to 0 (= normal text). 

Keyboard shortcut: (Ctrl)(Shiftª)(N) 

Tip: Additionally, keyboard shortcuts (Alt)(1) through (Alt)(3) are defined for 

outline levels 1 through 3. The keyboard shortcut (Alt)(0) is defined for level 0 

(normal text). Thus, you can use these key combinations to very quickly assign 

headings to levels 1 through 3 or convert headings back to normal text.  

Moreover, all of the key combinations mentioned above work not only in Outline 

view but also in the normal view. 

Selecting the outline levels to be displayed 

To enable you to gain a better overview of a document’s structure in Outline view, 

TextMaker provides you with a way to hide the normal text while leaving the hea-

dings visible. It also allows you to hide headings below a specified level whenever 

required. 

The Outline toolbar provides buttons for this purpose as follows: 

 

The Text button furthest to the right is especially helpful in this regard. With it, you 

can control whether only headings or headings together with associated text are 

displayed. You can activate or deactivate this button by clicking on it with the 

mouse. When the button is activated, the text is displayed. When it is deactivated 

only the headings remain visible. 

Hint: You can also use the keyboard shortcut (Alt)(Shiftª)(A) to turn the display 

of text on/off. 

With the other buttons, you can specify the outline levels to be displayed. A click 

on the “1” button hides all headings with outline levels below 1, so that only the 

major headings remain visible. A click on the “3” button makes all headings of 

level 3 and higher visible, etc. 

Hint: You can also use the keyboard shortcuts (Alt)(Shiftª)(1) through 
(Alt)(Shiftª)(9) instead of these buttons. 
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By default, the All button is activated; thus, TextMaker displays headings of all 

levels. 

Expanding/collapsing single headings 

As just described, in Outline view you can use the buttons “1” through “9” to hide 

details of the outline’s structure and view only headings of specified levels. 

But what if you want to examine what is contained at lower levels under a single 

heading? The following alternative methods are available to you: 

 “+” and “–” buttons in the Outline toolbar 

 You can position the text cursor in the desired heading and then click on one of 

the following icons in the Outline toolbar, or use one of the following keyboard 

shortcuts: 

Icon Function 

 
Expands the view to include the next lower level. 

Keyboard shortcut: (Alt)(Shiftª)(Num+) (Plus key on the numeric pad) 

 
Collapses the view to exclude all lower levels. 

Keyboard shortcut: (Alt)(Shiftª)(Num-) (Minus key on the numeric 

pad) 

 “+” and “–” symbols left of the text paragraphs 

 Alternatively, you can make use of the plus or minus symbol that is displayed 

immediately to the left of each heading in Outline view: 

 A “+” indicates that the heading contains subordinate headings or normal text 

paragraphs that are currently hidden.  

 A “–”, on the other hand, indicates that whatever is immediately subordinate to 

the heading is already visible.  

 A double click on a “+” makes the content at all levels below the paragraph 

visible; a double click on a “–” hides everything at the lower levels. 

Editing text in Outline view 

It is possible to enter, edit and format text in Outline view. However, the normal 

view is better suited for these tasks, and it is recommended that you switch back to 

normal view to perform them. 
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Deleting, copying and moving text 

On the other hand, the Outline view is especially well suited for deleting, copying 

and moving headings together with associated text. 

The easiest way to perform these tasks is to make use of the plus and minus sym-

bols at the left the headings. By clicking on one of these symbols you can select the 

associated heading and any text that is subordinated to it. Then you can delete, 

copy or move the contents of your selection with the usual commands in the Edit 

menu (see chapter “Working with selections” beginning on page 65). 

For example, to move a heading and its associated text, proceed as follows: 

1. Click on the plus or minus symbol to the left of the heading. In this way, you 

select the heading including all text subordinated to it. 

2. Invoke the Edit > Cut menu command. 

3. Position the text cursor at the beginning of the line before which you want to 

reinsert the text that you just cut. 

4. Invoke the Edit > Insert menu command. 

The heading and its associated text have now been moved accordingly. 

Hint: There are also two keyboard shortcuts available for moving selected text: 
(Alt)(Shiftª)(½) moves the text one paragraph up, (Alt)(Shiftª)(¼) moves it 

one paragraph down. 

Formatting headings 

There is nothing “magical” about headings. They are just paragraphs that have be-

en assigned to different outline levels. Accordingly, headings can be formatted as 

desired using the formatting commands with which you are already familiar. 

Tip: Formatting all the headings at a given level collectively (keyword 

“paragraph style”) 

TextMaker formats headings automatically with specific paragraph styles: level 

one headings are always formatted with the Heading 1 paragraph style, level two 

headings with the Heading 2 style, etc.  
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Thus, if you want to change the appearance of all headings at a specific level, all 

you have to do is edit the corresponding paragraph style. To do this, proceed as 

follows: 

1. Invoke the menu command Format > Paragraph style. 

2. Select the style corresponding to the headings you want to modify from the list. 

For example, if you want to modify all level one headings, select the Heading 

1 style. 

3. Click on Edit. 

4. A dialog box appears to enable you to set the desired paragraph formatting.  

 Hint: As needed, you can also modify the character formatting by clicking on 

the Character button on the Paragraph tab. 

5. Make the desired changes. 

6. Click on OK. 

7. Exit the dialog box with Close. 

If necessary you can review the detailed information about styles that is presented 

in chapter “Styles” beginning on page 129. 

Note: When you edit the structure of a document in Outline view, TextMaker au-

tomatically applies the Heading 1 ... 9 styles to the corresponding headings. You 

should not attempt to change the names of these styles or to apply other styles to 

the headings. Any such attempts would work, but not for long, because TextMa-

ker would automatically reapply “its” styles when you subsequently changed the 

outline levels of paragraphs in the Outline view. 

Expert tip: Managing headings with paragraph styles 

When you change the outline level of a paragraph in Outline view, nothing much 

really happens: TextMaker merely applies one of the paragraph styles Heading 1 

through Heading 9. 

What would some clever fox make of this? You guessed it: a clever user would 

infer that he or she could create a heading simply by applying one of the styles 

Heading 1 through Heading 9 to a text paragraph – which would be correct. 
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It follows that when you want to add a new heading you can do so without even 

using the Outline view. Simply type the heading and select the desired heading 

style from the Formatting toolbar – done. 

You can change the outline level of an existing heading just as easily. For example, 

if you position the text cursor in a level 2 heading and apply the Heading 3 style, 

the heading is demoted to level 3. 

And there is an even faster way: By default, keyboard shortcuts (Alt)(1) through 
(Alt)(3) are defined for Heading 1 through 3, and the shortcut (Alt)(0) is defined 

for Normal. Thus, you can very quickly add headings, change their levels or 

demote them to normal text by using these key combinations. 

Explanation: The outline level is a paragraph format! 

At this point, you might ask: “What do styles really have to do with the outline?” 

Simply put, the outline level is an altogether ordinary paragraph format as far as 

TextMaker is concerned. If you look at the dialog of the Format > Paragraph 

menu command, you will also find an Outline level option there (on the Para-

graph tab). 

This option is preset to 1 ... 9 for the styles Heading 1 through 9 respectively. This 

is the reason you can change the levels of headings with the styles. 

Note: Normally, you should not change the Outline level option in the Format > 

Paragraph dialog manually. Use the Outline view or the styles mentioned above 

to do this. These methods are more convenient and avoid potential sources of er-

ror. 

Practical outlining 

FreeOffice: Outline view is not included in SoftMaker FreeOffice. 

To summarize, let’s consider how outlines can be applied most effectively in your 

documents. 

Outlining an existing document 

Let’s assume that you have already typed a document that includes headings and 

now want to use outlining to restructure it. 
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To do this, all you need to do is to switch to the Outline view with the menu com-

mand View > Outline and assign the headings to the desired levels. 

To raise or lower the outline level of any heading, position the text cursor in the 

heading and use the  (higher level) or  (lower level) button.  

Assign the major headings to outline level 1, the immediately subordinate headings 

to outline level 2, etc. 

To exit Outline view, invoke the menu command View > Standard. 

Outlining a new document 

The procedure for outlining a new document is no different than the one described 

above, except that a new document will have no headings at first. 

You can write out the whole document in a single stretch and then worry about the 

outline. Alternatively, you can assign each new heading to an outline level as soon 

as you have typed it, using the procedure described above. 

Numbering headings 

The headings of a large document are often numbered. For example, a major hea-

ding might have the numbering 1. and its sub-headings the numberings 1.1., 1.2., 

1.3, etc.  

TextMaker can number the headings of a document for you automatically. You can 

instruct it to do so as follows: 

1. Create the document and outline it. 

2. Create a numbered list with the desired type of numbering. Set the list type to 

Hierarchical list and check the Use paragraph’s outline level as list level op-

tion. 

3. Apply the numbered list to the paragraph style “Heading 1”. 

Without having to do anything more, a numbering is immediately applied to each 

heading in the document in accordance with its level and your specifications. For 

example, level 1 headings might be numbered 1., 2., 3., etc., while level 2 headings 

would be numbered 1.2, 1.3, and so forth.  

The procedure for accomplishing this is given in detail in the following steps: 



 

Manual TextMaker Working with large documents  •  427 

Step 1: Creating and outlining the document 

First you must, of course, create the document and outline it. It makes no diffe-

rence whether you begin constructing the outline as you begin the document or do 

your outlining only after you have entered the entire text. 

You will find information about outlining documents in section “Outlines” begin-

ning on page 418. 

Step 2: Creating an appropriate numbered list 

The next step is to create a numbered list appropriate for headings. To do this, pro-

ceed as follows: 

1. Invoke the Format > Bullets and numbering menu command. 

2. Switch to the Numbered lists tab. 

3. Click on the New button. 

4. Give the new numbered list whatever name you like (for example, “Headings”) 

and confirm with OK. 

5. Important: Select the Hierarchical list option in the Numbered list group box. 

6. Important: Check the Use paragraph’s outline level as list level option. 

7. You can change other settings to suite your wishes or simply retain the default 

settings. You will find information about the individual options in section 

“Creating numbered lists” beginning on page 187. 

8. Confirm with OK. 

9. The numbered list is now defined, and you can exit the dialog box by clicking 

on Close. 

Step 3: Applying the numbered list to the “Heading 1” paragraph style 

This final step is the real “key”: once you apply the numbered list that you created 

in the previous step to the “Heading 1” paragraph style, everything else follows 

automatically – every existing and newly inserted heading will be numbered auto-

matically. 

Even subordinate headings (of the second, third, etc. levels) will be numbered, be-

cause their styles are based on the “Heading 1” style. 
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Proceed with this step as follows: 

1. Invoke the Format > Paragraph style menu command. 

2. Select the Heading 1 paragraph style. 

3. Click on the Edit button. 

4. A dialog appears to enable you to edit the style. Switch to the Paragraph tab. 

5. Click on the Bullets button contained there. 

6. Another dialog appears to enable you to set up numberings. Switch to the 

Numbered lists tab. 

7. Select the numbered list that you created in step 2. 

8. Click successively on OK, OK and Close to exit all the dialogs. 

All existing headings are now automatically numbered, and numbering will be ap-

plied automatically to any headings that you might add later. 

Tip: If the format of the numberings does not suit you, you can always change 

the settings for the numbered list that you created in step 2 to adapt the format to 

your needs. To do this, invoke the Format > Bullets and numbering menu 

command again, switch to the Numbered lists tab, select the list, click on Edit 

and make the desired changes. These changes will affect all the headings in the 

document – including those already numbered. 

Note for users of older versions of TextMaker 

In older versions of TextMaker, headings could not be numbered automatically 

based on a numbered list and had to be numbered by means of manual insertions of 

“Auto number” fields. 

If you have old documents in which the headings are still numbered using the old 

method, you can of course continue to use them without restriction. TextMaker 

continues to support the auto number field. 

However, use of the new method is recommended when composing new 

documents, because numbered lists have several advantages: 

 You no longer have to manually insert an “Auto Number” field at the beginning 

of each heading. 

 Numbered lists are more flexible: they provide more kinds of numberings and 

more formatting possibilities. 
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 Numbered lists can be conveniently modified even after they have been ap-

plied. For example, if you want to change the formatting of all the numberings, 

all you have to do is edit the formatting of the numbered list – the numberings 

of all the headings will immediately change accordingly. 

Outlined documents and chapters 

Outlined documents often have page headers and footers in which the reader can 

find information such as the title of the current chapter.  

Naturally, TextMaker allows you to create such headers and footers. The only re-

quirement is that you divide the document into chapters, which are permitted to 

have their own headers and footers. 

To do this, use the menu command Insert > Break > Chapter break to insert a so-

called chapter break before each new thematic section of the document – normally, 

that means before every major heading. 

Now you can set up headers and footers with different contents for each chapter. 

You can also make other settings relating to page formatting (including even the 

paper format, page margins, etc.) on a chapter-by-chapter basis.  

You will find detailed information about working with chapters in section 

“Dividing a document into chapters” beginning on page 119. 

Tables of references (TOC, index, etc.) 

TextMaker provides functions that authors can use to significantly lighten some of 

the most time-consuming work associated with the preparation of large documents:  

The creation of tables of contents and indices is easy with TextMaker, captions and 

tables of figures can be provided for pictures, and even the creation of bibliogra-

phies (for referencing cited literature) is supported: 

 Indices (see page 431) 

 For an index you merely have to tell TextMaker what words are to be indexed, 

and where they are in the text. This is done by selecting each word to be in-

dexed in the text and invoking the Tools > Index > Add index entry menu 

command for it.  
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 When all keywords have been set, you can tell TextMaker to create the index 

with the Tools > Index > Generate index menu command. 

 Tables of contents (see page 435) 

 For a table of contents all you have to do is outline your document as described 

in the section “Outlines” (page 418). The outline already contains all the infor-

mation TextMaker needs about the hierarchy of the headings to enable it to cre-

ate the table of contents.  

 All you have to do is invoke the Tools > Generate table of contents menu 

command. 

 Captions and tables of figures (see page 437) 

FreeOffice: The features Caption and Generate table of figures are not in-

cluded in SoftMaker FreeOffice. 

 The Insert > Caption menu command can be used to insert automatically 

numbered captions below pictures – for example, “Figure 1”, “Figure 2”, etc.  

 When you have done that, you can use the Tools > Generate table of figures 

menu command to create a table of figures, including page numbers. 

 Bibliographies (see page 443) 

FreeOffice: The Bibliography feature is not included in SoftMaker Free-

Office. 

 For a bibliography you first enter all your sources in a bibliography database. 

Now you can insert references to these sources into the document with the In-

sert bibliography field command.  

 At the end of the document, invoke the Tools > Bibliography > Generate bib-

liography menu command to generate a list of all the referenced sources. 

Our section about tables of references concludes with the following additional in-

formation: 

 Updating tables of references 

 Editing and formatting tables of references 

Detailed information on these topics is presented on the pages that follow. 
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Indices 

An index is an alphabetized list of important keywords that occur in a document, 

giving the pages on which these words are found. 

On the next pages you will learn how to set up an index. 

Preparing an index 

Before TextMaker can create an index, you must specify the terms that should 

appear in it. To do this, you add them to the document’s keyword list. 

Adding terms to the keyword list 

To add a term to the keyword list, do the following: 

1. Select the term that should appear in the index. This can be a word, a part of a 

word or a phrase. 

2. Invoke the menu command Tools > Index > Add index entry. 

3. By default, TextMaker records only the position of the occurrence of the term 

that is currently selected. If you want TextMaker to record the positions of all 

occurrences of the term in the text, check the Index all occurrences option (see 

below for additional information).  

4. Click on OK. 

Now you have added the selected term to the list of keywords. TextMaker records 

in this list not only the term itself, but also the position of its occurrence in the text. 

Later, when the index is created, this term will appear in it, and the number of the 

page on which the term was selected as a keyword will appear to the right of the 

term. 

For the index to fulfill its function, it is important to select the position at which a 

term is added to the keyword list with care. For example, the word “print” occurs 

frequently in a word processor manual. When indexing this word, in makes more 

sense to add to the keyword list only those occurrences that are found in a section 

of the document dealing particularly with the topic of “printing”, than to add all 

occurrences. This way, the index will not be overloaded with useless references. 
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Adding multiple occurrences of a keyword 

By the way, the same term can be added to the keyword list multiple times. Such a 

term appears in the index only once, but the entry for it includes multiple page 

numbers. 

Note: The cases of letters in keywords are ignored. If both “Print” and “print” 

are added to the keyword list, the index will collect references to both terms un-

der the single entry “Print”.  

Adding all occurrences of a term 

In some cases it makes sense to create an index entry that refers to all the positions 

in the text at which the keyword appears. Naturally, you can do this by selecting 

each separate occurrence of the term and adding it to the list in the manner descri-

bed above. However, TextMaker can relieve you of this task. 

To enable TextMaker to do this, check the Index all occurrences option when you 

add the keyword to the list with the Tools > Index > Add index entry menu com-

mand. TextMaker will then search the entire text for the given term when it creates 

the index and it will include the numbers of all the pages on which the term occurs.  

Editing the keyword list 

The content of the keyword list can be edited at any time after terms have been 

added. To edit the list, invoke the Tools > Index > Edit index entries menu com-

mand and proceed as follows: 

 Deleting an index entry 

 Keywords added to the list by mistake can be removed with the Delete button. 

To remove an entry, select it from the list and click on Delete. 

 Searching for occurrences of a keyword 

 You can find the position at which a specified entry in the keyword list occurs 

in the text with the Go to button. To do this, select the keyword from the list 

and click on Go to. TextMaker places the text cursor at the position in the text 

where the term occurs.  

 If several occurrences of the term were recorded, the cursor is positioned at the 

first occurrence. Click on the Go to button again to jump to the second occur-

rence, third occurrence, etc. 
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 Note: The Go to button is not available for keywords that have been added with 

the Index all occurrences option turned on. 

The {Index:'...'} field 

In conclusion, some technical information for advanced users: 

When a selected term is added to the keyword list, TextMaker inserts an invisible 

“Index” field in the text immediately following the selection. For example, if the 

term is “fish”, the index field inserted is: {Index: 'fish'}. 

You can make these index fields visible by invoking the File > Properties menu 

command, switching to the View tab and checking the Display field names option. 

In this way you can examine the text to determine exactly what terms have been 

added to the keyword list, and exactly where they occur. 

This method does not apply to terms that have been added to the list with the Index 

all occurrences option checked, because no index fields are inserted for such 

terms. They are handled by functions internal to the program. 

Creating the index 

In the course of adding terms to the keyword list with the Tools > Index > Add 

index entry menu command you have made TextMaker aware of the words that 

are to appear in the index. Now you can have TextMaker create the index itself. 

To do this, proceed as follows: 

1. Position the text cursor at the beginning of the line on which the index should 

be placed. 

2. Invoke the menu command Tools > Index > Generate index. 

3. Specify whether a new index is to be created at the current position, or an exis-

ting index is to be updated by selecting the appropriate option in the Placement 

group box. 

As soon as you confirm with OK, TextMaker inserts the index into the text. 
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Q 

Quantum mechanics, 78 

  

R 

Raster, 102, 163 

Registration card, 11 

Right arrow key, 20 

Roman, 151 

Sample from an index (with “First letter” headings) 

The keywords appear in alphabetical order. At the right of each keyword, TextMa-

ker inserts the numbers of the page(s) on which it occurs. 

Dialog options 

The options in the dialog box for this command are as follows: 

 Heading 

 Here you can select the desired style of the index: 

 None: Index entries follow each other without breaks. 

 Blank line: A blank line is inserted before each index entry that begins with a 

new first letter. 

 First letter: A large letter representing the first letter of the immediately follo-

wing index entries is inserted before each entry that begins with a new first let-

ter. 

 Use chapter number 

 If this option is checked, the chapter number (together with a separating dash) 

is added before each page reference.  

 Naturally, it makes sense to use this option only when you have divided the 

document into multiple chapters with the Insert > Break > Chapter break 

menu command (see section “Dividing a document into chapters” beginning on 

page 119). 

 Right align page numbers 

 If this option is checked, the page numbers in the index appear right aligned.  
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 Tab leader 

 If the option Right align page numbers is checked, this option lets you choose 

which character to use for filling the gap between index entry and page number 

(e.g. dots). 

Additional information: 

 You will find information about updating references in section “Updating tab-

les of references” beginning on page 450. 

 You will find information about editing and formatting references in section 

“Editing and formatting tables of references” beginning on page 451. 

Tables of contents 

A table of contents (TOC) is a list of all the headings in the document, each with a 

page number. 

Unlike an index, a table of contents does not depend on a list of entries that you 

have to create yourself prior to its creation. Your document merely has to be out-

lined. You can review the outlining process in section “Outlines” beginning on pa-

ge 418. 

TextMaker already knows from the outline what headings the text contains and 

what hierarchical relations they have to each other.  

Accordingly, the creation of a table of contents is easy: 

1. Position the text cursor at the beginning of the line on which the table of con-

tents is to be placed. 

2. Invoke the menu command Tools > Generate table of contents. 

3. Specify whether a new table of contents is to be created at the current position, 

or an existing table is to be updated by selecting the appropriate option in the 

Placement group box. 

As soon as you confirm with OK, the table of contents in inserted into the text. 
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The Love Life of Trees........1 

  In Spring...................1 

    March.....................1 

    April.....................3 

    May.......................4 

  In Summer...................7 

  In Autumn..................10 

Sample from a table of contents 

TextMaker puts the headings at the left; to the right of each heading it inserts a tab, 

followed by the corresponding page. 

Dialog options 

The options in the dialog box for this command are as follows: 

 You can select an option for Include levels to specify the outline levels to be 

included in the table of contents. By default, all levels (1 through 9) are in-

cluded. 

 When you check the Use up to first tab option, TextMaker examines each hea-

ding to see if it contains tabs. If a heading contains tabs, any text behind the 

first tab is ignored when the heading is imported into the table of contents.  

 The Use numbering option is checked by default. Thus, if you have numbered 

the headings in your document, they will appear in the table of contents with 

the corresponding numberings. 

 If you don’t want the table of contents entries numbered, uncheck this option. 

 You can review information about numbering the headings of a document in 

section “Numbering headings” beginning on page 426. 

 The options in the Placement group box allow you to specify what should hap-

pen if the document already contains a table of contents: 

 If you select Replace existing table, the existing table of contents is replaced. 

 On the other hand, if you select Create new table, TextMaker leaves the origi-

nal table in place and inserts an additional table of contents. 

Additional information: 

 You will find information about updating references in section “Updating tab-

les of references” beginning on page 450. 
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 You will find information about editing and formatting references in section 

“Editing and formatting tables of references” beginning on page 451. 

Captions and tables of figures 

FreeOffice: The features Caption and Generate Table of Figures are not in-

cluded in SoftMaker FreeOffice. 

You can insert automatically numbered captions below images – for example, “Fi-

gure 1”, “Figure 2” etc. When you have done that, you can even add a table of figu-

res to the document. It presents a list of all images that you have labeled that way, 

including their page numbers. 

Captions can be added not only to images but also to any other kind of text ele-

ments. For example, the tables in a document can be labeled as well. 

You can even insert captions for the images and the tables in a document, with both 

of them using their own numbering. Apart from that, you can insert an individual 

table of figures for each of them. 

Working with captions and tables of figures is actually quite easy: 

 Inserting captions for images and other objects 

 Use the Insert > Caption menu command to insert an automatically numbered 

caption into the text. 

 For example, if you want to label the images in a document, simply select the 

image of interest and invoke this command. TextMaker will insert a caption be-

low the picture. It consists of a label and a sequential number – e.g. “Figure 1”.  

 The numbering is performed fully automatically: If you add additional captions 

or remove existing ones, all other numbers are adapted accordingly. 

 If desired, you can always type in some explanatory text behind the caption – 

for example, to extend the caption “Figure 1” to “Figure 1: The Larch”. 

 Creating a table of figures 

 Once you have inserted captions, you can use the Tools > Generate table of 

figures menu command to insert a table of figures into the text. It presents a list 

of all images that you have added captions to. 
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 For example, if you have inserted captions for all images in a document, you 

can create a table of these images. It includes page numbers, so that the reader 

can see at a glance on which page each image is located. 

 Note: Text entered directly behind a caption also appears in the table of figures. 

For example, if you have extended the caption “Figure 1” to “Figure 1: The 

Larch”, this entire text will be displayed in the table. 

For detailed information, see the next pages. 

Inserting captions for images and other objects 

FreeOffice: The Caption feature is not included in SoftMaker FreeOffice. 

Use the Insert > Caption menu command to insert an automatically numbered 

caption into the text. 

For example, if you want to label the images in a document, simply select the 

image of interest and invoke this command. TextMaker will insert a caption below 

the picture. It consists of a label and a sequential number – e.g. “Figure 1”.  

The numbering is performed fully automatically: If you add additional captions or 

remove existing ones, all other numbers are adapted accordingly. 

To add a caption to a picture, proceed as follows: 

1. Select the picture that you want to add a caption to by clicking on it. 

 Alternatively, place the text cursor at the position where you want to insert the 

caption. For example, insert a blank line below the picture and place the text 

cursor there. 

2. Invoke the Insert > Caption menu command. 

3. In the Labels list, select the label that you want to be displayed in the caption – 

e.g. “Figure”. 

4. Make any additional required settings for the caption (see “Options” below). 

5. Click on the Insert button. 

TextMaker will now insert the selected label, followed by a sequential number – 

for example “Figure 1”. 
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If desired, you can always type in some explanatory text directly behind the capti-

on – for example, to extend the caption “Figure 1” to “Figure 1: The Larch”. This 

text will also appear in the table of figures, if you create one (see the next section). 

Proceed the same way for all pictures that you want to insert captions for. 

Note: Captions can be added not only to images but also to any other kind of text 

elements. For example, the tables in a document can be labeled the same way. 

Simply choose the corresponding entry in the Labels list. 

Dialog options 

The dialog box for this command offers the following options: 

 Labels 

 Use this option to choose which label to use in the caption. 

 The name of the selected label will be used for the text in the caption. For exa-

mple, when you choose the label named “Figure”, the caption “Figure 1” will 

be inserted. 

Note: Each label uses its own numbering. This allows you to add indepen-

dently numbered captions to, for example, the pictures and the tables of a 

document. Simply choose the label “Figure” when you want to insert a capti-

on for a picture, or “Table” to insert a caption for a table. 

Apart from that, you can create an individual table of figures for each label 

(see the next section). 

 Position 

 The Position option is only available when you had selected the object (e.g. 

picture) of interest before you invoked this command. If this is the case, you 

can use this option to choose if the caption should be added above or below the 

object. 

 TextMaker will automatically insert an empty paragraph to make room for the 

caption. If you have selected an object that is in a frame (e.g. a picture frame), 

TextMaker will automatically insert a text frame above or below the object and 

place the caption there. 
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 Format 

 Use this option to choose the desired representation of the sequential number – 

e.g. Arabic numbers (1, 2, 3, ...), Roman numbers (I, II, III, ...), or letters (A, B, 

C, ...). 

 Exclude label 

 If you enable this option, TextMaker omits the label in the caption and inserts 

only the sequential number. 

 For example, instead of “Figure 1”, just “1” will be inserted. 

 “New” button 

 The New button allows you to create a new label. 

 A dialog where can enter the name of the new label appears. As a name, enter 

exactly the text that should appear in the caption. For example, when you create 

a label named “Illustration”, the text “Illustration 1” appears when you insert a 

caption for this label. 

 As mentioned before, each label has its own numbering, independent from the 

numberings of other labels. Apart from that, an individual table of figures can 

be generated for each label (see the next section). 

 “Delete” button 

 The Delete button allows you to delete a label. Select the label to delete before-

hand. 

 When you delete a label, all existing captions are kept. However, you cannot 

insert new captions with that label anymore. Also, inserting or updating tables 

of figures for that label is no longer possible. 

Hint: In case you have deleted a label by mistake, you can fix this by simply 

clicking the New button and creating a label with exactly the same name. 

Notes 

 The label will be inserted into the caption as text. 

 The sequential number will be inserted as a field of the type “Sequence num-

ber”. Fields of this type return a sequential number that is increased by one for 

each of its occurrences (given that they belong to the same label). For each la-
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bel, an individual series of Sequence fields is used, with its numberings being 

independent from each other label. 

 For general information on working with fields, see the chapter “Fields” (page 

171). 

Creating a table of figures 

FreeOffice: The Table of figures feature is not included in SoftMaker Free-

Office. 

As described in the last section, you can insert automatically numbered captions 

into the text using the Insert > Caption menu command. For example, the pictures 

in a document can be labeled “Figure 1”, “Figure 2”, etc. This also works with 

other components of the document, e.g. tables. 

When you have done that, you have the option to create a table of figures and insert 

it into the text. It will contain a list of all images that you have added captions to. 

For example, if you have inserted captions for all images in a document, you can 

create a table of these images. It includes page numbers, so that the reader can see 

at a glance on which page each image is located. 

To insert a table of figures, proceed as follows: 

1. Using the Insert > Caption menu command, insert a many captions into the 

text as you like (as described in the previous section). 

2. Position the text cursor at the beginning of the line on which the table of figures 

should be placed. 

3. Invoke the menu command Tools > Generate table of figures. 

4. In the Labels list, select the label that you want to create a table of figures for 

(e.g. “Figures”). 

5. Specify whether a new table of figures is to be created at the current position, 

or an existing table is to be updated by selecting the appropriate option in the 

Placement group box. 

When you confirm with OK, TextMaker inserts the table of figures into the text. 
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Figure 1...................9 

Figure 2..................14 

Figure 3..................17 

Figure 4..................18 

Figure 5..................21 

Sample from a table of figures 

TextMaker puts the label and sequential number at the left; to the right of each cap-

tion it inserts a tab, followed by the corresponding page. 

If have typed in explanatory text directly behind a caption, it will also appear in the 

table of figures. For example, if you have extended the caption “Figure 1” to “Fi-

gure 1: The Larch”, this entire text will be displayed in the table. 

Dialog options 

The dialog box for this command offers the following options: 

 Labels 

 As described in the previous section, different labels can be used in captions. 

For example, you can insert captions with the label “Figures” – as well as cap-

tions with the label “Tables”. An individual table of figures can be created for 

each label used. 

 To specify for which label the table of figures is to be created, choose the cor-

responding label from the Labels list. 

 Note: Only labels for which at least one caption has been inserted into the 

document are available in this list. 

 Include label and number 

 As noted before, you can type in explanatory text directly behind captions – for 

example, to extend the caption “Figure 1” to “Figure 1: The Larch”. 

 In case you have done that, this option allows you to specify if the label and 

sequential number of captions should be displayed in the table of figures as 

well. 

 By default, this option is enabled. This means that, in the above example, the 

text “Figure 1: The Larch” would appear in the table of figures. 

 If you turn this option off, only “The Larch” is displayed. 
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 Right align page numbers 

 If this option is enabled, TextMaker separates the page numbers with a right-

aligned tab (filled with dots). 

 If disabled, only a space character will be inserted to separate the page num-

bers. 

 Placement 

 Use this option to specify what should happen if the document already contains 

a table of figures for the chosen label: 

 If you select Replace existing table, the existing table of figures is replaced. 

 On the other hand, if you select Create new table, TextMaker leaves the origi-

nal table in place and inserts an additional table of figures. 

Additional information: 

 You will find information about updating references in section “Updating tab-

les of references” beginning on page 450. 

 You will find information about editing and formatting references in section 

“Editing and formatting tables of references” beginning on page 451. 

Bibliographies 

FreeOffice: The Bibliography feature is not included in SoftMaker FreeOffice. 

In the appendices to scientific literature you often find a bibliography. This is a 

reference list of all the publications to which the author refers in his document. 

TextMaker has functions that you can use to make working with bibliographies 

much easier. 

These functions are best applied step by step, as follows: 

 Step 1: First of all, you need a bibliography database. There, you enter all your 

cited sources. You can use an existing database (an example is included with 

the program) or set up a new one with the menu command Tools > Create 

database.  
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 The database can be organized any way you like, except that it must always 

include a field for a “shortcut” (abbreviation) that can serve as a unique refe-

rence for each source, and also fields for the author and title of each source.  

 Step 2: Next, invoke the menu command Tools > Bibliography > Bibliography 

settings and click on the File button to assign your database to the document as 

a bibliography database. Then select those fields of your database that are to 

serve respectively as the Reference Field, Author Field and Title Field for the 

creation of the bibliography. 

 Step 3: Now you can invoke the menu command Tools > Bibliography > In-

sert bibliography field to insert references to the sources contained in the bib-

liography database into the text (for example, “As mentioned in [DNA1979] 

...”). 

 Step 4: Finally, at the end of the document, invoke the menu command Tools > 

Bibliography > Generate bibliography to have TextMaker create a biblio-

graphy. The bibliography represents a list of all sources to which you have inse-

rted references in the text (see step 3). Each source listing will be based on the 

corresponding record in the bibliography database. 

You will find detailed information about this on the following pages. 

Step 1: The bibliography database 

FreeOffice: The Bibliography feature is not included in SoftMaker FreeOffice. 

In order to be able to make use of TextMaker’s bibliography functions, you first 

need a bibliography database. This is a database in dBase format in which infor-

mation about all the sources can be entered.  

You can create an individual bibliography database for each document. However, if 

you are planning to write multiple documents that will refer to the same sources, it 

might be more useful to set up a single database that will be common to all those 

documents. 

The structure of a bibliography database 

A bibliography database must contain at least the following fields: 

 a field for a unique abbreviation for the source (see below) 

 a field for the name of the author of the source 

 a field for the title of the source 
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The abbreviation must be distinct for every source. By convention, the abbreviati-

on consists of author’s initials and the year of publication. For example, if the 

source were a book the author Harry Smith had published in 1979, HS1979 (or 

HS79) would be used as the abbreviation. 

Apart from the requirement that it must contain the above listed three fields, the 

database can be organized in whatever way is preferred. For example, it can con-

tain fields for the date of publication, the publisher, etc.  

Tip: TextMaker’s document folder contains a simple example database called 

BIBLIO.DBF that you can examine. Under Windows, this file can be found in the 

SOFTMAKER folder under your documents folder. 

Setting up a new bibliography database 

Unless you already have a bibliography database that you want to use, you will 

have to set up a new database. To do this, you can use TextMaker’s database modu-

le or any other dBase compatible database program. 

With TextMaker, you create a new bibliography database as follows: 

1. Invoke the Tools > Create database menu command. 

 Alternatively, you can use the menu command Tools > Bibliography > Create 

a new bibliography database for this; it does exactly the same. 

2. Give the database whatever name you like, and confirm with OK. 

3. Add the desired fields to the database. The database must always contain fields 

for a unique “shortcut” (abbreviation), author, and title. 

 You will find information about the operation of the field setup dialog in sec-

tion “Creating a new database” beginning on page 376. 

4. When you are finished, click on OK. 

5. TextMaker creates the database and then opens it.  

 If you want to enter your sources into the database at this point, you can do so. 

Otherwise, invoke the File > Close menu command to close the database. 
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Editing the bibliography database 

Next, you must fill in the bibliography database, entering there information about 

the sources to which you refer in your document. Naturally, it is up to you if you 

want to enter all sources at once, or add sources only as required. 

To enter sources, you can use TextMaker’s database module, which is invoked with 

the Tools > Edit database menu command. You will find information about the 

operation of the database module in chapter “Database” beginning on page 351. 

Alternatively, you can open the database using the menu command Tools > Biblio-

graphy > Edit the bibliography database, which does exactly the same. 

Step 2: Assigning the bibliography database 

FreeOffice: The Bibliography feature is not included in SoftMaker FreeOffice. 

In the next step, you tell TextMaker what database you want to use as the 

document’s bibliography database. In addition, you specify the fields of the data-

base from which TextMaker is to obtain the abbreviations for use in references, the 

author names, and the titles for the sources. 

To do this, proceed as follows: 

1. Open the document to which you want to assign the bibliography database you 

created in step 1, or start a new document. 

2. Invoke the menu command Tools > Bibliography > Bibliography settings. 

3. Click on the File button. 

4. A file dialog appears. There, navigate to the folder containing the bibliography 

database, select the database and confirm with OK. 

5. After that, specify the database fields that contain the abbreviations (“short-

cuts”), the author names, and the titles for the sources. To do this, make the ap-

propriate selections from the three dropdown lists in the Settings group box. 

6. If required, you can also specify the form in which the references that you will 

insert in step 3 (see next section) should be displayed by setting options in the 

Reference style group box. 

7. When you are satisfied with all the settings, confirm with OK. 



 

Manual TextMaker Working with large documents  •  447 

TextMaker now knows which database contains information about the sources for 

this document and how this information is distributed over the database fields. So 

you can proceed to step 3. 

Note: Alternatively, you can assign a database using the menu command Tools > 

Bibliography > Attach an existing bibliography database, which does exactly 

the same as the File button in the dialog mentioned above. 

Step 3: Inserting references to sources 

FreeOffice: The Bibliography feature is not included in SoftMaker FreeOffice. 

When you have completed steps 1 and 2, you can insert bibliography fields in the 

text. These are references to sources that are recorded in the bibliography database. 

You can insert such a reference whenever you refer to one of the sources in the text 

– for example “as mentioned in [DNA1979], ...”. 

You insert a reference to a source into the text as follows: 

1. Move the text cursor to the desired position. 

2. Invoke the menu command Tools > Bibliography > Insert bibliography field. 

3. Choose the desired database entry from the list.  

 Tip: You can always use the Edit button to edit the contents of the database. In 

this way you can, for example, add a new entry. 

4. As needed, you can enter additional text in the Additional information field – 

for example, “page 42”. This text will be displayed behind the reference, sepa-

rated by a comma. 

5. Confirm with OK. 

The reference is now inserted into the text. Depending on the options selected in 

the Bibliography settings dialog, either the abbreviation or the number of the 

source will appear in the text (see below). 

Proceed as described above each time you want to insert a reference to one of the 

sources in your database into your document. 



 

448  •  Working with large documents Manual TextMaker 

Options for the styles of references 

The bibliography settings dialog allows you to change the appearance of references 

whenever necessary. For example, you can specify whether they should appear as 

abbreviations taken from the database, or as automatically generated numbers.  

To change the style of references, invoke the menu command Tools > Biblio-

graphy > Bibliography settings and make the desired settings in the Reference 

style group box. 

The following options are available: 

 You can select Use reference field to specify that the references should be 

shown as “abbreviations” for the sources, based on entries in the database – for 

example [DNA1979]. 

 You can select Number entries to specify that the references should be shown 

as numbers, generated automatically – for example [42].  

 The source for the first reference that you insert receives the number [1], the 

source for the second reference receives the number [2], etc. 

Note: When you switch from one of these options to the other, the 

appearance of all the references in the document immediately changes in ac-

cordance with your selection. On the other hand, the bibliography itself (if it 

already exists) will not reflect your changes until you update it (see section 

“Updating tables of references” beginning on page 450). 

 The Parentheses option allows you to specify the type of parentheses in which 

the references will be enclosed. 

 For example, if you choose the setting { } instead of the default setting [ ], refe-

rences will be enclosed with curly braces rather than with square brackets. Ac-

cordingly, instead of [DNA1979] you will see {DNA1979}. 

Step 4: Creating the bibliography 

FreeOffice: The Bibliography feature is not included in SoftMaker FreeOffice. 

In the final step you have TextMaker generate the bibliography at the end of the 

document. The bibliography will list all the sources from the bibliography database 

to which you inserted references in the text (as described in step 3). 

To insert a bibliography, proceed as follows: 
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1. Position the text cursor at the beginning of the line on which you want the bib-

liography to be placed. 

2. Invoke the menu command Tools > Bibliography > Generate bibliography. 

3. Specify whether a new bibliography is to be created at the current position, or 

whether an existing bibliography is to be updated by selecting the appropriate 

option in the Placement group box. 

4. As required, you can modify the way the source listings will appear in the bib-

liography using the large edit field at the bottom of the dialog (see below). 

When you confirm with OK the bibliography is inserted into the text. 

Note: As mentioned in the introduction to step 4, only those sources from the 

bibliography database that are actually referenced in the document (see step 3) 

appear in bibliography. 

Changing the appearance of the bibliography 

Before clicking on OK to close the above described dialog, you can, if required, 

change the form in which the source listings will appear: 

Editing text: You can always edit the text that appears in the edit field. Use the stan-

dard editing procedures for this purpose. 

Changing formatting: The formatting can also be changed. To do so, first select the 

segment of text that you want to format in the edit field. Then use the miniature 

formatting toolbar displayed above it to change the character format. 

Inserting fields: Fields from the bibliography database are indicated with curly 

braces. As required, you can insert additional database fields into the edit field, 

either by manually typing the field name (e.g. {AUTHOR}) or by double clicking 

on the desired field in the Fields list. 

Hint: The first item in the Fields list is a field called {#REF}. This field is crea-

ted automatically – and it has a special function: It contains either the abbreviati-

on or an automatically generated number for the source, depending on which of 

these two options you have selected in the bibliography settings dialog. 

Additional information: 

 You will find information about updating references in section “Updating tab-

les of references” beginning on page 450. 
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 You will find information about editing and formatting references in section 

“Editing and formatting tables of references” beginning on page 451. 

Updating tables of references 

Important: When you edit a document into which you have already inserted a 

table of references (table of contents, index, table of figures or bibliography), the 

table is not automatically updated in step with your editing. 

Thus, when the document’s page numbers change because you have typed additio-

nal text, the table of references continues to show the now outdated page numbers. 

And when, for example, you add new headings, the table of contents does not ex-

pand automatically. 

To make a document’s tables of references reflect the current state of the 

document, you must update them. You do this as follows: 

1. To update the index, invoke the Tools > Index > Generate index menu com-

mand.  

 To update the table of contents, invoke the Tools > Generate table of contents 

menu command. 

 To update a table of figures, invoke the Tools > Generate table of figures 

menu command. 

 To update the bibliography, invoke the Tools > Bibliography > Generate bib-

liography menu command. 

2. Important: Make sure that the Placement option in the dialog box is set to Re-

place existing table. 

3. Confirm with OK. 

TextMaker now removes the existing table of references and replaces it with an 

updated version. 

Note: Before printing a document containing tables of references, always re-

member to update the tables, so that they reflect the document’s current state. 
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Editing and formatting tables of references 

In theory, tables of references (tables of contents, indices, tables of figures, biblio-

graphies) can be edited just like normal text. However, you should take note of the 

following: 

Important: If you manually change the content or formatting of a table of refe-

rences, your changes will be lost whenever you have TextMaker update it, be-

cause the updating process involves the removal and reinsertion of the table. 

It follows that manual changes to text or formatting in a table of references make 

sense only when your document is 100% ready for printing and the table will not 

have to be updated again. 

Normally it is not necessary to change the text in tables of references anyway, and 

there are much more elegant ways to change their formatting: 

Tip: Tables of references are automatically formatted using paragraph styles, and 

their formatting can be conveniently modified with the help of these styles. 

When you create a table of references, TextMaker creates the following styles: 

 “TOC 1” through “TOC 9” 

 Paragraph styles for entries in the table of contents, according to outline level. 

Entries for the first outline level (i.e., for major headings) are formatted with 

the “TOC 1” style, entries for the second level are formatted with the “TOC 2” 

style, etc. 

 “Index” 

 The paragraph style for entries in the index 

 “Index Heading” 

 The paragraph style for the large letters that are used as headings for sections of 

the index (when the First letter option has been selected prior to the creation of 

the index) 

 “Caption” 

 The paragraph style for captions 

 “Table of figures” 

 The paragraph style for entries in a table of figures 
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 “Bibliography” 

 The paragraph style for entries in the bibliography 

Thus, if you want to change the formatting of a table of references, you can change 

one or more of these styles. For example, if you want to increase the font size for 

the major headings in the table of contents, all you have to do is change the “TOC 

1” style accordingly: 

1. Invoke the menu command Format > Paragraph style. 

2. Select the “TOC 1” style from the list and click on Edit. 

3. A dialog appears to enable you to change the formatting. Switch to the Para-

graph tab. 

4. Click on the Character button. 

5. Set the desired font size in the Size field. 

6. Exit the dialogs by clicking in succession on OK, OK and Close. 

Now the major headings in the table of contents are rendered in the new font size. 

This formatting will remain in effect after you update the table and even if you 

remove and reinsert it. 

If necessary, you can go to chapter “Styles” beginning on page 129 to review gene-

ral information about the use of styles. 

Cross references 

FreeOffice: The Cross reference feature is not included in SoftMaker Free-

Office. 

With the Insert > Cross reference menu command, you can insert a reference to a 

specific text element (for example, a bookmark or an object) into the text.  

This command inserts a field that displays, for example, the page number of the 

targeted text element. Thus if you have inserted a picture on page 3 of the 

document, you can introduce a cross reference to this picture – for example, “see 

picture on page 3” – at some other place in the document. 

Cross references can target text elements of the following kinds: 

 bookmarks 
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 footnotes 

 objects (pictures, drawings, etc.) 

Cross references to bookmarks are often encountered in large documents.  

For example, if you want to insert a cross reference to the index at the end of your 

document, first put a bookmark at the beginning of the index. Then return to the 

place in the document where the reference should appear, type something like “See 

also the index beginning on page “, and insert a cross reference to the bookmark. 

The cross reference now shows the number of the page on which the index begins. 

Cross references are updated automatically when the document is printed. They 

can also be updated manually, if desired, with the Tools > Update fields menu 

command. 

The following pages contain detailed information about working with cross refe-

rences. 

Inserting a cross reference 

FreeOffice: The Cross reference feature is not included in SoftMaker Free-

Office. 

To insert a cross reference in the text, do the following: 

1. If you want to insert a cross reference to a bookmark, you must first set the 

bookmark at the target position with the Insert > Bookmark menu command 

(see also section “Bookmarks” beginning on page 166). 

2. Then, move the text cursor to the place in the text where the cross reference is 

to be inserted.  

3. Invoke the Insert > Cross reference menu command. 

4. Select the kind of text element that the cross reference should target from the 

Type list: a Bookmark, a Footnote or an Object. 

5. Select the specific bookmark, footnote or object to which the cross reference 

should refer from the Target list. 

6. From the Show list, select either Page, to specify that the cross reference 

should show the page number of the target, or Number, to specify that the 

cross reference should show the target’s own number (see “Options” section be-

low). 
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7. Confirm with OK.  

TextMaker now inserts the cross reference into the text. 

Dialog options 

The options in the dialog box for this command are as follows: 

 Type 

 Here you specify the kind of text element that the cross reference is to target: a 

Bookmark, a Footnote or an Object. 

 Target 

 Here you select the target for the cross reference. The contents of this list de-

pend on the Type of target selected. For example, if you have selected Book-

mark as the type, all the existing bookmarks in the document will be displayed 

in this list. Select the desired bookmark from the list with a mouse click. 

 Show 

 Here you specify what the cross reference should show: 

 Page: The cross reference shows the number of the page on which the target is 

to be found. 

 Number: The cross reference shows the number of the target itself: 

 For footnotes, the footnote’s number is shown. 

 For bookmarks, the number of the paragraph in which the bookmark has been 

set is shown. For this to work properly, the paragraph must have been given a 

numbering using the Format > Bullets and numbering menu command. If the 

paragraph has not been numbered, the cross reference will show a zero. 

 This option is not available for objects. 

Editing and updating a cross reference 

FreeOffice: The Cross reference feature is not included in SoftMaker Free-

Office. 
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Cross references are fields; thus, what goes for fields in general goes for cross refe-

rences as well: they can be formatted, deleted, copied and moved in the same way 

as normal text; however, their contents cannot be edited directly.  

Tip: Whenever you want to see a document’s cross references and the targets to 

which they refer you can check the Display Field Names option on the View tab 

in the dialog of the File > Properties menu command. Then the cross references 

will be displayed in a form in which their type and their target is visible – for 

example, “{Reference.Bookmark.Page:name_of_bookmark}”. 

Updating cross references 

Just like all other kinds of fields, cross references are not updated automatically. 

For example, if you move the target of a cross reference to another page, the page 

number displayed by the cross reference continues to reflect the original position of 

the target. 

However, when you print the document, TextMaker automatically updates all 

fields (including this cross reference) to reflect the latest state of the document. 

Thus, when you print the document you can be sure that all cross references will be 

correct. 

As needed, you can also update the fields of a document manually by invoking the 

Tools > Update fields menu command. All fields and calculations will then be 

brought up to date. 

Invalid references: If you delete the target of a cross reference, then of course the 

cross reference becomes invalid. In such a case, when you update the document, 

the message “Target not found!” is displayed in the text by the cross reference. 

You can correct this problem by removing the cross reference and inserting a 

new one (with a valid target). 

Style references 

Apart from cross references (detailed on the previous pages), you can also insert 

so-called style references into the text. 

A style reference is a field that functions as follows: It searches the document 

(from the place where you inserted it) backwards for text that is formatted in the 

paragraph style you specified – and displays the first text found.  
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This can be helpful, for example, in the following situation: 

Large documents are often organized according to an outline; i.e. headings with 

several levels are used. The easiest way to accomplish this is to format all headings 

with the provided paragraph styles “Heading 1”, “Heading 2”, etc. When you have 

done that, you can insert a style reference field at any place in the text. If you let it 

search for e.g. the style “Heading 1”, it will find – and display – the main heading 

of the text segment where you inserted it. 

Accordingly, such fields are often used in the headers or footers of books and other 

large documents, in order to display the main heading of the current chapter. 

Inserting a style reference field  

To insert a style reference field into the text, proceed as follows: 

1. Move the text cursor to the place in the text where the style reference field is to 

be inserted.  

2. Invoke the Insert > Field menu command. 

3. In the left list, select the entry Style Reference. 

4. In the right list, select the style to be searched for. 

5. Click on the Insert button.  

TextMaker now inserts the style reference field into the text. 

The field then automatically searches for text formatted with the specified para-

graph style. It first searches backwards (towards the beginning of the document). If 

nothing is found in this direction, it also searches forwards (towards the end of the 

document). 

As soon as text formatted in the given style is found, the field displays that text. 

Thus, if you had chosen e.g. the paragraph style “Heading 1”, the field displays the 

main heading of the text segment where it was inserted. (Given that all headings in 

the document have been formatted with the paragraph style “Heading 1”.) 

If no matching text is found, the field displays an error message like “Style refe-

rence: no matching text found”. In that case, make sure you have selected the cor-

rect style to search for and check if text formatted in that style actually exists. 
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Dialog options 

In the dialog box appearing when you insert a style reference field, the following 

options are available: 

 Style 

 In this list box, select the paragraph style (or character style) to be searched for. 

 Search for character styles 

 Usually, style reference fields are used to search for paragraph styles. If you 

want to search for character styles instead, choose this option. The list of styles 

displayed in the Style list box will change accordingly. 

 Search page from bottom 

 Affects only style reference fields that are inserted in headers or footers, since 

in that case they follow a special search order, as follows: 

 First, only the current document page is searched – in the following direction: 

 If this option is turned off, the page is searched from top to bottom. 

 If this option is turned on, the page is searched from bottom to top (back-

wards). 

 After that, the search is continued as usual: first towards the beginning of the 

document (backwards) and then, if nothing was found, towards the end of the 

document (forwards). 

 Insert paragraph number 

 If this option is checked, the style reference field returns the numbering of the 

found paragraph rather than its content. 

 (Of course this only works if a numbering has been applied to the text. See sec-

tions “Automatic numbering” (page 181) and “Numbering headings” (page 

426).) 

 Insert 'above' or 'below' 

 If this option is checked, the style reference field returns solely a hint on the 

position of the found text (either “above” or “below”) rather than its content. 

 If the text is located above the field, the field displays the text “above”. 

 If the text is located below the field, the field displays the text “below”. 

 This allows you to insert references like “see above” or “see below”. 
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Updating style reference fields 

Like all kinds of fields, style reference fields are updated automatically when the 

document is printed. They can also be updated manually, if desired, with the Tools 

> Update fields menu command. For more information on working with fields, see 

the chapter “Fields” (page 171). 

Footnotes 

When a word or a phrase in your text requires explanatory comments, you can 

place such comments in footnotes. Footnotes usually appear at the bottom of the 

pages on which they are referenced; however, they can also be grouped together at 

the ends of chapters or even at the end of the document. 

Footnotes consist of two parts: a superscripted footnote marker in the body text, 

and the footnote text to which it refers: 

When you encounter heavy fog1 you should immediately slow 

down2 and turn on your fog lights. 

 

_______________ 

1 Visibility less than 150 feet 

2 Maximum 30 mph 

An example of the use of footnotes 

TextMaker numbers footnotes automatically in an ascending sequence. If you in-

sert a new footnote in the text, or delete an existing footnote, the numbering of any 

following footnotes is automatically adjusted. 

By default, TextMaker automatically inserts a separator line between the text and 

the footnote area. If you wish, you can specify a custom format for this line, or 

even disable it. 

In this section you will learn everything you need to know about footnotes. The 

following topics are covered: 

 Inserting and editing footnotes 

 Changing the formatting of footnotes 

 Footnote options 

Read the following pages for detailed information. 
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Inserting and editing footnotes 

With TextMaker, you can add footnotes to a text segment very easily: Place the 

cursor right behind that text segment, invoke the Insert > Footnote > Insert foot-

note menu command, and type the footnote text. The rest (numbering, formatting, 

and placement of the footnote) is done automatically for you.  

In detail, you proceed as follows: 

1. Position the text cursor immediately after the word or phrase to which you want 

to append the footnote. 

2. Invoke the Insert > Footnote menu command. A sub-menu opens. Select the 

Insert footnote command from the sub-menu. 

3. TextMaker now inserts a superscripted footnote marker (an automatically gene-

rated number) for the footnote.  

 It then creates an area for the footnote at the bottom of the page, inserts a copy 

of the footnote marker in this area, and positions the text cursor behind that 

marker. 

4. You can now enter the text of the footnote. 

To return from the footnote area back to the body text simply click anywhere in the 

text. Alternatively, you can use the Insert > Footnote > Go to footnote reference 

menu command, which takes you back to the position in the text at which the foot-

note was inserted. 

Changing footnote text after it has been entered 

You can edit the footnote texts at the bottom page margin any time you wish. All 

you have to do is position the text cursor in the footnote area. You can use one of 

the following procedures: 

 Scroll to the page containing the footnote you want to change and click with the 

mouse in the footnote area in the bottom page margin. 

 Note: This works only in normal view. If you are working in some other vie-

wing mode, you must first switch to normal view using the menu command 

View > Standard. 

 You can also command TextMaker to find the next footnote in the text with the 

Insert > Footnote > Go to footnote menu command. When found, the text 

cursor is positioned within the footnote area at the beginning of the correspon-

ding footnote text. 
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Now you can edit the footnote text. You already know how to return to the normal 

text: simply click anywhere within it. 

Tip: You can also use keyboard shortcuts to jump into the footnote text of a foot-

note (and back): When you position the text cursor on a footnote number and 

press (Ctrl)(Alt)(¼), TextMaker jumps into the corresponding footnote text. To 

get back to the footnote in the body text, press (Ctrl)(Alt)(½). 

Reinserting footnote markers: If you should accidentally delete the footnote number 

in a footnote text, you can command TextMaker to reinsert it using the menu com-

mand Insert > Footnote > Footnote mark. 

Moving, copying and deleting footnotes 

You can move, copy or delete text segments containing footnotes in the usual man-

ner. TextMaker automatically reorders the footnote texts and adjusts the numbering 

without any special action on your part. 

However, you should observe the following rule when performing these functions: 

Important: When you copy, move or delete footnotes, you should always do it in 

the text – not in the footnote area at the bottom page margin. 

For example, if you delete the footnote text for a footnote in the footnote area, the 

footnote itself remains in place as before – what is gone is merely its footnote text. 

If, on the other hand, you select and delete the footnote marker in the text, the who-

le footnote (marker and text) is removed, and all the remaining footnotes are 

renumbered. 

Modifying the numbering of footnotes 

As mentioned above, footnotes are numbered automatically – so usually you don’t 

have to care about that at all. In case you want to apply manual changes to the 

numbering, you have the following options: 

 Modifying the number of an individual footnote 

 To modify the number of one individual footnote, place the text cursor behind it 

and invoke the Insert > Footnote > Edit Footnote menu command. In the dia-

log, change the numbering of the footnote marker from “Automatic” to 

“Custom” and type in the desired number. 
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 Modifying the overall numbering of footnotes 

 To modify settings related to the numbering of all footnotes in the document, 

invoke the Insert > Footnote > Options menu command. Its dialog allows you 

to change the start value, the type of numbering, and other settings. See section 

“Footnote options” (page 462). 

Changing the formatting of footnotes 

You can change the formatting of the footnote text or its footnote marker any time. 

Formatting footnote text 

To change the formatting of the text of a footnote, simply set the text cursor into 

the footnote text and apply the desired formatting. 

Tip: When you want to change the formatting of the text for all the footnotes in the 

entire document, TextMaker can save you a lot of work. All you need to do is 

change the “Footnote text” paragraph style that TextMaker creates automatically as 

soon as you insert the first footnote. 

By default, the text of all footnotes is formatted with this paragraph style. Thus, 

changes you make to the “Footnote text” paragraph style will affect all footnote 

texts (except those whose formatting you have changed manually).  

To edit this style, proceed as follows: 

1. Invoke the menu command Format > Paragraph style. 

2. Select the “Footnote Text” style from the list; then click on Edit. 

3. A dialog appears. Here, make the desired changes. Hint: You can also change 

the character formatting by clicking the Character button on the Paragraph 

tab. 

4. Exit the dialogs with OK, followed by Close. 

You will find general information about the use of styles in chapter “Styles” begin-

ning on page 129. 
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Formatting footnote markers 

TextMaker automatically formats the footnote marker as superscript. However, you 

can change the marker’s formatting according to your preference. To do this, select 

the footnote marker, invoke the Format > Character menu command and make 

the desired changes. 

Tip: By default, all footnote markers are formatted with the “Footnote Reference” 

character style (note: character style, not paragraph style!). Thus, if you change 

this character style with the Format > Character Style menu command, all foot-

note markers in the entire document will be affected. 

Footnote options 

The menu command Insert > Footnote > Options gives you access to additional 

settings for the footnotes in the current document. 

It opens a dialog box with the following options: 

Position 

Normally, the footnote texts are placed at the bottom of the pages on which they 

are referenced. You can specify that they should be placed elsewhere by changing 

the setting of the Position option: 

 Bottom of page 

 This is the default setting – the footnote texts are placed at the end of the pages 

on which they are referenced. 

 End of chapter 

 Select this option if you have used the menu command Insert > Break > 

Chapter break to divide your document into multiple chapters and you want 

the footnote texts referenced in each chapter to appear grouped together at the 

end of the chapter.  

 (For more information on the use of chapters, see the section “Dividing a 

document into chapters” beginning on page 119.) 

 End of document 

 With this option you obtain what are called end notes: all the footnote texts 

appear together at the end of the document. 
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Numbering group box 

Here you make settings that control the automatic numbering of the footnotes:  

 Type 

 Here you can change the type of numbering used. For example, you can select 

letters instead of numerals as markers for successive footnotes. The succession 

of footnotes is then represented by A, B, C, ... rather than by 1, 2, 3, ... 

 Start at 

 Here you can specify the number with which the enumeration should begin. 

The default value is “1”. If you enter “42”, for example, the first footnote will 

be numbered “42”, the second “43”, etc.  

 Mode 

 Here you can specify whether the footnote numbering should be reset to “1” 

e.g. on every page or every chapter: 

 Continuous numbering: The numbering is never reset. This is the default set-

ting. 

 Restart on each page: The numbering is reset to “1” at the beginning of every 

page of the document. 

 Restart on each section: The numbering is reset to “1” at the beginning of 

every section. (For more information on sections, see the section “What are 

sections?” beginning on page 157.) 

 Restart on each chapter: The numbering is reset to “1” at the beginning of 

every chapter. (For more information on chapters, see the section “Dividing a 

document into chapters” beginning on page 119.) 

Separator line margins group box 

Here you can set the margins for the separator line that is inserted automatically 

above the footnote area:  

The Top margin determines the minimum spacing between the text and the separa-

tor line, while the Bottom margin determines the spacing from the line to the foot-

note texts. 

As you increase the Left margin, the separator line starts further to the right; as you 

increase the Right margin, the separator line ends earlier. 
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Separator line tab 

When you want to change the appearance of the footnote separator line, switch to 

this tab. To change, for example, the line’s thickness, select the desired thickness 

from the Thickness 1 list. 

If you don’t want the footnote separator line to appear at all, select the option None 

from the Line style list. 



 

Manual TextMaker Document revisions  •  465 

Document revisions 
You can add comments to a document and track changes made to it. These capabi-

lities are useful, for example, when several users make successive revisions to a 

document. 

 Using comments 

 You can select text anywhere in a document and then attach a comment to it. 

 For example, if a colleague gives you a document to review, you can insert no-

tes like “make this section shorter” directly into the document and then return it 

to him. He can then make the revisions you have recommended in your com-

ments. 

 Tracking changes in a document 

 The “Track changes” function lets you do even more. When it is activated, you 

can make changes to a document – delete or add text, alter formatting, etc. – as 

you like. However, your changes are not simply applied as they would be 

otherwise; rather, they are at first only highlighted in color and saved as 

“proposed changes”. 

 So, if a colleague sends you a document for correction, turn on the “Track 

changes” function, make the desired changes, and return the document to your 

colleague. He can then review your proposed changes and separately accept or 

reject each of them. If he accepts a change, it is saved permanently in the 

document; if he rejects a change, it is removed. 

You can, of course, add comments and use the “Track changes” function in combi-

nation. 

For detailed information about these functions, see the pages that follow. 

Using comments 

You can insert comments anywhere you like in a document by invoking the com-

mands available in the sub-menu of the Tools > Comments menu command. 

Text to which a comment is attached is highlighted with color. If you point to such 

text with the mouse, the comment is displayed in a small window. 
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Or, if the comments pane is enabled, the comment is displayed there. When enab-

led, the comments pane appears in the right margin of the document and displays 

comments associated with the visible text at all times. 

By default comments are only displayed on the screen and are not printed. 

Tip: Using the Reviewing toolbar 

The easiest way to apply comments is to use the Reviewing toolbar. 

 

The Reviewing toolbar 

This toolbar appears automatically (below the Formatting toolbar) whenever the 

current document contains at least one comment.  

Should it not appear, it is most likely because it has been disabled. To re-enable it, 

invoke the menu command View > Toolbars and click on the check box next to 

Reviewing in the list of toolbars. 

The icons in this toolbar represent the following functions (from left to right): 

 Insert comment 

 Edit current comment 

 Delete current comment 

 Go to previous comment 

 Go to next comment 

 Comments pane on/off 

 The buttons further to the right are not for comments but for tracking changes 

in the document (see section “Tracking changes in a document”, page 471). 

Detailed information about these functions is presented in the following sections. 

Inserting comments 

To insert a comment, do the following: 

1. Select the text to which you want to attach a comment. 

2. Invoke the menu command Tools > Comments > Insert comment. 

 Tip: This command can also be invoked by clicking on the  icon in the Re-

viewing toolbar. 
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3. Type your comment in the small window that appears. 

4. When you have completed your comment, click anywhere in the text to close 

the comment window. 

The comment is now entered. You recognize this from the fact that the text to 

which it is attached is highlighted in color. 

Editing comments 

To edit a comment, do the following: 

1. Position the text cursor anywhere within the text whose comment you want to 

edit. 

2. Invoke the menu command Tools > Comments > Edit comment. 

 Tip: This command can also be invoked by clicking on the  icon in the Re-

viewing toolbar. 

3. Make the desired changes in the small editing window that appears. 

4. When you have finished editing, click anywhere in the text to close the com-

ment window. 

The comment now reflects your changes. 

Tip: You can also use keyboard shortcuts to jump into a comment (and back): 

When you position the text cursor somewhere inside a text segment that has a 

comment and press (Ctrl)(Alt)(¼), TextMaker jumps into the corresponding 

comment, and you can edit it. To get back to the body text, press (Ctrl)(Alt)(½). 

Deleting comments 

To delete a comment, do the following: 

1. Position the text cursor anywhere within the text whose comment you want to 

delete. 

2. Invoke the menu command Tools > Comments > Delete comment. 

 Tip: This command can also be invoked by clicking on the  icon in the Re-

viewing toolbar. 
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The comment is now removed. 

Displaying and printing comments 

There are two ways of viewing comments: 

 In the comments pane (always visible) 

 When you insert a comment into a document for the first time, or when you 

open a document that already contains comments, a comments pane automati-

cally appears in the right margin of the document. It displays all comments for 

the current page. To indicate the relationships between comments and text, each 

comment is connected by a line to the text segment to which it refers. 

 You can turn the comments pane on or off as needed by invoking the menu 

command Tools > Comments > Automatically show comments pane. 

 Tip: This command can also be invoked by clicking on the  icon in the Re-

viewing toolbar. 

Note: Even with this option enabled, the comments pane will not be visible 

unless the document actually contains comments. 

 In pop-up windows (made visible by pointing) 

 If the comments pane is disabled, a comment becomes visible only when you 

point with the mouse to a text segment to which a comment is attached. A small 

window will open and display the comment. 

Printing comments 

Normally comments appear only on the screen; they are not printed. If you want 

comments to be printed along with regular text, activate the Print comments opti-

on (see the section “Settings for comments” beginning on page 469). 

Note: Regular text will be reduced in size to make room on the printed page for 

the comments. Thus, its measurements will not correspond to the measurements 

specified for the document. 
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Locating comments 

The sub-menu of the Tools > Comments menu command also contains two com-

mands that can be used to jump from one comment in a document to another: 

 Tools > Comments > Previous comment jumps to the previous comment. 

 Tools > Comments > Next comment jumps to the next comment. 

Tip: These commands can also be invoked by clicking on the  and  icons in 

the Reviewing toolbar. 

Settings for comments 

You can make various settings for comments with the menu command Tools > 

Comments > Options. 

Note: The options dialog box is also accessible by invoking the menu command 

File > Properties and switching to the Reviewing tab. 

The following options are available: 

Comments group box 

 Highlight comments in text 

 When this option is enabled, all text segments to which comments are attached 

are highlighted in color. 

 Print comments 

 When this option is enabled, comments appear not only on the screen, but also 

on the printed page. 

Note: Regular text will be reduced in size to make room on the printed page 

for the comments. Thus, its measurements will not correspond to the measu-

rements specified for the document. 

 Color 

 Specifies the color to be used to highlight commented text and to display com-

ments in the comments pane. 
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 If you use the default setting By Author, a different color is selected automati-

cally for each user who edits the document. When the first user adds comments, 

these appear in red. When a second user subsequently opens the document and 

adds comments, those appear in blue, etc. 

Note: For this to work correctly, all users who edit the document must have 

specified their names in the preferences. To enter your name, invoke the 

menu command Tools > Options, switch to the General tab, click on the U-

ser info button and type your name (or at least your initials) in the appropria-

te edit boxes. 

Comments pane group box 

 Show automatically 

 This check box corresponds to the menu command Tools > Comments > Au-

tomatically show comments pane.  

 The comments pane is an area in the right margin that displays all comments for 

the current page of the document. 

 When this option is enabled, the comments pane is displayed automatically 

when you insert the first comment into a document, or when the document al-

ready contains comments. 

 When the option is disabled, the comments pane is not displayed. However, 

you can still make comments visible: In this case, whenever you point with the 

mouse to a segment of text to which a comment is attached, a small window 

containing the comment pops up. 

Note: Even when this option is enabled, the comments pane does not appear 

unless the document actually contains comments. 

 Width 

 Allows you to modify the width of the comment pane. 

 Position 

 Here you can modify the position of the comments pane: right, left, outside, or 

inside. 
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Changes group box 

The rest of the dialog contains additional options that pertain not to comments, but 

to the “Track changes” function (see the next section). 

Tracking changes in a document 

After you enable the “Track changes” function, you can continue, just as before, to 

make whatever changes you like in a document. However, the changes are not im-

mediately applied, but are highlighted in color and saved in the document as 

“proposed changes”. 

Subsequently, you – or another user – can review these changes and then separately 

accept or reject each of them. If a change is accepted, it is applied permanently to 

the document; if it is rejected, it is removed. 

This function is especially useful when several users in succession will edit a 

document. An example: A co-worker composes a document and gives it to you to 

correct. You enable the “Track changes” function and make the desired changes. 

Then you return the document to the author. He can now accept or reject separately 

each of your changes with the press of a button. 

Thus, revising a document with the help of the “Track changes” function involves 

three steps: 

 Step 1: Enabling the “Track changes” function 

 Step 2: Making the desired changes 

 Step 3: Accepting/rejecting the individual changes 

Read the following sections to learn more. 

Tip: Using the Reviewing toolbar 

The easiest way to revise documents is to use the Reviewing toolbar. 

 

The Reviewing toolbar 

This toolbar appears automatically (below the Formatting toolbar) whenever the 

current document contains changes that were made with the “Track changes” 

function enabled.  
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Should it not appear, it is most likely because it has been disabled. To re-enable it, 

invoke the View > Toolbars menu command and click on the check box next to 

Reviewing in the list of toolbars. 

The icons in this toolbar represent the following functions (from left to right): 

 The first six buttons are not for tracking changes, but for working with com-

ments (see section “Using comments”, page 465). 

 Track changes on/off 

 Go to previous change 

 Go to next change 

 Accept current change (and go to next) 

 Reject current change (and go to next) 

 Review all changes 

 Show changes in document on/off 

Detailed information about the individual functions of these buttons is given in the 

following sections. 

Step 1: Enabling the Track changes function 

In order to use the “Track changes” function, open the document that you want to 

revise and invoke the menu command Tools > Changes > Track changes. 

The “Track changes” function is now enabled, and all changes made to the current 

document will be tracked. 

(If you want to finish using this function, you can disable it anytime by invoking 

the same command once again.) 

Tip: This function can also be switched on/off by clicking on the  icon in the 

Reviewing toolbar. 

Step 2: Making the desired changes 

Next, make the desired changes in the document as you normally would. You can 

alter, delete and add text, change the formatting etc. etc. 

Thus, the document can be edited just as if the “Track changes” function didn’t 

exist. There is only one important difference: All your changes are highlighted in 

color and otherwise marked as follows: 
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 When you add text, it is colored and underlined. 

 When you delete text, it is colored and struck through. 

 When you change the formatting of text, it is colored. 

In addition, a vertical line appears in the margin beside each line that contains a 

change, providing an indication that a change was made at that point. 

Step 3: Accepting/rejecting changes 

When all the desired changes have been made, they can be either accepted or re-

moved one by one. 

Use the Reviewing toolbar described in the introduction for this purpose: 

 

The Reviewing toolbar 

This toolbar appears automatically (below the Formatting toolbar) whenever the 

current document contains changes that were made with the “Track changes” 

function enabled.  

Should it not appear, it is most likely because it has been disabled. To re-enable it, 

invoke the menu command View > Toolbars and click on the check box next to 

Reviewing in the list of toolbars. 

The following icons on the Reviewing toolbar are responsible for working with 

tracked changes: 

Icon Function 

 
Track changes on/off 

 Enables/disables the “Track changes” function (as described earlier). 

 Corresponds to the menu command Tools > Changes > Track changes. 

  

 
Go to previous change 

 Positions the text cursor at the previous change. 

 Corresponds to the menu command Tools > Changes > Previous change. 
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Go to next change 

 Positions the text cursor at the next change. 

 Corresponds to the menu command Tools > Changes > Next change. 

  

 
Accept current change (and go to next) 

 Clicking on this button will accept the change at which the text cursor is 

presently positioned, meaning that it will be saved permanently in the 

document. After that, TextMaker immediately jumps to the next change. 

 When you click on the arrow next to this button, a menu with the following 

commands opens: 

 Accept current change and go to next: does exactly the same as the button 

just described. 

 Accept current change: does the same as the button, but won’t jump to the 

next change afterwards. 

 Accept all changes: accepts all changes in the entire document at once. 

  

 
Reject current change (and go to next) 

 Similar to the button described above, this button rejects changes instead of 

accepting them. 

  

 
Review all changes 

 Opens a dialog box in which all changes are listed. To accept or remove a 

change, first click on the change in the list and then click on the Accept or 

Reject button. 

 Corresponds to the menu command Tools > Changes > Review all changes. 

  

 
Show changes in document on/off 

 Turns the Show changes option on or off. When the option is enabled chan-

ges are highlighted in color (as described previously). When it is disabled, 

the document appears as if all changes had been accepted. 

 Corresponds to the menu command Tools > Changes > Show changes. 
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Settings for the Track changes function 

With the menu command Tools > Changes > Options you can set various options 

for the “Track changes” function. 

Note: You can also access this dialog box by invoking the menu command File > 

Properties and changing to the Reviewing tab. 

The following options are available: 

 Comments and Comments pane group boxes 

 The options in these two group boxes pertain not to the “Track changes” func-

tion, but to the insertion of comments. You will find information about them in 

section “Using comments” beginning on page 465. 

 Track changes 

 Turns the tracking of changes on/off. 

 Corresponds to the  icon in the Reviewing toolbar and to the menu com-

mand Tools > Changes > Track changes. 

 Show changes 

 Turns the Show changes option on/off. When enabled, changes are highlighted 

in color. When disabled, the document appears as if all changes had been ac-

cepted. 

 Corresponds to the  icon in the Reviewing toolbar. 

 Print changes 

 When enabled, tracked changes are highlighted (colorized) not only on the 

screen, but also in printed output. When disabled, the document prints as if all 

tracked changes had been accepted. 

 Show tooltips 

 When enabled, additional information on a change are displayed on the screen 

when you point at it with your mouse (author, date, and type of change). 

 Inserted text, Deleted text, etc. 

 The options in the lower area of the dialog let you specify how changes will be 

represented in the document. You can modify both the manner in which chan-

ges are displayed and the colors to be used to highlight the changes. 
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 If you use the default setting By Author for a color, a new color will be selec-

ted automatically each time a new user makes changes. When the first user 

makes changes, they will appear in red. Subsequently, when another user opens 

the document and makes additional changes, these will appear in blue, etc. 

Note: For this to work correctly, all users who edit the document must have 

specified their names in the preferences. To enter your name, invoke the 

menu command Tools > Options, switch to the General tab, click on the U-

ser info button and type your name (or at least your initials) in the appropria-

te edit boxes. 
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Internet functions 

TextMaker is equipped with functions for editing HTML documents for the Inter-

net:  

 Opening HTML documents 

 Internet pages are usually in HTML format. With TextMaker you can open 

HTML files directly. Invoke the menu command File > Open and choose the 

HTML format from the Files of Type list box. 

 Editing HTML documents 

 The second section of this chapter covers the editing of HTML documents. He-

re you will learn what functions are available for HTML documents and how to 

use them. 

 Saving HTML documents 

 The last section covers the use of the menu command File > Save as to save 

documents in HTML format once they have been prepared. 

Detailed information is provided on the following pages. 

Opening HTML documents 

Internet pages are usually saved in HTML (HyperText Markup Language) format. 

HTML documents can be recognized by the extension .HTM or .HTML appended to 

their filenames. They can be opened in TextMaker as follows: 

1. Invoke the menu command File > Open. 

2. Choose the HTML format in the Files of Type list box. 

3. Specify the file to be opened and confirm with OK. 

TextMaker opens the HTML document and displays it on the screen. 

Note: The presentation of a document in TextMaker can differ from a web brow-

ser’s presentation of it. However, you can always check the way the document will 

look in a browser by opening it in your web browser. 
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Editing HTML documents 

In the following pages, you will learn which special features are available to you 

when working with HTML documents, and what you need to consider when using 

them. 

Page formatting 

Page formatting does not apply to HTML documents. 

If you make changes in the page format with the menu command File > Page 

setup, the changes are not saved in an HTML document. 

Pictures in HTML documents 

To insert a picture into an HTML document, you can use the menu command Ob-

ject > New Picture as described in the chapter “Pictures” beginning on page 225. 

However, you should take note of the following points: 

 The picture should reside in the same folder as the document 

 As a rule, the picture file should reside in the folder where the document is sa-

ved. 

 So, either copy the picture to that folder manually before adding it to the 

document, or simply check the Copy to document’s folder option in the Ob-

ject > New Picture dialog and allow TextMaker to do this for you. 

 The picture should not be saved in the document 

 Beyond that, you should not use the Save within document option, because 

picture files cannot be saved within HTML documents. 

Besides, it is not possible to insert picture frames in HTML format. 

Which picture file format? 

On the web, pictures are usually stored in one of the following file formats: GIF, 

JPG or PNG. All of these formats save the picture information in compressed form 

and thereby reduce picture file sizes considerably. 
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 The GIF format is most appropriate for smaller graphics with a maximum of 

256 colors. It uses a lossless compression method that does not impair image 

quality. 

 The JPG format is most appropriate for photographs and other large images in 

true color. However, the compression method used here is not lossless – the 

higher the chosen compression ratio, the worse the image quality. 

 The PNG format is the most versatile image file format. It comes in various 

sub-formats with different types of compression (including lossless as well as 

lossy compression). 

Use pictures in one of these file formats whenever possible, since other formats are 

not supported by all browsers. 

Tables in HTML documents 

It is also possible to insert tables into HTML documents. To do this, use the menu 

command Table > New table in the usual way (see chapter “Tables” beginning on 

page 199).  

Tip: With tables you can simulate sophisticated formatting for which the HTML 

format makes no explicit provisions. For example, you can produce double co-

lumned text by placing the text in a table with one row and two columns. 

Horizontal lines 

With the menu command Object > New Horizontal Line you can insert a horizon-

tal line into the text – for example, when a dividing line is needed. Of course such 

lines are not limited to HTML documents; they can also be used in normal 

documents. 

To insert a horizontal line, position the text cursor in the text line where the line is 

desired and invoke the menu command Object > New Horizontal Line. 

The line is now inserted. By default, it extends all the way from the left to the right 

margin. 
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Changing the line’s properties 

To change the way the line is rendered, select the line (by clicking on it) and invo-

ke the menu command Object > Properties. 

Tip: This command can also be invoked by double clicking on the line. 

A dialog box appears and presents the following options: 

 Width of line 

 The width of horizontal lines is normally specified as a percentage of the page 

width. By default, the width is set to 100 percent; thus, the line extends all the 

way from the left to the right margin. If you change this setting to 50 percent, 

for example, the line will be shortened to half the width of the page. 

 Alternatively, you can enable the Absolute option and enter the desired width 

as a fixed value. 

 Thickness 

 Here, you can enter the line thickness in points. 

 Justification 

 Here you can choose how the line should be justified: Left (at the left margin), 

Centered (in the middle of the page), or Right (at the right margin). 

 Color 

 Here you can choose the line’s color. 

 You can always define new colors to supplement those that are available by 

default (see section “Document properties, Colors tab” beginning on page 564). 

 3D shading 

 If this option is enabled, the line is rendered with a shadow effect. 

 Tip: With thin lines, this effect is hardly noticeable. Thus, it is recommended to 

increase the line’s thickness when using the 3D shading effect. 

 Color of 3D shading 

 You can choose the color of the 3D shading here. 
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Creating hyperlinks 

You can put hyperlinks in TextMaker documents and then follow them by clicking 

with the mouse. 

For example, you can place a link to a website in a document. When the user clicks 

on it, the web browser starts automatically and presents the page. 

You can also insert a link to another TextMaker document, allowing the document 

to be opened automatically by clicking on the link. 

Creating a hyperlink 

To create a hyperlink, proceed as follows: 

1. Select the text that is to be made into a link.  

2. Invoke the menu command Format > Link. 

3. Enter the target of the link in the URL or file name box; that is, enter the path 

and name of the internet resource or file to which the selected text is to refer. 

 Links to web pages must be entered as “http://” followed by the address of the 

page – for example, “http://www.example.com/index.htm”. 

4. Below, in the Bookmark field, you can specify, if desired, a position in the 

target document to be opened (see below). However, this field is normally left 

empty. 

5. Confirm with OK. 

The link is now created. You recognize this by a change in the color of the text, 

which indicates the presence of a link. 

Hint: An easier and faster way of creating links is available when the option 

Format URLs as hyperlinks is activated in the dialog of the Tools > Options 

menu command (Edit tab). You can then simply type the target address (for 

example, “http://www.example.com/index.htm”) right into the text and press the 

spacebar. TextMaker will detect that you have entered an Internet address and 

format it as a link automatically. 
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Specifying a target position 

The dialog described above gives you the option of specifying a position in the 

target document. To do this, enter at Bookmark either the address of an anchor (for 

HTML documents) or a bookmark (for TextMaker documents). 

Example: If you enter “Report.tmdx” at URL or file name and the name of a 

bookmark in this document at Bookmark and then follow the link you have crea-

ted, the file REPORT.TMDX will be opened and the text cursor will be positioned at 

the specified bookmark. 

Following hyperlinks 

To follow a hyperlink, simply click on the link text with the mouse. TextMaker 

responds by opening the linked document. 

Alternatively, position the text cursor at any character within the link text and in-

voke the menu command Edit > Go to link.  

Editing or removing a hyperlink 

Existing hyperlinks can be edited as follows: 

 Modifying the link target 

 To change the target of an existing hyperlink, first select the link text. Then 

invoke the menu command Format > Link. The dialog box described above 

appears. Here you can edit the target of the link. 

To remove a link, proceed as follows: 

 Removing a link by deleting the link text 

 When you delete text that has been formatted as a link, the link is removed with 

the text. 

 Removing only the link 

 If you want to remove only the link and leave the text in place, select the text 

and invoke the menu command Format > Remove link. 
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Saving HTML documents 

To save the current document in HTML format, proceed as follows: 

1. Invoke the menu command File > Save as. 

2. Choose the HTML format from the Save as Type list. 

3. Enter the filename under which the file is to be saved and confirm with OK. 

The document is now saved in HTML format. 

Tip: After saving the document, open it with your web browser to check its 

appearance. 
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Outputting documents 
In this chapter, you will find detailed information about outputting documents 

(printing, e-mailing, etc.). 

The following topics are covered: 

 Print preview 

 The first section covers the use of the File > Print preview menu command 

which displays a preview of the printed document on the screen. 

 Printing a document 

 The next section introduces the File > Print menu command which actually 

prints a document. 

 Printing a form letter 

FreeOffice: Printing form letters is not included in SoftMaker FreeOffice. 

 You can print form letters, which are documents that are to be sent to several 

addressees, with the menu command File > Print merge. 

 Exporting a document to a PDF file 

 Using the File > Export as PDF menu command, you can export a document 

to a PDF file. Such files can be viewed on virtually any computer, provided that 

it has a PDF viewer installed. 

 Exporting a document to an EPUB file 

 Alternatively, using the File > Export as EPUB menu command, you can ex-

port a document to an EPUB file.  

 EPUB is an open standard for e-books (electronic books) and other electronic 

publications. The EPUB format can be read by most hardware e-book readers. 

For PCs and mobile devices, various viewer applications are available. 

 E-mailing a document 

FreeOffice: The Send by e-mail feature is not included in SoftMaker Free-

Office. 

 When you would like to send a document by e-mail, you can use the menu 

command File > Send. 
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Detailed explanations are presented in the following pages. 

Print preview 

The print preview displays a preview of the printed document on the screen. Using 

this feature can help you avoid wasting paper on test prints. 

To open the print preview, choose the File > Print preview menu command. 

To close it, click on the Close button in the toolbar or press the (Esc) key. 

Using the print preview toolbar 

The print preview provides a toolbar with the following controls (from left to 

right): 

 

Use these controls to jump from page to page. From left to right: 

 To the first page 

 To the previous page 

 To a specific page. (Enter the desired page number into the little input field and 

press the Enter key (¢).) 

 To the next page 

 To the last page 

 

The next three buttons have the following functions: 

 The left button invokes the File > Page setup menu command to modify the 

page format (paper size, orientation, margins, etc.). See also section “Page for-

matting”, page 107. 

 Hint: The arrow right of this icon opens a list of all paper formats available, 

allowing you to choose a different page size for the document quickly. 

 The middle button invokes the File > Print menu command which prints the 

document. See also section “Printing a document”, page 487. 
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 The right button invokes the File > Export as PDF file menu command which 

generates a PDF file from the document. See also section “Exporting a 

document to a PDF file”, page 491. 

 

These controls can be used to change the zoom level. Either type in a zoom level in 

the edit field and press the Enter key (¢), or click one of the buttons at the left to 

choose the zoom level:  

 Actual document size (zoom level 100%) 

 Fit margins in window 

 Display one full page 

 Display two full pages 

 Activate magnifying glass. (When this tool is active, use your mouse to drag a 

rectangle around the part of the document that you want to magnify.) 

 

These buttons determine if the following should be included in the printout:  

 Comments  

 Markers for all changes that were added to the document with the “Track chan-

ges” feature activated (see chapter “Document revisions”, beginning on page 

465) 

 Pictures 

To close the print preview, click on the Close button or press the (Esc) key. 

Printing a document 

To print the current document, choose the menu command File > Print. 
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A dialog box appears, allowing you to make the following settings: 

Printer 

Here, choose from the installed printers the one that is to handle the printing. 

The Setup button opens a window for setting up and configuring the printer. You 

can find information about this in your printer manual.  

Linux users can also specify the command to be used for printing here. 

Pages 

Specify here the part of the document to be printed: 

 All 

 Print the entire document. 

 Current Page 

 Print only the page on which the text cursor is positioned. 

 Pages: 

 Print only the specified pages. You must enter the desired page numbers, for 

example: 
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12 Print page 12 only 

12-15 Print pages 12 through 15 

12- Print page 12 and all pages following 

-12 Print pages 1 through 12 

You can enter as many page ranges as you like provided you separate them with 

commas, for example: 

2-5, 12 Print pages 2 through 5 and page 12 

 In addition, you can specify with the Pages to print option, whether all pages 

or only the odd or even numbered pages in the given range are to be printed. 

 Furthermore, the Pages per sheet option allows you to print more than just one 

page on each sheet of paper. For example, when you select Four Pages, each 

sheet of the printout will contain four pages (scaled down accordingly). 

Options 

This part of the dialog box contains additional printing options: 

 Copies 

 Here you can specify the number of copies of the document to be printed. 

 Collate copies 

 When you print multiple copies of a document, this option determines if the 

printout will be sorted after page numbers. 

 If you check this option and print multiple copies of a document with e.g. three 

pages, the pages will be output in the following order: 1-2-3, 1-2-3, 1-2-3, ... 

 If it is not checked, the order will be: 1-1-1..., 2-2-2..., 3-3-3... 

 Note: Not all printers support this feature. 

 Print to file 

 Redirects the print output to a file instead of a physical printer. 

 Drop pictures 

 Skips over all pictures and drawings when printing (useful for fast test prin-

ting). 
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 Reverse order 

 Prints the pages from last to first. 

To start printing, click OK. 

Hint: Before actually printing a document, you can preview the printout using 

the File > Print preview menu command. 

Printing a form letter 

FreeOffice: Printing form letters is not included in SoftMaker FreeOffice. 

To print a form letter, proceed as follows: 

1. Open or create a form letter (see chapter “Form letters” beginning on page 

383).  

2. Make sure that the database with the desired addresses has been assigned to the 

form letter with the menu command Tools > Set database (see section 

“Assigning a database to a document” beginning on page 384). 

3. Select the database records to be printed as required (see section “Selecting 

data records” beginning on page 389). 

4. Invoke the menu command File > Print merge. 

5. In the Records group box, choose one of the options for controlling which re-

cords in the attached database are to be used: 

 All (every record in the entire database) 

 Selected (all records in the database that have been selected) 

 Range (a range of record numbers – in this case you must enter the first and 

last numbers in the range) 

Finally, confirm with OK to start the print job. 

You will find detailed information about creating form letters in chapter “Form 

letters” beginning on page 383. 
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Exporting a document to a PDF file 

You can also export documents to a PDF file. 

PDF files can be viewed on virtually any computer, provided that it has a PDF 

viewer installed (for example, “Adobe Reader”). Text formatting and objects (pic-

tures, drawings, etc.) are retained exactly as in the original file. 

To export a document to a PDF file, proceed as follows: 

1. Choose the File > Export as PDF menu command. 

2. A dialog window appears where you can change the settings described below. 

After that, confirm with OK. 

3. Another dialog window appears where you can specify the filename and locati-

on of the PDF file to create. After that, confirm with OK. 

The PDF file will then be created. To view it, open the PDF file in a PDF viewer of 

your choice. 

Hint: If your device does not have a PDF viewer installed, you can find suitable 

programs in the Internet by performing a search for “PDF viewer” in your web 

browser. 

The dialog window mentioned above provides the following options: 

General tab 

On this tab, you can specify which parts of the document to export, and change 

several other settings. The options available are mostly identical to the ones provi-

ded in the dialog for the File > Print menu command, which is described in the 

section “Printing a document” beginning on page 487. 

Apart from that, the following additional options are available: 

 Create table of contents 

 If this option is checked, TextMaker will store a bookmark in the PDF file for 

each heading that your document contains. 

 Your PDF viewer will then display these bookmarks in a pane left of the 

document. You can utilize this pane as an interactive table of contents: just click 

on a heading to jump to the corresponding section in the document. 
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 Hint: If your PDF viewer does not display a bookmark pane, search it for a 

command to display bookmarks and activate it. 

Note: Please note that, in order to use this feature, you have to outline the 

document (by adding headings) beforehand. See the section “Outlines” (page 

418)) for details. 

 Create interactive form 

 Determines if form objects (text boxes, dropdown lists, etc.) as well as text 

frames and tables should be exported as editable objects. 

 By default, this option is not checked. If you activate it, such objects can be 

edited when the PDF file is viewed in a PDF viewer (provided that the corres-

ponding permissions are set – see Security tab). 

 For more information on the creation of forms, see the chapter “Forms”, begin-

ning on page 307. 

 Create tagged PDF 

 If this option is checked, information about the logical structure of the 

document will be included in the PDF file. 

 This information is required in order to produce barrier-free PDF files that, for 

example, can also be used with screen readers or applications that are able to 

read the text in a PDF out loud. 

 Export comments 

 You can add comments to a document using the Tools > Comments menu 

command (as described in section “Using comments”, page 465). 

 When this option is enabled, these comments will appear not only in the origi-

nal document, but also in the PDF file. 

Note: Regular text will be reduced in size to make room for the comments. 

Thus, its measurements will not correspond to the measurements specified 

for the original document. 

 Export tracked changes 

 Using the Tools > Track changes menu command, you can achieve that all 

changes made to a document will be displayed in color and underlined (as 

described in section “Tracking changes in a document”, page 471). 
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 When this option is enabled, the text in the PDF file will be highlighted the 

same way as in the original document.  

Preferences tab 

This tab contains options for modifying the output quality, including the following: 

 AutoShape options 

 Sets the quality (resolution) in which AutoShapes and all other types of dra-

wings are exported. The higher the setting, the larger the resulting file will be. 

 Image options 

 Lets you choose if images should be stored using a lossless compression me-

thod or the (lossy) JPEG compression method. If you choose the latter option, 

the JPEG quality option becomes available and lets you modify the quality le-

vel of the compression. 

Hint: Lossless compression provides perfect image quality. However, if your 

document contains a large number of images (especially photographs), the re-

sulting file can become rather large. If this is the case, you may want to 

switch to JPEG compression, which provides a much higher compression rate 

for photographic images. 

 The option Use alpha channel for transparencies determines whether an “al-

pha channel” should be used when rendering transparencies in images or dra-

wings. Usually, these look best when this option is enabled. However, some 

PDF viewers are unable to render alpha channels flawlessly, so we included an 

option to deactivate this feature. 

 Other options 

 Include TextMaker document: Stores a copy of your TextMaker document 

inside the PDF file. This enables users to open the resulting PDF file directly in 

TextMaker. The program will then extract the original TextMaker document 

from the PDF file and display it. 

 Open file in PDF viewer after exporting: Launches your PDF viewer and 

displays the PDF file after it has been exported (provided that you have a PDF 

viewer installed on your computer). 

 Use relative paths for file links: Automatically converts any hyperlink to a file 

into a relative path (instead of an absolute path). For example, when you have 

inserted a link to the file c:\Documents\Lists\test.txt and export the PDF 
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document to the folder c:\Documents, the file path for this link will be changed 

to “Lists\text.txt”. 

 Font options 

 The Font embedding options let you choose if the fonts used in the document 

should be included in the PDF file.  

 If font embedding is enabled, the resulting PDF file can be viewed in its origi-

nal fonts on any computer – even if this computer does not have the fonts in-

stalled. If it is disabled, text will be rendered using some replacement fonts sel-

ected automatically by the system. 

 If the Embed only used characters option is enabled, only those characters of 

a font will be embedded that actually occur in the document. Advantage: The 

resulting PDF file is smaller in size. 

View tab 

This tab contains advanced options for the display of the PDF file in a PDF viewer, 

including the following: 

 Navigation pane 

 Use this option to specify what to display in the navigation pane of the PDF 

viewer. (The navigation pane is a panel displayed left of the PDF document.) 

 Options available: 

 Default: Use the PDF viewer’s default setting. 

 Empty: Do not display anything in the navigation pane. 

 Bookmarks: Display the document’s bookmarks in the navigation pane. 

 Page thumbnails: Display miniatures of the document’s pages in the navigati-

on pane. 

 Zoom 

 Use this option to set the default zoom level of the PDF file, as follows: 

 Default: Use the PDF viewer’s default setting. 

 Full page: Select the zoom level at which the entire page fits in the window. 

 Fit width: Select the zoom level at which the page width fits in the window. 
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 Fit height: Select the zoom level at which the page height fits in the window. 

 Custom: Set the zoom level to a custom value (in percent). 

 Page layout 

 Use this option to specify the page layout to display, as follows: 

 Default: Use the PDF viewer’s default setting. 

 Single pages: Display as single pages. 

 Two pages - odd pages left: Display as two facing pages (odd pages on the 

left). 

 Two pages - odd pages right: Display as two facing pages (odd pages on the 

right). 

 Additional options 

 This section provides the following additional options: 

 Display document title: Display the document’s title in the title bar of the PDF 

viewer (instead of its file name). Hint: You can change the title of a document 

on the Summary tab on the dialog of the File > Properties menu command. 

 Center viewer on screen: Automatically center the program window of the 

PDF viewer on the screen when the PDF file is opened. 

 Full-screen mode: Automatically switch the PDF viewer to full-screen mode 

when the PDF file is opened. 

 Hide menu bar: Hide the menu bar of the PDF viewer. 

 Hide toolbars: Hide all toolbars of the PDF viewer. 

 Hide navigation pane controls: Hide all controls of the navigation pane. 

Security tab 

This tab provides options that allow you to encrypt the resulting PDF file and to set 

up passwords that protect the file against opening or changing it. 

 Encryption type 

 Here you can select if the PDF file should be encrypted. You can choose 

between 40 bit encryption (low level of security) and 128 bit encryption 

(high level of security). 
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Note: The other options on this tab are not available until you have chosen an 

encryption method. 

 Password to open the document 

 If you enter a password here, the PDF viewer will ask for this password when 

users try to open the PDF file. If they don’t enter the correct password, the vie-

wer will refuse to display the file. 

 If you leave this field empty, any user can open the file without having to enter 

a password. 

 Password to set permissions 

 Additionally, you can restrict the access rights for the PDF file. To do this, first 

enter a password required to change the access rights. Then, use the options in 

the Permission section of the dialog to specify which permissions should be 

granted. 

 Background information: In some PDF viewers, a command for changing the 

access rights is available. If users try to invoke this command, they will be as-

ked for the password you have entered here. 

 Permissions 

 Here you can specify which types of actions should be permitted. Only availab-

le when you have specified a password to set permissions (see above). 

Exporting a document to an EPUB file 

As an alternative to the PDF format, you can also export documents using the E-

PUB format. 

EPUB is an open standard for e-books (electronic books) and other electronic 

publications. The EPUB format can be read by most hardware e-book readers. For 

PCs and mobile devices, various viewer applications are available. 

As opposed to the PDF format, where the text formatting is retained exactly as in 

the original document, EPUB files are usually re-rendered by the e-book reader in 

order to optimize the text flow to the given display size. Accordingly, your 

document might look quite different in an e-book reader. 

To export a document to an EPUB file, proceed as follows: 
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1. Choose the File > Export as EPUB menu command. 

2. A dialog window appears where you can change the settings described below. 

After that, confirm with OK. 

3. Another dialog window appears where you can specify the filename and locati-

on of the EPUB file to create. After that, confirm with OK. 

The EPUB file will then be created. To view it, open the EPUB file in an e-book 

reader or a reader application of your choice. 

Hint: If your device does not have a reader application for EPUB files installed, 

you can find suitable programs in the Internet by performing a search for “EPUB 

reader” in your web browser. 

The dialog window mentioned above provides the following options: 

General tab 

On this tab, you can edit the document’s summary information and some additional 

information, and specify several other settings.  

Options available: 

 Title, Author, Subject, Keywords, Description 

 Here you can edit the document’s summary information (title, author etc.) If 

you plan to publish the EPUB file after its generation, don’t forget to fill these 

fields with data. 

 Note: These fields can also be edited using the Summary tab in the dialog of 

the File > Properties menu command. 

 Language, ISBN, UUID, Publishing date, Publisher, Copyright notice 

 Here you can enter additional information on your document. If you plan to 

publish the EPUB file after its generation, these fields should be filled out as 

well. 

 The UUID (“universally unique identifier”) is a unique number that can be 

used to identify an individual document. The New button creates a new random 

UUID. (Technically spoken, randomly created UUIDs are not really unique – 

however, due to their sheer length, the chance to produce a UUID that is al-

ready taken is almost zero.) 
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 Please note that the UUID of a document should not be changed anymore once 

it is published – unless you want to release a new revision of the document. 

 The ISBN (optional) is another unique identifier number for a publication (and 

this one actually is unique). ISBNs are required by the book-trade. You usually 

obtain an ISBN from your publisher. 

 Cover 

 When you activate the option Create cover page, an image file for the creation 

of a cover page is added to the EPUB file. EPUB readers usually not only dis-

play this image file as a title page in your document, but also use it to generate 

a thumbnail image for the document (displayed e.g. in the user’s “library”). 

 To choose an image for the cover page, click on the three dots next to the text 

field below this option. This will open a file dialog, allowing you to browse y-

our device for the file. 

 Additionally, you can choose the background color for the cover page. 

 Table of contents 

 When the option Create table of contents is checked, TextMaker will store a 

bookmark in the EPUB file for each heading that your document contains. 

 Some EPUB readers are able to display these bookmarks, for example, in a 

pane left of the document. You can utilize this pane as an interactive table of 

contents: just click on a heading to jump to the corresponding section in the 

document. 

 Hint: If your reader does not display a bookmark pane, search it for a command 

to display the table of contents (or bookmarks) and activate it. 

Note: Please note that, in order to use this feature, you have to outline the 

document (by adding headings) beforehand. See the section “Outlines” (page 

418)) for details. 

Preferences tab 

This tab contains options related to the output of the EPUB file, including the 

following: 

 Image options 

 Lets you choose if images should be stored using a lossless compression me-

thod or the (lossy) JPEG compression method. If you choose the latter option, 
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the JPEG quality option becomes available and lets you modify the quality le-

vel of the compression. 

Hint: Lossless compression provides perfect image quality. However, if your 

document contains a large number of images (especially photographs), the re-

sulting file can become very large. If this is the case, you may want to switch 

to JPEG compression, which provides a much higher compression rate for 

photographic images. 

 Split EPUB text 

 When exporting documents that contain a huge amount of text, it is advisable to 

let TextMaker split the text into small segments. Otherwise, some low-end E-

PUB readers might be unable to process the document. 

 It is therefore recommended to have this option activated. TextMaker will split 

the text into segments of about 100 KB in the resulting EPUB file. When you 

open that file in your reader, these segments will automatically be combined to 

one single document again. 

 Font options 

 The Font embedding options let you choose if the fonts used in the document 

should be included in the EPUB file.  

 Note: This is usually not required, since most EPUB readers render the 

document in their own fonts anyway.  

 However, some readers provide an option for displaying the document in its 

original fonts. For such readers, embedding the document’s fonts would make 

sense. But please note that embedding fonts can lead to a much larger output fi-

le. 

Note: Please respect the license terms of the fonts’ vendors. For most com-

mercial font packages, embedding in EPUB files is not allowed (or requires 

the payment of additional charges). 

 CSS options 

 EPUB files usually include a CSS file where the document’s character/para-

graph styles are stored. TextMaker generates this file automatically, so normally 

you don’t have to care about it. 

 In case you have created a custom-made CSS file, you can alternatively use this 

file instead of the one that is generated automatically. To do so, activate the op-

tion Append custom CSS and click on the three dots next to the text field be-
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low this option. This will open a file dialog, allowing you to browse your de-

vice for the CSS file. 

 Note: Not all readers support the use of a custom CSS file. 

 Other options 

 Open file in an EPUB viewer after exporting: Launches your EPUB viewer 

and displays the EPUB file after it has been exported (provided that you have 

an EPUB viewer installed). 

E-mailing a document 

FreeOffice: The Send by E-Mail feature is not included in SoftMaker Free-

Office. 

Provided an appropriate e-mail program is installed on your device, you can send 

documents by e-mail directly from TextMaker. 

To do this, proceed as follows: 

1. Create or open the document that is to be e-mailed. 

2. Invoke the menu command File > Send. 

3. Select the format in which the document is to be sent. 

 Note: If you choose the TextMaker document format, the recipient receives an e-mail with the 

TextMaker document as an attachment. In order to read the attachment, the recipient needs to have 
TextMaker installed. 

Your default e-mail application is invoked and a blank e-mail message is genera-

ted, with the document as an attachment. 
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Document management 
TextMaker provides functions that simplify document management and speed up 

access to them: 

 Quick paths 

 You can set up quick paths to change immediately to folders that are frequently 

used to save or retrieve files. 

 Document summary 

 Every document can have a document summary that you can display and edit 

using the Summary tab in the dialog of the File > Properties menu command. 

You can specify the document’s title, subject and author, enter keywords for the 

file manager’s search function, and compose a brief description of the 

document’s contents. 

 The file manager 

FreeOffice: The File manager is not included in SoftMaker FreeOffice. 

 The integrated file manager provides a convenient way to access your 

documents. It allows you to see at a glance the names and summaries of your 

documents, and to examine, open, print or delete them with the press of a key. 

With the search function, you can look for documents not only by filename, but 

also by subject, title, author, etc. 

 Backup copies 

 Whenever you save a document, TextMaker can automatically create a backup 

copy containing its previous version. There is even an option to keep multiple 

generations of backup copies for each document. 

FreeOffice: In SoftMaker FreeOffice, only simple backup copies are sup-

ported (via the option Create backup files in the preferences).  

You will find detailed information for each of these functions on the following pa-

ges. 
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Quick paths 

TextMaker gives you the capability to define up to twenty quick paths and use 

them to change to specific folders where you open or save files frequently. 

A quick path is a symbolic statement like “Letters to the tax office” that stands for 

a specific folder on the hard disk (for example, the folder C:\LETTERS\TAXES). 

When you want to open a file in this folder, all you need to do is click on the 

Quick path button in the dialog of the File > Open menu command and select its 

quick path. The dialog changes immediately to the C:\LETTERS\TAXES folder. 

Quick paths are available not only in the File > Open dialog, but also in all other 

dialog boxes that have to do with opening or saving files. 

For detailed information on quick paths, see the pages that follow. 

Defining quick paths 

To define a new quick path, complete the following steps: 

1. Open any type of file dialog – for example, invoke the File > Open menu 

command. 

2. Click the Quick path button. 

3. A menu opens below the button. Select the Create new quick path command 

from it. 

4. At Name of quick path enter a meaningful name for the quick path – for exa-

mple, “Letters to the tax office”. 

5. At Path enter the desired folder – for example, c:\letters\taxes. 

Tip: Alternatively, click on the button with the three dots next to this text 

field. This opens a dialog where you can browse to the folder of interest. 

6. Confirm with OK. 

From now on, TextMaker will change to the folder C:\LETTERS\TAXES when the 

quick path “Letters to the tax office” is invoked. 

Quick paths with search patterns: Quick paths can also include search patterns for file 

names. For example, you can define a quick path as c:\letters\taxes\2018*.*, which 
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tells TextMaker to change to the folder C:\LETTERS\TAXES and display only those 

files whose names begin with “2018”. 

Keyboard shortcut: The & sign can be used in a quick path name to give the name a 

keyboard shortcut. For example, if you enter “Letters to the &tax office” as the 

name, the quick path of this name can be invoked by pressing the (T) key whenever 

the list of quick paths is opened. 

Using quick paths 

Quick paths are available in all file dialogs – for example the dialogs for the File > 

Open and the Object > New Picture menu command. 

To invoke a quick path, do the following: 

1. Click on the Quick path button in a file dialog. 

2. A menu of all the previously defined quick paths opens. Select the desired 

quick path. 

TextMaker now changes to the folder specified for the quick path. 

Editing and deleting quick paths 

To modify or delete an existing quick path, do the following: 

1. Click on the Quick path button in a file dialog. 

2. A menu opens. Select the Change quick paths command from it. 

3. A dialog box appears. Select the desired quick path from the list box. 

4. Click on Change to edit the name or path, or on Delete to remove the quick 

path. 

Document summary 

You can use the menu command File > Properties not only to make document 

specific settings, but also to enter summary information about the document.  
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The summary contains additional information (subject, author, keywords, etc.) 

about a document. To view or edit it, invoke the menu command File > Properties 

and switch to the Summary tab: 

 

Enter your modifications, and confirm with OK. 

Tip: Using the file manager (see the next section), you can search for documents 

based on the contents of their summaries. For example, you can have the file 

manager find all documents from a specific author. 

Automatic prompt for summary information when saving: At your option, you can have 

TextMaker prompt you to fill in the document summary whenever you save a 

newly created document. To enable this function, invoke the menu command Tools 

> Options, switch to the Files tab, and enable the Prompt for summary informa-

tion when saving option. Now, each time you save a new document for the first 

time, the dialog box for the entry of summary information will appear. 
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The file manager 

FreeOffice: The File manager is not included in SoftMaker FreeOffice. 

The file manager displays a list of documents from one or more folders and lets 

you open, print, delete or view any document with a click of the mouse. 

To start the file manager, use the menu command File > File manager. 

 

Using your mouse, you can resize the File manager window or move it to a diffe-

rent position anytime. The widths of the columns can be changed by dragging the 

lines that separate the column headers. 

By clicking on one of the column headers, you can sort the files according to the 

contents of the column under that header. 

You can use the Search button to change to another folder. Apart from that, this 

button also provides access to search functions that work with document summary 

information, so that you can search for specific titles, subjects, authors, keywords, 

etc. 

You can select a file and then invoke a function to be performed on the file by cli-

cking on one of the buttons. The functions associated with these buttons are descri-

bed in the next section. 

The file manager's buttons 

FreeOffice: The File manager is not included in SoftMaker FreeOffice. 

The buttons in the file manager have the following functions: 



 

506  •  Document management Manual TextMaker 

 Open 

 When you click on this button, TextMaker opens the selected file. 

Tip: You can also open a file by double clicking on its filename. 

 Close 

 Use this button to exit the file manager. 

 Search 

 You can click on this button to search for specific files or simply to select a new 

folder for display in the file manager. For more information on this topic, see 

the next section (entitled “Searching with the file manager”). 

 Output 

 Use this button to print or e-mail the selected file. When you click on the but-

ton, a menu opens with the following functions (depending on the operating 

system):  

 E-mail: Send the document by e-mail 

 Print: Print the document 

 Print merge: Print the document as a form letter 

FreeOffice: Printing form letters is not included in SoftMaker FreeOffice. 

 Rename 

 Click on this button if you want to change the name of the selected file. 

 Delete 

 If you click on this button, the selected file will be deleted (after confirmation). 

 Preview 

 Click on this button to preview the selected file. 

 A preview window appears. To open the document displayed in the preview 

window, click Open. To close the preview, click Cancel. 
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Searching with the file manager 

FreeOffice: The File manager is not included in SoftMaker FreeOffice. 

With the help of the file manager’s Search button, you can have TextMaker look 

for specific files or simply choose the folder to be displayed in the file manager. 

 

You can search for files that meet criteria of the following types: filename, folder, 

file type, as well as the items in the document summary (title, subject, author, 

keywords, and description).  

Moreover, you can combine several search criteria. For example, if you only spe-

cify a particular folder in the search dialog, TextMaker will display all the 

documents in this folder. But if you also enter a search term in the Title field, 

TextMaker will find only those documents that are both in the selected folder and 

contain the given search term in the Title field of their summaries. 

The search dialog has the following functions: 

 File name 

 Allows you to search for a specific file or a filename pattern. 

 With the default setting, the search function will find all documents of the cho-

sen file type in the chosen folder. 

 If you specify a unique filename like INVOICE.TMDX, only files with exactly 

this name will be found. 

 If you specify a filename pattern like INV*.TMDX, all TextMaker documents 

whose filenames begin with “Inv” will be found. 
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 File type 

 From this list, you can choose the type of the files to be targeted in the search. 

For example, if you want to search for files in Rich Text Format, select this 

format from the File type list. 

 Title, Subject, Author, etc. 

 By making entries in these fields, you can target your search to the contents of 

the summaries that are included in your documents (see the section “Document 

summary”).  

 If you fill in several fields, the file manager will search for documents that meet 

all of your specified conditions. For example, if you enter “tax” in the 

Keywords field and “Smith” in the Author field, only documents whose sum-

maries contain corresponding entries for both fields will be found. 

 You will get different search results depending on the precision with which you 

specify the search terms. For example, if you typed “tax” as the search term in 

the Keywords field, your search would also turn up documents whose 

keywords contain “tax increase” and “my income tax”, etc. – that is, all the 

documents in which “tax” was contained anywhere in the keywords. 

 Case is of no significance in search terms. If the search term is entered as “tax”, 

the search will also find documents whose keywords contain “Tax”. 

 Folders 

 Here you can select the folder in which the file manager is to carry out the se-

arch. 

 Include subfolders 

 If this option is enabled, the file manager searches not only the selected folder, 

but also all folders below the selected folder. 

 “New list” button 

 Starts a new search using the current settings. 

 “Add to list” button 

 Also starts a new search; however, any previous search results remain in the list 

rather than being cleared from the list. 
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Backup copies 

Note: This feature is not available in the Android version. On Android, only an 

option for simple (single) backups is available: the option Create backup files in 

the preferences. 

FreeOffice: SoftMaker FreeOffice also supports only simple backup copies.  

Whenever you save a document, TextMaker can automatically create a backup 

copy containing its previous version. There is even an option to keep multiple ge-

nerations of backup copies for each document. 

You will find the related settings in the dialog of the Tools > Options menu com-

mand, Files tab. The dropdown list in the Backup section allows you to specify if 

and how backup copies will be generated. Options available: 

 No backup 

 When you choose this option, no backup copy is created when you save a 

document. (Not recommended.) 

 Simple backup 

 Here, exactly one backup copy is created when you save a document. This copy 

contains the previous (i.e. last saved) version of the document. It is saved as a 

file with the name extension .BAK, stored in the same folder as the document. 

 For example, when you save the document LETTER.TMDX, the existing LET-

TER.TMDX file is first renamed LETTER.BAK, and then the edited document is 

saved under the name LETTER.TMDX.  

 (This option is identical to the Create backup files option in previous versions 

of SoftMaker Office.) 

 Advanced backup 

 With this option, multiple generations of backup copies are kept for each 

document. All of these copies are stored in a special Backup folder. 

 Tip: When this option is selected, also the File > Revert to previous version 

menu command becomes available. It provides a comfortable means of return-

ing to a previous version of the current document (see below). 

 Additional options: 
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 Folder for backup files: Here you can change the location of the Backup fol-

der in which all backup copies are stored. 

 Number of backup files per document: Here you can specify the maximum 

number of backup copies (= generations) to be kept for each document. 

 “Clean Up” button: Offers the following two commands for deleting backup 

copies: 

 Delete orphaned backup files: Removes any backup file that has lost its 

original file (for example, because the original file has been deleted). 

 Delete all backup files: Removes all backup files that reside in the folder 

for backup files. 

How to use the “File > Return to Previous Version” command 

When you have the selected the Advanced Backup option (see above), all backup 

copies are stored in a special Backup folder. This folder is maintained automatical-

ly by the application. It is not recommended to move or rename the files in this 

folder manually. 

To restore a previous version of a document, you don’t have to worry about this 

folder anyway. TextMaker has a special menu command for this: the menu com-

mand File > Revert to previous version.  

You can use this command to revert to a previous version of a document as 

follows: 

1. Open the document of interest (in case it isn’t opened already). 

2. Invoke the menu command File > Revert to previous version.  

3. A dialog opens, listing all backup copies available for the current document 

along with their creation date. Select the version that you want to revert to.  

 Hint: The Preview button opens a preview of the selected version. 

4. Click on Restore to revert the document in the current window to the selected 

previous version. 

Note: Please note that this action will replace the current document with a 

previous version. Accordingly, when you save it now, its current version is 

overwritten by an older version! 
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 Alternatively, a button named Open as Copy is available. When you click this 

button, the backup copy will open in a new window instead (rather than repla-

cing the document in the current window). This is useful when you want to 

compare the current version with an older version. 

But what to do when the original file is no longer available? 

The procedure described above only works as long as the original document is still 

available. But what to do when the original file has been lost, for example, because 

it was accidentally deleted? 

Even in that case you can still access the backup copies of this document (unless 

they have been deleted as well, naturally). Simply open the backup copy itself. 

To find out where the backup copies are located, have a look at the dialog of the 

Tools > Options menu command. The folder is listed as the Folder for backup 

files on the Files tab. By default, a folder named Backup is used, located in the 

SoftMaker folder in your documents folder. 

The backup copies in this folder can be opened in TextMaker directly, using e.g. 

the following procedure: 

1. In Windows Explorer, navigate to the Backup folder (location: see above). 

2. Browse this folder for file names that start with the name of the original 

document. For example, a backup copy of the file TEST.TMDX might be called 

TEST.TMDX.135.TMBAK. (As you can see, a running number and the extension 

.tmbak are added to the original file’s name.) 

 Hint: The higher the number, the more recent the version of the backup copy is. 

3. In Windows Explorer, double-click on the backup file that you want to open. 

4. TextMaker detects that you are trying to open a backup copy and asks you how 

to proceed. It displays a dialog with the following options: 

 Open the backup file: Opens the backup copy. 

 Invoke the version manager: Invokes the menu command File > Revert to previ-

ous version that displays a dialog with all available previous versions of the 

original document. For more details on this command, see above. 

 Open the original file: Opens the original file for this backup copy. (Of course this 

only works as long as the original file still exists.) 

5. Make your choice, and then click on OK. 
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Once again, please note that TextMaker creates and manages the files in the Ba-

ckup folder automatically. It is not recommended to e.g. manually rename or move 

files in this folder. 

In case you want to clean up your drive to gain more space, you can always delete 

the files in this folder. However, you will of course loose all backup files for all 

your documents by doing that. 
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Document protection 

You can protect your documents from being read or saved by unauthorized persons 

by applying document protection – or, to be more precise, read and/or write protec-

tion – to them. For example, you can require the entry of a password to open or 

save a protected document. 

To protect the current document, invoke the menu command File > Properties, 

switch to the Protection tab and select the kind of protection you want. Then enter 

whatever password you like for reading and/or writing. 

The following types of protection are available: 

 No protection 

 The document is not protected. This is the default setting. 

 Write protection 

 The document can be saved only when the correct write password has been 

entered at the time the document was opened. 

 Read protection 

 The document can be opened only when the correct read password is entered at 

the time an attempt is made to open it. Furthermore, the document will be au-

tomatically encrypted. 

 Protection depending on password 

 Here the protection depends on whether the read or the write password is en-

tered at the time the document is opened: 

 If the user enters the read password, he is permitted to open the document but 

not to save it. If he enters the write password, he has complete access. If he en-

ters a false password, or nothing at all, access is completely denied. 

Detailed information about enabling and disabling document protection is given on 

the following pages. 
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Enabling document protection 

You can protect your documents from being read or saved by unauthorized persons 

by applying document protection – or, to be more precise, read and/or write protec-

tion – to them. For example, you can require the entry of a password to open or 

save a protected document. 

When a document is read protected it is also encrypted, so that it cannot be exa-

mined with the use of programs other than TextMaker. 

To protect a document, do the following: 

1. Invoke the menu command File > Properties.  

2. Switch to the Protection tab. 

3. Select the kind of document protection desired (see below). 

4. Enter the read and/or write password (at least 4, and no more than 15 charac-

ters). 

Important: If you forget a password you can no longer open, or save, the 

document. Therefore, it is advisable to write down the password, paying at-

tention to the cases of letters! 

5. Confirm with OK. 

6. A dialog appears and requires you to verify the read and/or write password by 

reentering it.  

7. Confirm with OK. 

8. Exit the dialog box with OK. 

9. Save the document to make the changes effective. 

From now on anyone who attempts to open this document will be asked automati-

cally for the password. If the correct password is entered, the protection will be 

lifted for the duration of the edit session. 

Using the above described dialog, you can select any of the following types of pro-

tection: 

 No protection 

 The document is not protected. This is the default setting. 
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 Write protection 

 When the document is opened, the user is given the opportunity to enter the 

write password. The document can be saved only when the correct write pass-

word has been entered. 

 If the user enters a false password, or no password at all, the document is ope-

ned write protected and cannot be saved – not even under another name. 

 Read protection 

 When the user tries to open the document, he is prompted to enter the read 

password. If he enters a false password, or no password at all, the document is 

not opened. 

 Furthermore, the document is saved in an encrypted form, so that it cannot be 

examined with programs other than TextMaker. 

 Protection depending on password 

 Here the protection depends on whether the read or the write password is en-

tered at the time the document is opened: 

 If the user enters the read password, he is permitted to open the document but 

not to save it. 

 If he enters the write password, he has full access. Thus, he can both read and 

also save the document. 

 If he enters a false password, or nothing at all, access to the document is de-

nied. 

Encryption method: “Most compatible” or “Most secure”? 

For documents with read protection or protection depending on password, you 

can also choose the Encryption method to be used.  

Note: This setting primarily concerns the creation of new documents. When you 

open an existing encrypted document, the encryption method used in the 

document is determined automatically and this option is set accordingly. 

Choosing an encryption method is of importance especially for documents in 

Microsoft Word file format (.doc and .docx), since some older versions of Micro-

soft Office are unable to read documents using the new encryption method (“Most 

secure”). 
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The following two encryption methods are available: 

 Most compatible 

 When the document is saved, an old encryption method is used that can be read 

by all versions of Microsoft Office. However, this method is less secure than 

the other method. 

 Most secure 

 Here, a more modern and more secure encryption method is used. However, 

some older versions of Microsoft Office may not be able to read documents en-

crypted with this method. 

Detailed information about the currently selected encryption method is displayed at 

the bottom of the dialog. 

Disabling document protection 

When you succeed in opening a read or write protected document by entering the 

correct password, protection is disabled – but only temporarily. When you close 

the document, protection is again “armed” and the query for the password re-

appears the next time someone makes an attempt to open the document. 

To disable the protection on a document permanently, do the following: 

1. Open the document. 

2. Invoke the menu command File > Properties.  

3. Switch to the Protection tab. 

4. Select the No protection option. 

5. Confirm with OK. 

6. Save the document, so that the changes will take effect. 

Document protection is now permanently disabled. 

The next time someone opens the document, no password query will interfere. All 

users can now open and save it. 
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Working with other file formats 

Normally, TextMaker saves a document in its native file format, namely, the 

“TextMaker document” format. TextMaker documents can be recognized easily by 

the filename extension .TMDX. When you save a document, TextMaker automati-

cally appends this extension to the name you give it. For example, if you save a 

document under the name “Letter”, its complete filename will be LETTER.TMDX. 

You can save a file in various other file formats as well, which is useful, for exa-

mple, when you want to do additional work on a document using another program. 

And you can also open documents in TextMaker that have been created with other 

word processors. 

In this chapter you will learn how to work with other file formats. It covers the 

following topics: 

 Saving and opening files in other file formats 

 The first section describes how to save or open a document in a different file 

format. You simply invoke the File > Save as menu command (or, the File > 

Open command respectively) and choose the file format in the Save as type 

list. 

 Working with text files 

 When you open or save a text file, its character set is usually determined auto-

matically. As needed, you can specify the character set manually. This section 

contains information how to do this. 

See the following pages for detailed information. 

Saving and opening files in other file formats 

This section provides information on saving and opening documents in a different 

file format. 
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Saving a document in a different file format 

To save the active document in a different file format, invoke the menu command 

File > Save as and open the dropdown list Save as Type. Choose the desired for-

mat, enter a new filename if desired, and confirm by clicking on OK. 

Opening a document stored in a different file format 

To open a document stored in a different file format, invoke the menu command 

File > Open, open the Files of type list, and select the format of the file to be ope-

ned. Then select the file and confirm with OK.  

Supported file formats 

The list of available file types in Open and Save dialogs contains (among others) 

the following file formats: 

 Document 

 The native file format and default for TextMaker documents. This is the format 

in which you will typically save your documents (name extension: .tmdx). 

 Template 

 Document template for TextMaker documents (see section “Document templa-

tes” beginning on page 149) 

 Microsoft Word 

 You can also open and save documents in Microsoft Word file format. Supports 

.doc files (Word 6.0 through 2003) as well as .docx files (Word 2007 or later). 

FreeOffice: In SoftMaker FreeOffice, .doc files can only be opened. Saving 

files in this format is not supported. 

 OpenDocument Text 

 Documents stored in OpenDocument Text format (.odt) can be opened and sa-

ved as well, providing compatibility with applications like OpenOffice Writer. 

FreeOffice: In SoftMaker FreeOffice, .odt files can only be opened. Saving 

files in this format is not supported. 
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 TextMaker 2016 document 

 For storing documents in the file format of TextMaker 2016, an older version of 

TextMaker (name extension: .tmd). 

 Rich Text Format 

 The RTF format is very suitable for document exchange. It supports all basic 

kinds of formatting and can be read by many other programs. 

 HTML 

 HTML format, for web pages (see also chapter “Internet functions” beginning 

on page 477) 

 Text file 

 Plain text file 

 Text file with additional options 

 Same as above. However, before the file is opened/saved, an additional dialog 

opens, where you can specify the character set and other advanced settings. See 

the section “Working with text files” below for details. 

 TextMaker/DOS (import only, available under Windows only) 

 Opens a document that was created with TextMaker for DOS, version 3.0 or 

higher. (Saving in this file format is not possible.) 

Working with text files 

As described in the previous section, you can also open and save plain text files 

with TextMaker.  

When you do this, make sure the correct character set is used: 

Letting TextMaker determine the character set automatically 

Usually, you don’t have to care about choosing the correct character set, since 

TextMaker handles this automatically for you, as follows: 

 When you open a text file, TextMaker tries to determine its character set auto-

matically. If it fails, your system’s default character set is used. 
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 When you open a text file and save it, TextMaker automatically uses the cha-

racter set in which the file was opened. 

 When you save an existing document to a new text file, your system’s default 

character set is used. 

Setting the character set manually 

Alternatively, you can specify the character set manually when you open or save a 

text file. 

Proceed as follows: 

1. Invoke the File > Open menu command (or, the File > Save as command 

respectively). 

2. Important: Open the list of file types and choose the entry “Text file with ad-

ditional options”. 

3. Pick a file or specify the file name of the text file. Confirm with OK. 

4. An additional dialog will open, where you can choose the desired character set. 

The dialog provides the following options: 

 Character set 

 Here you can specify which character set to use when the text file is ope-

ned/saved. 

 Note: TextMaker suggests a suitable character set automatically. Usually, there 

is no need to change this setting. 

 Encoding of newlines 

 Only when saving: Here you can specify the control characters that are added at 

the end of lines (in order to indicate the beginning of a new line). 

 Note: TextMaker suggests suitable control characters automatically. Usually, 

there is no need to change this setting. 

 Available options: 

 CR+LF: This is the recommended setting for Windows. 

 LF: This is the recommended setting for Linux and Mac. 
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 CR: This control character used to be common on older Apple Mac systems 

(prior to Mac OS X). 
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Working with Arabic text 

In this chapter, you will learn everything you need to know about composing and 

editing text in Arabic script. The following topics are covered: 

 Activating extended support for Arabic text 

 Changing the text direction of paragraphs 

 Changing the direction of tables 

 Changing the direction of multi-column text 

 Changing the font of Arabic text 

 Inserting dates in Arabic 

See the next pages for details. 

Important: The features described in this chapter are only available when you 

have activated the Extended support for Arabic text option in the program set-

tings (see next section). 

Activating extended support for Arabic text 

TextMaker includes an “Extended Support for Arabic Text” option that provides 

some additional features for editing Arabic text. 

To activate this option, proceed as follows: 

1. Invoke the Tools > Options menu command. 

2. Switch to the General tab. 

3. Activate the Extended support for Arabic text option. 

Important: The features described in this chapter are only available when this 

option is activated. 
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Changing the text direction of paragraphs 

When the Extended support for Arabic text option is enabled, you can change 

the text direction of any given paragraph in your document whenever needed. 

To do so, proceed as follows: 

1. Invoke the Format > Paragraph menu command. 

2. Switch to the Paragraph tab. 

3. Under Text direction, chose the desired option (left-to-right or right-to-left). 

Tip: Using the keyboard 

A much quicker way to change the text direction of a paragraph is provided with 

the following keyboard shortcuts: 

 When you press (Ctrl) and the left Shift key (ª) simultaneously, the text direc-

tion changes to left-to-right. 

 When you press (Ctrl) and the right Shift key (ª) simultaneously, the text di-

rection changes to right-to-left. 

Mac/Linux: On some systems (including macOS and several Linux distributions), 

these keyboard shortcuts might be not available. In this case, you can alternatively 

use the keyboard shortcuts (Ctrl)(Shiftª)(A) (for left-to-right) and 
(Ctrl)(Shiftª)(D) (for right-to-left). 

Changing the direction of tables 

When the Extended support for Arabic text option is enabled, you can change 

the direction of a table whenever needed. 

To do so, proceed as follows: 

1. With the text cursor inside the table, invoke the Table > Table properties menu 

command. 

2. Switch to the Properties tab. 

3. Under Text direction, activate the option Right to left to change the direction 

to right-to-left. 
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 To set the direction to left-to-right, deactivate the option. 

The direction of the table changes accordingly. 

Thus, when you change the direction of a table to right-to-left, the column on the 

very right becomes the first column (instead of the column at the very left). 

In other words, the horizontal direction of the table is reversed – as follows: 

 

Left: Table direction set to left-to-right 

Right: Table direction set to right-to-left 

Note: Of course you can still change the writing direction of the text in each table 

cell individually (as described in the section “Changing the text direction of para-

graphs” above). 

Changing the direction of multi-column text 

When the Extended support for Arabic text option is enabled, you can change 

the direction of a text section that uses multi-column layout whenever needed. 

To do so, proceed as follows: 

1. With the text cursor inside the multi-column text section, invoke the Format > 

Section menu command. 

2. Switch to the Columns tab. 

3. Under Text direction, activate the option Right to left to change the direction 

to right-to-left. 

 To set the direction to left-to-right, deactivate the option. 

The direction of the multi-column text section changes accordingly. 

Thus, when you change the direction of a section to right-to-left, the column on the 

very right becomes the first column (instead of the column at the very left). 

Note: Of course you can still change the writing direction of the text in each para-

graph individually (as described in the section “Changing the text direction of pa-

ragraphs” above). 
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For general information on working with multi-column text, see the chapter 

“Multi-column page layouts” (page 153). 

Changing the font of Arabic text 

When the Extended support for Arabic text option is enabled, the dialog box for 

the Format > Character menu command presents lists for typeface, font size, 

style and language under not only a single category, but under three: 

 For Latin scripts (e.g. English) 

 For East Asian scripts (Chinese, Japanese, and Korean) 

 For complex scripts (e.g. Arabic) 

Thus, you can specify the settings for each kind of script separately. 

For example, if you specify “Arial” as the typeface for Latin characters and 

“Simplified Arabic” as the typeface for characters in complex scripts (like Arabic), 

all Latin characters that you type will appear in Arial, and all Arabic characters you 

type will appear in the font “Simplified Arabic”. 

Note: TextMaker recognizes automatically whether given characters are part of the 

Latin, Asian, or complex scripts. 

Inserting dates in Arabic 

When the Extended support for Arabic text option is enabled, the dialogs for the 

menu commands Insert > Date and Insert > Field contain additional options for 

the insertion of dates into the text. 

Options available: 

 Language 

 Here you can select the language in which day and month names are to be dis-

played in the date. You can choose between the language for Western scripts, 

for Asian scripts, or for complex scripts (e.g. Arabic). 

 Note: To specify the language for each of these script types, use the three Lan-

guage options in the Format > Character menu dialog. 
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 Calendar 

 Here you can choose if the date should be based on the Gregorian calendar or 

the Islamic (Hijri) calendar. 

For general information on inserting dates and other fields, see the chapter “Fields” 

(page 171). 
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Scripts (BasicMaker) 

Note: BasicMaker is not included in some versions of SoftMaker Office. 

Available only under Windows. 

FreeOffice: In SoftMaker FreeOffice, BasicMaker is not included. 

BasicMaker is a tool that allows you to compose and execute scripts written in the 

programming language SoftMaker Basic. SoftMaker Basic is modeled after the 

industry standard Visual Basic for Applications (VBA) from Microsoft. 

Scripts can be used to automate tasks in the word processor TextMaker and the 

spreadsheet application PlanMaker.  

Invoking BasicMaker 

To start BasicMaker, or to execute a BasicMaker script, use one of the following 

procedures: 

 Starting BasicMaker from the Start menu 

 You can start BasicMaker by clicking on Start > Programs > SoftMaker 

Office > Utilities > BasicMaker in the Start menu. 

 Starting BasicMaker from within TextMaker/PlanMaker 

 Alternatively, you can start BasicMaker from within TextMaker or PlanMaker. 

From the main menu in TextMaker/PlanMaker, choose the menu command 

Tools > Edit script. 

 Running a script directly from within TextMaker/PlanMaker 

 To execute a script, invoke the menu command Tools > Run script in TextMa-

ker/PlanMaker. A file dialog appears. Choose a script, confirm with OK, and 

the script will be executed. 

For more information on BasicMaker and details on “programming” TextMaker 

and PlanMaker, see the BasicMaker online documentation (which can be found in 

BasicMaker’s Help menu). 
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Working with multiple documents 

You can have multiple documents open at any time – to compare them, edit them at 

the same time, exchange data between them, etc.  

You work with multiple documents as follows: 

 Opening multiple documents in the same program window 

 You can open any number of documents at the same time in the current pro-

gram window.  

 There are many ways to switch between these documents, including a bar that 

contains document tabs for each currently open document (displayed above the 

current document):  

 

 

FreeOffice: The functions for working with Document tabs are not included 

in SoftMaker FreeOffice. However, you can open several documents in diffe-

rent program windows. 

 Opening documents in a new program window 

 You can also open documents in a new program window. This allows you, for 

example, to place documents side by side on the monitor.  

 To do so, switch on the option New program window in the dialog window of 

the menu command File > New or File > Open when you create/open the 

document. (Note: This option is not available in the Android version. 

These two methods can be combined as desired. You can open as many program 

windows as you like and open any number of documents in each of these windows. 

Or you can open all documents in just one program window. Or you can let the 

software create a separate program window for each document. Any way you like 

it. 

In this chapter you will learn everything you need to know about working with 

multiple documents at the same time. See the next pages for details. 
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Creating or opening a document 

To create a new document, or to open a document, proceed as follows: 

 Select the menu command File > New to create a new document. 

 Select the menu command File > Open to open an existing document. 

These two commands are described in detail in the chapter “Basics” beginning on 

page 37. 

“New program window” option 

The option New program window in the dialog box for these two commands has 

the following meaning: If it is switched on, the document will appear in a new pro-

gram window. If it is switched off, the document will appear in the existing pro-

gram window. 

Note: This option is not available in the Android version. 

Switching between open documents 

When working with multiple documents open at the same time, you have the 

following options for switching to a specific document – and thus making it the 

active document: 

 Menu: “Window” menu 

 In the Window menu you will find a list of all currently open documents. Sel-

ect the entry for the document you want to switch to. 

 Ribbon: “Switch windows” icon 

 In the ribbon you will find an icon named Switch windows on the View tab, 

which works in a similar way: When you click on it, a list of all open 

documents appears, allowing you to choose the document of interest.  

 Mouse: Clicking on a document tab 

 Under the toolbars or ribbon you will find a bar containing document tabs for 

each currently open document. Click on the tab for the document you want to 

switch to. 
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FreeOffice: The functions for working with Document tabs are not included 

in SoftMaker FreeOffice. However, you can open several documents in diffe-

rent program windows. 

 Mouse: Clicking into the program window containing the document 

 If you have opened documents in more than one program window (see previous 

section), you can of course also simply click into the program window contai-

ning the desired document. 

 Keyboard: Pressing Ctrl+F6 

 You can also use the keyboard to switch between the currently open documents: 
(Ctrl)(F6) switches to the next document and (Ctrl)(Shiftª)(F6) switches to the 

previous one. 

 Mac: On a Mac, the key combinations (Cmd)(F6) and (Cmd)(Shiftª)(F6) have to 

be used instead. 

Closing a document 

If you want to conclude your work on a document, you can close it at any time. 

You have the following options: 

 Menu: Choose the File > Close menu command to close the current document. 

Tip: You can close all currently open documents in one step with the menu 

command Window > Close all. 

 Ribbon: The File tab contains a Close icon that closes the current document. 

 Document tabs: Under the toolbars or ribbon, you will see a bar with 

document tabs for each currently open document. When you click on one of 

these tabs with the middle mouse button, the corresponding document is closed. 

 

 

 Alternatively, you can close a document by left-clicking on the x icon displayed 

on the right of its tab. 
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 And when you right-click on a tab, a small menu appears. It contains com-

mands for closing the current document or all other open documents. 

FreeOffice: The functions for working with Document tabs are not included 

in SoftMaker FreeOffice. However, you can open several documents in diffe-

rent program windows. 

 Keyboard: You can also use the keyboard shortcut (Ctrl)(F4) or alternatively 
(Ctrl)(W) to close the current document. 

 Mac: On a Mac, the key combination (Cmd)(F4) or (Cmd)(W) has to be used 

instead. 

Whenever you close a document that has been modified since it was last saved, the 

program automatically asks you if you want to save the document first. 

Arranging documents on the screen 

Android: This feature is not available in the Android version. 

If you have documents open in multiple program windows, you can arrange them 

on the screen as follows: 

 Of course you can move the individual program windows manually and change 

their size – just as it is possible with all kinds of program windows. 

 If you select Window > View side by side, the current program window and 

another (already opened) program window are arranged next to each other on 

the screen. If more than two program windows are currently open, the program 

first asks which other window should be used. 

FreeOffice: The View side by side feature is not included in SoftMaker 

FreeOffice.  
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Customizing TextMaker 

TextMaker gives you control over numerous program settings, allowing you to 

adapt the program to your personal working style. 

This chapter covers all the details. It is divided into the following sections: 

 Preferences 

 To modify TextMaker’s global preferences, use the Tools > Options menu 

command. These settings apply to the program as a whole, and thus to all 

documents. 

 Document properties 

 To modify the properties of a document, use the File > Properties menu com-

mand. These settings affect the current document only. 

 Customizing the document display 

 This section describes how to adjust the way a document is displayed on the 

screen. Most of the necessary commands are found in the View menu. 

 Customizing toolbars 

 “Classic menus and toolbars” only: This section is relevant only for users 

who have configured the program to use “classic menus and toolbars”.  

 You will learn here how to configure the program’s toolbars (Standard toolbar, 

Formatting toolbar, etc.) using the View > Toolbars menu command and how 

to customize the icons displayed on them using the Tools > Customize com-

mand. 

 Customizing the ribbon 

 “Ribbons” only: This section is relevant only for users who have configured 

the program to use the “ribbon” interface.  

 You will learn here how to configure and customize the ribbon. 

 Creating user-defined toolbar/ribbon icons 

 You can create user-defined icons and add them to a toolbar or to the ribbon. 

Such icons can be used to start other programs of your choosing.  
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 Customizing keyboard shortcuts 

 The dialog box of the Tools > Customize menu command also allows you to 

customize the keyboard shortcuts for commands. 

 Using the grid and Using guides 

 Guides and the grid are aids for positioning objects such as frames and dra-

wings that you move with your mouse. They can be activated and configured 

with the menu command Object > Grid and guides. 

 Installing additional dictionaries 

 This section contains instructions on installing additional dictionaries (for exa-

mple, Hunspell dictionaries). 

These topics are treated in detail on the following pages in the order listed. 

Preferences 

To modify TextMaker’s global preferences, use the Tools > Options menu com-

mand. These settings apply to all documents. 

The dialog box associated with this command contains several tabs, each of which 

presents options relating to a different topic area. If you click on the Files tab, for 

example, you will be able to make settings that control the opening and saving of 

files. 

On the next pages, you will find detailed information on each of the individual 

options available. 

Preferences, View tab 

The View tab in the dialog of the Tools > Options menu command allows you to 

control how documents are displayed on the screen. 

Document window group box 

Here you can choose the tools to be displayed in the document window: 
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 Table guidelines 

 Here you specify whether or not a grid of gray lines should be used to make the 

boundaries of table cells visible on the screen. These lines serve simply as visu-

al aids; they are not printed.  

 By default, this option is enabled. 

 Frame guidelines 

 Here you specify whether or not gray lines should be used to make the bounda-

ries of text frames visible. These lines merely indicate the position and size of 

the text frame on the screen; they are not printed. 

 By default, this option is enabled. 

 OLE object guidelines 

Windows only: Here you specify whether or not gray lines should be used to 

make the boundaries of OLE objects visible. These lines merely indicate the 

position and size of the object on the screen; they are not printed. 

 By default, this option is enabled. 

 Guides 

 As described in section “Using guides” beginning on page 596, you can set up 

guides for each document that will simplify the accurate positioning of objects.  

 With this option, you specify whether or not these guides should be displayed 

on the screen.  

 By default, this option is enabled. 

 Note: If you disable this option, the guides are no longer displayed, but retain 

their function.  

 Annotation: This option is identical to the Display guides option in the dialog 

of the Object > Grid and guides menu command. 

 Page borders 

 Here you specify whether or not page borders should be indicated in the 

document with dotted grey lines. These lines serve merely as visual aids; they 

are not printed. 

 By default, this option is enabled. 
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 Horizontal ruler 

 Here you can enable or disable the horizontal ruler. 

 The horizontal ruler is displayed above the text. It shows the current paragraph 

formatting, and it also provides a means of changing indents and tab stops with 

the mouse (see chapter “Paragraph formatting” beginning on page 83).  

 By default, this ruler is enabled. 

 Vertical ruler 

 Here you can enable or disable the vertical ruler. 

 The vertical ruler is displayed to the left of the text. It serves merely to provide 

information and not for formatting changes. 

 By default, this ruler is disabled. 

 Overflow mark 

 When this option is enabled, TextMaker displays a red bar at the bottom edge 

of text frames whenever there is too much text to be fitted completely in the 

frame.  

Show unprintable characters group box 

Here you specify if paragraph breaks, tabs, spaces, etc. should be indicated as 

symbols on the screen to make them easier to recognize. 

 Paragraph breaks 

 If you enable this option, TextMaker displays the paragraph break at the end of 

every paragraph, represented by the ¶ symbol. This lets you see exactly where 

paragraphs end. 

 Tabs 

 If you enable this option, all tabs become visible on the screen as small arrows. 

 Spaces 

 If you enable this option, small dots are used to make all spaces visible on the 

screen. 
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 Soft hyphens 

 If you enable this option, soft hyphens become visible on the screen. They are 

displayed as hyphens with a gray background. 

 All 

 Enables all the above listed options together. 

Show scrollbars group box 

Here you can specify whether or not horizontal and/or vertical scrollbars are to be 

displayed. 

Wrap text to window (in continuous and outline view) 

When this option is enabled, lines of text are always wrapped at the right border of 

the document window, regardless of their actual lengths. The actual layout of the 

document is thereby ignored, but the text becomes more legible on small displays 

(mobile devices, for example), which might otherwise require you to scroll to the 

right and left frequently in order to read a text. 

Note: Activating this option only affects continuous view (View > Continuous 

menu command) and the outliner (View > Outline). If the document is viewed in 

normal view (View > Standard) this option is ignored. 

Show multiple pages side by side 

With this option, you can specify if TextMaker should display multiple pages of a 

document side by side when the document is viewed at a very low zoom level: 

 On: Display as many document pages next to each other as fit into the 

document window. This allows you to view multiple pages at the same time. 

 Off: Display one page on top of each other. 

Preferences, General tab 

The General tab in the dialog of the Tools > Options menu command contains 

common program settings: 
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Maximum number of undo steps 

Here you can specify the number of actions that can be reversed with the Edit > 

Undo menu command. You can increase this number up to a maximum of 999 un-

do operations. 

Note: On devices with little main memory, it is not recommended to increase this 

value. 

You will find more information about the Edit > Undo menu command in section 

“Undoing changes” beginning on page 39. 

“User info” button 

Here you can enter your name, address and other contact information. These ent-

ries are used, for example, by the document templates supplied with the program to 

personalize letterheads, fax forms, etc. by filling in the sender address (see also 

section “Document templates” beginning on page 149). 

Note: In older versions of TextMaker, two buttons were available at this point, 

since you could enter your user data separately for home address and business 

address. Since TextMaker 2018, only one set of user data is supported in order to 

improve compatibility with Microsoft Word.  

Extended support for Asian fonts 

When this option is enabled, the dialog box for the Format > Character menu 

command presents lists for typeface, font size, style and language under not only a 

single category, but under three: 

 For Latin scripts (e.g. English) 

 For East Asian scripts (Chinese, Japanese, and Korean) 

 For complex scripts (e.g. Arabic) 

Thus, you can specify the settings for each kind of script separately. 

For example, if you specify “Arial” as the typeface for Latin characters and “Sim-

Hei” as the typeface for Asian characters, all the Latin characters that you type will 

appear in Arial, and all the Asian characters you type will appear in SimHei. 

Note: TextMaker recognizes automatically whether given characters are part of the 

Latin, Asian, or complex scripts. 
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Extended support for Arabic text 

When you activate this option, additional features for editing text in Arabic script 

will become available. See the chapter “Working with Arabic text” (page 523) for 

details. 

Display of digits 

Allows you to specify which type of numerals to use for the display of numbers in 

your documents: 

 Arabic: Display Arabic numerals (1234567890), as used e.g. in English. This is 

the default setting. 

 Hindi: Display Hindi numerals (١٢٣٤٥٦٧٨٩٠), as used e.g. in Arabic. 

 Context: Adapt automatically from the context. (If the number is surrounded 

by Arabic text, display Hindi numerals, else display Arabic numerals.) 

Show warning when loading OLE objects 

Mac, Linux, and Android only: When this option is enabled, the program dis-

plays a warning that OLE objects cannot be displayed when you open a document 

containing such objects. (OLE objects can be displayed only under Windows.) 

Preferences, Edit tab 

The Edit tab in the dialog of the Tools > Options menu command allows you to 

set preferences for editing text. 

Capitalize first letter of sentences 

When this option is enabled, TextMaker automatically capitalizes the first letter of 

every sentence you type – even if you accidentally enter a lowercase letter. 

For example, if you typed the sentence “this is a new sentence.”, it would be cor-

rected automatically to “This is a new sentence.”. 
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Correct first two uppercase letters 

When this option is enabled, TextMaker automatically corrects the case of words 

(such as proper names) whose first two letters have been capitalized inadvertently. 

For example, if you typed the word “HEnry”, it would be corrected automatically 

to “Henry”. 

Expand SmartText entries 

As described in the section “SmartText” (beginning on page 346), you can create 

SmartText entries (e.g. “sd” for “sales department”) with TextMaker. 

When this option is enabled, your SmartText entries can be expanded right in the 

text. All you have to do is type the abbreviation for the SmartText entry (e.g. “sd”) 

and then press the space bar, Enter key or a punctuation key in order to signal 

TextMaker to replace the abbreviation with the content of the SmartText entry. 

If this option is disabled, SmartText entries can be called out only with the Insert > 

SmartText menu command. 

Smart quotes 

TextMaker can automatically transform double quotes (") and single quotes (') as 

they are typed so that they are typographically correct, based on the selected langu-

age. You can specify the relevant language, or you can specify “None” if you want 

TextMaker to leave your quote marks as you typed them and make no changes.  

For example, if you type "Text" or 'Text', the result will depend on this setting as 

follows: 

Setting "Text" 'Text' 

Auto (see below)  

None "Text" 'Text'   (no change) 

German „Text“ ‘Text’ 

Swiss German »Text« ›Text‹ 

English “Text” ‘Text’ 

French «Text» ‹Text› 

Swedish ”Text” ’Text’ 
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The Auto option presents a special case: If you select this option, TextMaker de-

tects the language automatically (using either the default language set in the prefe-

rences or the language assigned with e.g. the menu command Format > Charac-

ter) and transforms the quote marks accordingly. 

Select whole words when selecting 

Windows, Mac, and Linux only: When this option is enabled, TextMaker auto-

matically extends any selection that you make with the mouse to word boundaries. 

When the option is disabled, selections can be made on a character-by-character 

basis. 

Add or remove spaces when pasting 

When this option is enabled, spaces are added or removed automatically as requi-

red when words are deleted or cut from the text, and when they are pasted into the 

text from the clipboard. 

For example, if you selected the word “is” in the sentence “This is a test” and cut it 

with the Cut command, TextMaker would automatically remove the space behind 

“is”, since it is now superfluous. 

If you subsequently pasted the word “is” into the text in front of another word u-

sing the Paste command, TextMaker would automatically add a space between “is” 

and the following word. 

Middle mouse button 

Mac and Linux only: Here you can specify what should happen when you click 

somewhere using the middle mouse button. Options available:  

 No function: The middle mouse button doesn’t have any function. 

 Paste selected content: A click with the middle mouse button inserts the con-

tent of the selection (e. g. the currently selected text) at the corresponding posi-

tion. 

Apply character formatting to entire words 

Enabling this option has the following effect: 
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When the text cursor is inside a word and you change the character formatting (i.e. 

choose a different font or activate boldface), the entire word will be affected. 

This allows you to format single words quickly, without having to select them first. 

Format URLs as hyperlinks 

When this option is enabled, URLs (web page addresses) will be formatted as hy-

perlinks automatically, right after you enter them. 

For example, when you type “www.softmaker.com”, it will automatically be con-

verted into a clickable hyperlink and displayed accordingly (usually blue and un-

derlined). 

Superscript ordinal numbers 

This option supports only the following languages: English, French, Italian, Portu-

guese, and Spanish. 

In these languages, parts of abbreviated ordinal numbers are usually superscripted 

– for example 1st, 2nd, 3rd in the English language. 

If this option is enabled, the superscripting is done automatically whenever you 

enter such a number. For example, when you type “2nd” and press the spacebar, 

this will be automatically reformatted to “2nd” (i.e. the letters “nd” will be super-

scripted). 

Note: This option only works with text in one of the supported languages. Infor-

mation on how to specify the language of text can be found in the section 

“Setting the language”, page 330. 

Set left and first-line indent with Tab and Backspace keys 

When this option is enabled, you can use the (Tab) key and the Backspace key 
(æ__) to set and change paragraph indents. 

To do this, place the text cursor at the beginning of the paragraph of interest or 

select the desired paragraphs. Then, press (Tab) to increase the indent or press 

Backspace (æ__) to decrease it. 
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Insert frames and drawings immediately 

Here you can specify what should happen when you insert a frame (text frame, 

picture frame, etc.) or a drawing into a document – for example, using the menu 

command Object > New text frame: 

 On: The corresponding object is inserted immediately. Its position and size are 

chosen automatically.  

 (Of course you can always change the object’s position after that, by simply 

dragging it to a different place with the mouse. And you can also modify its si-

ze, by dragging on one of the round handles that appear around the object.) 

 Off: Before the object is actually inserted, the mouse cursor changes to a cross-

hair. To proceed, draw a rectangle in the document with your mouse, in order to 

determine the exact position and size of the object. After that, the object will be 

inserted accordingly. 

Use left Alt as shortcut key 

Mac only: This option determines which function the left Alt key on your key-

board should have: 

 Off: The left Alt key does the same as the right Alt key: It inserts symbols into 

the text. 

 (Alt)(E), for example, gives you a Euro sign. 

 On: The left Alt key can be used to open menus in the classic menu. (Note: 

This only works if you use the program with classic menus instead of the rib-

bon.) 

 Here, (Alt)(E) no longer returns a Euro sign, but opens the Edit menu instead. 

Preferences, Appearance tab 

The Appearance tab in the dialog of the Tools > Options menu command allows 

you to customize the appearance of the program’s user interface. 

Dialog language 

Here you can select the language to be used for the user interface (menus, dialog 

boxes, etc).  
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User interface 

When you click on the User interface button, a dialog box appears in which you 

can select the type of user interface that the applications in SoftMaker Office 

should use: 

 Ribbon (upper row) 

 When you select one of the items from the top row, the programs will use a 

ribbon interface, as some modern Windows applications do. (The differences 

between the individual entries are only in the color scheme used.) 

 Classic menus and toolbars (lower row) 

 When you select one of the entries from the bottom row, the programs will use 

classic menus and toolbars. (Also for this, several different color variants are 

offered.) 

In addition, the following settings can be made in the dialog box: 

 Quick Access Toolbar 

 Ribbons only: Determines where the Quick Access Toolbar, which contains 

icons for some of the most frequently used commands, should be displayed: to 

the left of the document tabs – or in a separate toolbar directly below the rib-

bon. 

 Touch mode 

 If you activate this option, all icons in the ribbon or in menus/toolbars are 

enlarged a bit. This is useful when operating the software with your finger (for 

example, on a tablet). 

 Tip: In addition to this option, you can also switch touch mode on/off with the 

following commands: 

 Menu: command View > Touch mode 

 Quick Access Toolbar: command Touch mode 

Dialog style 

Sets the general style of TextMaker’s dialog boxes and toolbars. This does not 

change the way you use the software, only the way it appears. 
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Show fonts in font list 

When this option is enabled, TextMaker renders the names of fonts that appear in 

lists (such as the font list in the Formatting toolbar) using their corresponding 

fonts. This lets you see at a glance how each font looks like. 

Show tooltips 

Lets you specify whether or not tooltips should be displayed. 

Tooltips are little text boxes that are displayed next to the mouse pointer when you 

position the pointer over certain screen elements, for example a button on a toolbar. 

Beep on errors 

When this option is enabled, a sound plays when TextMaker displays an error or 

warning message. 

Live preview 

FreeOffice: Live Preview is not included in SoftMaker FreeOffice. 

Enable/disables a live preview for the dropdown lists in the Formatting toolbar. 

When this option is enabled, you can e.g. select some text, open the font dropdown 

in the Formatting toolbar and hover over the fonts with your mouse. While you do 

that, the selected text is updated “live” to give you an impression how it would 

look like in the corresponding font. 

To actually apply the font, simply click on it. To discard the change, click anywhe-

re outside the list or press the (Esc) key. 

Use system menus 

Mac only: This option determines whether or not the program should display its 

main menu in the menu bar at the very top of the screen (as is customary for Mac 

applications). 

Depending on the type of user interface you have chosen (“Ribbon” or “Classic 

menus and toolbars”), this option has the following effect:  

 Off: The main menu is not displayed in the menu bar at the top of the screen.  
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 Details: 

 Classic menus and toolbars: With the classic user interface, the main 

menu is no longer displayed at the top of the screen, but in its own bar (be-

low the title bar). 

 Ribbon: If you have chosen the “Ribbon” user interface, only the “hambur-

ger menu button” (i.e. the  icon in the Quick Access Bar) is available to 

you if you want to access the classic main menu. 

 On: The main menu is displayed in the menu bar at the top of the screen.  

 Details: 

 Classic menus and toolbars: The main menu is now displayed in the menu 

bar at the top of the screen, not in its own bar below the title bar. 

 Ribbon: Ribbon users now have access not only to the Ribbon user inter-

face but can additionally use the classic menu in the menu bar whenever de-

sired. 

Use system file dialogs 

Windows, Mac, and Linux only: This option controls the type of dialogs that 

appear when commands to open and save files are issued. The options are: 

 Off: TextMaker uses its own file dialogs. 

 On: TextMaker uses the file dialogs provided by the operating system. 

The former are easier to use; the latter offer more options. 

Smooth edges of screen fonts 

When this option is enabled, TextMaker uses a technology called “anti-aliasing” to 

smooth the edges of fonts and improve their appearance on the screen. 

The options available vary according to the operating system. 

Workspace color 

This option allows you to change the background color of document windows. 
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User interface size 

Mac, Linux, and Android only: This button opens a dialog where you can de-

crease or increase the scaling of the application’s user interface (menu, toolbars, 

dialogs, etc.). 

Choosing a smaller setting will scale all user interface elements down, allowing 

you to can see more elements at a time. A larger setting, on the other hand, in-

creases the legibility. 

While the Controls size option changes the scaling in large steps, the Font size 

adjustment option can be used to perform some fine-tuning in smaller steps.  

The Sample field is there to help you find a decent setting: It gives you a preview 

of how a checkbox in a dialog will look like when you apply your changes. 

Note: With inappropriate settings, the user interface might become far too small 

or too large, especially on devices with a rather low resolution. In case this hap-

pens, you can always click on the Reset to default button in the lower left of this 

dialog to return to the original settings. 

Measurement 

Mac, Linux, and Android only: Here you can specify the units of measure Text-

Maker should use by default: Metric (centimeter) or U.S. (inch). 

(Under Windows, this option is not necessary, since the program automatically 

uses the setting chosen in the “Regional and Language” options of Windows’ Con-

trol Panel.) 

Tip: You can always override this setting and enter a value into a dialog field in 

another unit of measure by typing one of the following unit abbreviations after the 

value: 

Unit Explanation 

cm centimeter 

in inch – 1 in equals 2.54 cm. 

pt point – 72 pt equals 1 in. 

pi Pica (for characters) 

For example if you typed “5.08 cm” for the left margin, TextMaker would set the 

margin to 5.08 cm (= 2 in). 
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Preferences, Language tab 

The Language tab in the dialog of the Tools > Options menu command contains 

settings that are related to the program’s language tools (spell checker, hyphenator, 

etc.). 

Default language 

Here you can select the default language to be used for spell checking, hyphenati-

on, and the thesaurus. To choose your setting, open the dropdown list and select the 

desired language from the available options. 

Tip: If you want to employ more than one language in a document, you can use the 

Format > Character menu command to format any particular segment of text in a 

different language.  

You can read more about this topic in the section “Setting the language” (page 

330). 

Spell-checking 

Here you can configure the spell-checker. Settings available: 

 Use background spell checking 

 If you activate this option, the entire document will be continuously scanned for 

spelling errors in the background. Incorrectly spelled words are indicated with 

wavy red underlines and can be corrected at any time. See section “Background 

spell checking” (page 335). 

 Note: When this option is turned off, you can still check the spelling in a 

document using the manual spell-checker. To launch it, use the Tools > Check 

spelling menu command. See section “Manual spell checking” (page 333). 

 Color 

 Here you can change the color of the wavy red underlines that the background 

spell checker uses to indicate incorrectly spelled words in a document. 

 Underline old German spelling in blue 

 German language only: When this option is enabled, the background spell che-

cker additionally underlines in blue all German words that are correct according 

to the old German spellings but should be spelled differently to conform to the 
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new, reformed spellings. See section “Conversion to new German spelling” be-

ginning on page 337. 

Note: This option only works with text in the language “German (Germa-

ny)”, “German (Austria)”, or “German (Switzerland)”. 

 Ignore words that start with a number 

 Check this option if you would like the spell checker to ignore all words that 

start with a number (for example, “42nd”). 

 Hunspell dictionaries 

FreeOffice: SoftMaker FreeOffice does not include any of the premium 

SoftMaker dictionaries normally shipped with SoftMaker Office. Its spell 

checker supports solely the use of Hunspell dictionaries. 

In a standard installation, only Hunspell dictionaries for English and German 

are installed. If you want to add additional languages, refer to the section 

“Installing Hunspell dictionaries”.  

 Windows, Mac, and Linux only: As an alternative to its own dictionaries, 

SoftMaker Office also supports the use of Hunspell dictionaries. These dictio-

naries are available as free downloads. Most of them were created by private 

users or non-profit organizations. 

 The Hunspell dictionaries button allows you to a) install Hunspell dictionaries 

that you have downloaded and b) specify which languages should use a Hun-

spell dictionary. 

 For details, see section “Installing additional dictionaries” (page 600). 

Hyphenation 

Here you can configure the automatic hyphenation module. Settings available: 

 Use automatic hyphenation 

 Identical to the Tools > Automatic hyphenation menu command. 

 In TextMaker, hyphenation is completely automatic and takes effect as you ty-

pe. However, if you turn this option off, automatic hyphenation will be comple-

tely disabled (for the current document). Hyphens will no longer be inserted au-

tomatically, and existing ones are removed. See also section “Hyphenation” 

(page 341). 



 

552  •  Customizing TextMaker Manual TextMaker 

Note: Unlike all other options in this dialog, this setting is not a global setting 

but a document setting. In other words: TextMaker remembers its state per 

document. 

Preferences, Files tab 

The Files tab in the dialog of the Tools > Options menu command contains set-

tings related to opening and saving files: 

Template folder 

Here you can specify the folder in which the templates for TextMaker documents 

are stored. The dialog that appears when you invoke the menu command File > 

New presents templates for your selection that are found in this folder. 

Note: Normally, this setting should not be changed. Change it only in the event 

that you have actually moved the template folder to another place. 

Default file format 

Here you can select the file format that TextMaker will use by default to save 

newly created documents.  

The available choices include “TextMaker”, “MS Word” in several versions, “O-

penDocument”, and “RTF”. 

Important: The latter formats are not able to accommodate features specific to 

TextMaker. For example, if you save a TextMaker document in Word format, 

certain formatting options and other features could be lost. Accordingly, it is 

recommended to use the default setting “TextMaker”. 

Saving group box 

Here you can make settings related to saving documents: 



 

Manual TextMaker Customizing TextMaker  •  553 

 Create backup files 

 Android and SoftMaker FreeOffice only: If this option is enabled, whenever 

you save a document, the application will first create a backup copy of the last 

saved version in a file with the name extension .BAK.  

 (In SoftMaker Office for Windows, Mac, and Linux, more advanced options are 

available for backup copies – see section Backup below.) 

 Prompt for summary information when saving 

 When you enable this option, a dialog box will appear automatically the first 

time you save a new document to enable you to enter some additional informa-

tion about it (for more information, see the section “Document summary” be-

ginning on page 503). 

 Auto recovery: Save state every ... minutes 

 When this option is enabled, TextMaker automatically makes a temporary ba-

ckup copy of every open document on a periodic basis. You can enter a period 

of 1 to 100 minutes. 

Note: These temporary backup copies are totally independent of the regular 

backup copies that you can set up in the Backup section on this tab (see be-

low). 

 When you exit TextMaker in the normal manner, these temporary backup co-

pies are automatically deleted. However, if TextMaker is abruptly shut down by 

a power failure, for example, while you are working on open documents, these 

copies become available when the program is restarted. TextMaker recognizes 

that there has been a failure and offers to open the automatic backup copies of 

all documents that had been modified but not saved just prior to the failure. 

 You can then check each of the restored documents to determine if any of the 

most recently made changes have actually been lost, and then save them. 

 Display warning when saving documents in text format 

 If this option is enabled, a warning will be issued whenever you save a 

document in plain text format, to remind you that all objects and formattings 

will be lost in the resulting file. 

Opening group box 

Here you can make settings related to opening documents: 
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 Return to the last editing position when a document has been opened 

 When you open a document and this option is enabled, TextMaker automatical-

ly positions the text cursor at the place where it was located the last time you 

saved the document. 

 Note: This works only with documents in the following file formats: TextMaker 

(.tmd or .tmdx) and Microsoft Word (.doc or .docx). 

 Recently used files 

 TextMaker displays a list of the files most recently opened in it in the File 

menu. If you select an item on the list, the corresponding file will be opened 

immediately. Using the Recently used files option you can specify the number 

of files to be displayed in the list. 

Backup group box 

Note: This feature is not available in the Android version. On Android, only an 

option for simple (single) backups is available: the option Create backup files 

(described above). 

Here you can specify if the program should, whenever you save a document, auto-

matically create a backup copy containing its previous version. 

The dropdown list in this section offers the following options: 

 No backup 

 When you choose this option, no backup copy is created when you save a 

document. (Not recommended.) 

 Simple backup 

 Here, exactly one backup copy is created when you save a document. This copy 

contains the previous (i.e. last saved) version of the document. It is saved as a 

file with the name extension .BAK, stored in the same folder as the document. 

 Advanced backup 

 With this option, multiple generations of backup copies are kept for each 

document. All of these copies are stored in a special Backup folder. 

 Tip: When this option is selected, also the File > Revert to previous version 

menu command becomes available. It provides a comfortable means of return-

ing to a previous version of the current document. 



 

Manual TextMaker Customizing TextMaker  •  555 

 Additional options: 

 Folder for backup files: Here you can change the location of the Backup fol-

der in which all backup copies are stored. 

 Number of backup files per document: Here you can specify the maximum 

number of backup copies (= generations) to be kept for each document. 

 “Clean Up” button: Offers the following two commands for deleting backup 

copies: 

 Delete orphaned backup files: Removes each backup file for which the 

corresponding original file no longer exists. 

 Delete all backup files: Removes all backup files that reside in the folder 

for backup files. 

More detailed information on the usage of backup copies can be found in the sec-

tion “Backup copies”. 

Preferences, System tab 

The System tab in the dialog of the Tools > Options menu command contains the 

following system settings: 

Compress pictures in memory 

If this option is enabled, pictures inserted into documents will be stored (losslessly) 

compressed in memory. Advantage: Documents containing many pictures consume 

significantly less main memory. Disadvantage: The compression of course consu-

mes some CPU time. 

As a general rule, you should leave this option enabled. 

Note: Changes to this setting become effective only after TextMaker is restarted. 

Limit internal picture cache 

TextMaker uses an internal picture cache to speed up the display of images in a 

document. If this option is enabled, the size of this cache is restricted to a maxi-

mum of 20% of your main memory. 

As a general rule, you should leave this option enabled. 
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If you frequently work with documents containing many high-resolution pictures, 

you may consider deactivating this option. Pictures will then usually be displayed 

faster throughout the document; however, it can occur that TextMaker consumes a 

large amount of main memory. 

Smooth edges of pictures 

When this option is enabled, TextMaker uses anti-aliasing to smooth edges and 

lines in images. Advantage: The display quality of scaled images is improved. Di-

sadvantage: This of course consumes some CPU time. 

Check for updates 

Windows, Mac, and Linux only: Here you can specify if (and how often) the 

software should check if updates for SoftMaker Office are available. Updates pro-

vide bug fixes and feature improvements. 

Note: Checking for updates is possible only when your device has Internet access. 

In case you want to disable the automatic update check (not recommended), choose 

the Never option from the list. In that case you have to check for updates manually 

(by clicking on the Check Now button.) 

Tip: Subscribe to our free newsletter at www.softmaker.com to get an e-mail 

automatically whenever updates are available. The newsletter will also provide 

you with other useful information and special offers related to SoftMaker Office. 

Android: With the Android version, updates can be obtained as follows: 

 Android version, purchased in Google Play Store: When you have installed 

an application via Google Play Store, your device will inform you about soft-

ware updates automatically (unless you have deactivated automatic updates in 

the Play Store settings).  

 Android version, purchased in Amazon App Shop: The same goes for apps 

installed via Amazon’s app shop. 

 Android version, purchased at www.softmaker.com: With this version, use 

the Tools > Check for Updates menu command to check if updates are 

available. 
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Associate file types 

Windows only: This button opens a dialog where you can associate certain file 

types with TextMaker. This will make TextMaker the default application for the 

corresponding file types. 

For example, when you associate the file type “Microsoft Word documents” with 

TextMaker, from now on, files of this type will always be opened in TextMaker 

when you double-click on such a file in Windows Explorer. 

Show/hide keyboard automatically 

Android only: When checked, the on-screen keyboard will pop up automatically 

whenever you are given an opportunity to enter text (for example, when you tap 

into the document, or when you tap into an input field in a dialog).  

Change keyboard layout automatically 

Android only: When checked, the layout of the on-screen keyboard will automati-

cally adapt to the current situation. For example, in a dialog, when you tap into an 

input field that accepts only numbers, the keyboard will automatically be switched 

into numeric mode.  

Use OpenGL engine 

Linux only: When this option is enabled, the software utilizes the OpenGL gra-

phics library. This will increase the responsiveness of the display, so you usually 

want to keep this option turned on. 

Note: On systems with an outdated or faulty OpenGL installation, you may experi-

ence rendering issues within the application. This depends on your individual sys-

tem configuration and especially the graphics driver used. In this case, turn this 

option off and restart the application.  

Also, the application checks for OpenGL support at startup and will automatically 

deactivate this option if any problems are detected.  

Use SHM extensions 

Linux only: This option is only available if the Use OpenGL engine option has 

been turned off (not recommended).  
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When the SHM extensions are turned on, the application tries to use shared memo-

ry to speed up the responsiveness of the display. 

Use XIM 

Linux only: When this option is enabled, TextMaker supports the composition of 

accented characters (à, ô, é, etc.) using “XIM”. 

For example, with a German keyboard, you can insert the character “ô” by first 

pressing the (^) key and then pressing the (O) key. 

If you disable this option, composing characters like this is no longer possible. 

Note: On some systems, disabling this option improves the responsiveness of the 

display when you are typing text fast. 

Show hidden files and folders 

Mac, Linux only: When this option is enabled, file lists in file dialogs (e.g. the one 

of the File > Open menu command) will also display hidden files and folders. 

Mouse wheel 

Mac, Linux only: If your mouse has a mouse wheel, you can set the scrolling in-

crement for a turn of the wheel either by page (one complete page) or by a certain 

number of lines. 

External applications 

Mac, Linux only: This button opens a dialog where you can specify which exter-

nal applications to start on certain actions. For example, when a PDF file is crea-

ted, the application specified in the PDF Viewer field will be launched to display 

the result. 

Note: You don’t have to fill out these fields. For all fields that are left empty, your 

system’s default application for the corresponding action will be used. Make chan-

ges to this dialog only when you want applications different from the default appli-

cations to be used. To do so, enter the file name of the corresponding executable 

(including the entire file path, if necessary). 
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User-defined font paths 

Mac, Linux, and Android only: Here you can specify paths to supplementary 

fonts for TextMaker. To do this, enter the subdirectory in which the font files resi-

de. If you want to enter multiple directories, separate them with colons. 

TextMaker can then use these fonts in addition to the fonts available to it from the 

operating system.  

Note: Changes to this setting become effective only after the program is restarted. 

Preferences, Fonts tab 

The Fonts tab in the dialog of the Tools > Options menu command allows you to 

specify which fonts to display in font lists (e.g. in the dialog of the Format > Cha-

racter menu command). 

The tab presents a list of all fonts installed on your system. To activate or deacti-

vate a font in the list, click on the checkbox in front of its name. Fonts where you 

have removed the checkmark are no longer displayed in font lists. 

Background information: The fonts installed on your system by default contain 

several fonts that you will probably never need – for example, fonts that contain 

solely glyphs for foreign languages that you don’t use. If you like, you can hide 

such fonts as described above. 

Use font filtering of the operating system 

Windows only: Windows users will additionally find an option named Use font 

filtering of the operating system on this tab. When activated, Windows will au-

tomatically hide all fonts that contain solely glyphs for foreign languages in font 

lists. 

Document properties 

With the File > Properties menu command you can make settings that apply only 

to the current document and are saved with it. These settings are called document 

properties. 
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The settable document properties are grouped by topic and each group is presented 

on one of several tabs. For example, if you click on the Summary tab, you can 

enter summary information about the document. 

On the next pages, you will find detailed information on each of the individual 

document properties available. 

Document properties, Summary tab 

The Summary tab in the dialog of the File > Properties menu command allows 

you to enter summary information about the current document. 

The summary information can include descriptive entries about the document (sub-

ject, author, keywords, etc.) that the file manager can use in searches. 

For more information, see section “Document summary” beginning on page 503. 

Document properties, View tab 

The View tab in the dialog of the File > Properties menu command contains set-

tings that affect the way the current document appears on the screen. 

Display field names 

Controls whether fields (like date, page number, etc.) are displayed as they would 

appear when printed or symbolically, in the form of the field name surrounded by 

braces. Normally, you want to see the printed rendition, so leave this option disab-

led (see also chapter “Fields” beginning on page 171). 

By default, this option is disabled. 

Show bookmarks 

You can set “bookmarks” in a document using e.g. the menu command Insert > 

Bookmark (see section “Bookmarks” beginning on page 166). 

Normally these text markers are invisible. However, if you enable Show book-

marks they are displayed in the text (surrounded by angle brackets). 

This option is disabled by default. 
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Shade fields 

When you enable this option, all fields inserted into the document with e.g. the 

menu command Insert > Field (date, page number, etc.) are indicated with a gray 

background so that their positions in the document can be easily recognized. 

This option is disabled by default. 

Show merge record 

This option is available only when you have attached a database to the current 

document with the menu command Tools > Set database. 

When you enable this option, the field names that normally represent database 

fields inserted into a document are replaced on the screen with the contents of the 

field from a specified record of the database. You can enter the number of the re-

cord whose contents are to be displayed in the edit box to the right of Show merge 

record. If you enter “10”, for example, the content of the field from the tenth re-

cord will be displayed. 

This option is useful for checking the final appearance of a form letter before prin-

ting it (see also chapter “Form letters” beginning on page 383). 

By default, this option is disabled. 

Objects group box 

As described in the section “Hiding objects” (page 284), you can make inserted 

objects invisible on the screen and/or on the printed page. 

By means of these two options, you can make these objects visible and/or printable 

again, overriding their individual visibility settings: 

 Show invisible objects: If you enable this option, any object whose Visible 

property is disabled becomes visible on the screen. 

 Print unprintable objects: If you enable this option, any object whose Prin-

table property is disabled will nevertheless be printed along with normally 

printable objects. 

By default, both options are disabled. 
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Hidden text group box 

Not only objects, but text too can be hidden (see section “Hiding text” beginning 

on page 78). 

The Show hidden text and Print hidden text options control respectively the dis-

play and printing of text that has been formatted hidden. 

By default, Show hidden text is enabled and Print hidden text is disabled. Ac-

cordingly, hidden text is visible on the screen but does not appear on the printed 

page. 

If you enable Print hidden text, hidden text will appear on the printed page along 

with visible text. 

Print page background 

Use this option to specify if a page background set up with the Format > Page 

background menu command should also appear in printouts. This option is off by 

default, meaning that the page background will be displayed on the screen only. 

Please note that this option has no effect on a page background set up with the 

Format > Chapter menu command. This type of background will always be 

printed. 

See also section “Changing the page background”, page 126. 

Pictures and OLE objects group box 

With the default setting Show pictures all the graphics and OLE objects present in 

the text are displayed on the screen. 

If instead you select the Use placeholders option, gray boxes are displayed at the 

positions of these objects. Advantage: The responsiveness of the display is impro-

ved when paging through a document with a lot of pictures. 

Locking group box 

With these options you can “lock” all objects on the master page and all guides and 

thereby protect them from being shifted inadvertently: 
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 Lock objects on master page: If you activate this option, objects that have 

been inserted on the master page can be moved only in the master page view 

(see also section “Master pages” beginning on page 117). 

 Lock guides: If you activate this option, guides can no longer be dragged with 

the mouse. They can be edited only from the dialog of the menu command Ob-

ject > Grid and guides (see also section “Using guides” beginning on page 

596). 

By default, both options are disabled. 

Format view for... group box 

Note: This option is available only in TextMaker for Windows. 

Usually, this should be set to the standard option Use printer-independent for-

matting. The alternative option is provided just for compatibility reasons with ol-

der documents. 

Options available: 

 Use printer-independent formatting: The recommended setting. Formats the 

document using a very high internal resolution, which is independent from the 

currently selected printer driver. When you switch to a different printer driver, 

the document will not change by any means. 

 Printer output: Formats the document using the resolution of the current prin-

ter driver. This may, in some cases, lead to changes in line breaks and thus even 

page breaks when you switch to a different printer driver. 

Decimal separator 

Here you can specify the character to be used as a decimal separator. 

This setting only affects the behavior of decimal tab stops. If you change the sepa-

rator character from a period to a comma, for example, numbers at decimal tab 

stops will be aligned not on periods but on commas. 

“Compatibility” button 

This button provides access to settings that affect functions internal to the program, 

in order to improve compatibility with documents created in older versions of 
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TextMaker or in Microsoft Word. These options are set automatically when such a 

document is opened and normally should not be changed. 

Document properties, Colors tab 

The Colors tab in the dialog of the File > Properties menu command allows you 

to add and edit custom colors for the current document. 

When you open a color list – for example, the color list in the Formatting toolbar – 

you see only a small subset of the more than 16 million colors that are available. 

This subset is called the color palette of the document. 

You can modify this color palette at any time. You can add new colors and modify 

colors you have added. However, the first 24 colors in the palette are default colors 

than cannot be changed. 

Important: Changes in the color palette are saved in the document. Thus, you 

can compose a different color palette for every document. 

Adding a color 

To add a color to the palette of the current document, do the following: 

1. Invoke the menu command File > Properties and switch to the Colors tab. 

Tip: Alternatively, you can gain access to this dialog from any other dialog 

box that contains a color list. To do this, select the Define color... entry in the 

color list (the last entry). 

2. Set the desired color (see the section “Working with the color controls” below). 

3. Click on the New button. 

4. Give the new color whatever name you like and confirm with OK. 

5. Exit the dialog with OK. 

TextMaker now adds the new color to the document’s color palette. From now on, 

it will be available in all dialog boxes that permit color selection. 
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Changing a color 

Note: You can change only those colors that you have added. The first 24 colors 

in the palette are default colors that cannot be changed. 

To change a color, do the following: 

1. Invoke the menu command File > Properties and switch to the Colors tab. 

 Or: Select the Define color... entry in any color list. 

2. Select the color to be changed from the Color palette list. 

3. Make the desired changes (see the section “Working with the color controls” 

below). 

4. Click on Change. 

The color is now changed for the current document. 

Deleting or renaming a color 

You can delete or rename user-defined colors at any time. To do this, invoke the 

colors dialog, select a color from the Color palette list, and click the Delete or 

Rename button. 

Working with the color controls 

The controls in the colors dialog allow you to set colors in a number of different 

ways. All these ways lead to the same results – just choose the method that suits 

you the best: 

 Using the color field and luminance slider 

 Setting colors is easiest when you use the large color field and the luminance 

slider to its right. The color field presents all the available hues in all available 

saturations, while the luminance slider next to it provides a means of varying 

the luminance. 

 To set a color, first click on the desired color in the large color field. Then click 

on the desired luminance in the luminance slider. 
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 Using the hue, saturation and luminance controls 

 Alternatively you can set colors with the controls labeled Hue, Sat (saturation) 

and Lum (luminance). Values between 0 and 240 are allowed for each. 

 Using the Red, Green and Blue controls 

 Colors can also be specified by their red, green and blue components. The con-

trols labeled Red, Green and Blue are provided for this purpose. Here, values 

between 0 and 255 are allowed. 

 Entering the hex code of a color 

 Additionally, you can specify a color by entering its hex code (like in HTML 

code for web pages) into the edit control labeled with a # sign.  

 The hex code for colors consists of 3 two-digit hexadecimal values, standing 

for red, green, and blue (RRGGBB). For example, 00FF00 represents pure 

green. 

Document properties, Statistics tab 

The Statistics tab in the dialog of the File > Properties menu command displays 

statistical information about the current document (number of characters, number 

of sentences, average word length, etc.). 

Tip: If you select a segment of text before you open this tab, it will show statis-

tics for the selected text only; otherwise, it will show them for the entire 

document. 

The items of information shown are mostly self-explanatory. However, the diffe-

rence between the first two items needs some clarification: 

 The number of characters counts the visible characters only. 

 The number of keystrokes also counts white spaces (created with the space bar, 

tab key, etc.). 

Accordingly, the sentence “This is a test” has 11 characters and 14 keystrokes 

(since it contains three space characters). 
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Hint: Using the Statistics toolbar 

If you need statistical functions frequently, you may want to activate the Statistics 

toolbar, which displays this information permanently. 

 

To display or hide this toolbar, right-click on any toolbar to display a menu of all 

toolbars available. There, select the entry Statistics. 

Then, open the dropdown list in the Statistics toolbar and select which information 

to display (characters, words, sentences, etc.). 

Note: The statistics toolbar is not updated automatically while you type text. To 

update it, click the icon with the red arrows. 

Document properties, Protection tab 

The Protection tab in the dialog of the File > Properties menu command allows 

you to apply document protection to the current document. 

Opening and/or saving a protected document is possible only following the entry of 

a correct password. Documents with read protection are also encrypted, so that 

they cannot be examined with programs other than TextMaker. 

You will find information about this topic in chapter “Document protection” be-

ginning on page 513. 

Document properties, Forms tab 

The Forms tab in the dialog of the File > Properties menu command allows you 

to enable or disable Form mode and optionally require a password to disable this 

mode. 

When Form mode is enabled, only form objects (text fields, checkboxes, dropdown 

lists, etc.) can be filled out. Access to the rest of the document and to most of 

TextMaker’s functions is blocked.  

Note: When you save a document in Form mode, Form mode will still be active 

when you reopen the document. 
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You can enable or disable Form mode with the Form mode activated option. 

Tip: You can also use the View > Form mode menu command to do this. 

When you enable Form mode and, in addition, enter a Password to deactivate, 

anyone who subsequently attempts to disable this mode will be prompted for the 

password. The mode will be disabled only if the user supplies the correct password. 

Important: If you save a document with Form mode enabled and a password set 

and then forget the password, you will never again be able to disable this mode. 

So be sure to make a note of the password and keep it in a safe place! 

You will find detailed information about working with forms in chapter “Forms” 

beginning on page 307. 

Shade form objects 

Also available on this tab is an option called Shade form objects. If you check it, 

all form objects (text fields, checkboxes, lists, etc.) are displayed with a light gray 

background so that they can be more easily distinguished from normal text. 

Document properties, Reviewing tab 

The Reviewing tab in the dialog of the File > Properties menu command allows 

you to make settings that control the way comments and document revisions are 

handled. 

You will find information about these settings in the following sections: 

 Settings for comments (beginning on page 469) 

 Settings for the Track changes function (beginning on page 475) 

General information about comments and document revisions is available in chap-

ter “Document revisions” beginning on page 465. 

Document properties, Fonts tab 

The Fonts tab in the dialog of the File > Properties menu command displays a list 

of all fonts used in the current document. 
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The list is divided into fonts that are available on the current device – and fonts that 

are not available (i.e. not installed). 

Customizing the document display 

You can adjust the way the document appears on the screen and either hide or bring 

into view various components of the program window with the commands in the 

View menu.  

The commands and their associated functions are listed as follows: 

Menu command Function 

Standard Switches the document view to standard view. This is the 

view that you normally use when working with TextMaker, 

often referenced as normal view in the manual. 

Continuous Switches to the continuous view, which displays the 

document in a simplified way (in order to improve the legibi-

lity of the plain text in the document).  

 In this view, the document is presented not as a sequence of 

separate pages but as a single continuous text.  

 Additionally, the lines of text are automatically rewrapped to 

utilize the full width of the document window. (The latter 

can be deactivated anytime by turning off the option Wrap 

text to window in the dialog of the Tools > Options menu 

command, View tab.) 

 Please note: In the continuous view, some components of 

the document will not be displayed anymore. This includes 

all types of frames and drawings, as well as page hea-

ders/footers and footnotes. 

Master pages Switches to the master pages view. In this view you can edit 

only the document’s master page(s). 

 Objects residing on the master page will be replicated on 

every page of the document. See the section “Master pages” 

beginning on page 117. 

Outline Switches to the Outline view. In this view you can see the 

structure of the document, assign text to a header and assign 

existing headers to higher or lower levels. See the section 

“Outlines” beginning on page 418. 
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Actual size etc. You can set the zoom level with the menu commands View > 

Actual size through View > Zoom level. See the section 

“Changing the zoom level” beginning on page 571. 

Object mode Turns Object mode on or off. In Object mode, you can no 

longer edit text. However, this mode provides many func-

tions that lighten work with objects like pictures, frames, etc. 

See the section “Object mode” beginning on page 261. 

Form mode Turns Form mode on or off. In Form mode, only form ob-

jects (text fields, checkboxes, lists, etc.) can be filled out. 

Access to the rest of the document and to most of TextMa-

ker’s functions is blocked. See the chapter “Forms” begin-

ning on page 307. 

Toolbars Opens a dialog box where you can show or hide toolbars, 

reposition them, or edit them. See the section “Customizing 

toolbars” beginning on page 573. 

Full screen Enters the full screen view mode, where the program maxi-

mizes its program window and hides all toolbars in order to 

display as much of the document as possible. See the section 

“Full screen view” beginning on page 572. (Full screen view 

is not included in SoftMaker FreeOffice.) 

Horizontal ruler Turns the horizontal ruler on or off. See the section 

“Document” beginning on page 34. 

Sidebar Turns the sidebar on or off. The sidebar provides a means of 

navigating in the document and some other useful functions. 

See the section “Document” beginning on page 34. 

Additional settings for customizing the display of documents are available with the 

following menu commands: 

 Tools > Options allows you to modify general settings that apply to all 

documents (see section “Preferences, View tab” beginning on page 536). 

 File > Properties allows you to modify settings that apply to the current 

document only (see section “Document properties, View tab” beginning on pa-

ge 560). 
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Changing the zoom level 

TextMaker offers you several different ways to specify the zoom level at which a 

document is displayed on the screen.  

Use the following View menu commands to do this: 

Menu command Function 

Actual size Sets the zoom level to 100%. This is the default set-

ting. 

Fit margins to window Automatically selects the zoom level at which the 

width of a page fits exactly in the window. 

Full page Displays one entire page of the document. 

Two full pages Displays two entire pages next to each other. 

Magnifying glass Activates the magnifying glass with which you can 

draw a frame around whatever part of the document 

you want to enlarge. 

Zoom level Allows you to select the zoom level from a list. You 

can also enter a value manually (e.g. “125” for a 

zoom level of 125%). 

Tip: Using the zoom slider 

You can also use the zoom slider at the bottom right of the screen to modify the 

zoom level. 

 

To change the zoom level, either drag the slider with your mouse, or click on the 

minus icon or the plus icon. 

Tip: And when you click on the percent value displayed to the right of the slider, 

the dialog of the View > Zoom level command mentioned above will open. 
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Full screen view 

FreeOffice: The Full screen view is not included in SoftMaker FreeOffice. 

In full screen view mode, TextMaker maximizes its program window and hides all 

toolbars in order to display as much of the document content as possible.  

To enter this mode, use the View > Full screen menu command. 

To exit it, choose the View > Full screen menu command again or press the (Esc) 

key. 

Using the toolbar of the full screen view 

When you activate the full screen view mode, an additional toolbar appears on the 

screen. 

 

The “Fullscreen” toolbar 

The icons in this toolbar have the following functions (from left to right): 

 Show/hide menu bar 

 Show/hide side bar 

 Enter/exit “Drag sheet” mode 

 When “Drag sheet” mode is activated, you can scroll your document using the 

mouse. Simply click into the document and drag the mouse pointer into the de-

sired direction (with the mouse button still held down). 

 Note: Selecting text or objects is not possible in this mode. 

 To exit “Drag sheet” mode, click this button once again. 

 A click on the Close button leaves full screen mode. 
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Customizing toolbars 

“Classic menus and toolbars” only: This section is relevant only for users who 

have configured the program to use classic menus and toolbars. (Information 

on customizing the ribbon can be found in the section “Customizing the ribbon”, 

page 583.) 

Hint: You can switch the user interface between ribbon and classic menus and 

toolbars at any time. To do this, invoke the menu command Tools > Option (or, 

in the ribbon, the command File > Options). In the dialog, switch to the 

Appearance tab and click on the User Interface button. A dialog box appears in 

which you can select the type of user interface you prefer. 

In this section you will learn how to configure the program’s toolbars (Standard 

toolbar, Formatting toolbar, etc.) using the View > Toolbars menu command and 

how to customize the icons displayed on them using the Tools > Customize com-

mand. 

 

A toolbar (here: the Standard toolbar) 

Topics covered in this section: 

 Displaying and hiding toolbars 

 Positioning toolbars on the screen 

 Managing toolbars (creating, deleting, renaming, or resetting toolbars) 

 Customizing toolbar icons (adding, removing or repositioning icons) 

 Using the toolbar menu (for quick access to the features listed above) 

See the following pages for details. 

Displaying and hiding toolbars 

“Classic menus and toolbars” only: This section is relevant only for users who 

have configured the program to use classic menus and toolbars. (Information 

on customizing the ribbon can be found in the section “Customizing the ribbon”, 

page 583.) 

You can enable or disable individual toolbars at any time. 
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Proceed as follows: 

1. Invoke the View > Toolbars menu command. 

2. Click on the checkbox in front of a toolbar’s name to enable or disable it.  

3. Exit the dialog box with Close. 

The toolbars you have checked or unchecked are now enabled or disabled. 

Tip: There is a faster way to do this: When you click on any toolbar with the 

right mouse button, a list of all available toolbars is displayed. To enable or 

disable a toolbar, click on the corresponding list entry. 

Visible in mode ... 

Some toolbars are visible only in particular situations. The Picture toolbar, for 

example, appears only when you select a picture.  

The Visible in mode option controls this behavior. With it, you can specify when a 

toolbar will be visible, for example: 

Option Meaning 

All modes The selected toolbar is always visible (provided that it is not 

disabled). 

Edit mode The toolbar is visible only in normal Edit mode, and not in 

Object mode (see also section “Object mode” beginning on 

page 261). Example: the Formatting toolbar 

Object mode The toolbar is visible only in Object mode and not in normal 

Edit mode (see also section “Object mode” beginning on 

page 261). Example: the Object toolbar 

Outline The toolbar is visible only in Outline view (see also section 

“Using the Outline view” beginning on page 420). Example: 

the Outline toolbar 

Database mode The toolbar is visible only in the database module. Example: 

the Database toolbar 

Picture The toolbar appears only when a picture is selected. Examp-

le: the Picture toolbar 

Header/Footer The toolbar appears only when the text cursor is in a header 

or footer. 
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To change the setting for one of the toolbars, invoke the menu command View > 

Toolbars, select the toolbar in the list, and choose the desired option for Visible in 

mode. 

Note: Normally, it does not make sense to change this setting for any of the 

default toolbars (Standard toolbar, Formatting toolbar, etc.). These options are 

primarily meant for user-defined toolbars. 

Positioning toolbars on the screen 

“Classic menus and toolbars” only: This section is relevant only for users who 

have configured the program to use classic menus and toolbars. (Information 

on customizing the ribbon can be found in the section “Customizing the ribbon”, 

page 583.) 

You change the position of toolbars to your liking. To do this, use one of the follo-

wing procedures: 

Changing the position with the View > Toolbars command 

The position of a toolbar can be changed with the help of the View > Toolbars 

menu command. Proceed as follows: 

1. Invoke the View > Toolbars menu command. 

2. Select the toolbar you want to move in the Toolbars list. 

3. Select the desired position for the toolbar in the Position list. 

Note: If you choose the Floating option, the toolbar icons are displayed in a 

window that can be moved or sized just like an application window. 

Changing the position with the mouse 

Some toolbars can also be repositioned with the mouse. Proceed as follows:  

1. Position the mouse pointer over an empty area of the toolbar. 

2. Press and hold the left mouse button. 

3. While still holding the mouse button down, drag the toolbar to the desired posi-

tion. 
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4. Release the mouse button to place the toolbar at the new position. 

Note: By default, most toolbars are locked against moving with the mouse, in 

order to protect them from being moved accidentally. To remove the lock, invoke 

the menu command View > Toolbars, select the toolbar of interest, and disable 

the Locked option.  

Hint: A positioning aid is active while dragging a toolbar: When you drag the tool-

bar near one of the edges of the program window, it jumps automatically to that 

edge. If you leave the toolbar at the top edge of the window, for example, the result 

is the same as if you selected the Top position in the dialog box of the View > 

Toolbars menu command.  

Managing toolbars 

“Classic menus and toolbars” only: This section is relevant only for users who 

have configured the program to use classic menus and toolbars. (Information 

on customizing the ribbon can be found in the section “Customizing the ribbon”, 

page 583.) 

You can create new toolbars, delete, and rename existing toolbars, etc. To perform 

these tasks, use the buttons in the dialog box for the View > Toolbars menu com-

mand. 

Creating new toolbars 

You can create your own toolbars whenever you wish. 

For example, if you frequently need to use commands in the Windows menu that 

are not present in the Standard toolbar, it might be worthwhile for you to set up 

your own toolbar for them. 

You create a new toolbar as follows: 

1. Click the New button (in the dialog box of the View > Toolbars menu com-

mand). 

2. A dialog box appears and prompts you to enter a name for the new toolbar – 

“My toolbar” for example. Enter a name and confirm with OK. 

3. The new toolbar is set up. Close the dialog box or click on the Customize but-

ton to add icons to the toolbar. You can read more about this in the section entit-

led “Customizing toolbar icons” beginning on page 578. 
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Customizing the icons on a toolbar 

You can edit the icons on toolbars with the Customize button. Information about 

this is provided in the next section. 

Deleting toolbars 

The Delete button allows you to delete a user-created toolbar, as follows:  

1. Select the toolbar to be deleted in the list. 

2. Click on the Delete button. 

Note: You can delete only toolbars that you have created yourself. The default 

toolbars (Standard toolbar, Formatting toolbar, etc.) cannot be removed.  

However, you can always disable toolbars that you do not need at the moment (see 

section “Displaying and hiding toolbars”, page 573). 

Renaming toolbars 

The Rename button can be used to rename a user-created toolbar, as follows:  

1. Select the toolbar of interest in the list. 

2. Click on the Rename button. 

3. Type in a new name and confirm with OK. 

Note: You can rename only toolbars that you have created yourself. The default 

toolbars (Standard toolbar, Formatting toolbar, etc.) cannot be renamed. 

Resetting toolbars 

You can undo any changes you have made to one of the default toolbars by selec-

ting the toolbar in the View > Toolbars dialog box and clicking Reset. 

When you do that, the toolbar is reset to its default icons. In addition, the default 

settings for Visible in mode and Position are restored. 

Note: This command is applicable only to the default toolbars (Standard toolbar, 

Formatting toolbar, etc.), and not to user-created toolbars. 
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Resetting all toolbars 

To reset all toolbars at once, click on the Reset All button. 

Note: This command only resets the default toolbars. User-created toolbars will not 

be touched. 

Customizing toolbar icons 

“Classic menus and toolbars” only: This section is relevant only for users who 

have configured the program to use classic menus and toolbars. (Information 

on customizing the ribbon can be found in the section “Customizing the ribbon”, 

page 583.) 

The Tools > Customize menu command allows you to customize the icons contai-

ned in a toolbar. Among other things, you can add, remove and reposition icons. 

Proceed as follows: 

1. Invoke the Tools > Customize menu command. 

2. Use one of the procedures described below to add, remove, or reposition icons. 

3. Exit the dialog with Close. 

Tip: This command can also be invoked by double-clicking on an empty area in 

any of the toolbars. 

When you invoke this command, a dialog box appears. 

This dialog contains two list boxes: 

 Left list: all available commands 

 The left list shows all commands available in the program.  

 Tip: You can use the Categories dropdown list (displayed above the list) to 

filter the list for a specific category (for example, show only commands of the 

“File” category).  

 You can also search the list by typing something in the Quicksearch field. 

 Right list: icons contained in the currently selected toolbar 

 The right list displays the icons contained in the currently selected toolbar. 
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 You can choose which toolbar to display here using the Customize dropdown 

list (displayed above the right list).  

The following actions can be performed in this dialog box: 

Adding an icon 

To add an icon to a toolbar, follow these steps (in the Tools > Customize dialog 

box): 

1. Select the toolbar to which you want to add an icon in the Customize 

dropdown list (displayed above the right list). 

 The right list now displays all icons that are currently contained in the selected 

toolbar. 

2. Optional: In the right list, select the icon after which the new icon is to be inser-

ted. 

3. Select the icon to be added from the left list. 

4. Click on the >> button (displayed between the lists). 

The icon is now added to the toolbar. 

Tip: Alternatively, you can add an icon to a toolbar as follows: Invoke the Tools 

> Customize command. With your mouse, simply drag the icon out of the dialog 

window and drop it at the desired position in the toolbar. (Do this in the toolbar 

itself, not in the dialog!) Of course this procedure only works when the toolbar is 

currently visible on the screen. 

Removing an icon 

To remove an icon from a toolbar, follow these steps (in the dialog box): 

1. Select the toolbar of interest in the Customize dropdown list (displayed above 

the right list). 

2. Select the icon to be removed from the right list. 

3. Click on the << button (displayed between the lists). 

The icon is now removed from the toolbar. 
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Tip: Alternatively, you can remove an icon from a toolbar as follows: Invoke the 

Tools > Customize command. Then simply drag the icon out of the toolbar with 

your mouse and drop it somewhere outside the toolbar, for example in the 

document. (Do this in the toolbar itself, not in the dialog!) 

Moving an icon 

To move a toolbar icon to a different position, follow these steps (in the dialog 

box): 

1. Select the toolbar of interest in the Customize dropdown list. 

2. Select the icon to be moved from the right list. 

3. Use the up or down arrow buttons (displayed left of the list) to change the 

icon’s position within the toolbar. 

 Note: If you want to move an icon to a different toolbar, you must first remove 

it from its current toolbar and then add it to the other toolbar. 

Tip #1: Alternatively, you can move an icon as follows: Invoke the Tools > 

Customize command. Then drag the icon to the desired position with your 

mouse (in the toolbar itself, not in the dialog!). With this method, you can even 

move an icon from one toolbar to another. 

Tip #2: By the way, moving icons works even if this dialog box is not open: 

When you hold down the (Alt) key, you can move a toolbar icon by clicking on 

it and then (with the mouse button still pressed) dragging it to the desired positi-

on. 

Inserting a separator line 

To add a separator line to the left of a toolbar icon, follow these steps: 

1. Select the toolbar of interest in the Customize dropdown list. 

2. In the right list, select the icon in front of which the separator line is to be inser-

ted. 

3. Click the New Separator button (displayed below the right list). 

The separator line is now inserted. 
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Tip: Alternatively, you can also use the following procedure: Invoke the Tools > 

Customize command. Then, in order to insert a separator to the left of a toolbar 

icon, simply drag this icon a small distance to the right using your mouse. (Do 

this in the toolbar itself, not in the dialog!) 

Removing a separator line 

To remove a separator line from a toolbar, follow these steps (in the dialog box): 

1. Select the toolbar of interest in the Customize dropdown list. 

2. Select the separator line to be removed from the right list. 

3. Click on the << button (displayed between the lists). 

The separator line is now removed from the toolbar. 

Tip: Alternatively, you can remove an icon from a toolbar as follows: Invoke the 

Tools > Customize command. If you now drag the icon that is to the immediate 

right of the separator a little bit to the left, the separator will be removed. (Do 

this in the toolbar itself, not in the dialog!) 

Assigning keyboard shortcuts 

When you click on the Shortcut keys button in the dialog, the dialog box expands 

to include an additional section called Shortcut. This section can be used to edit 

the keyboard shortcuts for commands.  

In short: You can assign a keyboard shortcut of your choice to any command here: 

Select the command in either of the two lists, click into the Please press accelera-

tor field and then press the key combination with which you want to call this 

command in the future. 

For details, refer to the section “Customizing keyboard shortcuts” (page 592). 

Managing toolbars 

The dialog box for the Tools > Customize command also provides buttons for ma-

naging toolbars, as follows: 

 New 

 Creates a new, empty toolbar. 
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 Rename 

 Renames the toolbar selected in the Customize list (only available for user-

created toolbars). 

 Reset 

 Resets the toolbar selected in the Customize list back to its factory defaults.  

 Delete 

 Deletes the toolbar selected in the Customize list (only available for user-

created toolbars). 

 Reset all (displayed below the right list) 

 Resets all toolbars back to their factory defaults.  

Further options for managing and configuring toolbars are available in the dialog 

box of the View > Toolbars menu command (see section “Managing toolbars”, 

page 576). 

Using the toolbar menu 

“Classic menus and toolbars” only: This section is relevant only for users who 

have configured the program to use classic menus and toolbars. (Information 

on customizing the ribbon can be found in the section “Customizing the ribbon”, 

page 583.) 

Some toolbars end with a double arrow », as shown in the following picture: 

 

When you click on this double arrow, the toolbar menu will open. 

This menu gives you quick access to all the toolbar related commands mentioned 

in the previous sections. In detail, the toolbar menu includes the following com-

mands: 

 Add/remove buttons 

 This command opens a list of all icons available for the toolbar. When you click 

on one of its entries, the corresponding icon will instantaneously be activated or 

deactivated in the toolbar.  
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 (Note: This command is meant for quickly turning icons on or off. If you want 

to perform further customizations to the icons displayed in a toolbar, follow the 

instructions given in the section “Customizing toolbar icons”, page 578.) 

 Position 

 Use this command to change the position of a toolbar. Available options: top, 

bottom, left, right, or floating (in a little window that can be moved and resized 

with the mouse). 

 Toolbars 

 Invokes the View > Toolbars menu command that allows you to activate or 

deactivate, configure, and manage toolbars. 

 See section “Customizing toolbars” (page 573). 

 Customize 

 Invokes the Tools > Customize menu command that allows you to edit the 

icons on a toolbar (add, remove, move icons). 

 See section “Customizing toolbar icons” (page 578). 

 Reset this toolbar 

 Resets the toolbar. All customizations made to the toolbar’s icons and settings 

will be reverted. 

Customizing the ribbon 

“Ribbons” only: This section is relevant only for users who have configured the 

program to use the ribbon interface. (Information on customizing the classic 

menus and toolbars can be found in the section “Customizing toolbars”, page 

573). 

Hint: You can switch the user interface between ribbon and classic menus and 

toolbars at any time. To do this, invoke the menu command Tools > Option (or, 

in the ribbon, the command File > Options). In the dialog, switch to the 

Appearance tab and click on the User Interface button. A dialog box appears in 

which you can select the type of user interface you prefer. 

In this section you will learn how to configure and customize the ribbon (e.g. by 

adding additional icons). 
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The ribbon and the Quick Access Toolbar (at the bottom) 

Topics covered in this section: 

 Showing and hiding the ribbon 

 Changing the position of the Quick Access Toolbar 

 Customizing icons on the ribbon 

 Customizing icons on the Quick Access Toolbar 

See the following pages for details. 

Showing and hiding the ribbon 

“Ribbons” only: This section is relevant only for users who have configured the 

program to use the ribbon interface. (Information on customizing the classic 

menus and toolbars can be found in the section “Customizing toolbars”, page 

573). 

The ribbon is usually fully visible, as in the following picture: 

  

The ribbon and the Quick Access Toolbar (at the bottom) 

However, you can hide the ribbon at any time by minimizing it. This is useful if 

you want to save as much space on the screen as possible for displaying the 

document. 

Proceed as follows: 
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1. In the ribbon, click the Customize icon on the File tab. 

2. A menu opens. There you will find an option called Minimized ribbon, which 

can be turned on or off by clicking on it. (A tick appears in front of the option if 

it is currently on.) 

When you enable this option, the ribbon is minimized – only its tabs will still be 

visible. 

Tip: Alternatively, you can minimize the ribbon by clicking on the  icon in the 

upper right corner of the program window. Click on the icon again to bring the 

ribbon back in its full size. 

In addition, the key combination (Ctrl)(F1) (Mac: (Cmd)(F1)) is available for mi-

nimizing/restoring the ribbon. 

Working with the ribbon minimized 

When the ribbon is minimized, you can operate it as follows: 

 When you click on one of the tabs of the minimized ribbon, the ribbon will 

temporarily become fully visible again and display the corresponding tab. As 

soon as you trigger a command (e. g. click on the icon for a command) the rib-

bon will be minimized again. 

 When you double-click on one of the tabs, the ribbon will be permanently vi-

sible again.  

 As mentioned above, you can also use the  icon in the upper right corner of 

the program window to enable/disable minimizing the ribbon. 

Changing the position of the Quick Access Toolbar 

FreeOffice: Customizing the Quick Access Toolbar is not included in SoftMaker 

FreeOffice. 

“Ribbons” only: This section is relevant only for users who have configured the 

program to use the ribbon interface. (Information on customizing the classic 

menus and toolbars can be found in the section “Customizing toolbars”, page 

573). 
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The Quick Access Toolbar is displayed below the ribbon. It provides a selection of 

the most frequently used commands. 

  

The ribbon and the Quick Access Toolbar (at the bottom) 

The Quick Access Toolbar can either share the space with the documents tabs – or 

reside in its own toolbar. To change this, proceed as follows: 

1. In the ribbon, click the Customize icon in the File tab. 

2. A menu opens which contains either of the following two commands: 

 Show Quick Access Toolbar as separate toolbar: By default, the Quick Ac-

cess Toolbar is displayed in the bar that also contains the document tabs. When 

you invoke this command, the Quick Access Toolbar moves to its own toolbar 

instead. 

 Show Quick Access Toolbar beside the document tabs: This command does 

exactly the opposite: If the Quick Access Toolbar is currently displayed as a se-

parate toolbar, invoking this command causes the Quick Access Toolbar to mo-

ve back to the bar containing the document tabs. 

Customizing icons on the ribbon 

FreeOffice: The Customize Ribbon feature is not included for ribbons in Soft-

Maker FreeOffice. 

“Ribbons” only: This section is relevant only for users who have configured the 

program to use the ribbon interface. (Information on customizing the classic 

menus and toolbars can be found in the section “Customizing toolbars”, page 

573). 

The ribbon command File > Customize > Customize Ribbon allows you to 

customize the ribbon to a certain extent. Primarily this command is intended to add 

additional icons, sections or even complete tabs to the ribbon.  
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Important: The icons in the predefined sections on the ribbon can not be modifi-

ed. In the existing sections, you can neither add icons nor remove icons nor 

change their order. Only adding icons in a new section at the end of a ribbon tab 

(or alternatively in a completely new tab) is allowed. 

To customize the ribbon, proceed as follows: 

1. Invoke the ribbon command File > Customize > Customize ribbon. 

2. Use one of the procedures described below to edit the icons on a ribbon tab. 

3. Exit the dialog with Close. 

Tip: This command can also be invoked by double-clicking on any empty area 

inside the ribbon.  

When you invoke this command, a dialog box appears. 

This dialog contains two list boxes: 

 Left list: all available commands 

 The left list shows all commands available in the program.  

 Tip: You can use the Categories dropdown list (displayed above the list) to 

filter the list for a specific category (for example, show only commands of the 

“File” category).  

 You can also search the list by typing something in the Quicksearch field. 

 Right list: icons contained in the currently ribbon tab 

 The right list displays the icons contained in the currently selected tab of the 

ribbon. 

 You can choose which tab to display here using the Customize dropdown list 

(displayed above the right list).  

The following actions can be performed in the dialog box: 

Adding an icon 

Note: You can add icons only in sections that you created yourself (or on a com-

pletely new tab). It is not possible to insert an icon within the predefined sec-

tions.  
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To add an icon to a ribbon tab, follow these steps (in the dialog box of the ribbon 

command File > Customize > Customize ribbon): 

1. Select the ribbon tab to which you want to add an icon in the Customize 

dropdown list (displayed above the right list). 

 The right list now displays all icons that are currently contained in the selected 

tab. 

2. Select the icon to be added from the left list. 

3. Click on the >> button (displayed between the lists). 

The icon is now added to the selected ribbon tab. If necessary, the program auto-

matically creates a new section at the end of the tab. 

Removing an icon 

Note: You can only remove icons that you added to the ribbon yourself. It is not 

possible to delete any of the predefined icons.  

To remove an icon from a ribbon tab, follow these steps (in the dialog box): 

1. Select the ribbon tab of interest in the Customize dropdown list. 

2. Select the icon to be removed from the right list. 

3. Click on the << button (displayed between the lists). 

The icon is now removed from the ribbon tab. 

Moving an icon 

Note: You can only move icons that you added to the ribbon yourself. It is not 

possible to change the position of any of the predefined icons.  

To move an icon within a ribbon tab, follow these steps (in the dialog box): 

1. Select the ribbon tab of interest in the Customize dropdown list. 

2. Select the icon to be moved from the right list. 

3. Use the up or down arrow buttons (displayed left of the list) to change the 

icon’s position within the ribbon tab. 
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 Note: If you want to move an icon to a different ribbon tab, you must first re-

move it from its current tab and then add it to the other tab. 

Adding a new section 

Note: New sections can be added only after the predefined sections. It is not pos-

sible to insert a section between the predefined sections. 

To add a new section to a ribbon tab, follow these steps (in the dialog box): 

1. Select the ribbon tab of interest in the Customize dropdown list. 

2. Click on the New section button (displayed below the right list). 

The new section is now added (appended) to the ribbon tab.  

Renaming a section 

Note: You can only rename sections that you added yourself. It is not possible to 

rename any of the predefined sections.  

To rename a user-created section on a ribbon tab, follow these steps (in the dialog 

box): 

1. Select the ribbon tab of interest in the Customize dropdown list. 

2. Select the section to be renamed in the right list. 

3. Click on the Rename button (displayed below the right list). 

4. Type in a new name and confirm. 

The section is now renamed accordingly.  

Removing a section 

Note: You can only remove sections that you added yourself. It is not possible to 

delete any of the predefined sections.  

To delete a user-created section on a ribbon tab, follow these steps (in the dialog 

box): 

1. Select the ribbon tab of interest in the Customize dropdown list. 
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2. Select the section to be removed in the right list. 

3. Click on the << button (displayed between the lists). 

The section is now removed from the ribbon tab. 

Assigning keyboard shortcuts 

When you click on the Shortcut keys button in the dialog, the dialog box expands 

to include an additional section called Shortcut. This section can be used to edit 

the keyboard shortcuts for commands.  

In short: You can assign a keyboard shortcut of your choice to any command here: 

Select the command in either of the two lists, click into the Please press accelera-

tor field and then press the key combination with which you want to call this 

command in the future. 

For details, refer to the section “Customizing keyboard shortcuts” (page 592). 

Managing ribbon tabs 

The dialog box for this command also provides buttons for managing ribbon tabs, 

as follows: 

 New 

 Creates a new, empty ribbon tab. 

 Rename 

 Renames the tab selected in the Customize list (only available for user-created 

tabs). 

 Reset 

 Resets the tab selected in the Customize list back to its factory defaults.  

 Delete 

 Deletes the tab selected in the Customize list (only available for user-created 

tab). 

 Reset all (displayed below the right list) 

 Resets all tabs back to their factory defaults.  
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Customizing icons on the Quick Access Toolbar 

FreeOffice: Customizing the Quick Access Toolbar is not included in SoftMaker 

FreeOffice. 

“Ribbons” only: This section is relevant only for users who have configured the 

program to use the ribbon interface. (Information on customizing the classic 

menus and toolbars can be found in the section “Customizing toolbars”, page 

573). 

The Quick Access Toolbar is displayed below the ribbon. It provides a selection of 

the most frequently used commands. 

  

The ribbon and the Quick Access Toolbar (at the bottom) 

If you wish, you can customize the icons on the Quick Access Toolbar at any time, 

for example, you can add, remove, and reposition icons.  

To do this, invoke the ribbon command File > Customize > Customize Quick 

Access Toolbar. A dialog box for customizing toolbars will appear in which you 

can make the desired changes.  

The Quick Access Toolbar behaves exactly like a classic toolbar. To customize its 

icons, you can proceed exactly as described in the section “Customizing toolbar 

icons” (page 578). All explanations given there also apply to the Quick Access 

Toolbar – except for the section “Managing toolbars”.  

Creating user-defined toolbar/ribbon icons 

FreeOffice: The Customize Ribbon feature is not included for ribbons in Soft-

Maker FreeOffice. 

You can create user-defined icons and add them to a toolbar or to the ribbon. Such 

icons can be used to start other programs of your choosing. 
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To set up a user-defined icon, for example, an icon for starting Windows’ Notepad 

application, proceed as follows: 

1. Invoke the following command in the menu or ribbon: 

 Menu: Tools > Customize 

 Ribbon: File > Customize > Customize Ribbon 

2. In the Categories dropdown list, choose the User category. 

3. Select one of the icons from the Commands list.  

 The first three icons are already assigned to the Windows Calculator, the 

Windows Character Map, and the Windows Control Panel to serve as examples. 

Select e.g. the fourth icon for this exercise. 

4. Click on the Edit button displayed below the list. Another dialog box appears. 

5. Enter a short description of the program to be started in the Description field. 

In this example, you could enter “Notepad”. 

6. Enter the complete path and filename for the program to be started in the 

Command line field, for example, C:\WINDOWS\NOTEPAD.EXE.  

7. Optional: If the program’s own icon is not the one you want to use, you can 

enter the path and name of a different icon file in the Icon file field.  

 Note, however, that toolbars icons are a bit smaller than standard Windows 

icons. 

As soon as you confirm with OK, the icon is created. 

If you want to add your custom icon to a toolbar or ribbon tab right now, proceed 

as described in one of the following sections: 

 Toolbars: section “Customizing toolbar icons” (page 578) 

 Ribbon: section “Customizing icons on the ribbon” (page 586) 

Customizing keyboard shortcuts 

FreeOffice: Customizing shortcut keys is not included in SoftMaker FreeOffice. 
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The most commonly used commands in a program have keyboard shortcuts. For 

example, the command for saving the current document can be invoked very 

quickly by pressing the key combination (Ctrl)(S).  

The predefined keyboard shortcuts can be customized in the dialog box of the 

menu command Tools > Customize. There, you can assign keyboard shortcuts to 

commands and also change or remove existing shortcuts.  

Proceed as follows: 

Adding keyboard shortcuts 

To assign a keyboard shortcut to a command, perform the following steps: 

1. Invoke the following command in the menu or ribbon: 

 Menu: Tools > Customize 

 Ribbon: File > Customize > Customize Ribbon 

2. Click on the Shortcut keys button.  

 The dialog box now expands to include an additional section called Shortcut. 

This section can be used to edit the keyboard shortcuts for commands.  

3. Select the command to which you want to assign a keyboard shortcut from eit-

her the left list or the right list.  

 The left list shows all commands available in the program. (Hint: The Catego-

ries dropdown list allows you to filter the list by category, and the Quicksearch 

field can be used to search the list). 

 The right list shows only those icons that are contained in the currently selected 

toolbar or ribbon tab. 

4. Once you have selected the desired command, click into the Please press ac-

celerator field and press the key combination with which you want to call this 

command in the future. 

 Hint: If you make a typing mistake, you can always press the backspace key 
(æ__) to remove the keyboard shortcut you entered. 

5. Do not forget: Click on Add to assign this shortcut to the command now.  

6. Exit the dialog with Close. 

From now on, you can execute the selected command with the specified key com-

bination. 
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Editing keyboard shortcuts (remove, change, etc.) 

You can edit existing keyboard shortcuts for commands (for example, delete or 

change them) at any time. Proceed as follows: 

1. Invoke the following command in the menu or ribbon: 

 Menu: Tools > Customize 

 Ribbon: File > Customize > Customize Ribbon 

2. Click on the Shortcut keys button.  

 The dialog box now expands to include an additional section called Shortcut. 

This section can be used to edit the keyboard shortcuts for commands.  

3. Select the command whose keyboard shortcut you want to edit from either the 

left or the right list.  

4. Perform one of the following actions: 

 Removing shortcuts: The Current shortcut keys listbox displays all keyboard 

shortcuts currently assigned to the selected command. To remove a shortcut, se-

lect it from the list and click on Remove. 

 Changing shortcuts: To change the keyboard shortcut for a command, first remo-

ve it (as just described) and then assign it a new shortcut (as described at the 

beginning of this section). 

 Resetting shortcuts: To reset all keyboard shortcuts for the entire program to 

their default values, click the Reset all accelerators button and confirm. Any 

changes made to the default keyboard shortcuts are then discarded.  

 Display a list of all shortcuts: When you click on the Export button, a table listing 

all currently assigned keyboard shortcuts is displayed. The buttons placed next 

to the table allow you to copy it to the clipboard, for example. 

Available keyboard shortcuts 

Notice that some of the keystroke combinations that are possible on your keyboard 

are not allowed as keyboard shortcuts. 

As a rule, you should use alphabetic keys, numeric keys or function keys for 

shortcuts. You can combine them with (Ctrl), (Alt) and/or the (Shiftª) key. 
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You can easily check to see if the key combination you want to use is allowed. 

Click in the Please press accelerator field, and then try to enter your key combi-

nation. If it does not appear in the field, it is not allowed. 

Some examples of valid keyboard shortcuts include: 

 (Ctrl)(A) 

 (Alt)(A) (However, key combinations including the Alt key are not recom-

mended, since they are usually occupied by the main menu entries). 

 (Ctrl)(Alt)(A) 

 (Ctrl)(Shiftª)(A) 

 (Ctrl)(Alt)(Shiftª)(A) 

 (Ctrl)(F2) 

 etc. 

Note: Alphabetic keys by themselves are of course not allowed. Thus, you cannot 

use (A) or (Shiftª)(A) as a shortcut. 

Shortcut already assigned: If you press a shortcut that is already assigned, the current 

assignment will be shown just below the entry field. You should press the Back-

space key (æ__) to delete your shortcut and try a different shortcut. Otherwise, you 

will overwrite the existing assignment for the shortcut. 

Two part shortcuts: You can also use two part shortcuts (in accordance with the Wor-

dStar standard), for example, (Ctrl)(K)(X). Please note that only shortcuts of the 

form “Ctrl + letter + letter” are allowed here. 

Using the grid 

The grid is a positioning aid for objects frames and drawings. When it is enabled, 

you can no longer move such objects arbitrarily with your mouse – instead they 

snap from one grid point to the next. The same happens when you try to change the 

size of an object with your mouse.  

Activating the “Snap to grid” function 

To enable or disable the “Snap to grid” function, do the following: 

1. Invoke the menu command Object > Grid and guides. 
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2. Switch to the Grid tab. 

3. Enable (or disable) the Snap to grid option. 

Whenever the grid is enabled and, for example, you try to change the position of a 

picture frame with your mouse, the object cannot be positioned arbitrarily. Instead, 

it jumps from one point on the grid to the next. 

When you disable the grid again, frames and drawings can be moved with comple-

te freedom using the mouse. 

Disabling the grid temporarily: When the Snap to grid option is enabled, you can 

temporarily disable it anytime by holding down the (Alt) key while you drag an 

object with your mouse. 

Changing the grid distance 

You can set the distance between the grid points to any value you like.  

Proceed as follows: 

1. Invoke the menu command Object > Grid and guides.  

2. Switch to the Grid tab. 

3. Enter the desired values in the Grid distance group box. 

Showing the grid on the screen 

By default, the grid is not shown on the screen. If you want it to be displayed, acti-

vate the Show grid option in the dialog described above.  

Note: The grid is displayed on the screen only; it does not appear on the printed 

page. 

Using guides 

Besides the grid, described in the previous section, TextMaker gives you an additi-

onal aid for positioning frames and drawings called guides.  

You can set up horizontal and vertical guides. When you move a frame or drawing 

with your mouse, and you are getting close to one of these guides, the object auto-
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matically snaps to that guide – as if guides were magnetic. The same happens when 

you change the size of an object with your mouse.  

Enabling the “Snap to guides” function 

To enable or disable the “Snap to guides” function, do the following: 

1. Invoke the menu command Object > Grid and guides. 

2. Switch to the Guides tab. 

3. Enable (or disable) the Snap to guides option. 

Note: Even if this option is disabled, the guides can still be displayed and changed, 

but they will not have any effect on the repositioning of objects. 

Disabling the guides temporarily: When the Snap to guides option is enabled, you can 

temporarily disable it anytime by holding down the (Alt) key while you drag an 

object with your mouse. 

Showing the guides on the screen 

In the same dialog, the option Show guides allows you to specify whether or not 

guides should be displayed on the screen.  

By default, this option is enabled.  

Note: If the option Show guides is disabled, but the option Show guides is still 

enabled, guides are no longer displayed – but nevertheless retain their function.  

Guides are displayed on the screen only; they do not appear on the printed page. 

Adding guides under menu control 

To set up new guides, do the following: 

1. Invoke the menu command Object > Grid and guides. 

2. Switch to the Guides tab. 

3. Under Horizontal or Vertical, enter the position at which the guide should be 

placed. 

4. Click the Add button. 
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Adding guides with the mouse 

Alternatively, you can set up new guides with the mouse: 

1. Click on the  icon in the Formatting toolbar or invoke the menu command 

View > Object mode to activate Object mode. 

2. Now you can drag vertical guides out of the vertical ruler and horizontal guides 

out of the horizontal ruler. 

 To do this, click with the mouse on one of the rulers and drag the mouse pointer 

(left mouse button held down) into the text area. Release the mouse button 

when you reach the position at which you would like the guide to be set. 

3. Finally, click once more on the  icon or invoke the menu command View > 

Object mode again in order to exit Object mode. 

Note: If the ruler you want to use is not displayed, invoke the menu command 

Tools > Options, switch to the View tab and there enable Horizontal ruler or Ver-

tical ruler as needed. 

Moving and deleting guides 

To delete or reposition a guide, proceed as follows: 

Keyboard: Invoke the menu command Object > Grid and guides. To remove a 

guide, select it from the list and click the Delete button. To reposition a guide, de-

lete it and then set a new guide at the desired position. 

Mouse: In Object mode, guides can simply be grabbed with the mouse and drag-

ged to new positions. Also, if you move a guide into the horizontal or vertical ruler, 

the guide will be deleted. The same happens when you hit the (Del) key while 

dragging a guide. 

Locking guides 

You can “lock” guides so that they cannot be moved accidentally with the mouse. 

To do this, enable the Lock guides option in the dialog of the Objects > Grid and 

guides menu command (Guides tab). 

(Alternatively, you can also invoke the File > Properties menu command, switch 

to the View tab and enable the Lock guides option. This option does exactly the 

same.) 
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From this point on, guides cannot be shifted with the mouse. Their positions can be 

changed only in the dialog box of the Object > Grid and guides menu command. 

Using the “Snap to page margins” function 

When the Snap to page margins option is enabled in the dialog of the Object > 

Grid and guides menu command, the four page margins of the document also be-

have like guides.  

Hint: To enable or disable the display of the page borders, invoke the Tools > Op-

tions menu command, switch to the View tab and turn Page borders on or off. 

Using the “Snap to other objects” function 

FreeOffice: The Snap to other objects feature is not included in SoftMaker 

FreeOffice. 

When the Snap to other objects option is enabled in the Object > Grid and gui-

des dialog, the software automatically creates “magic” guides for the edges of each 

object on the current page. These guides make it a lot easier to place objects per-

fectly aligned or distributed. 

“Magic” guides are usually invisible. They become visible only when you move an 

object to a position close to any of these guides with your mouse. As soon as the 

guide appears, the object automatically snaps to it. The same happens when you 

change the size of an object with your mouse. 

Some examples for “magic” guides: 

 When you drag an object to a position where it is roughly left-aligned with 

another object, a guide will appear representing the left edge of the other object. 

If you let your object snap to it, it will be exactly left-aligned with the existing 

object. 

 The same applies for the right edge of objects. 

 When you drag an object to a place where it is roughly centered with another 

object, a guide will appear representing the center of the object. If you let your 

object snap to it, it will be aligned exactly centered with the other object. 

 When you drag an object to a position below two other objects, you will also 

see a horizontal guide at the position where this third object would have exactly 

the same relative distance as the two other objects. (The three objects would 

then be distributed evenly.) 
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All of the above works in both directions (horizontally and vertically) – for examp-

le, there are also magic guides for the top edge and the bottom edge of each object. 

Changing the tolerance for guides 

By default, a frame or drawing snaps automatically to a guide when it is moved 

with the mouse to within 8 pixels of the guide. However, the tolerance level is 

customizable. If you raise the tolerance to 20, for example, the object will snap to 

the guide when it is at a distance of 20 or fewer pixels from the guide. 

To change the tolerance, invoke the menu command Object > Grid and guides, 

switch to the Guides tab and enter the desired value in pixels in the Tolerance 

field. 

Installing additional dictionaries 

FreeOffice: SoftMaker FreeOffice does not include any of the premium Soft-

Maker dictionaries normally shipped with SoftMaker Office. However, as an 

alternative, the spell checker supports the use of free Hunspell dictionaries. 

You can install additional dictionaries for the spell-checker whenever needed. Just 

follow the instructions given in the following sections: 

 Installing additional SoftMaker dictionaries 

 This section explains how to add additional SoftMaker dictionaries to your in-

stallation. 

 Note: This is only relevant for the Android version. When you install SoftMa-

ker Office for Windows, Mac, or Linux, all available SoftMaker dictionaries 

are included already. 

 Installing Hunspell dictionaries 

 Windows, Mac, and Linux: Apart from SoftMaker dictionaries, SoftMaker 

Office additionally supports the use of Hunspell dictionaries. Read this section 

to learn more. 

 Choosing a different dictionary for a language 

 Windows, Mac, and Linux: In case you have installed more than one dictiona-

ry for a certain language (e.g. a SoftMaker dictionary and a Hunspell dictiona-
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ry), you can switch between these dictionaries anytime. Read this section for 

details. 

More information on these topics can be found on the next pages. 

Installing additional SoftMaker dictionaries 

FreeOffice: SoftMaker FreeOffice does not include any of the premium Soft-

Maker dictionaries normally shipped with SoftMaker Office. However, as an 

alternative, the spell checker supports the use of free Hunspell dictionaries. 

For information on installing additional Hunspell dictionaries, see the next sec-

tion (“Installing Hunspell dictionaries”).  

SoftMaker Office comes with high-quality dictionaries for numerous languages. 

This section explains how to install dictionaries that are not currently installed: 

Windows, Mac and Linux 

When you install SoftMaker Office for Windows, Mac, or Linux, all available 

SoftMaker dictionaries are included already – so there is no need to add additional 

SoftMaker dictionaries later. 

Android 

This is different with the Android version: It allows you to download and automa-

tically install SoftMaker dictionaries that are currently not installed from our server 

whenever needed, free of charge.  

Proceed as follows: 

1. Launch any of the apps (TextMaker, PlanMaker, or Presentations) on your 

Android device. 

2. Invoke the Tools > Options menu command and switch to the Language tab. 

3. Tap on the Get more dictionaries button. 

4. A dialog with a list of all available languages opens. To download and install a 

language, tap on the corresponding download button displayed at its right. 

When the download has finished, the dictionary is installed and from now on 

available in any SoftMaker Office application. 
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Installing Hunspell dictionaries 

FreeOffice: SoftMaker FreeOffice does not include any of the premium Soft-

Maker dictionaries normally shipped with SoftMaker Office. However, as an 

alternative, the spell checker supports the use of free Hunspell dictionaries. 

In a standard installation, only Hunspell dictionaries for English and German 

are installed. In case you want to add additional languages, follow the procedure 

described below.  

Note: This feature is not available in the Android version. 

Apart from SoftMaker’s own dictionaries, SoftMaker Office for Windows, Mac, 

and Linux also supports the use of Hunspell dictionaries. These dictionaries are 

available as free downloads. Most of them were created by private users or non-

profit organizations. 

Hunspell dictionaries are available for very many languages. In case you don’t find 

a SoftMaker dictionary for a certain language, it might be worth checking if a Hun-

spell dictionary is available for it. 

For a list of all Hunspell dictionaries supported by SoftMaker Office, visit the 

“Downloads” area of our website www.softmaker.com. You can also download 

the dictionaries there, free of charge. 

To download and install a Hunspell dictionary, proceed as follows: 

1. With your web browser, navigate to our homepage www.softmaker.com 

2. In the menu of the web page, choose “Downloads”, then choose “Dictionaries”.  

3. Your browser now displays a page presenting a list of all Hunspell dictionaries 

that SoftMaker Office supports. Download the dictionary of interest and store it 

on your hard disk. 

4. Launch any SoftMaker Office application (TextMaker, PlanMaker, or Presenta-

tions). 

5. Invoke the Tools > Options menu command and switch to the Language tab. 

6. Click on the Hunspell dictionaries button. 

7. A dialog showing a list of all languages/dictionaries installed appears. Click on 

the Add Hunspell dictionary button. 

8. A file dialog is displayed. Use it to browse to the folder where you have stored 

the downloaded dictionary. 

http://www.softmaker.com/
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9. Select the dictionary file from the files list and click on Open. 

The dictionary will be installed and is from now on available in any SoftMaker 

Office application. 

Choosing a different dictionary for a language 

FreeOffice: SoftMaker FreeOffice does not include any of the premium Soft-

Maker dictionaries normally shipped with SoftMaker Office. However, as an 

alternative, the spell checker supports the use of free Hunspell dictionaries. 

(See also section “Installing Hunspell dictionaries”.)  

Note: This feature is not available in the Android version. 

In case you have installed more than one dictionary for a certain language (e.g. a 

SoftMaker dictionary and a Hunspell dictionary), you can switch between these 

dictionaries anytime. Proceed as follows: 

1. Invoke the Tools > Options menu command and switch to the Language tab. 

2. Click on the Hunspell dictionaries button. 

 A dialog showing a list of all languages appears. On the right, it displays which 

type of dictionary each language is using currently. 

3. Select the language of interest in that list. 

4. Select the dictionary to be used for this language in the Dictionary dropdown 

list.  

 Choices available: 

 SoftMaker: The SoftMaker dictionary shipped with SoftMaker Office. 

(This is the default setting.) 

 Hunspell: A Hunspell dictionary (free downloadable dictionary, see previ-

ous section) 

5. Confirm with OK. 

From now on, the spell-checker will use the selected dictionary for the specified 

language. 
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Addendum 
In the addendum, the following information is given: 

 Menu commands and corresponding ribbon commands 

 In this section you will find a table of each menu command, together with the 

corresponding command in the ribbon. 

 Keyboard shortcuts 

 This section provides tables for the most frequently used keyboard shortcuts in 

the program.  

Menu commands and corresponding ribbon 

commands 

In this section you will find a table of each menu command, together with the cor-

responding command in the ribbon. 

Tip: You can switch the user interface between ribbon and classic menus and 

toolbars at any time. To do this, invoke the menu command Tools > Option (or, 

in the ribbon, the command File > Options). In the dialog, switch to the 

Appearance tab and click on the User Interface button. A dialog box appears in 

which you can select the type of user interface you prefer. 

The table contains the following columns: 

 Left column: menu command 

 The left column lists all menu commands in the program, sorted by the order in 

the main menu.  

 Right column: corresponding command in the ribbon 

 In the right column you will find the corresponding command in the ribbon – in 

the following notation: 

 Tab > Section > Command 

 Example:  
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 The command File > Document > Save on the ribbon can be found as follows: 

File tab, Document section, Save icon.  

 With some commands, an additional fourth entry is displayed. Here, you can 

find the corresponding command in the list that opens when you click on the 

specified icon (or the arrow to the right of it). 

So here is the announced table: 

 

 Menu       Ribbon 

 
File > New  File > File > New >> More 

 
File > Open  File > File > Open 

 
File > Close  File > File > Close 

 
File > Save  File > Document > Save 

 
File > Save as  File > Document > Save as 

 
File > Save all  File > Document > Save all 

 
File > Revert to previous version  File > File management > Versions 

 
File > Acquire  Insert > Objects > Picture >> From 

scanner 

 File > Select source  Insert > Objects > Picture >> Select 

source 

 
File > Properties  File > File management > Properties 

 
File > File manager  File > File management > File mana-

ger 

 
File > Page setup  Layout > Page setup 

 
File > Print preview  File > Print > Print preview 

 
File > Print  File > Print > Print 
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File > Print merge  File > Print > Print merge 

 
File > Export as PDF  File > Document > PDF export 

 
File > Export as EPUB  File > Document > EPUB export 

 
File > Send  File > Document > Send 

 
File > Exit  File > New > Exit 

    

 
Edit > Undo  Quick Access Toolbar > Undo 

 
Edit > Redo  Quick Access Toolbar > Redo 

 
Edit > Cut  Home > Edit > Cut 

 
Edit > Copy  Home > Edit > Copy 

 
Edit > Paste  Home > Edit > Paste 

 
Edit > Paste special  Home > Edit > Paste >> Paste special 

 
Edit > Duplicate  Layout > Objects > Duplicate 

 
Edit > Select all  Home > Selection > Select all 

 
Edit > Search  Home > Search > Search 

 
Edit > Replace  Home > Search > Replace 

 
Edit > Search again  Home > Search > Search again 

 
Edit > Go to  Home > Search > Go to 

 
Edit > Sort  Home > Paragraph > Sort text/table 
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Edit > Link  OLE object > OLE > Edit link 

 
Edit > OLE object  OLE object > OLE > OLE object 

    

 
View > Touch mode  Quick Access Toolbar > Touch mode 

 
View > Standard  View > Views > Standard 

 
View > Continuous  View > Views > Continuous 

 
View > Master pages  View > Views > Master page 

 
View > Outline  View > Views > Outline 

 
View > Actual size  View > Zoom > Actual size 

 
View > Fit margins to window  View > Zoom > Fit margins 

 
View > Full page  View > Zoom > Full page 

 
View > Two full pages  View > Zoom > Two pages 

 
View > Magnifying glass  View > Zoom > Zoom 

 
View > Zoom level  View > Zoom > Set zoom 

 
View > Object mode  View > Mode > Object mode 

 
View > Form mode  View > Forms > Form mode 

 
View > Full screen  View > Windows > Full screen 

 
View > Horizontal ruler  View > View > Horiz. ruler 

 View > Sidebar  View > Windows > Sidebar 
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Format > Character  Home > Character 

 
Format > Standard  Home > Character > Standard 

 
Format > Paragraph  Home > Paragraph 

 
Format > Tabs  Layout > Paragraph > Tabs 

 
Format > Bullets and numbering  Home > Paragraph 

 
Format > Borders  Home > Paragraph > Borders 

 
Format > Shading  Home > Paragraph > Shading 

 
Format > Drop caps  Layout > Paragraph > Drop caps 

 
Format > Link  Insert > Links > Hyperlink 

 
Format > Transfer formatting  Home > Edit > Format painter 

 
Format > Section  Layout > Section > Columns 

 
Format > Chapter  Layout > Chapter > Chapter 

 
Format > Page background  Layout > Section > Background 

 
Format > Character style  Sidebar > “Character styles” tab 

 
Format > Paragraph style  Home > Styles 

 Format > Manage styles  Sidebar > “Paragraph styles” tab > 

“Organize” button 

    

 
Insert > Date/time  Insert > Text > Date / time 

 
Insert > Field  Insert > Text > Field 
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Insert > Calculation  Insert > Text > Field >> Calculation 

 
Insert > Caption  References > Captions > Insert caption 

 
Insert > Symbol  Insert > Text > Insert symbol 

 
Insert > Document  Insert > Text > Document 

 
Insert > List/label  Mailings > Create > List/Label 

 
Insert > Envelope  Mailings > Create > Envelope 

 
Insert > SmartText  Insert > Text > SmartText 

 
Insert > Bookmark  Insert > Links > Bookmark 

 
Insert > Cross reference  Insert > Links > Cross reference 

 
Insert > Header  Insert > Header and footer > Header 

 
Insert > Footer  Insert > Header and footer > Footer 

 
Insert > Footnote > Insert footnote  Insert > Header and footer > Footnote 

 Insert > Footnote > Edit footnote  Insert > Header and footer > Footnote 

>> Change numbering 

 Insert > Footnote > Footnote mark  Insert > Header and footer > Footnote 

>> Insert footnote mark 

 
Insert > Footnote > Go to footnote  References > Footnotes > Go to foot-

note 

 
Insert > Footnote > Go to footnote 

reference 

 References > Footnotes > Go to refe-

rence 

 Insert > Footnote > Options  Insert > Header and footer > Footnote 

>> Footnote options 

 
Insert > Break > Line break  Insert > Breaks > Break >> Line break 

 
Insert > Break > break  Insert > Breaks > Break >> Column 

break 
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Insert > Break > break  Insert > Breaks > Break >> Page break 

 
Insert > Break > Section break  Insert > Breaks > Break >> Section 

break 

 
Insert > Break > Chapter break  Insert > Breaks > Break >> Chapter 

break 

    

 
Object > New text frame  Insert > Objects > Text frame 

 
Object > New picture  Insert > Objects > Picture 

 
Object > New picture frame  Insert > Objects > Text frame 

 
Object > New chart  Insert > Objects > Chart frame 

 
Object > New chart frame  Insert > Objects > Chart frame 

 
Object > New OLE object  Insert > Objects > OLE object frame 

 
Object > New OLE object frame  Insert > Objects > OLE object frame 

 
Object > New form object > Text field  Insert > Objects > Form object >> Text 

field 

 
Object > New form object > Checkbox  Insert > Objects > Form object >> 

Checkbox 

 
Object > New form object > 

Dropdown 

 Insert > Objects > Form object >> 

Dropdown 

 
Object > New form object > Checkbox 

frame 

 Insert > Objects > Form object >> 

Checkbox frame 

 
Object > New form object > 

Dropdown frame 

 Insert > Objects > Form object >> 

Dropdown frame 

 
Object > New form object > Label  Insert > Objects > Form object >> 

Label 

 
Object > New form object > Groupbox  Insert > Objects > Form object >> 

Groupbox 
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Object > New drawing > Line  Insert > Objects > Lines 

 
Object > New drawing > Curve  Insert > Objects > Lines 

 
Object > New drawing > Freehand 

form 

 Insert > Objects > Lines 

 
Object > New drawing > Rectangle  Insert > Objects > AutoShape 

 
Object > New drawing > Rounded 

rectangle 

 Insert > Objects > AutoShape 

 
Object > New drawing > Ellipse/circle  Insert > Objects > AutoShape 

 
Object > New drawing > Straight 

connector 

 Insert > Objects > Lines 

 
Object > New drawing > Elbow 

connector 

 Insert > Objects > Lines 

 
Object > New drawing > Curved 

connector 

 Insert > Objects > Lines 

 
Object > New drawing > TextArt  Insert > Objects > TextArt object 

 
Object > New drawing > AutoShapes  Insert > Objects > AutoShape 

 
Object > Grid and guides  Layout > Position > Grid and guides 

 
Object > Group  Layout > Objects > Group 

 
Object > Order > Bring to front  Layout > Position > Bring to front 

 
Object > Order > Send to back  Layout > Position > Send to back 

 
Object > Order > Bring forward one 

level 

 Layout > Position > Bring to front >> 

Bring forward one level 

 
Object > Order > Send backward one 

level 

 Layout > Position > Send to back >> 

Send backward one level 

 Object > Order > Convert to object 

frame 

 Object > Objects > Convert 

 Object > Order > Convert to embedded  Object > Objects > Convert 
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object 

 
Object > Tab order  Insert > Objects > Form object >> Tab 

order 

 
Object > Rotate or flip > Flip horizon-

tally 

 Layout > Position > Rotate object >> 

Flip horizontally 

 
Object > Rotate or flip > Flip vertically  Layout > Position > Rotate object >> 

Flip vertically 

 
Object > Rotate or flip > Rotate left  Layout > Position > Rotate object >> 

Rotate left 

 
Object > Rotate or flip > Rotate right  Layout > Position > Rotate object >> 

Rotate right 

 
Object > Align or distribute > Align 

left 

 Layout > Position > Align objects >> 

Align left 

 
Object > Align or distribute > Align 

center 

 Layout > Position > Align objects >> 

Align center 

 
Object > Align or distribute > Align 

right 

 Layout > Position > Align objects >> 

Align right 

 
Object > Align or distribute > Align 

top 

 Layout > Position > Align objects >> 

Align top 

 
Object > Align or distribute > Align 

middle 

 Layout > Position > Align objects >> 

Align middle 

 
Object > Align or distribute > Align 

bottom 

 Layout > Position > Align objects >> 

Align bottom 

 
Object > Align or distribute > Distribu-

te horizontally 

 Layout > Position > Align objects >> 

Distribute horizontally 

 
Object > Align or distribute > Distribu-

te vertically 

 Layout > Position > Align objects >> 

Distribute vertically 

 
Object > Chart > Edit data  Chart > Data > Edit data 

 
Object > Chart > Element properties  Chart > Chart elements > Edit proper-

ties 

 
Object > Properties  Object > Format > AutoShape templa-

tes >> More 
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Table > New table  Insert > Table > Table 

 
Table > Table properties  Table > Table > Properties 

 
Table > Row properties  Table > Table > Properties >> Row 

properties 

 
Table > Cell properties  Table > Table > Properties >> Cell 

properties 

 
Table > Table style  Table > Style > Table styles 

 
Table > Insert cells > Insert row above  Table > Cells > Insert rows >> Insert 

row above 

 
Table > Insert cells > Insert row below  Table > Cells > Insert rows >> Insert 

row below 

 
Table > Insert cells > Insert column 

left 

 Table > Cells > Insert columns >> 

Insert column left 

 
Table > Insert cells > Insert column 

right 

 Table > Cells > Insert columns >> 

Insert column right 

 
Table > Insert cells > Insert cells  Table > Cells > Insert rows >> Insert 

cells 

 
Table > Delete cells > Delete rows  Table > Cells > Delete cells >> Delete 

rows 

 
Table > Delete cells > Delete columns  Table > Cells > Delete cells >> Delete 

columns 

 
Table > Delete cells > Delete table  Table > Cells > Delete cells >> Delete 

table 

 
Table > Delete cells > Delete cells  Table > Cells > Delete cells >> Delete 

cells 

 
Table > Merge cells  Table > Merge and split > Merge cells 

 
Table > Split cells  Table > Merge and split > Split cells 

 
Table > Split table  Table > Merge and split > Split table 

 
Table > Select > Table  Table > Table > Select 
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 Table > Select > Row  Table > Table > Select >> Select rows 

 Table > Select > Column  Table > Table > Select >> Select co-

lumns 

 Table > Select > Cell  Table > Table > Select >> Select cur-

rent cell 

 
Table > Distribute rows  Table > Cells > Distribute rows 

 
Table > Distribute columns  Table > Cells > Distribute columns 

 
Table > Convert table to text  Table > Data > Convert table to text 

 
Table > Convert text to table  Insert > Table > Table >> Convert text 

to table 

 
Table > Sort table  Table > Data > Sort table 

    

 
Tools > Edit database  Mailings > Database > Edit database 

 
Tools > Create database  Mailings > Database > New database 

 
Tools > Modify database structure  Mailings > Database > Modify struc-

ture 

 
Tools > Set database  Mailings > Recipients > Select data-

base >> Use existing database 

 
Tools > Index > Add index entry  References > Index > Add entry 

 
Tools > Index > Edit index entries  References > Index > Edit entries 

 
Tools > Index > Generate index  References > Index > Generate 

 Tools > Bibliography > Attach an exis-

ting bibliography database 

 References > Bibliography > Insert 

field >> Use existing database 

 Tools > Bibliography > Create a new 

bibliography database 

 References > Bibliography > Insert 

field >> Create new database 

 Tools > Bibliography > Edit the bibli-

ography database 

 References > Bibliography > Manage 

>> Edit database 
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 Tools > Bibliography > Bibliography 

settings 

 References > Bibliography > Manage 

>> Bibliography settings 

 
Tools > Bibliography > Insert biblio-

graphy field 

 References > Bibliography > Insert 

field 

 
Tools > Bibliography > Generate bib-

liography 

 References > Bibliography > Generate 

 
Tools > Generate table of contents  References > Table of contents > Ge-

nerate 

 
Tools > Generate table of figures  References > Captions > Generate 

 
Tools > Run script  File > Scripts > Run script 

 Tools > Edit script  File > Scripts > Edit script 

 
Tools > Comments > Automatically 

show comments pane 

 Review > Comments > Comments 

pane 

 
Tools > Comments > Insert comment  Review > Comments > Insert 

 
Tools > Comments > Edit comment  Review > Comments > Edit 

 
Tools > Comments > Delete comment  Review > Comments > Delete 

 
Tools > Comments > Previous com-

ment 

 Review > Comments > Previous 

 
Tools > Comments > Next comment  Review > Comments > Next 

 Tools > Comments > Options  Review > Comments 

 
Tools > Changes > Track changes  Review > Changes > Track changes 

 
Tools > Changes > Show changes  Review > Changes > Show 

 
Tools > Changes > Previous change  Review > Changes > Previous 

 
Tools > Changes > Next change  Review > Changes > Next 

 
Tools > Changes > Review all changes  Review > Changes > Review 
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 Tools > Changes > Options  Review > Changes 

 
Tools > Check spelling  Review > Spelling > Spell check 

 Tools > Edit user dictionaries  Review > Spelling > Spell check >> 

Edit user dictionaries 

 Tools > Automatic hyphenation  Review > Spelling > Hyphenation > 

Automatic hyphenation 

 Tools > Thesaurus  Review > Dictionaries > Thesaurus 

 
Tools > Duden  Review > Dictionaries > Duden 

 
Tools > Langenscheidt  Review > Dictionaries > Translation 

 
Tools > Update fields  References > Fields > Update fields 

 Tools > Customize  File > Settings > Customize >> 

Customize ribbon 

 
Tools > Options  File > Settings > Options 

 

Keyboard shortcuts 

The following pages provide tables for the most frequently used keyboard short-

cuts in the program: 

 Keyboards shortcuts in the Windows and the Linux version 

 Keyboards shortcuts in the Mac version 

Tip: You can customize the predefined keyboard shortcuts and create new short-

cuts with the menu command Tools > Customize (see section “Customizing 

keyboard shortcuts” beginning on page 592). 
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Keyboards shortcuts in the Windows and the Linux version 

In the Windows and the Linux version, the following keyboard shortcuts are 

available: 

Keyboard shortcuts for menu commands 

Menu command  Keyboard shortcut 

File > New            (Ctrl)(N) 

File > Open  (Ctrl)(O) 

File > Close  (Ctrl)(F4) or (Ctrl)(W) 

File > Save  (Ctrl)(S) 

File > File manager  (F12) 

File > Print  (Ctrl)(P) 

File > Exit  (Alt)(F4) or (Ctrl)(Q) 

   

Edit > Undo  (Ctrl)(Z) 

Edit > Redo  (Ctrl)(Y) 

Edit > Cut  (Ctrl)(X) 

Edit > Copy  (Ctrl)(C) 

Edit > Paste  (Ctrl)(V) 

Edit > Paste special  (Ctrl)(Shiftª)(V) 

Edit > Select all  (Ctrl)(A) 

Edit > Search  (Ctrl)(F) 

Edit > Replace  (Ctrl)(H) 

Edit > Search Again  

(or Replace Again) 

 (F3) 

Edit > Go To  (F5) or (Ctrl)(G) 

Edit > Evaluate  (F8) 
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Menu command  Keyboard shortcut 

View > Full screen  (F6) 

   

Format > Standard  (Ctrl)(Space) 

   

Character formattings:   

Select font (in the Formatting toolbar)  (Ctrl)(D) 

Decrease font size  (Ctrl)(8) 

Increase font size  (Ctrl)(9) 

Boldface on/off  (Ctrl)(B) 

Italics on/off  (Ctrl)(I) 

Underlining on/off  (Ctrl)(U) 

Superscript  (Ctrl)(Shiftª)(Num+) 
(Plus key on the numeric pad) 

Subscript  (Ctrl)(Shiftª)(Num-) 

Remove super- or subscript  (Ctrl)(Shiftª)(Num*) 

   

Paragraph formattings:   

Increase left indent  (Ctrl)(M) 

Decrease left indent  (Ctrl)(Shiftª)(M) 

Increase hanging indent  (Ctrl)(T) 

Decrease hanging indent  (Ctrl)(Shiftª)(T) 

Automatic single line spacing (1 line)  (Ctrl)(1) 

Automatic one and a half line spacing (1.5 lines)  (Ctrl)(5) 

Automatic double line spacing (2 lines)  (Ctrl)(2) 

Alignment: Left  (Ctrl)(L) 

Alignment: Centered  (Ctrl)(E) 

Alignment: Right  (Ctrl)(R) 
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Menu command  Keyboard shortcut 

Alignment: Justified  (Ctrl)(J) 

   

Paragraph styles:   

Paragraph style “Normal”  (Alt)(0) 

Paragraph style “Heading 1”  (Alt)(1) 

Paragraph style “Heading 2”  (Alt)(2) 

Paragraph style “Heading 3”  (Alt)(3) 

   

Insert > Date  (Ctrl)(.) (period) 

Insert > Time  (Ctrl)(:) (colon) 

Insert > Calculation  (F2) 

Insert > Footnote > Insert footnote  (Ctrl)(Alt)(F) 

Insert > Break > Page Break  (Ctrl)(¢) 

Insert > Break > Column Break  (Ctrl)(Shiftª)(¢) 

   

Tools > Changes > Track changes  (Ctrl)(Shiftª)(E) 

Tools > Check spelling  (F7) 

Tools > Thesaurus  (Shiftª)(F7) 

Tools > Berlitz  (Ctrl)(F7) 

Tools > Update fields  (F9) 

Keyboard shortcuts for editing text 

Command  Keyboard shortcut 

Select next form object            (F11) 

Select previous form object  (Shiftª)(F11) 

Select next form object (in Form mode)  (Tab) 
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Command  Keyboard shortcut 

Select previous form object (in Form mode)  (Shiftª)(Tab) 

   

Change case of the selected text (from “test” to “Test” to 

“TEST”) 

 (Shiftª)(F3) 

   

Insert an en dash (–)  (Ctrl)(Num-) 

Insert an em dash (—)  (Ctrl)(Alt)(Num-) 

   

Insert a non-breaking space  (Ctrl)(Shiftª)(Space) 

Insert a non-breaking hyphen  (Ctrl)(Shiftª)(-) 

   

Convert a hexadecimal character code into the respective 

Unicode character* 

 (Ctrl)(Alt)(Shiftª)(X) 

* For example, when you type in 20AC and then press this keyboard shortcut, a euro sign € will appear 

(since the euro sign’s character code is 20AC in the Unicode character set table). 

Keyboards shortcuts in the Mac version 

Note: For most keyboard shortcuts with the Cmd key, you can alternatively use 

the Ctrl key instead of the Cmd key. For example, for the shortcut key (Cmd)(S) 

you can also press (Ctrl)(S) if desired. 

In the Mac version, the following keyboard shortcuts are available: 

Keyboard shortcuts for menu commands 

Menu command  Keyboard shortcut 

File > New            (Cmd)(N) 

File > Open  (Cmd)(O) 

File > Close  (Cmd)(F4) or (Cmd)(W) 
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Menu command  Keyboard shortcut 

File > Save  (Cmd)(S) 

File > File manager  (F12) 

File > Print  (Cmd)(P) 

File > Exit  (Alt)(F4) or (Cmd)(Q) 

   

Edit > Undo  (Cmd)(Z) 

Edit > Redo  (Cmd)(Y) 

Edit > Cut  (Cmd)(X) 

Edit > Copy  (Cmd)(C) 

Edit > Paste  (Cmd)(V) 

Edit > Paste special  (Cmd)(Shiftª)(V) 

Edit > Select all  (Cmd)(A) 

Edit > Search  (Cmd)(F) 

Edit > Replace  (Ctrl)(H) 

Edit > Search Again  

(or Replace Again) 

 (F3) 

Edit > Go To  (F5) or (Cmd)(G) 

Edit > Evaluate  (F8) 

   

View > Full screen  (F6) 

   

Format > Standard  (Ctrl)(Space) 

   

Character formattings:   

Select font (in the Formatting toolbar)  (Cmd)(D) 

Decrease font size  (Cmd)(8) 
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Menu command  Keyboard shortcut 

Increase font size  (Cmd)(9) 

Boldface on/off  (Cmd)(B) 

Italics on/off  (Cmd)(I) 

Underlining on/off  (Cmd)(U) 

Superscript  (Cmd)(Shiftª)(Num+) 
(Plus key on the numeric pad) 

Subscript  (Cmd)(Shiftª)(Num-) 

Remove super- or subscript  (Cmd)(Shiftª)(Num*) 

   

Paragraph formattings:   

Increase left indent  (Cmd)(M) 

Decrease left indent  (Cmd)(Shiftª)(M) 

Increase hanging indent  (Cmd)(T) 

Decrease hanging indent  (Cmd)(Shiftª)(T) 

Automatic single line spacing (1 line)  (Cmd)(1) 

Automatic one and a half line spacing (1.5 lines)  (Cmd)(5) 

Automatic double line spacing (2 lines)  (Cmd)(2) 

Alignment: Left  (Cmd)(L) 

Alignment: Centered  (Cmd)(E) 

Alignment: Right  (Cmd)(R) 

Alignment: Justified  (Cmd)(J) 

   

Paragraph styles:   

Paragraph style “Normal”  (Alt)(0) 

Paragraph style “Heading 1”  (Alt)(1) 

Paragraph style “Heading 2”  (Alt)(2) 

Paragraph style “Heading 3”  (Alt)(3) 
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Menu command  Keyboard shortcut 

   

Insert > Date  (Cmd)(.) (period) 

Insert > Time  (Cmd)(:) (colon) 

Insert > Calculation  (F2) 

Insert > Footnote > Insert footnote  (Cmd)(Alt)(F) 

Insert > Break > Page Break  (Cmd)(¢) 

Insert > Break > Column Break  (Cmd)(Shiftª)(¢) 

   

Tools > Changes > Track changes  (Cmd)(Shiftª)(E) 

Tools > Check spelling  (F7) 

Tools > Thesaurus  (Shiftª)(F7) 

Tools > Berlitz  (Cmd)(F7) 

Tools > Update fields  (F9) 

Keyboard shortcuts for editing text 

Command  Keyboard shortcut 

Select next form object            (F11) 

Select previous form object  (Shiftª)(F11) 

Select next form object (in Form mode)  (Tab) 

Select previous form object (in Form mode)  (Shiftª)(Tab) 

   

Change case of the selected text (from “test” to “Test” to 

“TEST”) 

 (Shiftª)(F3) 

   

Insert an en dash (–)  (Cmd)(Num-) 

Insert an em dash (—)  (Cmd)(Alt)(Num-) 
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Command  Keyboard shortcut 

   

Insert a non-breaking space  (Cmd)(Shiftª)(Space) 

Insert a non-breaking hyphen  (Cmd)(Shiftª)(-) 

   

Convert a hexadecimal character code into the respective 

Unicode character* 

 (Cmd)(Alt)(Shiftª)(X) 

* For example, when you type in 20AC and then press this keyboard shortcut, a euro sign € will appear 

(since the euro sign’s character code is 20AC in the Unicode character set table). 
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Index 

3 
3D effects (for objects) 279 

A 
ABOVE 400, 401 

ABS function 412, 413 

Acquire (File menu) 227 

Actual size (View menu) 571 

Add or remove spaces when pasting 541, 543 

Address 171, 174, 351, 539, 540 

Address database 351 

Address labels 367 

Address lists 367 

Align or distribute (Object menu) 267 

Alignment 

of pages 121, 123 
of paragraphs 89 

of tabs 91, 92 

of text fields 317, 318 
of text frames 288, 290 

of text in AutoShapes 304 

alignment tabs 113 

All caps 73 

Anchor (of objects) 264, 268, 273 

Anti-aliasing 545, 548 

Apply character formatting to entire words 

541, 543 

Arabic script 523, 539, 541 

ASC function 412, 413 

Asian scripts 539, 540 

Associate files types 555, 557 

AT function 412, 413 

Auto number 

resetting 195 
use 195 

Auto recovery 552, 553 

AutoFormat (Table menu) 215, 216 

Automatic hyphenation (Tools menu) 341, 

343, 550, 551 

AutoShapes 

adding text to 302 

drawing 299, 301 
properties 303 

AVG function 412, 413 

B 
Background color 

of document pages 126 

of text 75 

of the workspace 545, 548 

Background spell checking 550 

Backup copy 509, 552, 554 

BAK files 509 

BasicMaker 529 

Beep on errors 545, 547 

BELOW 400, 401 

Berlitz (Tools menu) 345, 346 

Berlitz translation dictionaries 345, 346 

Bibliography 443 

Bibliography (Tools menu) 443 

Attach an existing bibliography database 
446, 447 

Bibliography settings 446, 447, 448 

Create a new bibliography database 444, 
445 

Edit the bibliography database 444, 446 

Generate bibliography 448, 449, 450 
Insert bibliography field 447 

Bold 73 

Bookmark (Insert menu) 166 

Bookmarks 166, 452 

Borders 

of master pages 121, 123 

of objects 277 

of paragraphs 100 
of table cells 209, 212, 213, 214 

Borders (Format menu) 100 

Break (Insert menu) 

Chapter break 119, 120 
Column break 153 

Page break 108 

Section break 157, 195, 196, 197 

Breaks between words, preventing 105, 106 

Bring forward one level 285 

Bring to front 285 

Bullets and numbering (Format menu) 94, 

182, 184, 187, 192, 194, 426, 427 

C 
Calculation (Insert menu) 396, 404 

Calculations 395 

formatting 404 
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inserting 396 

rounding 404 

with database fields 401 
with objects 403 

with table cells 400 

with variables 397 

Capitalize first letter of sentences 541 

Caption (Insert menu) 438 

Cell properties (Table menu) 209 

Centered (paragraph alignment) 89 

Centimeter 83, 84 

Changes (Tools menu) 

Next change 473, 474 

Options 475 
Previous change 473 

Review all changes 473, 474 

Show changes 473, 474 
Track changes 472, 473 

Chapter (Format menu) 112, 113, 116, 121, 

122 

Chapter break 119, 120 

Chapter number 121, 123, 171, 173 

Chapters 

formatting 121 

use 119 

Character (Format menu) 71, 72, 73, 74, 75, 

76, 77, 78, 79, 80, 81 

Character count 566 

Character field (database) 376, 377 

Character formatting 

modifying for an entire paragraph 90 

searching and replacing 165 

Character pitch 76 

Character Style (Format menu) 131, 133, 136 

Character styles 130, 147 

Chart (Object menu) 

Edit data 235, 236, 238 

Chart toolbar 237, 238 

Charts 233 

chart elements 241 

editing 237 

entering/editing data 238 
inserting 233 

properties 243 

Check for updates 555, 556 

Check spelling (Tools Menu) 333 

Checkbox frames 311, 321 

Checkboxes 311, 319 

CHR function 412, 413 

Circles 

drawing 299, 301 

properties 303 

Classic menus and toolbars 545, 546 

Clearance (for borders) 100, 104 

Close (File menu) 533 

Close all (Window menu) 533 

Color 

of objects 275 

of text 75 
of the workspace 545, 548 

Color gradient (for objects) 275, 276 

Color palette, modifying 564 

Column break 104, 153 

Comments 465 

Comments (Tools menu) 465 

Automatically show comments pane 468, 

469, 470 

Delete comment 467 
Edit comment 467 

Insert comment 466 

Next comment 469 
Options 469 

Previous comment 469 

Compatibility (document properties) 560, 563 

Complex scripts 539, 540 

Compress pictures in memory 555 

Computational functions 412 

Conditional text (IF function) 406 

Connectors 

drawing 299, 300 
properties 303 

Context menu 30 

Continuous (View menu) 569 

Contour (for frames) 268, 273 

Convert table to text (Table menu) 216 

Convert text to table (Table menu) 217 

Convert Thunderbird address book (Tools 

menu) 380, 381 

Convert to embedded object 284 

Convert to object frame 284 

Converting text to a table 217 

Copy (Edit menu) 67, 68 

Copy to document’s folder (pictures) 226, 292 

Correct first two uppercase letters 541, 542 

COUNT function 412, 413 

Create database (Tools menu) 376 

Creation date 171, 172 
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Creation time 171, 172 

Cropping (of pictures) 229, 231, 232, 293, 

294 

Cross reference (Insert menu) 452, 453 

Cross references 452 

Curves 

drawing 299, 300 

properties 303 

Customize (Tools menu) 

creating user-defined icons 591, 592 
customizing keyboard shortcuts 592, 593 

customizing toolbars 578 

Cut (Edit menu) 67, 68 

D 
Data record number 354, 355 

Database 351 

adding records 359 
assigning to a document 384 

calling up records by their number 357 

closing 362 
creating 376 

deleting records 360 

editing records 359 
form letters 383 

form view 356 

importing addresses 149, 150, 151, 362 
list view 356 

modifying the structure 379 

opening 352 
restoring records 360 

searching 357 

selecting 389 
sorting 361 

use 353 

Database field 171, 173 

Database info 171, 173 

Date 171, see Print date 

Date field (database) 376, 377 

Date last changed 171, 173 

Date/time (Insert menu) 177 

DAY function 412, 413 

dBase/DOS file format (database) 352, 376, 

378 

dBase/Unicode file format (database) 352, 

353, 376, 378 

dBase/Windows file format (database) 352, 

376, 378 

Decimal separator 560, 563 

Decimal tab 91, 92 

Default character format, changing 81, 135 

Default file format 552 

Default font 81, 135 

Default language 330, 550 

Default paragraph format, changing 144 

Delete 38 

Delete (Edit menu) 67, 68 

Delete cells (Table menu) 203 

Design Science 255, 256 

Dialog language 545 

Dialog style 545, 546 

Dictionaries, installing (for spell checking) 
600 

Different first page 121, 122 

Different left and right pages 116, 121, 122 

Display field names 171, 175, 560 

Display of digits 539, 541 

Display warning when saving documents in 

text format 552, 553 

DOC file format 517, 518 

Document (Insert menu) 69 

Document properties 559 

Colors tab 564 

Fonts tab 568 

Forms tab 567 
Protection tab 567 

Reviewing tab 469, 475, 568 

Statistics tab 566 
Summary tab 560 

View tab 560 

Document protection 513 

Document statistics 566 

Document summary 

entering 503 
inserting as fields 171, 174 

Document tabs 33, 531, 532, 533 

Document templates 149 

applying 150 
creating 150 

editing 151 

importing addresses 149, 150, 151, 362 
Normal.tmvx template 152 

Document window 531 

DOCX file format 517, 518 

Drag and drop 67, 68 

Drawings 259, 260, 298 

grouping 285 

inserting 299 

properties 303 
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rotating 266 

Drop caps (Format menu) 98 

Dropdown list frames 311, 312, 323 

Dropdown lists 311, 312, 321 

DTON function 412, 413 

Duplicate (Edit menu) 268 

E 
Edit > Copy 67, 68 

Edit > Cut 67, 68 

Edit > Delete 67, 68 

Edit > Duplicate 268 

Edit > Evaluate 406, 407 

Edit > Go to 166, 167, 168, 169 

Edit > Go to link 481, 482 

Edit > Link 252 

Edit > Paste 67, 68 

Edit > Paste special 69 

Edit > Redo 39 

Edit > Replace 161, 162, 165 

Edit > Replace again 161 

Edit > Search 160, 162, 165 

Edit > Search again 161 

Edit > Select all 66, 67 

Edit > Sort 221 

Edit > Undo 39 

Edit database (Tools menu) 352 

Edit mode 261 

Edit script (Tools menu) 529 

Edit user dictionaries (Tools menu) 340 

Effects (for objects) 280 

Ellipses 

drawing 299, 301 
properties 303 

Email 500 

E-mail 500 

E-mail 500 

E-mailing a document 500 

Encryption 513, See Document protection 

End notes 462 

Enter key 37 

Enumeration 94, 181, 182, 186 

Envelope (Insert menu) 373 

EPUB export 496, 497 

Equation Editor 255, 256 

Evaluate (Edit menu) 406, 407 

Exit (File menu) 44 

Export as EPUB (File menu) 496, 497 

Export as PDF (File menu) 491 

Exporting documents 517 

Extended support for Arabic text 523, 539, 

541 

Extended support for Asian fonts 539, 540 

F 
Field (Insert menu) 171 

Field names, display 171, 175 

File > Acquire 227 

File > Close 533 

File > Exit 44 

File > Export as EPUB 496, 497 

File > Export as PDF 491 

File > File manager 505 

File > New 40, 149, 150, 362, 363 

File > Open 41, 151, 517, 518 

File > Page setup 108 

File > Print 43, 487 

File > Print merge 490 

File > Print preview 486 

File > Properties 559 

Colors tab 564 
Fonts tab 568 

Forms tab 567 

Protection tab 514, 567 
Reviewing tab 469, 475, 568 

Statistics tab 566 

Summary tab 503, 560 
View tab 560 

File > Revert to previous version 509, 510 

File > Save 44 

File > Save all 44 

File > Save as 44, 150, 517, 518 

File > Select source 227, 228 

File > Send 500 

File format 517, 518 

File manager (File menu) 505 

File name 171, 174 

Filling (of objects) 275 

First line indent 84, 85 

Fit margins to window (View menu) 571 

Flipping objects 266 

Flush left (paragraph alignment) 89 
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Flush right (paragraph alignment) 89 

Font size 72 

Footer (Insert menu) 110, 111 

Footers 110 

Footnote (Insert menu) 

Edit Footnote 459, 460 

Footnote mark 459, 460 

Go to footnote 459 
Go to footnote reference 459 

Options 462 

Footnote separator line 462, 463, 464 

Footnotes 458 

Form letter 383 
assigning a database 384 

inserting database fields 386 

practice letter 387 
printing 490 

selecting records 389 

suppression of white spaces 393 
viewing test records 386 

Form mode (View menu) 308, 310, 327 

Form objects 

protecting contents 326 
use 317 

Format > Borders 100 

Format > Bullets and numbering 94, 182, 184, 

187, 192, 194, 426, 427 

Format > Chapter 112, 113, 116, 121, 122 

Format > Character 71, 72, 73, 74, 75, 76, 77, 

78, 79, 80, 81 

Format > Character Style 131, 133, 136 

Format > Drop caps 98 

Format > Link 481 

Format > Manage styles 147 

Format > Page background 126 

Format > Paragraph 83 

Borders tab 100 
Drop caps tab 98 

Paragraph tab 84, 86, 88, 89, 90 

Shading tab 99 
Tabs tab 91, 93 

Text flow tab 104, 105, 106, 341, 342 

Format > Paragraph style 139, 142, 143, 145 

Format > Remove link 481, 482 

Format > Section 

line numbers 196 
multi-column page layouts 153, 157 

resetting auto numbers 195 

Format > Shading 99 

Format > Standard 80, 135 

Format > Tabs 91, 93 

Format > Transfer formatting 77 

Format URLs as hyperlinks 541, 544 

Format view for... 560, 563 

Formatting toolbar 31, 72, 73, 74, 89 

Forms 307 

creating 311 
example 314 

filling out 308 

protecting contents of form objects 326 
protecting forms 327 

Forms toolbar 313 

Formulas 408 

Frame guidelines 536, 537 

Frames 259, 260 

aligning and distributing 267 

converting 284 
distributing 267 

grouping 285 

inserting 260 
margins 265 

order 285 

position 264, 268 
selecting 261 

size 265, 274 

Freehand forms 

drawing 299, 300 

properties 303 

Full page (View menu) 571 

Full screen (View menu) 572 

Full screen view 572 

Functions (in calculations) 412 

G 
Generate table of contents (Tools menu) 435, 

450 

Generate table of figures (Tools menu) 441, 

450 

German spelling reform 337 

Glow effect (for objects) 280, 281 

Go to (Edit menu) 166, 167, 168, 169 

Go to link (Edit menu) 481, 482 

Gradient (color gradient) 275, 276 

Grid 

between table cells 209, 212, 213, 215 

for positioning objects 595 

Grid and guides (Object menu) 595, 596, 597 

Group (Object menu) 285, 286 

Groupboxes (form object) 311, 312, 324 
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Guides 536, 537, 596 

Gutter 108, 109 

H 
Header (Insert menu) 110 

Header and footer toolbar 110, 111 

Headers 110 

Headings 418, See Outlines 

numbering 426 

Hidden text 560, 562 

Hiding 

objects 281, 284, 560, 561 

text 78 

Highlighter 75 

Horizontal line 479 

Horizontal position (of objects) 268 

Horizontal ruler 33, 84, 85, 93, 536, 538, 569, 

570 

Horizontal ruler (View menu) 569, 570 

HTML Documents 477 

Hunspell dictionaries 550, 551, 600 

Hyperlinks 

in objects 281, 282 
in the text 481 

Hyphen, non-breaking 341, 344 

Hyphen, soft 341, 343, 536, 539 

Hyphenation 

language selection 330 

use 341 

I 
IF function 406, 412, 413 

Ignore words that start with a number 550, 

551 

Importing documents 517 

Inch 83, 84 

Indents 84 

Index 431 

Index (Tools menu) 

Add index entry 431 

Edit index entries 432 

Generate index 433, 450 

Inner margins 

of AutoShapes 304 
of text frames 288, 289 

Insert > Bookmark 166 

Insert > Break 

Chapter break 119, 120 

Column break 153 

Page break 108 
Section break 157, 195, 196, 197 

Insert > Calculation 396, 404 

Insert > Caption 438 

Insert > Cross reference 452, 453 

Insert > Date/time 177 

Insert > Document 69 

Insert > Envelope 373 

Insert > Field 171 

Insert > Footer 110, 111 

Insert > Footnote 

Edit Footnote 459, 460 
Footnote mark 459, 460 

Go to footnote 459 

Go to footnote reference 459 
Insert footnote 459 

Options 462 

Insert > Header 110 

Insert > List/Label 367 

Insert > SmartText 347, 349 

Insert > Symbol 179 

Insert cells (Table menu) 203 

Insert footnote (Insert menu) 

Footnote 459 

Insert frames and drawings immediately 541, 

545 

Insert mode 40 

Installation 

Android 25, 26 

Linux 25 
macOS 24 

Windows 23 

INT function 412, 413 

Internet 

editing HTML Documents 477 

Italic 73 

J 
Justified (paragraph alignment) 89 

K 
Keep aspect ratio 274 

Keep scaling 274 

Keep together (paragraphs) 105 

Keep with next (paragraphs) 105 

Kerning 77 
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Keyboard shortcuts 

customizing 592, 593 

default keyboard shortcuts 617 
Mac 621 

Windows/Linux 618 

for character styles 131, 133 
for paragraph styles 139, 140, 142 

for special characters 179 

Keyboard, show/hide automatically 555, 557 

Keystroke count 566 

L 
Labels 367 

Labels (form object) 311, 312, 324 

Landscape format 108, 109 

Language 

for spell checking and hyphenation 330 
user interface 545 

Language tools 329 

Last edited by 171, 174 

LEFT 400, 401 

LEFT function 412, 413 

Left indent 84, 85 

LEN function 412, 413 

Letter spacing 76 

Limit internal picture cache 555 

Line numbers 196 

Line spacing 86 

Lines 

around master pages 121, 123 
around paragraphs 100 

around table cells 209, 212, 213, 214 

drawing 299 

of objects 277 

properties 303 

Link (Edit menu) 252 

Link (Format menu) 481 

Linking text frames 290 

Links 

in objects 281, 282 
in the text 481 

List, bulleted 94 

List, numbered 181, 182, 186 

List/Label (Insert menu) 367 

Lists (address lists) 367 

Live preview 545, 547 

Locked (object property) 281, 282 

Locking 

guides 560, 562, 596, 598 

objects 266, 281, 282 

objects on the master page 117, 119, 560, 
562 

Logical field (database) 376, 377 

LOWER function 412, 414 

LTRIM function 412, 414 

M 
Magnifying glass (View menu) 571 

Mail merge toolbar 386, 387 

Manage styles (Format menu) 147 

Manual 19 

Margins 

inner margins of AutoShapes 304 
inner margins of text frames 288, 289 

of objects 265 

page margins 108, 109 

Master pages 117 

Master pages (View menu) 117, 118, 569 

MathType 255, 256 

MAX function 412, 414 

Maximum number of undo steps 539, 540 

Measurement 545, 549 

Memo field (database) 376, 377 

Menu bar 30 

Menus/toolbars or ribbon? 545, 546 

Merge cells (Table menu) 206 

Microsoft Word file format 517, 518, 552 

Middle mouse button 541, 543 

MIN function 412, 414 

Mirror effect (for objects) 280 

Modify database structure (Tools menu) 379 

MONTH function 412, 414 

N 
Names (of objects) 286 

New (File menu) 40, 149, 150, 362, 363 

New chart (Object menu) 235, 236 

New chart frame (Object menu) 235, 237 

New drawing (Object menu) 299 

New form object (Object menu) 313 

Checkbox 319 
Checkbox frame 321 

Dropdown 321 

Dropdown frame 323 
Groupbox 324 
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Label 324 

Text field 317 

New horizontal line (Object menu) 479 

New OLE object (Object menu) 249, 250, 251 

New OLE object frame (Object menu) 295 

New Picture (Object menu) 226 

New picture frame (Object menu) 292 

New picture from gallery (Object menu) 228 

New table (Table menu) 200 

New text frame (Object menu) 288 

Non-breaking hyphen 341, 344 

Non-breaking spaces 105, 106, 393, 394 

Normal.tmvx 152 

NTOD function 412, 414 

Numbered list 181, 182, 186 

Numbering 

numbered lists 181, 182, 186 

of headings 426 
with auto numbers 195 

Numeric field (database) 376, 377 

O 
Object > Align or distribute 267 

Object > Charts 

Edit data 235, 236, 238 

Object > Grid and guides 595, 596, 597 

Object > Group 285, 286 

Object > New chart 235, 236 

Object > New chart frame 235, 237 

Object > New drawing 299 

Object > New form object 

Checkbox 319 

Checkbox frame 321 
Dropdown 321 

Groupbox 324 

Label 324 
Text field 317 

Object > New form Object 

Dropdown frame 323 

Object > New Form Object 313 

Checkbox 319 

Checkbox frame 321 
Dropdown 321 

Dropdown frame 323 

Groupbox 324 
Label 324 

Text field 317 

Object > New horizontal line 479 

Object > New OLE object 249, 250, 251 

Object > New OLE object frame 295 

Object > New Picture 226 

Object > New picture frame 292 

Object > New picture from gallery 228 

Object > New text frame 288 

Object > Order 285 

Object > Properties 

changing default settings 283 

for charts 243 

for checkbox frames 320 
for checkboxes 320 

for drawings 303 
for dropdown list frames 322 

for dropdown lists 322 

for footers 114 
for groupboxes 324 

for headers 114 

for horizontal lines 479, 480 
for labels 324 

for OLE object frames 296 

for OLE objects 254 
for picture frames 293 

for pictures 229 

for tables 213 
for text fields 317 

for text frames 288 

general properties 268 

Object > Rotate or flip 266, 267 

Object > Tab order 326 

Object > Ungroup 285, 286 

Object mode 261 

Object mode (View menu) 261, 262 

Object toolbar 261, 262 

Objects 259, 260 

changing default settings 283 
duplicating 268 

flipping 266 

grouping 285 
hiding 281, 284, 560, 561 

locking 266 

order 285 
position 264, 268 

properties 268 

rotating 266, 274, 275 
selecting 261 

size 265, 274 

OLE object frames 259, 260, 295 

inserting 295 

properties 296 

OLE object guidelines 536, 537 
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OLE objects 

editing 251 

inserting 249 
position and size 253 

properties 254 

OLE Objects 249 

editing 251 

inserting 249 
position and size 253 

properties 254 

Open (File menu) 41, 151, 517, 518 

Open Document file format 552 

Open Office file format 517, 518 

OpenDocument file format 517, 518 

OpenGL 555, 557 

Operators (in calculations) 411 

Options (Tools menu) 536 

Appearance tab 545 
Edit tab 541 

Files tab 552 

Fonts tab 559 
General tab 539 

Language tab 550 

System tab 555 

View tab 536 

Order (Object menu) 285 

Order (of objects) 285 

Orientation 

of pages 108, 109 

Outline (View menu) 420 

Outline level 104, 418, 419 

Outline toolbar 418, 419 

Outlines 418 

Overlapping objects 288, 289, 304 

Overwrite mode 40 

P 
Page background (Format menu) 126 

Page borders 
displaying in the document 536, 537 

Page break 104, 108 

Page count 171, 173 

Page margins 

setting 108, 109 

Page number 112, 121, 124, 171, 173 

Page orientation 108, 109 

Page setup (File menu) 108 

Pagination 105 

Paper bins 108, 110 

Paper size 108, 109 

Paragraph (Format menu) 83 

Borders tab 100 
Drop caps tab 98 

Paragraph tab 84, 86, 88, 89, 90 

Shading tab 99 
Tabs tab 91, 93 

Text flow tab 104, 105, 106, 341, 342 

Paragraph alignment 89 

Paragraph breaks 536, 538 

Paragraph control 105 

Paragraph formatting 

searching and replacing 165 

Paragraph style (Format menu) 139, 142, 143, 

145 

Paragraph styles 138, 147 

Password 

for documents 513 

for forms 327, 328 

Paste (Edit menu) 67, 68 

Paste special (Edit menu) 69 

Pattern 99, 100 

PDF export 491 

Pica 83, 84 

Picture frames 259, 260, 291 

inserting 292 

properties 293 

Pictures 

inserting 226 

labeling 438 
position and size 229 

properties 229 

rotating 266 

scanning in 227 

Point 72, 83, 84 

Portrait format 108, 109 

Position (of objects) 264, 268 

POW function 412, 414 

Preview (of files) 41, 43 

Print (File menu) 43, 487 

Print date 171, 173 

Print merge (File menu) 490 

Print page background 560, 562 

Print preview (File menu) 486 

Print time 171, 173 

Printable (object property) 281 

Printing 487 

form letters 490 
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PROD function 412, 414 

Professional 17, 18 

Prompt for summary information when saving 

552, 553 

Properties (File menu) 559 

Colors tab 564 
Fonts tab 568 

Forms tab 567 

Protection tab 514, 567 
Reviewing tab 469, 475, 568 

Statistics tab 566 

Summary tab 503, 560 
View tab 560 

Properties (Object menu) 

changing default settings 283 

for charts 243 
for checkbox frames 320 

for checkboxes 320 

for drawings 303 
for dropdown list frames 322 

for dropdown lists 322 

for footers 114 
for groupboxes 324 

for headers 114 

for horizontal lines 479, 480 

for labels 324 

for OLE object frames 296 

for OLE objects 254 
for picture frames 293 

for pictures 229 

for tables 213 
for text fields 317 

for text frames 288 

general properties 268 

Protecting 

contents of form objects 326 
documents 513 

forms 327 

text 79 

Q 
Quick Access Toolbar 32, 545, 546, 585, 586, 

591 

Quick paths 502 

Quotes, typographically correct 

search 162, 164 

use 541, 542 

R 
Record number 354, 355 

Rectangles 

drawing 299, 301 

properties 303 

Redo 39 

Redo (Edit menu) 39 

References 452, 455 

Reflection effect (for objects) 280 

Remove link (Format menu) 481, 482 

Replace (Edit menu) 161, 162, 165 

Replace again (Edit menu) 161 

Replacing 

formatting 165 

text 161 

Return to the last editing position when a 

document has been opened 552, 554 

Revert to previous version (File menu) 509, 

510 

Reviewing toolbar 465, 466, 471, 473 

Ribbon 17, 32, 545, 546 

customizing 583 

Ribbon commands and corresponding menu 
commands 605 

Ribbon or menus/toolbars? 545, 546 

RIGHT 400, 401 

RIGHT function 412, 414 

Right indent 84, 85 

Rotate or flip (Object menu) 266, 267 

Rotating 

objects 266, 274, 275 

text in AutoShapes 304 
text in text frames 288, 290 

ROUND function 404, 405, 412, 414 

Row properties (Table menu) 207 

RTF file format 517, 519, 552 

RTRIM function 412, 414 

Ruler 33, 84, 85, 93 

Run script (Tools menu) 529 

S 
Save (File menu) 44 

Save all (File menu) 44 

Save as (File menu) 44, 150, 517, 518 

Save within document (pictures) 226, 292 

Scanning 227 

scripts 529 

Search (Edit menu) 160, 162, 165 

Search again (Edit menu) 161 

Searching 
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files 507 

formatting 165 

in a database 357 
text 160 

Section (Format menu) 

line numbers 196 

multi-column page layouts 153, 157 

resetting auto numbers 195 

Section break 157, 195, 196, 197 

Sections 157 

Select (Table menu) 201 

Select all (Edit menu) 66, 67 

Select source (File menu) 227, 228 

Select whole words when selecting 541, 543 

Selecting 

database records 389 

objects 261 

text 65 

Send (File menu) 500 

Send backward one level 285 

Send to back 285 

Sending a document by e-mail 500 

Sequence number (field) 171, 173, 438, 440 

Set database (Tools menu) 384, 385 

Set default 152 

Set left and first-line indent with Tab and 

Backspace keys 541, 544 

Settings 535 

Shade 99 

Shade fields 171, 175, 560, 561 

Shading (Format menu) 99 

Shadow (for objects) 278 

SHM extensions 555, 557 

Show bookmarks 166, 167, 560 

Show fonts in font list 545, 547 

Show hidden files and folders 555, 558 

Show merge record 560, 561 

Show multiple pages side by side 536, 539 

Show pictures 560, 562 

Show unprintable characters 536, 538 

Sidebar (View menu) 34, 137, 146, 169 

Size (of objects) 265, 274 

Small caps 73 

Smart quotes 

search 162, 164 

use 541, 542 

SmartText 

expand automatically 541, 542 

use 346 

SmartText (Insert menu) 347, 349 

Smooth edges of pictures 555, 556 

Smooth edges of screen fonts 545, 548 

Snap to other objects 596, 599 

Snap to page margins 596, 599 

Soft edges effect (for objects) 280, 281 

Soft hyphen 341, 343 

Soft hyphens 536, 539 

SoftMaker 19 

SoftMaker Basic 529 

SoftMaker Equation Editor 255, 256 

SoftMaker Office Professional 17, 18 

Sort (Edit menu) 221 

Sort table (Table menu) 219 

Sorting 

databases 361 
tables 219 

text 221 

Spaces 536, 538 

Spaces, non-breaking 105, 106, 393, 394 

Special characters 179 

Spell checking 

in the background 335, 550 

installing additional dictionaries 600 
language selection 330 

manually 333 

user dictionaries 340 

Spelling reform (German) 337 

Split cells (Table menu) 205 

Split table (Table menu) 206 

SQRT function 412, 414 

Standard (Format menu) 80, 135 

Standard (View menu) 569 

Standard toolbar 31 

Statistics 566 

Status bar 35 

STR function 412, 414 

Strike out 73 

STRING function 412, 414 

Style manager 147 

Style reference (field) 171, 174, 455 

StyleRef field 171, 174, 455 

Styles 129, 147 

Subscript 76 

SUBSTR function 412, 415 

SUM function 400, 401, 412, 415 



 

638  •  Index Manual TextMaker 

Summary 503 

Superscript 76 

Superscript ordinal numbers 541, 544 

Support 19 

Symbol (Insert menu) 179 

Synonym dictionary (thesaurus) 344 

System requirements 20 

T 
Tab alignment 91, 92 

Tab leader 91, 92 

Tab order (Object menu) 326 

Tab stops 90 

Table > AutoFormat 215, 216 

Table > Cell properties 209 

Table > Convert table to text 216 

Table > Convert text to table 217 

Table > Delete cells 203 

Table > Insert cells 203 

Table > Merge cells 206 

Table > New table 200 

Table > Row properties 207 

Table > Select 201 

Table > Sort table 219 

Table > Split cells 205 

Table > Split table 206 

Table > Table properties 213 

Table > Table style 215 

Table guidelines 536, 537 

Table of contents 435 

Table properties (Table menu) 213 

Table style (Table menu) 215 

Tables 

converting text into a table 217 

converting to text 216 
deleting cells 203 

deleting, copying, moving cell contents 202 

editing 200 
formatting 207, 209, 213, 215 

inserting cells 203 
inserting tables 200 

merging cells 206 

merging tables 206 

properties 213 

sorting 219 

splitting cells 205 
splitting tables 206 

Tabs 90, 536, 538 

Tabs (Format menu) 91, 93 

Technical support 19 

Template folder 552 

Text color 75 

Text cursor 37 

Text direction 524, 525 

Text fields 311, 317 

Text file format 517, 519 

Text file format (database) 384, 385 

Text frames 259, 260, 287, 311 

inserting 288 

linking 290 
properties 288 

Text styles 73 

Text wrapping (around frames) 268, 272 

TextArt objects 

drawing 299, 302 
properties 303 

TextMaker file format 517, 518, 519 

TextMaker for DOS 

file format 517, 519 

TextMaker Professional 17, 18 

Thesaurus 

language selection 330 

use 344 

Thesaurus (Tools menu) 344 

Thunderbird address book, importing 380, 

381 

Time 171, see Print time 

Time last changed 171, 173 

Title bar 29 

TMBAK files 509, 511 

TMD file format 517, 519 

TMDX file format 517, 518 

Tmw.dbf 354 

TOC 435 

TODAY function 412, 415 

Toolbars 31 

creating user-defined icons 591, 592 

customizing 573, 578 

Toolbars (View menu) 573 

Tools > Automatic hyphenation 341, 343, 550, 

551 

Tools > Berlitz 345, 346 

Tools > Bibliography 443 

Attach an existing bibliography database 

446, 447 

Bibliography settings 446, 447, 448 
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Create a new bibliography database 444, 

445 

Edit the bibliography database 444, 446 
Generate bibliography 448, 449, 450 

Insert bibliography field 447 

Tools > Changes 

Next change 473, 474 

Options 475 
Previous change 473 

Review all changes 473, 474 

Show changes 473, 474 
Track changes 472, 473 

Tools > Check spelling 333 

Tools > Comments 465 

Automatically show comments pane 468, 

469, 470 

Delete comment 467 
Edit comment 467 

Insert comment 466 

Next comment 469 
Options 469 

Previous comment 469 

Tools > Convert Thunderbird address book 

380, 381 

Tools > Create database 376 

Tools > Customize 

creating user-defined icons 591, 592 

customizing keyboard shortcuts 592, 593 

customizing toolbars 578 

Tools > Edit database 352 

Tools > Edit script 529 

Tools > Edit user dictionaries 340 

Tools > Generate table of contents 435, 450 

Tools > Generate table of figures 441, 450 

Tools > Index 

Add index entry 431 

Edit index entries 432 

Generate index 433, 450 

Tools > Modify database structure 379 

Tools > Options 536 

Appearance tab 545 

Edit tab 541 
Files tab 552 

Fonts tab 559 

General tab 539 
Language tab 550 

System tab 555 

View tab 536 

Tools > Run script 529 

Tools > Set database 384, 385 

Tools > Thesaurus 344 

Tools > Update fields 171, 175, 405 

Tooltips 545, 547 

Touch mode 545, 546 

Touch mode (View menu) 545, 546 

Tracking changes 471 

Transfer formatting (Format menu) 77 

Transparency (of pictures) 229, 231, 293, 294 

TRIM function 412, 415 

TRUNC function 412, 415 

Two full pages (View menu) 571 

Typeface 72 

U 
Underline 73 

Underline old German spelling in blue 337, 

338, 550 

Undo (Edit menu) 39 

Ungroup (Object menu) 285, 286 

Unicode databases 352, 353, 376, 378 

Units of measure 83, 84, 545, 549 

Update fields (Tools menu) 171, 175, 405 

Updates 555, 556 

UPPER function 412, 415 

Use left Alt as shortcut key 541, 545 

Use OpenGL engine 555, 557 

Use placeholders (for graphics) 560, 562 

Use SHM extensions 555, 557 

Use system file dialogs 545, 548 

Use system menus 545, 547 

Use XIM 555, 558 

USER function 412, 415 

User info 171, 174, 539, 540 

User interface (ribbon or menus/toolbars?) 

545, 546 

User interface size 545, 549 

V 
VAL function 412, 415 

VBA 529 

Vertical alignment 

of pages 121, 123 

of text fields 317, 318 

of text frames 288, 290 
of text in AutoShapes 304 

Vertical position (of objects) 268, 271 

Vertical ruler 536, 538 
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View > Actual size 571 

View > Continuous 569 

View > Fit margins to window 571 

View > Form mode 308, 310, 327 

View > Full page 571 

View > Full screen 572 

View > Horizontal ruler 569, 570 

View > Magnifying glass 571 

View > Master pages 117, 118, 569 

View > Object mode 261, 262 

View > Outline 420 

View > Sidebar 34, 137, 146, 169 

View > Standard 569 

View > Toolbars 573 

View > Touch mode 545, 546 

View > Two full pages 571 

View > Zoom level 571 

View side by side (Window menu) 534 

Visible (object property) 281 

Visual Basic 529 

W 
Warn when loading OLE objects 539, 541 

Watermark 117 

Widows/orphans 105 

Window > Close all 533 

Window > View side by side 534 

Word count 566 

Word file format 517, 518, 552 

Workspace color 545, 548 

Wrap text to window 536, 539 

X 
XIM 555, 558 

Y 
YEAR function 412, 415 

Z 
Zoom level 571 

Zoom level (View menu) 571 
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