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Legal Statement

Copyright © 2013, LSOFT TECHNOLOGIES INC. All rights reserved. No part of this documentation may
be reproduced in any form or by any means or used to make any derivative work (such as translation,
transformation, or adaptation) without written permission from LSOFT TECHNOLOGIES INC.

LSOFT TECHNOLOGIES INC. reserves the right to revise this documentation and to make changes in
content from time to time without obligation on the part of LSOFT TECHNOLOGIES INC. to provide
notification of such revision or change.

LSOFT TECHNOLOGIES INC. provides this documentation without warranty of any kind, either implied
or expressed, including, but not limited to, the implied warranties of merchantability and fitness for a
particular purpose. LSOFT may make improvements or changes in the product(s) and/or the program(s)
described in this documentation at any time.

All technical data and computer software is commercial in nature and developed solely at private expense.
As the User, or Installer/Administrator of this software, you agree not to remove or deface any portion
of any legend provided on any licensed program or documentation contained in, or delivered to you in
conjunction with, this User Guide.

LSOFT.NET logo is a trademark of LSOFT TECHNOLOGIES INC.
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Disk Editor Tool

Overview

Disk Editor is advanced tool for viewing and editing sectors of Physical Disks or Partitions and Volumes
and contents of any file type. Disk Editor uses a simple, low-level disk viewer which displays information
in binary and text modes at the same time. You can use this view to analyze the contents of data storage
structure elements such as:

• Hard disk drives (disks)
• Partitions
• Volumes (Logical drives)

Open items for editing

At every application start, the Open Data Storage dialog appears.

• Select Disk, Partition or volume and click Open button to open selected item in editor.
• Double-click on any item in the tree view to open.

Toggle Details button to show or hide detailed information about selected (highlighted) item.

Click Open Disk Image button to open previously stored disk image, made by any LSoft Disk Utilities or
other third party applications. See: Open Disk Image on page 17

Use Ctrl+O shortcut any time after while using the editor or click File > Open Disk... command to open
this dialog again.

Disk Editor shows detailed information about the selected object in the information panel on the left side of
the view. The right panel displays the binary and text view of the file. After the Disk Editor view appears,
you may browse through the content of the open item using the scroll bar, keyboard arrows or the mouse
wheel.
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Click either the binary area or the text area to focus on it. You may also use the Tab keyboard key to
switch the focus between hexadecimal and text modes.

Warning:  As with any advanced tool, use extreme caution with the Disk Editor. Changes that
you make may affect disk structure integrity. You must be certain that the changes you make are in
line with correct data structures before you save changes.

Disk Editor Preferences

Disk Editor memorize its state and when closed those settings are preserved. The settings saved are view
options and geometry of windows.

Saving Changes

Unless stated otherwise, all modifications made in the Disk Editor are stored in memory. Changes are
written to the drive when you click Save.
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Subject Navigation and Information

After you have opened an object with the Disk Editor, you may navigate by scrolling block by block, or
by jumping directly to specific addresses. You may jump to disk system records such as the boot sector
(primary and copy) or a partition table.

Use the Navigate button in the toolbar to jump to a specific area in the open object.

The selections that appear depend on the type of object that you are editing.

No matter what object is opened for editing, the first two menu items in the Navigate menu will be Go to
Offset  and Go to Sector.

Go to Offset

The Go to Offset menu opens a dialog allowing specification of an exact location (offset) in the disk to
jump to.

You can use both decimal and hexadecimal values, preceding hexadecimal values with 0x. For example,
to specify location 512 as a hexadecimal number, enter 0x200. There are also options to specify an offset
from the beginning, from the current position, or from the end.

Next to the offset edit field there are two labels specifying the minimum and maximum allowed vales for
offsets displayed as decimal numbers.

You can also open this dialog directly by using the shortcut Ctrl+Shift+G.

Go to Sector

This command allows jumping to the beginning of a specified sector or cluster.

There are two edit fields in this dialog that allow entering a desired location either as a sector number or a
cluster number.

The Cluster edit field is available only for logical disks and greyed out for all other objects.

As with the offset dialog, you can also use both decimal and hexadecimal numbers.

Next to the edit field is the range of allowed values in brackets. Notice that not all sectors correspond to
clusters, but every cluster corresponds to a particular sector.

You can enter either a sector value or a cluster value. Depending on which field is active, the dialog will
use a sector or cluster. If you enter a number in the cluster edit field, a corresponding sector is displayed
automatically.

You can also open this dialog directly using the shortcut Ctrl+G.

Back and Forward navigation

When you navigate to an access point through the Navigate menu or jump to a specific offset or sector,
those addresses are stored in a stack. You can move backward and forward to the previous locations by
using the Back and Forward commands located in the Disk Editor Toolbar.

Navigate a Physical Disk
To navigate to the disk system records of a physical disk, click on the  Navigate button in the toolbar.
Depending on the partition scheme and contents of the physical disk you are editing, the Navigate menu
will contain different options.
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Navigating basic disks

After the Go to Offset and Go to Sector items there is a Partition Table menu item which allows
jumping to sector 0 of a physical disk. As you jump to the partition table, a Master Boot Record template is
automatically selected.

If the disk is not empty, the names of the partitions and their system areas will be in sub menus below the
Partition Table menu item.

Navigating dynamic disks

For dynamic disks the following system areas are available for direct access:

• LDM Private Header
• LDM Primary TOC Block
• LDM Backup TOC Block
• LDM VMDB Block
• LDM KLog
• LDM First VBLK Block

After each access point a sector number is specified in the brackets.

Navigate a Logical Drive
To navigate to the disk system records of a logical drive, click on the Navigate button in the toolbar.

Depending on the file system present in a logical drive, the navigation menu will have different access
points.

FAT and FAT32 drives

• Boot Sector
• Boot Sector Copy (FAT32 only)
• FAT1
• FAT2
• Root Directory

NTFS drives

• Boot Sector
• Boot Sector Copy
• $MFT
• $MFT Mirror
• Arbitrary MFT record

HFS+ drives

• Volume Header
• Volume Header Copy

Ext2/Ext3 drives

• Superblock

Some of the access points when used automatically select a corresponding template. For example, if a
boot sector access point is selected, a boot sector template is applied to the boot sector offset.
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Data Inspector

The Data Inspector is a small tool view window that provides the service of “inspecting” (or interpreting)
data currently selected in the edit pane. The Data Inspector lets you view the type of data you have
selected. This may help you interpret data as displayed in Disk Editor.

To open the Data Inspector, from the Disk Editor toolbar, choose View > Data Inspector;

To copy an interpreted data from Data Inspector as a text:

1. Right-click anywhere in the Data Inspector window.
2. Select Copy.

To switch between little endian and big endian representation:

1. Right-click anywhere in the Data Inspector window.
2. Select Big Endian

The Data Inspector window is dockable and its location can be changed by clicking on the window title
and dragging it to the new location. If the Data Inspector window is sharing its space with other tool
views, you can change its relative position by left clicking and dragging the window tab. You can close the
window by clicking on the [X] button in the top right corner of the window and reopen it again using the
View menu in the Disk Editor Toolbar.
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Using Bookmarks

Bookmarks allow you to save the current cursor location and quickly return to it later on. You may also give
a name to a bookmark to make orientation easier.

Bookmarks are shown in the tool window called Bookmarks. If the Bookmarks window is closed you can
open it using the menu View > Bookmarks.

Placing and removing a bookmark

Press Ctrl+F2 in order add a bookmark. Alternatively, you can right click in the hex editor and select a
command from a context menu. The bookmark position is shown with a light blue box and also added to
the list of bookmarks in the Bookmarks window. To remove a bookmark, press  Ctrl+F2 while having the
cursor over the position of that bookmark. You can also remove a bookmark from the Bookmarks window
by selecting a bookmark button in a toolbar and clicking delete. The delete function may also be selected
from a context menu.

Going to a bookmark

If you have defined bookmarks, pressing F2 will move your current position to the next enabled bookmark
in the list.

You can also right click a bookmark and select the Next bookmark command from a context menu.
Another option is to double click a bookmark name in the Bookmarks window.

Editing bookmarks

Bookmarks are named automatically when they are placed. You can rename a bookmark in the Bookmarks
window to give it some meaningful name. To do so make a single mouse click on the bookmark name and
edit it. Press Enter to accept your changes or Esc to cancel editing and revert to the original name. You
can also rename a bookmark by right clicking on it and selecting the Rename command from a context
menu.

Sometimes instead of deleting a bookmark it is useful to temporarily disable it. A disabled bookmark will
not be counted when moving to the next bookmark. Uncheck a bookmark in the Bookmarks window
to disable it. To disable all bookmarks at once click Disable all bookmarks in a toolbar or select this
command in a context menu.
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Searching in Disk Editor

To search text or byte sequence in Disk Editor:

• Click Ctrl+F shortcut key or
• Use Find button in Disk Editor's toolbar then Find dialog will appear.

Search data by ANSI, Hex or Unicode pattern. To speed up the process you can ask to search only at
given offset inside used-defined blocks. Regular expressions and wildcard are even greater expand search
capabilities.

Search direction will specify search direction from current cursor position.

When using Find All command, list of all search entries will appear. Use this list to navigate between
search result entries (if any) by double clicking on entry line.

Examples of using regular expressions:

^\d\d?$ - match integers 0 to 99

^\S+$ - match strings without white space

\b(mail|letter|correspondence)\b - match strings containing 'mail' or 'letter' or 'correspondence' but
only match whole words i.e. not 'email'

&(?!amp;) - match ampersands but not &

\b(Eric|Eirik)\b - match Eric or Eirik

*.html - using a wildcard
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Editing with Disk Editor

The Disk Editor allows you to edit the content of a selected part of an opened object. By default, the Disk
Editor shows the content of an object in a Read Only mode that prevents accidental modifications. In Edit
mode, you can change the content of the opened file or disk and all modifications are stored in memory.
Changes are written to the drive when you click Save.

To toggle between Read Only and Edit modes, do one of the following:

• From the Disk Editor toolbar, choose Edit > Allow Edit content.
• Right-click in the edit pane choose Allow Edit content from the context menu.

When you copy selected text from the edit pane to the clipboard, you may store it there in one of two
formats using the following commands:

• Copy - selected data is copied into the clipboard as binary.
• Copy Formatted - selected data is copied as formatted text suitable to paste into a text editor.

Working with selection
In order to select data in the Disk Editor Area, click and hold down the left mouse button and start
dragging to select an area. The selected area background will be highlighted. Release the mouse to finish
selecting. You can select an area bigger than will fit into the screen by dragging the mouse beyond the top
or bottom edge of the hex editor window.

The alternative way to make a selection is to define a beginning and an end of the block. This method
might be more convenient when a large area has to be selected in order to simply select data in a
particular range. Move the cursor to the position where you want the selection to start and do one of the
following:

• Select the menu command Edit > Beginning of block from the Edit menu in the toolbar.
• Right click and select Edit > Beginning of block from a context menu.
• Press Ctrl+1.

Move the cursor to the end of the desired selection and set the end of a selection in a similar way. If you
need to select all the data, you can use the Select All command instead.

Copying to the clipboard

Select an area of data as described above and either select the command Edit > Copy or press Ctrl+C.
The selected area will be copied into the clipboard in binary format. If you later want to insert it into a text
editor, use the Copy Formatted command instead. It will copy data as a formatted text.

Please note that you can copy a maximum of 1MB of data into the clipboard.

Pasting data from the clipboard

If you copied data into the clipboard, you can paste it into a different place by moving the cursor to the
position where you want the data to be copied. Use the command Edit > Paste or press Ctrl+V.

If you copied a text into the clipboard in a text editor, it will be pasted into the Disk Editor as text.
Otherwise, the data will be copied as binaries.
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Filling a selection

You can fill a selection with an arbitrary text or binary data. Make a selection first, then right click Edit >
Fill block. The Fill Block dialog allows entering either text or hex value patterns which will be used to fill
the selection. Patterns are used in a loop until the whole selection is filled. For example, if you need to fill
a selection with 0 bytes, just enter 00 into the Hex values edit field. If you want fill it with an 'ERASED'
pattern, enter it as a text and it will be repeated as many times as necessary to fill the block.

Use Template Editing
You can edit system records (like boot sectors, MBR, MFT etc.) by using a template tool window. Template
window is a small dockable window normally located to the left from main Disk Editor editing area. If it is
not visible, you can turn it on by selecting toolbar menu View > Templates.
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Applying a template

In order to apply a template to the desired offset, move the cursor to the location and use Edit menu
command Set Template position. You can select this command either from Edit toolbar menu or from
a context menu. The next step select a required template from the list box with template names in the
toolbar of templates window.



 | Editing with Disk Editor | 14

When you are jumping to particular system areas using Navigate menu, the corresponding template
might be applied automatically. This is true for templates like boot sectors, MBR or MFT record but not all
access points have a template associated with them.

The following templates are supported:

• MBR
• GUID Partition table
• NTFS boot sector
• NTFS MFT file record
• FAT boot sector
• FAT32 boot sector
• FAT directory entry
• exFAT boot sector
• exFAT directory entry
• HFS+ Volume header
• HFS+ Catalog Node
• HFS+ File Record
• Ext2/Ext3/Ext4 superblock
• Ext2/Ext3/Ext4 inode
• UFS superblock
• UFS inode
• LDM structures

As you edit data in Hex, ASCII or Unicode pane or in Templates window, modified data is fully
synchronized between views. After each modification a template view is recalculated giving you an up-to-
date interpretation of data.
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Template Copy

The following templates have their copy:

• NTFS Boot Sector
• FAT32 Boot Sector
• HFS+ Volume Header
• Ext2/Ext3 super block
• LDM Private Header
• LDM TOC Block

In this case template window will have an additional column named Copy Value which contains the data
from the copy record. Template copies are useful to compare record located in different locations using the
same pattern, for example to compare a boot record with its copy.

In case of Copy template its location is set separately from a main record using the same pattern. If the
main template and its copy are intersecting, the copy template data will be shown in template window but
not highlighted in the main edit area.

Setting template position

In order to set a template position or change an existing one move the cursor to desired location and use
Edit menu command Set Template position (or Set Template Copy Position for its copy).

Navigating to a system area which has an attached template using Navigate menu also changes template
position.

In order to facilitate the movement between records located in sequence, use arrow buttons located in
the template window toolbar next to the templates list. For example, if you are editing or viewing an MFT
record you can easily move to the next or previous record using those buttons.

Another way to set a template position is to enter new offset directly into template offset edit field in
the template window toolbar. One of those fields are used for entering an offset of the main record and
another is for its copy. The format of offset used in offset field is <sector:>:<sector offset>. You don't
need to specify sector offset if you want to move to the beginning of the sector. For example, you can
simply enter 100 to go to sector 100 and template offset will be shown as 100:0, but if you need to specify
128 byte in sector 100, you have to enter 100:128.

Highlighting template fields

By default all individual fields of template record are highlighted in Disk Editor main area (in hexadecimal
and ASCII columns only). This coloring highlighting can be disabled by clicking Toggle template fields
coloring button in template window toolbar next to arrow buttons.

The colors used by template coloring are arbitrary and have no specific meaning, their main purpose is to
make separate fields visible and distinguish from each other. Actually, a palette of several colors is chosen
and colors are used in a circle. When you select a field in the template window, the current field is also
highlighted in hex editing area with bold field frame.

When you move a mouse cursor above colored field in editing area, the name and value of the
corresponding field is also shown in a tooltip.

Navigating around template fields

You can set the cursor (current position) to a particular field in a template by double clicking it. If you
double click in Name, Offset or Value column, the position inside the main record is selected, but if you
click inside Copy Value column, the navigation is performed to the field in template copy.

Please note, that in Edit mode double clicking inside of Value or Copy Value starts editing of the field
instead of navigating to that field.
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Editing using template

Double click in the Value or Copy Value column to start editing the field (make sure that Allow Edit
Content is enabled).

Some of the fields are edited according to the mask and will not allow to enter invalid values. For example,
you cannot enter the number bigger than 65535 when editing a 2-byte field or invalid date when editing a
date.

To exit the editing of the field with saving the result of edit, press Enter or click to another field. To exit
editing without saving the result and revert to original value, press Esc.

Some of the templates fields depend on other fields. When a template is selected, an initial parsing occurs.
If some of the fields contain invalid values, the further parsing of the record might be not possible and
parsing will be stopped at this point, resulting in incomplete record. As an example lets take an MFT
record. The record header is always parsed, but if it contains invalid fields or update sequence, attributes
will not be parsed. The same is true when parsing an attribute - if an error occurs, the further parse is
canceled and no subsequent attributes are added to the record.

Furthermore, the whole set of fields for the template might depend on some field values. For example,
FAT Directory Entry template will show a Short File Name Entry fields or Long File Name depending on the
value of the flags.

Hyperlinks in templates 

Many templates contain hyperlinks allowing navigate easily to important data points.

For example, MFT records contain links to first cluster in data runs and MBR provides links to partitions.
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Open Disk Image

You may open a Disk Image to browse for files and folders or to scan for deleted files and folders.

1. To open the Open Disk Image dialog, do one of the following:

• From the main toolbar, click File > Open > Open Disk Image.
• From Open Disk Storage dialog click Open Disk Image button.

2. Open disk image using Configuration file

Use Browse button to locate .DIM (Disk Image Configuration) file. Once it selected, file ill be opened
and presented with detailed preview of Disk Image information.

Click OK to open disk image or click Compose button to alter disk image configuration (see next step).
3. Compose Disk Image [optional]

If there is no DIM file for Disk Image or to open third party Disk Images click Compose button.
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Dialog Options
Caption

Enter any label to distinguish newly opened disk image among other devices and disks.

Disk Image Chunks
A Disk Image consists of one or many files, which contains actual image data. A Disk
Image can be cut into several files (chunks) during creation for better space allocation. In
this list you have to specify all these files which make ups the image. To Add a Disk Image
chunk to the list click the Add New button and use browse for a file dialog to select a file.
To Remove a Disk Image chunk, select this chunk in the list and click the Remove button.
To modify the order of Disk Image chunks, select any chunk you wish to relocate and use
the Up and  Down buttons to move a selected chunk in the chunk stack.

Image Type
Select image type you about to open. Usually it assigned automatically, depending on Disk
Image chunks added.

• Raw Disk Image - Raw fragment of a disk;
• LSoft Disk Image - Disk Image created by any LSoft Technology product;
• Virtual PC - Disk Images from Virtual PC software;
• VMWare Image - Disk Images from VMWare software;

Media Type
Select appropriate media type. Usually it assign automatically. Use Fixed Disk by default.

Bytes per Sector
Enter sector size in bytes;

Sectors per Track
Enter track size in sectors;

Tracks per Cylinder
Enter cylinder size in tracks;

Save DIM File as...
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In case of manual composition of Disk Image properties you may save final configuration
file for later use;
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Application Log

This log view monitors each action taken by the application and displays messages, notifications and other
service information. Use the messages in this screen to observe and further understand the flow of the
recovery process.

We recommend that you attach a copy of the log file to all requests made to our technical support group.
The entries in this file will help us resolve certain issues.

To prepare a log file, turn on Display Trace Events and Write Log on Disk options in the Preferences
dialog box.

It is best to save the log file to a physical disk that is different from the disk that holds the deleted data. By
doing this, you reduce the risk of writing over the data that you are trying to recover.
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